Jump to content

[Guide] macOS Sierra 10.12 - Dell Optiplex 780 (760) (755) (790) (990)


MacPeet
 Share

1,596 posts in this topic

Recommended Posts

Hi all  :) 

@MacPeet

I made a Clover themes Specially for the PC Dell Optiplex 

Dell-HD

Its pretty the same of my previous Dell theme but this one the Logo is more bigger, adapted for PC Only  :D

The themes is attaching here

Enjoy your Dell Optiplex Clover

screen16.jpg

Dell-HD.zip

  • Like 1
Link to comment
Share on other sites

@Macpeet thanks for the feedback but I tried multiple things and could never get full qe/ci on high sierra 10.13.2. I'm now on Sierra 10.12.6 with full graphics acceleration. One issue I'm having is that after computer wakes up from sleep, it restarts after a few seconds. Not sure why that happens. Any help would be greatly appreciated.

Link to comment
Share on other sites

 

Hello everyone,
I have a small problem with a High Sierra installation on an Optiplex 780 (Q9650 / 3.00GHz, GeForce 310M). I installed without much problem and it works (graphics card, usb, Firewire card, I would see the sound after).
 
My concern is that when I do update 10.13.2, mac osx reboot before updating! (on the option Mas osx update in Clover).
 
I installed Clover UEFI on the EFI partition and I still have access to version 10.13.0.
 
An idea ? :)
 
Bruno

 

I have successfully updated to Mac OS 10.13.2 without any issues. Just downloaded latest combo update from App store, restarted the computer and every thing is work as it was earlier. 

 

Link to comment
Share on other sites

So, I'm going to attempt a High Sierra upgrade on my two Dell E8400 3 Ghz Hackintoshes, both with 512 mb Raedon 5450s... one with 4 mb RAM (media server), the other with 8 mb (wife's daily computer).

 

So, if I understand what's in this thread, I can upgrade to High Sierra from the App Store if I update to the latest version of Clover (already on the EFI partition), move my all my kexts to /Other, and replace my combined Lilu/AppleALC kext with the latest separate Lilu and ALC kexts? And move my vanilla AppleHDA from S/L/E to /Other?

 

Right now, I have AppleIntel1000e, FakeSMC, and USB_injector all in /10.12, and a combined Lilu/AppleALC kext (1.1.0) in /Other. For High Sierra, I should move ALL kexts to /Other, and replace the combined audio kext with Lilu 1.2.1 and the latest Apple ALC (1.2.2), then I can update from the App Store? 

 

Have I captured it? Thanks for any advice and guidance from those who have made this transition. I am currently at 10.12.3 on both machines.

Link to comment
Share on other sites

@I managed to upgrade with AppleALC, AppleIntelE1000, FakeSMC, Lilu and USBInjectAll in the 10.3 folder. I think you can put the same thing in Other (I just have FakeSMC). It takes the latest version of AppleALC and Lilu otherwise it does not work. I got the information a post up by MacPeet because I was not there either.

 

 

@Mac Peet

Hi, I ended up being able to install High Sierra (fresh install of the High Sierra image) directly in version 10.3.2 with a bootable USB key. After a few attempts I have a config.plist which boot with the video card AND the sound (before it was or the video card with a config or the sound :)).
 
By cons, I have a problem, the boot is very slow. He slowed down when he injects the sound (see screenshot). Is this normal or did I miss something?
 
Another small detail before my Firewire card was in the system report correctly. Now I only have pci8086,3a02 - AHCI controller written in the hardware part - PCI. Is there a way to fix that?
 
If you had time, could you see if my config.plist is perfect? After a lot of attempts it works but I do not know if it is well optimized. As a reminder, I have a Q9650, 8Mb RAM, Geforce 310 M + Firewire card (I do not know the brand).
 
thank you in advance
 
 
Link to comment
Share on other sites

Dell Optiplex 790 ➥ macOS High Sierra 10.13.2 (17C205)

Zotac Geforce GT 1030 2 Gig runs flawless with the Drivers 17C89 edit with ➤ Nvidia Payload Packager

sans_t95.png

Usage:

⬇︎

 

Download Drivers 17C89 with ➤  Web Drivers Getter

captu210.png

 

Used ➤ Nvidia Payload Packager

 

Install MyWebDrivers.pkg thats it Reboot  Done! 

128.png

 

 

 

Reboot and BOUM Voila   :thumbsup_anim:

⬇︎

 

sans_t37.jpg

 

captu212.png

 

Link to comment
Share on other sites

Okay, I'm holding off attempting High Sierra for the moment in favor of trying to update my two 10.12.3 Optiplex 780s to 10.12.6. I already had the full installer downloaded. On rig one, I ran the update from the applications folder, the rig restarted, the installer ran, the rig restarted, and the update was complete.

 

On rig two, I did the same thing, but on restart I just got a blinking cursor... no updater launched. So, I restarted and pressed F12 for boot options, selected the hard drive, and Clover gave me two options: Boot macOS from <hard drive> and Boot Clover from EFI. I chose to book macOS from <hard drive>, but it came up 10.12.3 with no changes. Does anyone have any suggestions for what is wrong and how I can move forward with the update?

Link to comment
Share on other sites

 

Update in 2 phases

After the 1st reboot in the Clover Bootloader more choice!
Clover Bootloader after Reboot -> "Install macOS High Sierra"
 
I hope I understood you correctly.

 

Thanks, MacPeet, but that's my issue. I'm not seeing "Install macOS from..." on reboot into Clover. I'm only seeing "Boot macOS from..." and "Boot Clover from EFI." Choosing "Boot Clover from EFI" just brings me back to the Clover boot screen. So, something is wonky somewhere...

Link to comment
Share on other sites

 

Update in 2 phases

After the 1st reboot in the Clover Bootloader more choice!
Clover Bootloader after Reboot -> "Install macOS High Sierra"
 
I hope I understood you correctly.

 

 

All good now, MacPeet. I copied my entire EFI folder from Rig One to the EFI partition on Rig Two, restored the config.plist for Rig Two, and restarted. Ran the 10.12.6 installer, and this time when it rebooted, "Install macOS from..." was an option in Clover. Selected it, the install went smoothly... applied the 10.12.6 Night Shift patch, and all is well. Thanks again for your help and all you do here!

  • Like 1
Link to comment
Share on other sites

Firmware data and bios data in Clover are up to date?

 
For some users, EmuVariableUEFI and nvram.plist interfered with the installation.
Delete EmuVariableUEFI and nvram.plist and try the update again.
Link to comment
Share on other sites

 

Firmware data and bios data in Clover are up to date?

 
For some users, EmuVariableUEFI and nvram.plist interfered with the installation.
Delete EmuVariableUEFI and nvram.plist and try the update again.

 

 

 

 

Did not help.

 

This on Optiplex 990. High Sierra, 10.13.2

 

Everything worked until I tried to install 10.13.2 Supplemental update.

 

Guess I am not going to update my Optiplex 790, not yet anyways. :(

 

 

 

 

 

28ksox0.jpg

Link to comment
Share on other sites

hi to all,

i have an optiplex 990 With ATi Radeon 260.

After a lot of try to configure it i give up.......so i replace it with an ATI Radeon 5450 with 512MB and hardware acceleration working fine in Sierra.

Audio not working .....solved copying Applehda e lilu kexts under 10.12 folder

now everything working good.

 

Now i want to update to HIGH Sierra .

What are the correct steps to do?

 

i think i have to update clover to the last version?

i have to move every kext to 10.13 folder?

 

GPU and audio kext will work correctly?

 

Thanks in advance

 

edit: if can be usef i go straight from sierra to high sierra without any problem.

 

I've simply copied every kext from 10.12 to 10.13 folder leaving Applehda e lilu kexts in both folder.

After that i download High SIerra update and launch it

after a pair of reboot i find both working gpu and audio

i make a backup and update also to the last update without any problem.

 

using ATI 5450 with 512 MB

Edited by twingolover
Link to comment
Share on other sites

Hello,

 

Was just wondering if anybody else has had trouble with the new security update for Sierra.

I am now unable to boot into the OS and get a panic very soon after powering on.

I've tried updating to the latest Clover. I believe it's 4380 as I write this. That however has not helped matters!

Was hoping to maybe get some ideas of what to try next.

 

Thanks in advance.

 

Oh and the offending machine is a 780 Core 2 Duo with a HD5450 graphics card.

Link to comment
Share on other sites

Your AppleALC.kext is too old. Boot with this flag:

 

-alcoff

 

Then update to the latest one and install Lilu.kext too. It's now mandatory when using plugins like AppleALC.kext (read more here).

 

You might want to update Clover in the meantime as it now have an option to block ESP/CLOVER/kexts before macOS starts ;).

  • Like 2
Link to comment
Share on other sites

Thank you very much for the quick response, I really do appreciate the help you guys give!

I'd be lost trying to figure this stuff out.

I'll report back if that works either way!

 

:) 

 

Wooohooo,

 

I'm back in.

 

Nice one, Polyzargone

 

Thanks again.

  • Like 1
Link to comment
Share on other sites

@vdubbus77

 
KernelPanic by Lilu !!!
Lilu too old.
Boot with flag -liluoff -alcoff
... then renew Lilu and AppleALC !!!
Update Lilu to version 1.2.1 and AppleALC 1.2.2, then all right!
 
 
 
LayoutID 11 (0B) or even better (NEW) LayoutID 13 (0D) !!!
 
Optiplex works, yes.  :wub:
 
@for all:
First DP Beta 10.13.4 works here, too.
  • Like 1
Link to comment
Share on other sites

 

@vdubbus77

 
KernelPanic by Lilu !!!
Lilu too old.
Boot with flag -liluoff
... then renew Lilu and AppleALC !!!
Update Lilu to version 1.2.1 and AppleALC 1.2.2, then all right!
 
 
 
LayoutID 11 (0B) or even better (NEW) LayoutID 13 (0D) !!!
 
Optiplex works, yes.  :wub:
 
@for all:
First DP Beta 10.13.4 works here, too.

 

You need also Update all file Clover in first Post because lots people have issue with AppleALC and Lilu

  • Like 1
Link to comment
Share on other sites

Agree with Chris1111 :).

 

IMHO, it would be better to tell users they have to download both AppleALC.kext & Lilu.kext by themselves so they all use the latest version. There's no need to provide a "special" version since Optiplex 7xx support is now embedded in AppleALC.kext.

 

Also, it would be better to delete the on-the-fly method because it may confuse people.

 

Keep it simple :D !

Link to comment
Share on other sites

Post #1 is from 2016 !!!

A little thought should the users already!
Post #1 says: "3. Install Clover 3985 or later ..."
 
Links for current releases Lilu and AppleALC already available in Post #1.
 
I will revise Post #1 in the next few days, delete on the fly method and more.
  • Like 1
Link to comment
Share on other sites

  • Allan unpinned this topic
 Share

×
×
  • Create New...