Jump to content

Blaggah

Members
  • Content Count

    533
  • Joined

  • Last visited

  • Days Won

    1

Everything posted by Blaggah

  1. Blaggah

    [GUIDE] Lenovo T460 macOS with Clover

    I'm experiencing serious battery drainage here on my x1 carbon 4th gen. Haven't used this machine for over 2 mos and i just turned it on, it was at 97%, and battery drainage decreases every 30 seconds or so. It just now dropped from 46% to 6%. Anything else i should be aware of? How do i fix this?
  2. Beware if you are using USB dongle for wifi, sleep/wake function might not work properly. I suffered with that with my optiplex 780. Sent from my iPhone using Tapatalk
  3. On a good note my machine is now rocking 20gb of ram along with 480gb SSD dual booting with Windows. My only gripe is the machine always seems to reset itself with this checksum message. I changed the CMOS battery and still no dice. The only good thing is, machine boots into Mac OS normally without having to chance anything in bios. But I want my wake from sleep to work and those are the only issues I'm having. Here's a picture of that stupid message. Sent from my iPhone using Tapatalk
  4. I managed to fix my audio, i had to go way back in 2016 when Jaymac helped me with his DSDT and i added what i needed to it in order to get audio to work. The only thing is, the layout is swapped.. Audio works when internal speaker is selected. That's better than nothing because i just needed vanilla sound without using voodoohda.. I'll post my dsdt and config and kexts folder for anyone willing to give it a try. Keep in mind im running a Radeon 6450 and not an Nvidia gpu so you might have to change that in config.plist prior to using. z400_CLOVER.zip
  5. Did you ever sort your sound issue with applealc on the z420? I have a z400 and i too am looking for audio solution. I've tried everything but nothing works.
  6. Ok good luck. Sent from my iPhone using Tapatalk
  7. I use terminal to mount the efi. Open terminal, and type: sudo diskutil list and then you press enter.. This will show you your system internal disks and any other storage device connected. If you only have one drive, it's less confusing. Then you type into terminal, sudo diskutil mount diskXX, the XX corresponds to your efi partion like disk0s1, disk1s1 and so on.. You follow?
  8. you could do it from within terminal but im not that advanced.. You have to boot off your usb in order to access the SSD partition and boot it up. Once you get on the desktop, you mount the usb efi partition and copy its contents to the desktop.. Then you mount the ssd efi partition and copy the contents from usb efi which you copied to desktop and paste into the ssd efi and replace.
  9. Yes, you need to copy of the efi from usb and replace with with efi from ssd. Voodoohda is another driver for getting audio to work even if your audio driver isn’t supported. I just don’t like using it. Just finished high Sierra on my z400, and I can’t get vanilla audio to work. Sent from my iPhone using Tapatalk
  10. Blaggah

    [GUIDE] Lenovo T460 macOS with Clover

    Ahhh I see. Well maybe mine could possibly be the same as I never did further testing passed to it working. I have multiple machines so I don’t use that x1 like that. I’ll do so testing later on today and see. Sent from my iPhone using Tapatalk Ahhh I see. Well maybe mine could possibly be the same as I never did further testing passed to it working. I have multiple machines so I don’t use that x1 like that. I’ll do so testing later on today and see. Sent from my iPhone using Tapatalk Ahhh I see. Well maybe mine could possibly be the same as I never did further testing passed to it working. I have multiple machines so I don’t use that x1 like that. I’ll do so testing later on today and see. Sent from my iPhone using Tapatalk
  11. Blaggah

    [GUIDE] Lenovo T460 macOS with Clover

    Did you use my dsdt as well? If you have the same same specs as mine, all should as mine does. Make sure to fix permissions and clear cache if you've made any experiments with some other kexts inside S/L/E. Sent from my iPhone using Tapatalk
  12. I like vanilla way better. Voodoohda is a hit or miss for me. I’m trying to do a fresh install on my z400 now with High Sierra. I’ll do the plunge to Mojave until the last version update is out. Sent from my iPhone using Tapatalk
  13. Anybody got audio working on Z400 using AppleALC kext? I've sound works in El Capitan but not Sierra..Just took my machine out of storage since 2017.
  14. Blaggah

    [GUIDE] Lenovo T460 macOS with Clover

    I'll send you the EFI folder sometime this weekend. I'm out of town and don't have my X1 Carbon with me. It's 99% stable, just have issues with battery indication not syncing properly sometimes. Other than that, it's rock solid. @aleixsr here's the clover from my x1 carbon.. I only have the DSDT and plnf.ssdt inside patched folder as they are the only ones i need for my machine. if you friend's x1 is the same as mine, he could use the same dsdt or else i'd recommend patching one himself for his machine.. Sent from my iPhone using Tapatalk X1 Carbon 4thGen CLOVER.zip
  15. Your HP Lappy is closely related to my HP EliteBook G3.. Try this clover and replace with yours.. CLOVER.zip
  16. Blaggah

    [GUIDE] Lenovo T460 macOS with Clover

    @tluck I did just that and now i have screen brightness working again and my X1 Carbon doesn't feel sluggish at all. I'm so glad i got this thing working. Thank you for all the help m8.. One quick question though, the x1 has a password where it needs to be typed on cold boot, i tried disabling it but it doesn't work. ----------Edited.. I downloaded the latest kext from Rehabman and it's working properly now. I must say that my X1 Carbon is now a success.. Thanks guys..
  17. Blaggah

    [GUIDE] Lenovo T460 macOS with Clover

    Thanks tluck, i took your advice and i managed to run patched the dsdt on my x1 and i deleted all the other ssdt in patched folder. I don't know what codec it is, but im assuming it's the same for the T470. Because it uses the same layout id as my x1 carbon 4th gen. Now the lappy doesn't seem to lag.. Now my audio is working but screen brightness doesn't seem to be working anymore. I only have DSDT.aml in patched folder now.. Do i need the PLNF ssdt in there as well? Because it was working prior to removing the files and patched dsdt.
  18. Blaggah

    [GUIDE] Lenovo T460 macOS with Clover

    Well to start, my x1 carbon 4th gen runs with the same EFI folder from T460 but x1 carbon's performance lags especially when accessing Apps. I could clone my T460 SSD and run it on my x1 and apply the necessary patches there once I finish copying the partitions. -------------Edit. Forgot to add that my x1 carbon is running but with no audio. I used the same clover files from my T460. I recompiled the screen brightness kext and that's working fine. Where's the repo with the files you're talking about?
  19. Blaggah

    [GUIDE] Lenovo T460 macOS with Clover

    Well to start, my x1 carbon 4th gen runs with the same EFI folder from T460 but x1 carbon's performance lags especially when accessing Apps. I could clone my T460 SSD and run it on my x1 and apply the necessary patches there once I finish copying the partitions.
  20. Blaggah

    [GUIDE] Lenovo T460 macOS with Clover

    You have to make sure apfs.efi or the other apfs driver is included inside your ego clover/drivers64 folder. Sent from my iPhone using Tapatalk
  21. Blaggah

    [GUIDE] Lenovo T460 macOS with Clover

    What's the likelihood of you implementing my x1 Carbon 4th gen into your package? I had to do a fresh install on my carbon today and I need to get my sound and the rest of the stuff sorted out. What do I need to provide in order to achieve this?
  22. Blaggah

    [GUIDE] Lenovo T460 macOS with Clover

    Nice, i managed to do it. Thanks. How would i go about doing the same on my x1 carbon 4th generation? I think i fixed my problem. I already had the latest pack for some odd reason, i think i was running the default dsdt which wasn't suited for my 1366x768 screen. I reran the command to create my dsdt and all is well now. Thanks for the feedback..
  23. Blaggah

    [GUIDE] Lenovo T460 macOS with Clover

    Could it be why my T460 isn't shutting down properly? I'll check later to see if I have that ssdt and report back. If not, where do I find it?
  24. Blaggah

    [GUIDE] Lenovo T460 macOS with Clover

    Whatever do you mean? Did I miss something? Please elaborate. I haven't been using my t460 because of this issue.
  25. Blaggah

    [GUIDE] Lenovo T460 macOS with Clover

    For some odd reason, my 460 doesn't seem to want to shut down from MacOs High Sierra. I could've sworn it worked from Sierra. Even when I try to turn off by pressing power button it restarts.
×