Jump to content

[Guide] macOS Sierra 10.12 - Dell Optiplex 780 (760) (755) (790) (990)


1,596 posts in this topic

Recommended Posts

Hi, I need a little help. I managed to install Yosemite, Dell 790 i5 2400, gtx 1060. Everything works, except the gtx1060 video card. I installed nvidia web driver, it loads it but it has no graphics acceleration. El Capitan, Sierra, High Sierra do not manage to install them. I have attached the EFI file, maybe someone can help me make my DSDT. The files are extracted to the origin folder.

 

https://mega.nz/#!k9JHHIaZ!JmuzVfcB6I5QPsbq1FBTUKYZycMBTR2lEXKxv1naw3Y

 

https://mega.nz/#F!lwAxVAoJ!XckwbahrS71yXIxxTpUZTQ

 

image.png

I managed to make updates to Sierra from Yosemite. Even so the video card has no graphics acceleration. I installed nvidia web driver. What more needs to be done. So far I have not had any such problem.

20200320_164556.jpg

20200320_164620.jpg

  • 4 months later...

Good night.  I  just had a problem installing osx mojave ... creat install media using MBR after successfully making an installation on usb then I install it to the PC and the hard drive is installed then the pc restarts loading again approximately 85% complete then the pc always repeats the restard My EFI clover  from you @chris1111

 

after the IOsconsole error then the white screen appears, the mouse pointer 2 seconds the PC is off and restarts again

 

DELL 780 CORE2DUO E8500 VGA CARD Nvidia GT710 5gb ram hd. 250GB

CLOVER.zip

IMG_20200721_221439.jpg

IMG_20200721_221123.jpg

Screenshot_2020-07-21-22-48-34-710_com.tokopedia.tkpd.jpg

Edited by sonia sudarsono
On 7/21/2020 at 11:10 AM, sonia sudarsono said:

Good night.  I  just had a problem installing osx mojave ... creat install media using MBR after successfully making an installation on usb then I install it to the PC and the hard drive is installed then the pc restarts loading again approximately 85% complete then the pc always repeats the restard My EFI clover  from you @chris1111

 

after the IOsconsole error then the white screen appears, the mouse pointer 2 seconds the PC is off and restarts again

 

DELL 780 CORE2DUO E8500 VGA CARD Nvidia GT710 5gb ram hd. 250GB

CLOVER.zip

 

 

 

Remove this -no_compat_check from boot args then add this dart=0

 

Your DSDT.aml is not good

Edited by chris1111
  • Like 1
5 hours ago, chris1111 said:

Remove this -no_compat_check from boot args then add this dart=0

 

Your DSDT.aml is not good

 

ok sir i will try to reinstall again sir
 if there is an error again I will look for you back sir thank you for the reply sir

1 hour ago, sonia sudarsono said:

@ chris1111

 

 

 

 

IMG_20200725_000823.jpg

Sister, you are using an older SMBIOS for iMac11,1 from 2009.
that is not compatible with Mojave, hence the error message that appears at the bottom of your screen "Mac-F228CC8" Use a compatible SMBIOS that will run with macOS mojave.

 

https://de.wikipedia.org/wiki/IMac
Under this link you will find all compatible Macs that are compatible with mojave.
Then search for these listed compatible models:
iMac: A1418, A1419
iMac Pro: A1862
Mac Pro: A1481
Mac Mini: A1347
MacBook Pro: A1278, A1286, A1398, A1425, A1502, A1706, A1707, A1708
MacBook Air: A1465, A1466
MacBook: A1534

 

then generate a new smbios for your system using clover configurator.app, then it should boot.

28 minutes ago, spakk said:

Sister, you are using an older SMBIOS for iMac11,1 from 2009.
that is not compatible with Mojave, hence the error message that appears at the bottom of your screen "Mac-F228CC8" Use a compatible SMBIOS that will run with macOS mojave.

 

https://de.wikipedia.org/wiki/IMac
Under this link you will find all compatible Macs that are compatible with mojave.
Then search for these listed compatible models:
iMac: A1418, A1419
iMac Pro: A1862
Mac Pro: A1481
Mac Mini: A1347
MacBook Pro: A1278, A1286, A1398, A1425, A1502, A1706, A1707, A1708
MacBook Air: A1465, A1466
MacBook: A1534

 

then generate a new smbios for your system using clover configurator.app, then it should boot.

Yes sir
tomorrow saturday my office is off and at home there is only a windows 10 pc how do i make smbios from win 10 is there any ideas or waiting for monday

 

oh yes sir
  I connect the PC to the monitor using an HDMI cable, sir

Edited by sonia sudarsono
15 hours ago, sonia sudarsono said:

Yes sir
tomorrow saturday my office is off and at home there is only a windows 10 pc how do i make smbios from win 10 is there any ideas or waiting for monday

 

oh yes sir
  I connect the PC to the monitor using an HDMI cable, sir

Quite simply, follow these instructions and download these tools to get to your EFI partition and in the end to get to your Config.plist from Windwos operating system. But be careful with these tools!

 

To make the partition of your macOS EFI partitions visible under Windows operating system, you need Partitionwizard tool.

For info:
The Efi partition is about 200 MB small partition that stands in front of the actual macOS partition of your macOS system, which is created during the creation of the main partition.

Download link: https://www.partitionwizard.com/free-partition-manager.html
After download, you have to install the tool, then open the program and change the drive letter by right-clicking on the EFI partition in the pulldown menu.
Here you have to select and confirm an unused letter. Confirm changes with "yes" and click on "Apply" in the top left of the menu. (if you have any questions, be sure to read the information on the website)
The EFI partition is then mounted and is visible in the Explorer. However, without access rights.

 

To get the necessary access rights, you need another tool, the tool is called "Explorer++"

Downloadlink: https://explorerplusplus.com/
download the tool and extract the packed file to your desktop, then start the "Explorer++.exe" by right-clicking as administrator.

now you have the option to access the files to change or even delete these files. 
But be careful with these tools!

Thanks to German www.hackintosh-forum.de team for this helpful information: (https://www.hackintosh-forum.de/lexicon/entry/108-efi-mit-windows-mounten-und-reparieren/)


To change or edit the config.plist under Windows operating system, you need the DiffMerge, here is the download link: https://sourcegear.com/diffmerge/downloads.php

On 25/7/2020 at 18.03, spakk said:

Cukup sederhana, ikuti instruksi ini dan unduh alat-alat ini untuk sampai ke partisi EFI Anda dan pada akhirnya untuk sampai ke Config.plist Anda dari sistem operasi Windwos. Tapi hati-hati dengan alat-alat ini!

 

Untuk membuat partisi partisi MacOS EFI Anda terlihat di bawah sistem operasi Windows, Anda memerlukan alat Partitionwizard.

Untuk info:
Partisi Efi adalah sekitar 200 MB partisi kecil yang berdiri di depan partisi macOS sebenarnya dari sistem macOS Anda, yang dibuat selama pembuatan partisi utama.

Tautan unduhan: https://www.partitionwizard.com/free-partition-manager.html
Setelah mengunduh, Anda harus menginstal alat, lalu membuka program dan mengubah huruf drive dengan mengklik kanan pada partisi EFI di pulldown Tidak bisa.
Di sini Anda harus memilih dan mengkonfirmasi surat yang tidak digunakan. Konfirmasikan perubahan dengan "ya" dan klik "Terapkan" di kiri atas menu. (jika Anda memiliki pertanyaan, pastikan untuk membaca informasi di situs web)
Partisi EFI kemudian dipasang dan terlihat di Explorer. Namun, tanpa hak akses.

 

Untuk mendapatkan hak akses yang diperlukan, Anda memerlukan alat lain, alat ini disebut "Explorer ++"

Unduh tautan : https://explorerplusplus.com/
unduh alat dan ekstrak file yang sudah dikemas ke desktop Anda, lalu mulai "Explorer ++. Exe" dengan mengklik kanan sebagai administrator.

sekarang Anda memiliki opsi untuk mengakses file untuk mengubah atau bahkan menghapus file-file ini. 
Tapi hati-hati dengan alat-alat ini!

Terima kasih kepada tim www.hackintosh-forum.de Jerman untuk informasi yang bermanfaat ini: ( https://www.hackintosh-forum.de/lexicon/entry/108-efi-mit-windows-mounten-und-reparieren/ )


Untuk mengubah atau mengedit config.plist di bawah sistem operasi Windows, Anda memerlukan DiffMerge, di sini adalah tautan unduhan: https://sourcegear.com/diffmerge/downloads.php

 

 

how to be able to edit like this .... while this kind of programming language I do not understand at all

 

image.thumb.png.0bf434bbd31d3c9054b92336e5605661.png

On 7/21/2020 at 10:10 PM, sonia sudarsono said:

@ chris1111

Good night. I just had a problem installing osx mojave ... to install media using MBR after successfully making an installation on USB then I install it to the PC and the hard drive is installed then the PC restarts loading again about 85% complete then the PC always repeat the clover EFI my clover from you @chris1111

 

after an IOsconsole error a white screen appears, the mouse pointer 2 seconds the PC turns off

780 CORE2DUO E 8500 VGA CARD Nvidia GT710 5gb ram hd. 250GB

CLOVER.zip

IMG_20200721_221439.jpg

IMG_20200721_221123.jpg

Screenshot_2020-07-21-22-48-34-710_com.tokopedia.tkpd.jpg

 

 

yesterday I tried to use original clover to have didn't edit anything then I installed an error like this ...

 

 

780.png

780.zip

 

 

 

 

Edited by sonia sudarsono

I've changed iMac10,1 to iMac15,1, whereby your config.plist needs to be changed according to your hardware spec. 

I do not known if the current DSDT is from your system?

In addition, you should hold down the F4 key while booting with clover Bootloader, so that clover saves various DSDTs in EFI folder under EFI/ACPI/origin , then you should upload this folder so that we can try to adapt your DSDT

 

config.plist

Big Sur B3 run on my Optiplex 790 with OpenCore + GeForce GT 710 :wink_anim:

the system has been installed for more than a week already

Everything is perfect and boot twice as fast as Clover with OpenCore

 

Edited by chris1111
  • Like 2
4 minutes ago, Rocky12 said:

Hi Chris 1111, Bro did you manage to install BS from usb installer or is this the vm Methode

I have no problem to install issue comes at the 2 boot on macOS Installer it not load the count system reboot so I can not pass the 2 boot

I have made the SSD BS from my HP Prodesk and put on my Optiplex 790 and Voila 

Wait to test USB Installer on Beta 4 hope its work for the Dell Optiplex?

Edited by chris1111
  • Like 1
1 minute ago, Rocky12 said:

I have the Same Probleme can,t get pass the second Stage when i try to install from usb installer:(

If you find solution let me know :wink_anim:

  • Like 1
  • Allan unpinned this topic
×
×
  • Create New...