Jump to content

[AMD] Working Builds!

259 posts in this topic

Recommended Posts

CPU: AMD Phenom II x4 955 Black Edition @ 3.2GHz

Motherboard: Asus M4N82 Deluxe

ChipSet: Nvidia 980a

RAM: 4GB DDR2 1066Mhz

SATA: 5 HDDs , Mixed 7TB

IDE: None Connected

USB 2.0: All ports work.

USB 3.0: Not Supported by motherboard. (Plan on buying a card)

Firewire: Disabled (But works enabled, used a Sony HandyCam to transfer a home movie)

GPU: Zotac GeForce 9500GT (1GB) and Asus GTX 560 (1GB). Both work seperately not together. Nvidia drivers are buggy no acceleration! Investigating EFI Strings.

LAN: Realtek 8211CL Gigabit

Sound: Internal - Realtek ALC1200

PS2: KeyBoard.


In case I have not been detailed enough about my board:



Using Chameleon 2.2 r2155

For Fermi cards disable GeforceGA.plugin and GLDriver.bundle in System/Library/Extensions! This will disable acceleration, but you will boot without -x (safe mode).

This is all on Mountain Lion 10.8.2.

Will post kexts and/or howto later. I have been without internet for 3/4 days (DTing... lol)

  • Like 1

CPU: AMD FX-8120 Black Edition @ OC 3.8GHz

Motherboard: Asus M5A97 EVO

ChipSet: AMD 970

RAM: 16GB DDR3 1600Mhz

SATA: 3 HDDs , Mixed 5TB

IDE: None on board

USB 2.0: All ports work.

USB 3.0: Currently Untested

Firewire: Works

GPU: Galaxy GTX 465. no acceleration.

LAN: RTL8111/8168 Uknown

Wifi: TP-Link TL-WDN4800 Works

Sound: Internal - AMD: Currently not working

PS2: None


Kernel: Sinetek test1



All other kernels instant reboot.

  • Like 1

- AMD Athlon 64 X2 3800+ Manchester
- DFI LANParty UT NF4 SLI-DR Expert / No AHCI
- Dual ch OCZ EL PC3200 Platinum Rev2 1024
- HIS ATI X1300 IceQ Turbo 256MB DDR2 PCIe
- ALC850 / AC97 Internal sound

SNOW LEOPARD - Screen + bench

Install ; Hazard 10.6.6i -> 10.6.8
Kernel ; Nawcom 10.8 v2, flags ; arch=i386 -force64
Graphic ; Natit + RadeonHD Framebuffer (QE/CI)
Sound ; AppleAC97Audio

LION - Screen + bench

Install ; Retail 10.7.4. Tested ; Retail 10.7.2 + iAtkos L2, Niresh 10.7.3, 10.7.5 Virgin install image
Kernel ; RAW:86/Sinetek/Connactic (x86), flags ; arch=i386 -legacy. IiTz ShAnE build (x64), flags ; -nossse3bit
* bronzovka latest kernel failed, instant reboot.. too bad
Graphic ; DSDT (QE/CI)
Sound ; AppleAC97Audio (x86)

MOUNTAIN LION - Screen + bench

Install ; iAtkos ML2
Kernel ; Andy Vandijck (md5: 8F8E8B639E2CFB37293EDE5A34458B49), no-flags
Graphic ; DSDT + 10.7.5 ATI kexts (No - QE/CI) :P
Sound ; AppleAC97Audio (x86)

* All need "VoodooTSCSyncAMD" to reduce lag + hang

Thanks to all developers who made this happen

Hello to everyone , and thanks for making all of this happen, especially to the developers and thread creators, much thanks to all........here is my working build/builds


- Amd Phenom 9950 (black edition) 2.6 quad core

- MSI K9a2 Platinum

- 4 gigs kingston hyperx ddr2

- VisionTek Radeon Hd 4870 1gig gddr5 (fully functional with GE=yes)

- Soundblaster Audiogy 2zs PCI card (working with kxaudiodriver version 1.1b)

- Realetek 8169 working with kext i found in ######

- USB 2.0 working

- firewire 400 working

- Sata and IDE working with AppleATI kext (add on after install with kext utility)

- HDD1 ML with Andy's latest greatest kernel

- HDD2 SL with nawcoms legacy 10.8.0 v2 (used hazards distro , nedded the appleNforcekext by medevil)

- HDD3 Lion with Shanes 64bit lion kernel dual booting win7 64bit


for mountain lion i used ###### with ###### method , installed on 1st try the day the kernel was posted on osx86.net, no issues what so ever

for Lion i used the iatkos L2 with my working SL installed on native drive and changed kernel and installed chamira boot loader

for snow leopard i just used hazard intel/amd client server distro


besides sleep, evthing works on all my osx's, with no dsdt , just used the amd auto patcher in snow leo, to have 32 bit and 64 bit both working

MIne is :- { Snow Leopard 10.6.8 (with legacy kernel) and LION (bronzovka AMD kernel ) }


CPU : AMD Athlon LE-1640 2.7GHZ

MOBO :Assus M2N8-AM SE2

GPU :Nvidia Geforce 9400GT 1GB

SSD :250 GB

Ram :8 GB

i have this config can i install mountain lion on it

i did try with all amd_kernel but i got instant restart every time..........

Guy's i really need help......................!

My turn, I think:


CPU: AMD Athlon II x2 250 @ 3k

Motherboard: Asus M4A78 (the first one with no extra designations)

Ram: 2G 533 DDR2 Kingston memory

1 SATA drive: 80.03 GB (Snow Leopard boot disc)(GPT)

1 USB2 external drive: 80.03 GB (misc Mac apps and Android apps/os (4.2.1 on my 'Droid device - a B&N NOOK Tablet 16GB (this is a HackDroid))

1 USB2 external DVD r/w drive. (only a 4x speed, but that is all I need)

1 ATAIDE drive: 40.06 GB IDE harddrive (this is my Windoze7Ultimate boot drive)

1 ATAIDE drive: 163.93 GB IDE harddrive (misc OSX, Windoze and Anddroid appls (plus installation software for each) Also my music for Itunes and videos and movies. This stuff is all accessable by both Windoze and OSX OS's.

IDE drives enabled by inserting AppleATIATA.kext ver. 1.0.3 in /S/L/E with KextWizard.

Audio: On-board enabled by VoodooHDA 2.7.3 plus HDAEnabler888b.kext: full range sound in stereo. (some things do quadraphonic.)

Video: ATI Radeon HD 4350 enabled by GraphicsEnabler and ATI4350.Fix.kexts Fully operational QE/CI and drives 2 monitors

Lan: RTL8168 enabled by RealtekRTL81xx.kext


OS: Mac OS-X 10.6.8

Chameleon 2.2svn r2168 (1-18-2013)

FakeSMC.kext ver. 4.2.0

Kernel: legacy_kernel_V8 with boot args: -v cpus=1 busratio=15 arch=i386 -force64 GraphicsEnabler=Yes PCIRootUID=1

Original install iATKOS S3 v2 with chocolate_kernel. Updated by downloading 10.6.8 combo update dmg and installing that then installing legacy_kernel_V8 before restart.


Been operating this setup since Jan of 2012 with no hickups


(I am attempting to install the new 64bit kernel for AMD at this time.)


Same setup as listed.


Using sinetek_pp kernel with Boot Args: rd=*uuid -v -f npci=0x2000 -force64 arch=i386 -s cpus=1 busratio=15 arch=x86_64



put me into single user mode, where I ran applejack auto to fix permission and fsck and other things. Then typed exit and it booted up in X86_64.


video is handled the same as the i386 -force64 mode and gives me full QE/CI and if I had a hdmi cable I would be able to run three monitors in both 32bit and 64bit environments.


Going to reboot and see if I can duplicate this without going through single user mode first.



Oh yeah. And another thing : No DSDT.aml or SSDT.aml files or a custom DSDT or stock DSDT because I find it just messes up my install.

amd_insn_patcher did not work for me either so doing this with the stock B.dylib and QuickTime components.


Ok. I can repeatedly boot into 64bit 10.6.8 with sinetek_pp. Itunes won't start and probably others but with amd_insn_patcher not working for me, I am not sure what I can do about it.


Ok now, this has changed. Someone posted the correct QuicktimeComponents and after that the hard part was figuring out where it went.

/System/Library/Quicktime/QuickTimeComponents.component/Contents/MacOS/QuickTimeComponents is the location. Backup the original before sticking it in there, run kext utility, then reboot. (at least this is what worked for me)

  • Like 1

MB: Asus M5A88-M||

CPU: AMD Phenom II x2 565||

RAM: DDR3 - 2x2GB kingston 1333 MHz||

GPU: GDDR5 - AMD Radeon HD6670 1Gb||

LAN: Realtek 8168||

HDD: WD 500Gb||



10.6.8 - Nawcom kernel ||

10.7.4 - IiTz ShAnE patched kernel - perfectly working! (boot flags: -nossse3bit npci=0x2000) ||

  • Like 2

I used a Sun Ultra40-M2

2 x 2.8 GHz Duo Processors

8 GB ram

8 Sata drives

1 MAT{censored}A DVD-RAM UJ-845S (came with the ultra40)

Quadro FX 3700 video

onboard nvidia HD sound

working nvidia onboard 10/100/1000 lan

10.8.0 Darwin Kernel Version 10.8.0: Mon Jun 27 20:06:12 EDT 2011; legacy kernel v8 :xnu-1504.15.3/BUILD/obj/RELEASE_I386 i386 with -force64 to get 8 GB ram

Everything runs smooth, running 10.6.8

  • Like 1

System Build:

OS: Mac OS X 10.7.2 updated to 10.7.4

Kernel: Bronzovka 32/64-bit Lion kernel

CPU: AMD Phenom II x4 820 2.8Ghz with L3 unlocked to 6MB

Memory: 12GB DDR3 1600Mhz Ram

Mainboard: MSI 790FX-GD70

Graphics: AMD/ATI Radeon HD5850 flashed rom to clock high as HD5870

Storage: 74GB Raptor Sata Drive and 750GB Western Digital Black Edition Sata Drive

OS: Dual boot with Windows 8 Pro 64-bit and Mac OS X Lion


Only one non-operational component: Firewire400 is recognized, but does not access externel device and shown as a network device


Mountain Lion is mostly functional, except for the common graphics issue. Hopefully a 32-bit/64-bit kernel with 64-bit userland makes it to ML....

  • Like 1

Mountain Lion 10.8.2 running nicely here. :king:


AMD FX 4100


I remade the XNU source patch by Sinetek.


It fixes boot on AMD FX using Chameleon Bootloader / bypasses non-working FSB detection.


it also has shutdown and reboot fix


Download via attachment / includes source code.


MSI 760GM-P23


Bootloader: Chameleon 2.2svn

RTL8111E / RealtekRTL81xx.kext

ALC887 / VoodooHDA


ATI Radeon HD4650


working with QE / CI enabled


Only application with small display bugs, I noticed, is Firefox. [th]

(I am using ML about 3-4 days with intense - have not tried much yet!)


AMD Radeon HD6570


unusable due to heavy distortions / replaced with above





  • Like 3

Gilles, i don't think you need GraphicsEnabler=Y in your boot flags array: Clover won't recognize it, and you already have GraphicsInjector=Yes under the Graphics section of your confg.plist. Maybe this is making your G610 underperform, since i get more than 25 points with the HD4000 integrated graphics of my i5 rig in Cinebench's OpenGL benchmark. By the way, are you booting from UEFI or using BIOS mode?


Congratulations for your build!

  • Like 1

Are you sure it's not the other way around, GraphicsEnabler is cosmetic and GraphicsInjector is the responsible for your good result? GraphicsEnabler is not recognized by clover! It uses GraphicsInjector, which means the same thing, but is the only flag Clover can use for the task of injecting Graphics. Try removing GraphicsEnabler and you'll see.


Best regards!

  • Like 2

CPU: AMD Phenom II 960T

Motherboard: Biostar TA880G+

RAM: 8GB DDR3 1333Mhz

SATA: 500GB Hitachi, Sony Optiarc DVD

USB 2.0: All ports work.

GPU: AMD Radeon HD 6870, works OOB

LAN: Realtek RTL8111E

Sound: Realtek ALC892, latest voodoo working


Bootloader: Chameleon 2.2 r2187


Lion 10.7.5, boot flags: -f, nossse3bit, usblegacy=off, npci=0x2000 arch=x86_64

Kernel: Bronya RC15


Edit: Got ML up and working, but with tons of graphics glitches (the only thing holding me back from using as a daily driver)

10.8.2, bootflags: -arch=x86_64, npci=0x2000


Edited by burkett375
  • Like 2

Mountain Lion 10.8.2 @ amd_kernel


CPU: AMD Phenom II x4 965 BE @ 4GHz

Motherboard: Gigabyte UA-970A-UD3

RAM: 12GB DDR3 1600MHz

SATA: Samsung F1 500GB

USB All ports 2.0/3.0 works


LAN: Realtek RTL8169

Sound: Realtek ALC889[coming...]


SMBios? -> Check my historial


+info coming soon...

5850 @ Mountain Lion 10.8.2.zip



Edited by Kikobeats
  • Like 3

Mountain Lion 10.8.2 @ amd_kernel


CPU: AMD Phenom II x4 965 BE @ 4GHz

Motherboard: Gigabyte UA-970A-UD3

RAM: 12GB DDR3 1600MHz

SATA: Samsung F1 500GB

USB All ports 2.0/3.0 works


LAN: Realtek RTL8169

Sound: Realtek ALC889[coming...]


SMBios? -> Check my historial


+info coming soon...


Does the graphics work without glitches? :)

  • Like 1

Yes, but not with QE/QI effect. (is amd_kernel bug)


try my ATI drivers!


I'm planning on trying to install ML again... My other HDD died, there went all of my Hackintosh stuff... Remember to backup! :D



AMD Athlon X64 LE 1640 2.71 GHZ

250 SSD



Everything is working under 10.6.8

LAN and 9400GT QE/CI not working in 10.8.2

i am using this kernel for Mountain Lion

https://www.dropbox.... AMD KERNEL.rar

  • Like 1

CPU: AMD Athlon II X2 250 3.o Ghz

Motherboard: ECS A780LM-M2

RAM: 8GB DDR3 1333Mhz


PATA: 40GB (Windows 8)

USB 2.0: All 4 rear and 2 front ports work.

GPU: AMD Radeon HD 5450, works with kext plist edits and GE=Yes (also GE=No thanks to a DSDT edit, but reports as a HD5000)

LAN: Realtek RTL8111E, Realtek RTL8195E (onboard, not working)

Sound: Realtek VIA VT1705, latest voodoo working. HDMI audio not working


Bootloader: Chameleon 2.2 r2170


Mountain Lion 10.8.2, bootflags: amd_kernel, arch=x86_64, npci=0x2000, GraphicsEnabler=Y (latest Anv amd_kernel for 10.8.x)

System works fine, litlle to no graphics corruption (only Safari, heavily affected, and Chrome, almost never affected). Games, movies, animations and graphics benchmarks perform as expected from the card. Until now, only DVD Player (crashes upon launch), ArchiveUtility (becomes unusable a couple of hours after startup) and the zoom shortcut (have to reenable it in Accessibility PrefPane from time to time) don't work as they should. Geekbench score: 4400 +


Lion 10.7.5, boot flags: bronya_kernel, arch=i386, -nossse3bit, npci=0x2000, GraphicsEnabler=Y (Bronzovka's 10.7.5 RC7 kernel)

System works almost flawlessly, with full support for 64-bit applications and impecable graphics performance. Only HDMI audio doesn't work. Geekbench score: 4400 +

  • Like 1

CPU: AMD Phenom II X4 925 2.8 Ghz

Motherboard: ASROCK 990FX Extreme3

RAM: 4GB DDR3 1333Mhz

SATA: 1X 500GB, 1X320GB, SSD120GB, DVD-R

USB 2.0: All 4 rear ports work

USB 3.0: 2 rear ports work

GPU: PALIT GTX 550ti, works OOB

LAN: BCM57781 works with kext

Sound: Audigy SB0350 works with kXAudioDriver-1.3b0

Bootloader: Cameleon 2.1 r2126


10.7.3 Lion, Kernel Lion 10.7.4-5 for AMD x86_64 Bit UPDATE 3, boot flags: -legacy arch=i386 npci=0x3000

Everything is working so far, except Quicktime Player. Geekbench score 6300

  • Like 1
  • Create New...