Jump to content

[AMD] Working Builds!


259 posts in this topic

Recommended Posts

 

:)

 

My build

 

-MSI AM1I (AM1 PCIE x4)

-APU Athlon 5350 with R3 (R3 no works CI/QE)

-Kingston DDR3 4 G0 1600 (667)

-HD 6670 1024 low profile

-SSD SanDisk 128 GO 

-Lan RTL 8111

-Audio ?  (voodooHDA 2.8.4)

 

-kext : 

 

FakeSMC (V 2009)

IOPCIFamily  M 10.9 13A603

AppleACPIPlatform M 10.9 13A603

IOUSBFamily M 10.9 13A603

IOUSBMassStorageClass M 10.9 13A603

 

RealtekRTL8111
VoodooHDA 2.8.4
 
No use NullCPUPowerManagement ;)
No use DSDT
No use SSDT 
 
use chameleon 2437 
the kernel Bronya rc2 use v1 opemu Bronya   (the Kernel 14.0.0 the Darwin the Version 14.0.0: Friday, November 14, 2014 00:59:36 (MSK); root: xnu -2782.1.97 / BUILD / obj / RELEASE_X86_64 x86_64)
 
Sleep no works 
USB3 no works works !!   :thumbsup_anim:
 
 
 
Software: All works except iCoud. (Useless)
 
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
        <key>EthernetBuiltIn</key>
	<string>Yes</string>
        <key>AtiConfig</key>
	<string>Lotus</string>
	<key>AtiPorts</key>
	<string>2</string>
	<key>Kernel Flags</key>
	<string>npci=0x2000 dart=0 -f</string>
</dict>
</plist>

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
	<key>SMbiosdate</key>
	<string>10/12/2012</string>
	<key>SMbiosvendor</key>
	<string>Apple Inc.</string>
	<key>SMbiosversion</key>
	<string>IM131.88Z.010A.B05.1210121459</string>
	<key>SMboardproduct</key>
	<string>Mac-FC02E91DDD3FA6A4</string>
	<key>SMfamily</key>
	<string>iMac</string>
	<key>SMmanufacturer</key>
	<string>Apple Inc.</string>
	<key>SMproductname</key>
	<string>iMac13,2</string>
	<key>SMserial</key>
	<string>C02LRU80DNMP</string>
	<key>SMsystemversion</key>
	<string>1.0</string>
</dict>
</plist>

machdep.user_idle_level: 0
machdep.cpu.max_basic: 13
machdep.cpu.max_ext: 2147483678
machdep.cpu.vendor: AuthenticAMD
machdep.cpu.brand_string: AMD Athlon(tm) 5350 APU with Radeon(tm) R3     
machdep.cpu.family: 22
machdep.cpu.model: 0
machdep.cpu.extmodel: 0
machdep.cpu.extfamily: 7
machdep.cpu.stepping: 1
machdep.cpu.feature_bits: 4528406856356068351
machdep.cpu.extfeature_bits: 1531285442464578559
machdep.cpu.signature: 7343873
machdep.cpu.brand: 0
machdep.cpu.features: FPU VME DE PSE TSC MSR PAE MCE CX8 APIC SEP MTRR PGE MCA CMOV PAT PSE36 CLFSH MMX FXSR SSE SSE2 HTT SSE3 PCLMULQDQ MON SSSE3 CX16 SSE4.1 SSE4.2 MOVBE POPCNT AES XSAVE OSXSAVE AVX1.0 F16C
machdep.cpu.extfeatures: SYSCALL XD 1GBPAGE EM64T LAHF LZCNT PREFETCHW RDTSCP TSCI
machdep.cpu.logical_per_package: 4
machdep.cpu.cores_per_package: 4
machdep.cpu.microcode_version: 21
machdep.cpu.processor_flag: 1
machdep.cpu.mwait.linesize_min: 64
machdep.cpu.mwait.linesize_max: 64
machdep.cpu.mwait.extensions: 3
machdep.cpu.mwait.sub_Cstates: 0
machdep.cpu.thermal.sensor: 0
machdep.cpu.thermal.dynamic_acceleration: 0
machdep.cpu.thermal.invariant_APIC_timer: 0
machdep.cpu.thermal.thresholds: 0
machdep.cpu.thermal.ACNT_MCNT: 1
machdep.cpu.thermal.core_power_limits: 0
machdep.cpu.thermal.fine_grain_clock_mod: 0
machdep.cpu.thermal.package_thermal_intr: 0
machdep.cpu.thermal.hardware_feedback: 0
machdep.cpu.thermal.energy_policy: 0
machdep.cpu.xsave.extended_state: 7 832 832 0
machdep.cpu.arch_perf.version: 0
machdep.cpu.arch_perf.number: 0
machdep.cpu.arch_perf.width: 0
machdep.cpu.arch_perf.events_number: 0
machdep.cpu.arch_perf.events: 0
machdep.cpu.arch_perf.fixed_number: 0
machdep.cpu.arch_perf.fixed_width: 0
machdep.cpu.cache.linesize: 64
machdep.cpu.cache.L2_associativity: 16
machdep.cpu.cache.size: 2048
machdep.cpu.tlb.inst.small: 32
machdep.cpu.tlb.inst.large: 8
machdep.cpu.tlb.data.small: 40
machdep.cpu.tlb.data.small_level1: 512
machdep.cpu.tlb.data.large: 8
machdep.cpu.tlb.data.large_level1: 256
machdep.cpu.address_bits.physical: 40
machdep.cpu.address_bits.virtual: 48
machdep.cpu.core_count: 4
machdep.cpu.thread_count: 4
machdep.vectors.timer: 221
machdep.vectors.IPI: 222
machdep.pmap.hashwalks: 1685760
machdep.pmap.hashcnts: 3409483
machdep.pmap.hashmax: 39
machdep.pmap.kernel_text_ps: 2097152
machdep.pmap.kern_pv_reserve: 4000
machdep.memmap.Conventional: 4238385152
machdep.memmap.RuntimeServices: 0
machdep.memmap.ACPIReclaim: 0
machdep.memmap.ACPINVS: 798720
machdep.memmap.PalCode: 0
machdep.memmap.Reserved: 38842368
machdep.memmap.Unusable: 0
machdep.memmap.Other: 0
machdep.tsc.frequency: 2049999300
machdep.tsc.deep_idle_rebase: 1
machdep.tsc.nanotime.tsc_base: 60199215827
machdep.tsc.nanotime.ns_base: 0
machdep.tsc.nanotime.scale: 2095106713
machdep.tsc.nanotime.shift: 0
machdep.tsc.nanotime.generation: 2
machdep.misc.panic_restart_timeout: 1266874889
machdep.misc.interrupt_latency_max: 0x0 0xde 0x71ae1
machdep.misc.machine_check_panic: 
machdep.misc.timer_queue_trace: 
machdep.misc.nmis: 0
machdep.eager_timer_evaluations: 885
machdep.eager_timer_evaluation_max: 522033
iMac-the-gils: ~ $ gils 


Can you tell me which Yosemite build  did you use ?

 

 

  • 2 weeks later...

CPU: AMD FX - 4100 OC 4.0 Ghz 
Motherboard: Asus M5A78L-M LX V2

Chipset:AMD 760G (780L)/SB710

RAM: 8GB 800MHz DDR3 Kingston
HDD: SSD 128 Gb Kingston Hyper X- 1 Tb Seagate 
USB : 2.0 All working front and rear 
GPU: GeForce GTS 450 1GB (GE=Yes)
LAN: Realtek RTL8111N

Sound:Focusritte Scarlette 2i2 Usb

Installed OS':Yosemite 10.10.5

Bootloader: Enoch

Installation Method: Retail USB

  • 1 month later...

Zrzut_ekranu_2017_01_02_o_22_43_01.png

 

CPU: Athlon 640 No-OC
Motherboard: Asus m5a97

RAM: 12gB 1333mhz
HDD: Samsung Evo 850 (SSD) for OS X (I got also HDD for Linux/Windows). 
USB : All working, maybe some issues, not sure.
GPU: 6790 HD 1gB vRAM No-OC (yes, it works, but got slower performance than Intel's iGPU and also when I play CS:GO there are some graphical issues)
LAN: Built-in mobo

Sound: Built-in mobo

Installed OS: El Capitan 10.11.6 + Ubuntu 16.04 + Windows 10

Bootloader: Enoch

Installation Method: Retail USB, because distros are for noobs!

  • 3 weeks later...

TkA9qn2.png

CPU:amd a10 5800k

MOBO:asus f2a85 v-pro

RAM:8GB

STORAGE:toshiba 1tb 7200rpm hdd,sandisk x300 ssd

USB:usb 3.0 using caldigitfastio.kext,usb 2.0 all ports are working using appleusbohcipci.kext

LAN:realtek 811

GPU:Palit 8500 gt

SOUND:alc 892 voodoo hda

Bootloader:Clover 4049

Installed OS:mavericks 10.9.0.yosemite 10.10.4,macOS sierra 10.12.4

  • 2 months later...

Thought I'd post an update on my System :)

 

8mmGfaD.png

 

CPU: AMD FX 4300

 

Motherboard: GIGABYTE 78LMT-USB (rev 6.0)

Chipset: North Bridge: AMD 760G - South Bridge: AMD SB710 (SuperVIAATA.kext)

RAM: 6GB

HDD: 1x 2TB Seagate 1x 640GB WDC 1x500GB WDC

USB : 2.0 / 3.0 Both Working

GPU: GeForce GT430 1GB ( Works OOB with GraphicsEnabler=Yes )

WLAN: Atheros AR5B91 with PCI Adapter ( Works OOB )

LAN: Realtek RTL8111 ( RTL8111.kext )

Sound: HDMI

Sleep: Works ( Sort Of )

Monitor: 32" HD TV ( Spoofed as Apple Thunderbolt Display )

Bootloader: Enoch installed to ESP set to auto boot OS X

Other: iCloud on El Capitan/Sierra works OOB. Working Bluetooth.

Installation Method: Retail USB

Installed OS': Sierra 10.12.4 - El Capitan 10.11.6 - Windows 10 Pro Insider

  • Like 6

Main AMD system 

Latest 10.12.4 Sierra. Nvidia Web drivers 

App store and i-Message worked OB

Using latest Enoch r2877 

WiFi and Bluetooth work normally 

USB 2.0 and 3.0 work also. 

 

I would have never got it all working without all the help from Insanely Mac and AMD-OSX! Much appreciated to both sites for all there Wisdom :)

 

An update to the system..

Currently running 10.12.6 

Latest Nvidia drivers 

All USB 2.0 and 3.0 Seem to still be working. 

Switched to Clover bootloader r4114. UEFI mode. 

All still working flawless to date. 

post-1420666-0-62427000-1492805590_thumb.png

Extra.zip

config.plist.zip

  • Like 2
  • 8 months later...

macOS 10.12.6 (16G1114)

 

CPU: AMD FX-8350

Mobo: GA-970A-DS3P FX (rev. 2.1)

RAM: 1 x 8GB DDR3 1866 MHz

GPU: GigaByte GeForce GTX 750Ti 2GB (GV-N75TD5-GI) (Nvidia web drivers + LiLu + NvidiaGraphicsFixup)

Ethernet: Realtek  RTL8111/8168B

Sound: VoodooHDA (version 2.9.0d10)

Kernel: Shaneee kernel

boot flags: npci=0x2000 nvda_drv=1 -f -v EthernetBuiltIn=Yes kext-dev-mode=1

bootloader: installation was with Enoch, but post-installation is with Clover

extra kexts: DummyUSBEHCIPCI, DummyUSBXHCPCI, GenericUSBXHCI, VoodooTSCSyncAMD, FakeSMC (well that's obligatory) and NullCPUPowerManagement

 

The system is running really smoothly and with Geekbench4 i have the same results as on Windows. The only problem was at the beginning with the installation and all the USB errors. Once i used the proper kexts (DummyUSB* and GenericUSB) it was smooth sailing from there. Sound is working really well thanks to VoodooHDA (there's just no point in trying to get Realtek 887 audio to work).

 

 

post-1257632-0-55695000-1514913151_thumb.png

  • Like 2
  • 1 year later...
On 12/19/2012 at 4:52 AM, theconnactic said:

Only AMD builds. Only tested working builds. Post your successful OSX instalation, listing CPU, Motherboard (detailing what works and doesn't), OSX version, boot loader brand and revision, with the boot flags if possible, graphics, sound and any other information you can or want to share with your fellow AMD users.

 

I'll be the first:

 

AMD Athlon II X2 250 3.0 GHZ;

 

ECS EliteGroup A780 LM-MB:

- Audio codec VIA 1705 (working with Voodoo HDA)

- LAN RTL 8111E (not working)

- On-board video ATI HD3100 (not working, neither QE/CI nor resolution)

- 6 USB ports, 4 rear, two front, USB 2.0, all working

- PS2 working but unstable with VoodooPS2;

 

GeForce G210 VGA/DVI/HDMI - QE/CI with all outs in both Snow Leopard and Lion with GraphicsEnabler=Y, HDMI audio with VoodooHDA;

 

Network card (PCI-e): RTL 8168, worked out of the box;

 

Bluetooth USB dongle: Cambridge Silicon Radio Firmware v. 3164, bluetooth 2.4.5f3;

 

8 GB RAM;

 

3 HDs: 1x500GB (250 for each OS), 1x40GB (IDE, for Windows, not seen on OSX), 1x500GB (time machine);

 

Snow Leopard 10.6.8, 32-bit kernel from AnV (http://www.osx86.net...do=file&id=1675) with 64-bit user land: take a little while to boot, but shuts down and restart in less than 3 seconds. For using more than 4GB of RAM, i had to use this method: [GUIDE] Use more than 4gb RAM on AMD with 32 and 64 bit apps ..., bootflags: legacy_kernel arch=i386 -force64, GraphicsEnabler=Y, npci=0x2000;

 

Lion 10.7.5. 32-bit kernel (connactic.zip) in pure 32-bit mode (-legacy): had to swap the stock finder with this one: Finder from Lion DP 2 - Downloads - OSx86.net), iCloud with this method: iCloud for AMD hackintoshes: a workaround. - OSx86 10.7 (Lion ... and solved the core apps crashing using jeaton's method:

 

1) Wait for xpchelper to crash

2) Open terminal and type these in:

"sudo su"

"cd /private/var/folders"

"find /private/var/folders/ -type f | grep -i com.apple.xpchelper.cache"

3) cd to the first one that shows up on the list (it will be in a separate folder from the other xpchelper caches)

"rm -r com.apple.xpchelper.cache"

"pico com.apple.xpchelper.cache" ---> hit ctrl+o to save and ctrl+x to exit

"chflags uchg com.apple.xpchelper.cache"

4) Reboot and you're done!

 

Bootflags: connactic arch=i386 -legacy, GraphicsEnabler=Y, npci=0x2000;

 

Chameleon bootloader 2.2, installed with this package (no modules selected): Chameleon 2.2svn r2117 - Downloads - OSx86.net

 

Least but not last: Geekbench 64bit: 4450! (screenshot in the zip file: Screen shot 2012-12-19 at 7.18.55 AM.png.zip)

 

Post yours!

can i make a hackintosh with this build??

  

amd phenom tm ii x4 965

 gigabyte ga 78lmt s2

memory 4gb ddr3

ati radeon 3000 graphics

can i make a hackintosh with this build??

  

amd phenom tm ii x4 965

 gigabyte ga 78lmt s2

memory 4gb ddr3

ati radeon 3000 graphics

  • 2 years later...

 

My huge victory, i'm install catalina on my HP Proliant DL385 G7

unnamed.jpeg.de46126f255c3b12fee5a99914b53fe8.jpeg

 

CPU: 2x AMD Opteron 6238 (24cores 2.6GHz)


RAM: 64GB (8 channel 16x4gb sticks)

HDD: 320GB WD Black ( With usb type-c adapter )

USB : 2.0 ( Works with XLNCUSBFix.kext & usb 1.1 speed )/ 3.1 ( Works OOB USB 3.1 card - exegate exe-313 )

GPU: Asus Radeon RX470 4GB ( Works OOB )

WLAN: NoName 802.11ac NIC USB Adapter ( 
RtWlanU1827.kext + RtWlanU.kext + Wlan APP )

LAN: NetXtreme II BCM5709 Quad Port ( Kext not found )

Sound: USB Sound card (cm108 chip) + type-c to jack3,5 with dac ( Works OOB )

Sleep: not work on any OS

Monitor: 21,5" Lenovo


Bootloader: Clover EFI 5138

Installed OS: macOS Catalina 10.15.7 (19H2)  + Windows 10 Pro

444224630_2021-07-2118_38_39.png.ad7b6f48c6347bcd1cdd243298524b80.png

Edited by Magomedov_05_RUS
×
×
  • Create New...