Jump to content

Leaderboard

The search index is currently processing. Leaderboard results may not be complete.

Popular Content

Showing content with the highest reputation on 01/29/2020 in all areas

  1. 3 points
    Build 19D76
  2. 2 points
    Slice

    Clover General discussion

    I made the follow Device (PRRE) { Name (_HID, EisaId ("PNP0C02") /* PNP Motherboard Resources */) // _HID: Hardware ID Name (_UID, "PCHRESV") // _UID: Unique ID Name (_STA, 0x03) // _STA: Status Method (_CRS, 0, Serialized) // _CRS: Current Resource Settings { Name (BUF0, ResourceTemplate () { Memory32Fixed (ReadWrite, 0xFD000000, // Address Base 0x006A0000, // Address Length ) Memory32Fixed (ReadWrite, 0x00000000, // Address Base 0x00000000, // Address Length _Y16) Memory32Fixed (ReadWrite, 0xFD6F0000, // Address Base 0x00910000, // Address Length ) // Memory32Fixed (ReadWrite, // 0xFE000000, // Address Base // 0x00020000, // Address Length // ) Memory32Fixed (ReadWrite, 0xFE200000, // Address Base 0x00600000, // Address Length ) Memory32Fixed (ReadOnly, 0xFF000000, // Address Base 0x01000000, // Address Length ) IO (Decode16, 0x0000, // Range Minimum 0x0000, // Range Maximum 0x01, // Alignment 0xFF, // Length _Y15) }) And then add PMC device as in example.
  3. 1 point
    nmano

    ACPI patches for Sleep

    DSDT patches for Sleep I made this patches for All latest motherboard. Just Add 9 ACPI patches Clover or Open Core. config-Clover.plist config-OC.plist Enjoy. Thanks for your Likes.
  4. 1 point
    I have put together this simple little guide for anybody wanting to use a Patched DSDT EFI with the same configuration as me. This is also a thread to discuss everything Z390 Pro and try and help where we can and maybe make things a little better for you. A huge massive thank you to @glasgood @MaLd0n @larabee These three guys have helped me and talked me so much and are as helpful as you could ever get, Without them I wouldn't have a perfect working build like I do or be putting up this Guide & Discussion Thread sharing the hard work and countless hours that we have all put in to this. This EFI and Patched DSDT have been created to work with a Gigabyte Aorus Z390 Pro, 9900k with a Vega 56 but has also been tested and verified fully working with the following Hardware using Catalina 10.15.4 CPU's 8600K, 8700, 8700K, 9400K, 9600K, 9700K, 9900K, 9900KS (All KF Models work but use SMBios iMacPro1,1 instead) GPU's RX 560, 570, 580, 590, Vega 56, Vega 64, Radion VII, RX 5500, 5500 XT, 5600, 5600 XT, 5700, 5700 XT (If you have success with any different CPU or GPU's then please do let me know) @glasgood Has kindly put together a new simple Catalina install guide so Just Follow He's Guide For a Perfect Install. HARDWARE USED • Intel I9 9900k • Gigabyte AORUS Z390 PRO • Sapphire Nitro+ SE Vega56 (connected to monitor with DisplayPort) • Corsair Vengeance Pro RGB 16GB @3200mhz (2 x 8GB) • Corsair RM850x 80 Plus Gold Power Supply Unit. • CoolerMaster MASTERLIQUID ML360R RGB CPU Cooler • Samsung 970 EVO 1TB NVMe SSD macOS Catalina 10.15.3 • Samsung 860 EVO 1TB SSD (2.5) Windows 10 Pro • ABWB BCM94360CS2 802.11AC WI-FI With Bluetooth 4.0 PCI-Express (PCI-E) • Lian Li PC-O11DW Dynamic ATX Case WORKING • Sound • Ethernet Port • WiFi • SSD Trim • USB 3.0 & 2.0 (All ports Open Natively) • AirDrop • iCloud • Hardware Acceleration • iMessages • Facetime • Sleep & Wake • Sleep and Shutdown via the Power Button • Handoff • Netflix on Safari browser • Continuity • Sidecar CLOVER & OPENCORE EFIs Current EFIs Updated 01/06/2020 Clover EFI Update - 01/06/2020 - Use with Bios revision F12d Only or Replace with the older F11 DSDT if you don't want to update the bios  Clover Z390 Pro Navi Vega EFI 010620.zip - Vega, Navi (5700, 5700XT etc), Radeon VII DSDT EFI Clover Z390 Pro Polaris EFI 010620.zip - RX500 Polaris Series (RX590, 580, 570 etc) DSDT EFI  Please Note - I have now set KernelPM to No as standard so if you don’t have a unlocked MSR or not using my MSR Unlocked Bios Profile then go into the Clover Config.plist and set KernelPM to Yes or you won’t be able to boot up. An even better fix would be to unlock your MSR using my profile method. Note - If your not using a 5700 XT or any other Navi GPU then remove agdpmod=pikera from the boot arguments. OpenCore EFI Update - 01/06/2020 Myself and @texem have now created a OpenCore EFI done the way the OpenCore Devs intended it to be made, There is no DSDT in use so you can use this EFI on any supported GPU and the SSDTs have been made so they will not be used in any other Operating System apart from MacOS. OpenCore 059 Z390 Pro 19,1 010620.zip - OpenCore v0.5.9, SMBios iMac19,1 OpenCore 059 Z390 Pro 1,1 010620.zip - OpenCore v0.5.9, SMBios iMacPro1,1 (IGPU Disabled) Note - If your not using a 5700 XT or any other Navi GPU then remove agdpmod=pikera from the boot arguments. Note 2 - Do not try to carry across your old OpenCore Config.plist to the new EFI as to many changes have occurred in 0.5.9. Use the new Config.plist instead. PlistEdit Pro.zip - PlistEdit Pro (use to edit OpenCore) For OpenCore Using PlistEdit Pro add your details by modifying the following PLEASE NOTE - These EFIs are setup to be used with your msr Unlocked so make sure you use the F11c Unlocked Profile but if for any reason you can not unlock MSR then just modify following in the OpenCore config.plist :  Default USB Setup For All OpenCore EFIs   PLEASE NOTE - Please flash your motherboard bios to revision F12d to use my current Clover EFI. It’s a major rework of the bios and vital changes have been made to the layout and power tables. New DSDTs have been created and installed into the new EFI’s but will not work correctly with any other bios revision. Latest Gigabyte Z390 PRO BIOS (F12d) mb_bios_z390-aorus-pro_f12d.zip CFG Unlock (MSR) F12d (F12c Pro WIFI) BIOS Profile - The Easy Way Highly recommended if your using a Vega 56/64, Radeon VII or Navi GPU DSDT's FOR CLOVER ONLY (A big thanks to @MaLd0n for compiling these DSDT's) To Create Your Own Patched DSDT Message @MaLd0n using the link bellow https://www.olarila.com/forum/17-dsdt-patch-requests/ (If you want a perfect setup then getting your own patched DSDT made would be the best thing to do, Mine will work perfectly fine but different hardware no matter how small a change it is can tend to have some sort of effect on the DSDT and your setup) If Your Not Using File Vault Then Please Disable Hibernate disablehibernate.command ADDITONAL DOWNLOADS Clover Clover Configurator Kext Updater OPTIONAL DOWNLOADS BroadcomFix.zip (Use these kexts if your Broadcom bluetooth/Wifi isn't working properly) FakeSMC (Can be used instead of VirtualSMC) Hackintool IORegistryExplorer Native Display Brightness with MonitorControl BIOS SETTINGS (Bios Revision F12d) • Enter BIOS → Press F12 → Enter Setup • Save & Exit → Load Optimized Defaults • Boot -> Windows 8/10 Features -> Win 8/10WHQL • Boot -> CSM Support -> Disabled (Can be set to Enabled if need be but try to have it set to Disabled first) • Favourites -> Extreme Memory Profile (X.M.P.) -> Profile1 • Favourites -> VT-d -> Disabled (Can be set to Enabled or Disabled, Your choice) • Settings -> IO Ports -> Internal Display Output -> PCIe 1 Slot • Settings -> IO Ports -> Internal Graphics -> Enabled (Set to Disabled if using SMBios iMacPro1,1) • Settings -> IO Ports -> DVMT Pre-Allocated -> 64M • Settings -> IO Ports -> DVMT Total GFX0-Allocated -> 256M • Settings -> IO Ports -> Aperture Size -> 256MB • Settings -> IO Ports -> Audio Controller -> Enabled • Settings -> IO Ports -> Above 4G Decoding -> Enabled • Settings -> IO Ports -> USB Configuration -> Legacy USB Support -> Auto • Settings -> IO Ports -> USB Configuration -> XHCI Hand-off -> Enabled • Settings -> Miscellaneous -> Software Guard Extensions (SGX) -> Disabled • Settings -> Platform Power -> Platform Power Management -> Enabled • Settings -> Platform Power -> ErP -> Enabled • Settings -> Platform Power -> RC6(Render Standby) -> Enabled • Save & Exit → Save & Exit Setup SCREENSHOTS
  5. 1 point
    this is OPEMU for Lilu Plugin Intel Haswell Pentium / Celeron Series Or older processor expansion instruction set Emulation USAGE: copy Lilu.kext & OpcodeEmulator.kext To /EFI/CLOVER/kexts/Other/ NOTE: if it don't work, please rebuild Lilu and OpcodeEmulator On Your Machine. Lilu Releases: https://github.com/acidanthera/Lilu/releases UPD: 2017/11/17 FIX kernel_trap UPD: 2019/02/11 BMI1/BMI2 Instruction Set Fix UPD: 2019/02/15 Store & Load x86/x64 Register Fix UPD: 2019/02/18 Modrm Addressing、XMM/R64/R32 Register Store & Load Fix UPD: 2019/02/20 BMI1/BMI2 Instruction Set Completed UPD: 2019/02/22 IMM Byte Fix UPD: 2019/03/03 High Sierra Support UPD: 2019/03/07 "lock" & "ud2" instruction return UPD: 2019/04/08 add YMM Register & F16C Instruction Set & VSSEX Instruction Set UPD: 2019/04/25 add AES / VAES Instruction Set、AVX 2.0 Gather Instruction、VSIB Addressing UPD: 2019/05/03 add AVX / AVX2 / FMA Instruction Set UPD: 2019/05/15 VSSE (VEX SSE) 、VSSE2 (VEX SSE2) Instruction Set Completed. UPD: 2019/05/18 VSSE3、VSSSE3、VSSE4.1 VSSE4.2 Instruction Set Completed. UPD: 2019/05/19 add "vpclmulqdq" instruction. & fix BMI andn & bzhi instruction. UPD: 2019/05/20 add "sysenter"、"sysexit" instruction for AMD Machines 32-bit Mode UPD: 2019/05/21 add "vpclmulqdq" VEX.256 Version & Update Lilu to 1.3.5 (Build based on Lilu 1.3.5) UPD: 2019/05/25 YMM Register Store & Load FIX. AVX、AVX 2.0 Opcode Emulator Completed. OpcodeEmulator-20190525.zip
  6. 1 point
    Insanelyhack.com

    OpenCore Builder 5.7 (NEW)

    Download and Auto-Compile OpenCore, Drivers and General Kexts (Debug or Release) https://github.com/Pavo-IM/ocbuilder/releases
  7. 1 point
    SUN_sw1

    Catalina MBR HFS Firmware Check Patch

    Hi, crazybirdy: Thanks a lot for your great job! macOS Catalina 10.15.3 19D76 test passed on my hackintosh build: i5-6400 + MSI B250M G1 Gamer + Samsumg PM951 256G m.2 SSD ! Intel HD530 Graphic , ALC892 audio, Realtek8111 ethernet works fine, except sleep wake. But there is a bug, the icon of my system volume (testOS) is a folder icon. It takes long time before get into desktop for the first time.
  8. 1 point
  9. 1 point
    iCanaro

    [Release] macOS Catalina 10.15.3 is out!

    hack 2 signature
  10. 1 point
    gcenx83

    Wineskin Unofficial Update

    @Slice sorry I don’t come here much it’s always better to open an issue on GitHub or contact me via Discord. The issue you’re mentioned was resolved PaulTheTall contacted about the issue, seems 7z likes a fixed path so I’d removed it and let winetricks just use the windows version to extract 7z files. ulimit -S -n 2048 # or whatever number you choose You could properly add that to the “Custom CLI” field. In other news I’ve also added something interesting WineCX19.0.1 that contains macOS Catalina support if SIP is disabled.
  11. 1 point
    You need to press spacebar to see all hidden boot options, EFI, tools, hidden entries. ( It is explained in the first page of this thread )
  12. 1 point
    Hervé

    macOS Catalina 10.15.3 est disponible

    La routine... Ca roule tout seul; c'est plus drôle, on s'ennuie!
  13. 1 point
    Slice

    HWSensors3

    @tyufhl Здесь по-русски запрещено, есть отдельная ветка где можно. AppleIntelInfo panics because it uses MSR registers not allowed on some CPUs. Panics observed by numerous users. Just wonder why such non-safe kext appears in DarwinDumper.
  14. 1 point
    No need to quote every message in your replies; direct replies using the dedicated box at bottom of threads do perfectly.
  15. 1 point
    nmano

    OpenCore Discussion

    Thats detail from https://www.insanelymac.com/forum/applications/core/interface/file/attachment.php?id=341489
  16. 1 point
    vandroiy2012

    OpenCore Discussion

    Just enable this patch. It's an RTC problem. Or you can use RTCMemoryFixup.kext https://github.com/acidanthera/RTCMemoryFixup
  17. 1 point
    Ok, so I got a reply from the OpenCore developer: https://github.com/acidanthera/bugtracker/issues/681
  18. 1 point
    Andrey1970

    OpenCore Discussion

    Delete it: And add HfsPlus.efi HfsPlus.efi.zip
  19. 1 point
    Pavo

    OpenCore Discussion

    It will compile the latest commits on GitHub.
  20. 1 point
    Download-Fritz

    OpenCore Builder 5.7 (NEW)

    @drayon I have heard OpenCore is Open Source, maybe you can spend the time complaining on working instead.
  21. 1 point
    This is what worked for me in Catalina final- - Disable SIP from recovery - Get Hackintool - Unlock it (Bottom left corner) - In Tools tab, run Disable Gatekeeper (Home icon on the bottom) - Run the installer by Cyberdevs
  22. 1 point
    When you get to the main screen do you receive a "there is a problem with the graphics" related message? I have a gtx 750 ti EVGA running on Yosemite 10.10.1, I had the freezes too, after months of having this problem I solved it using this bootflag: msibase=0x90 Since then I've been having my GPU fully working, hope it helps you
  23. 0 points
    Hi, Im glad to hear your happy buddy and in answer to your question its a no, when your using the gpu you can only use the igpu in headless mode im afraid. trying to use it usually results in a crash straight away. A cheap second compatible AMD card would be your best option if you need more outputs.
  24. 0 points
  25. 0 points
    Because I several people pinged me privately about this, I want to quickly clarify why none of these are going to be merged. - ACPI/SMBIOS: While that hasn't always been applied properly for time and resource reasons, but OpenCore is definitely aimed to be deterministic and be formally verifiable. For example, we want to be able to assert "SMBIOS and ACPI data have been patched when macOS boots" (assuming there are no errors). Now, if we also want to assert "SMBIOS and ACPI data have not been patched when Windows boots", we may run into consistency issues. For example take we boot a system for which SMBIOS and ACPI are patched, the booter returns to OpenCore, and then a system is booted for which such shall not be patched - we cannot easily roll those changes back. There are two approaches to resolve this: Make it unconditional -or- do not allow error-exits of loaded images. We opted for former for multiple reasons, among of them that the whole reason ACPI exists is to abstract for *any* OS (which works in practice, at least as far as we are aware, at least with _OSI) and things like Boot Camp tools support in Windows. Also, we do not see any reason why anyone would insist on booting anything but macOS from OpenCore, you may just as well use the firmware boot menu (Clover has caused Windows boot issues as well several times in the past). For many design reasons, OpenCore just ensures a consistent environment instead of supporting a specific OS boot whereever possible. - W hotkey: We believe that even the X hotkey is bad design, but it was added as part of Apple UEFI consistency. This is not the case for W, there simply is no good point in having it at all. - non-verbose APFS: Using apfs.efi is terrible practice and nobody will ever be supported in any way using it. - duplicated entires: You can rename entries with .contentDetails just fine, there simply is no point in having auto-scan *and* custom entires describe the same thing. It's a pointless complication of the control flow and adds complexity to the semantics ("adds an entry *except* when it already exists, where it overwrites"), especially latter we try to avoid at all cost (e.g. "Add" *never* replaces anywhere else). - boot entry with arrow keys: Well, this is discussible, but I simply see no point? Numbers are one key each, arrow keys is arbitrarily many (depending on entry count). - last booted entry: The only reasons I have ever heard in favour of this is updates, for which nobody has reported whether it even is an issue - both macOS and Windows *are* aware they can use BootNext to have be booted on the next startup, so they might actually. Other than that, it wears the SPI flash, requires a new config option and yet again complicates the flow. - hiding tools/recovery by default: OC's boot menu is very small already having a text nature, there yet again simply is no reason to do this. If there are more than a dozen entries, I would call the setup busted. Unused recovery environments can be deleted, some tools might better be off started by UEFI Shell, etc. - fixed Apple logo: I do not know of any present issues and there is no description of how this had been fixed, so nothing to really do here. If you want to submit a bugreport and a fix proposal for this, that'd be good. @n.d.k I'd be glad if you could make sure your fork is easily recognised as such from both boot menu and log, like appending a suffix ("OpenCore-ndk"?) and I'm thinking we actually want that as part of a license extension, as we only want to support release binaries from our GitHub page (not even own compilations, except proper bug reports of course). Other than that, while we do not agree with your changes, the whole point of OSS is a level of freedom, so we wish you the best of luck with adapting this to suit your needs! EDIT: arrow keys were implemented to support bugged laptop hotkeys in the future. Hiding Recovery *might* be considered as, and I didn't realise this when writing this post, Apple hides it in most situations as well

Announcements

  • Newsletter

    Want to keep up to date with all our latest news and information?

    Sign Up
×