Jump to content

OSX86 10.5 Leo [ToH]-RC2 SSE3/SSE2 Intel Only


379 posts in this topic

Recommended Posts



Ladies and gentlemen, ToH brings the latest and greatest from Apple to your PCs.


First release of RC2 had some problems that did not allow to install. This one works!!


This is the second public release candidate (RC2) of the Install Kit of Mac OS X Leopard for grey X86 PCs.



Because of the above mentioned reason, it lacks some things. Those features will be added via PPFs.


Therefore, INTEL PC users can download and install it as it is, while others can get it and wait for the PPF.


What it can do:


Run on INTEL SSE2 and SSE3 machines

It might upgrade OS X Tiger X86 to Leo X86

It has support for NoNX/NoHPET/etc

The kernel can work on AMD machines

It has all the languages and printer drivers





What it doesn't do:


It's not yet ready for AMD machines, because of missing decrypts

It doesn't have all the patches you used to find on the old OSX86 DVDs





A PPF should be out in a day or two which will add AMD support and other goodies, so all can enjoy them.



MD5 Checksum:


83909703A60283FFC8F3DA1D8A8594F0 *ToH_x86_9A581_RC2.iso






To the would-be users:


This DVD should only be used to preview Mac OS X Leopard. If you really like Mac OS X Leopard and you want to use it,


you should get a real Mac. If buying a real Mac is too much, you can, at least, buy a license for Mac OS X Leopard.





To Apple:


Think of this as of a demo version and as of a free marketing campaign. Therefore, let it be .





It seems that some people can't boot their Leopard after installing it. I'm not sure what it looks like but I assume they don't get into Darwin's Bootloader without building a bridge with the Install DVD. So rofl aka roflcopterguy found a solution for this I think



Boot into the install DVD

Open Terminal from the disk


/usr/misc/script.sh VOLNAME

(where VOLNAME is the name of your partition for example "Leopard")

Now reboot without the disk and you should have Leopard running


regards iHack



on daemon!


this 3d for collect experience





Link to comment
Share on other sites


I have a Dell Latitude D630 as well and I get the same results with this distro as with Brazilmac. The GMA3100 kext does not load properly while booting the DVD. As a result your video basically locks right as the GUI part of the installation should launch.

Link to comment
Share on other sites

I patched my own DVD using the method describe by BrazilMac, but I ended up with the problem with the Flashing _ on the screen during boot. Grabbing this release now, from the Green D, and will see how it works with the script to fix the booting problems. I will post my results tomorrow after I am done burning it,and installing.

Link to comment
Share on other sites


I have a Dell Latitude D630 as well and I get the same results with this distro as with Brazilmac. The GMA3100 kext does not load properly while booting the DVD. As a result your video basically locks right as the GUI part of the installation should launch.


I hope that the developers solve this problem soon... uphuck... kalyway... or a other "major release" solve this Hateful and paralyzing problem for the x3100 users! :)



why this 1 works!!!!


external display on benq monitor


Link to comment
Share on other sites

I have three major issues with this release:


1) As said it won`t boot on some machines without running the script after the Leopard is insalled.


2) As soon as it boots, give me a KERNEL PANIC, but I managed to copy the kernel from other Leopard installation (Brazil`s one) and it booted.


3) Now it won`t go tho the GUI, it stops after negotiating with the NIC (recongnized) and stops at mDNSResponder a few lines after detecting all other harddrives in the system.


I`ve also tried without the other drives and with -X or -S flags. None boots to the GUI.


Any help?

Link to comment
Share on other sites

I upgraded to this release!! Worked great except on my Intel D915GUX Onboard LAN not working. Sound Not working, keep getting AppleAzalia not installed correctly (I ran diskutil to fix permissions) Intel GMA915, works but no QE/CI - Tried Jas's Patch for 10.4.8 but it wouldn't run. Ohh and my mouse won't scroll or right click. Anyone have any ideas Everything worked fine in 10.4.10

Link to comment
Share on other sites

OMG! I'm having the exact same problem. My video card is also X3100 and it doesnt boot to GUI. One should do -x to boot and install. However, after installing and patching it, it gives the mDNSResponder error(not error but it just sits there doing nothing). By the way, the script.sh included in ToH image doesnt solve the blinking cursor of doom IN MY CASE. Other people reported that the script.sh worked on them. Its really confusing. I had to dual boot Tiger (1st partition), Leo (2nd partition) in order to bypass the blinking "_". After bypassing here comes the mDNSResponder problem!


Also, Can anyone confirm if LEO can be installed in an External USB HDD? I feel like it could be the reason. Please help. heres a screenshot:


My hardware is: X3100 video / GM965 Chipset / EXTERNAL USB HDD (tiger boots here perfectly) I cant install in internal because of laptop warranty reasons [sony Vaio VGN-CR140E/B]




for your reference: this is also the screenshot for the X3100 not loading properly (you have to do -x to bypass this):



Link to comment
Share on other sites

The FIXBOOT patch is not working either for me. I have to leave the Leo DVD in the drive to boot.


I found a solution to the no-boot problem, but it adds another stage: I started with an *utterly vanilla* (bare-minimum) Tiger install (kernel patches are okay; however, do *not* install any of the third-party display drivers, such as NATIT or Callisto); then installed Leopard over that. The kernel patches are fine because Leopard will replace it; however, third-party display drivers will likely need rewriting for Leopard. I have the default VESA driver in use with Leopard (there is no native support for ATI's X1650 Pro in Leopard, which is identical to the Tiger situation), which still gives me 1024x768. Because I still have the boot sector that Tiger created (this was an *upgrade*, not a bare-metal Leopard install), Leopard boots without the DVD drive being involved.


I haven't enabled the onboard sound yet (that was supported in Tiger); a reboot is upcoming to test that.


The onboard sound works a treat in Leopard; no special fiddling needed.


*However*, no resolution switching (any attempt to fix using ATIinject/NATIT/other method results in a KP), so I modified my upgrade method by adding the AGPGart 2.2 kext when installing 10.4.9, then installed ToH over that. Still no resolution switching, but video performance is snappier.

Link to comment
Share on other sites

i tried to install with RC2 on d630 , boot weel with -x -v

installed in a 20gigs partition (second primary partition), preactiveted with diskpart from xp

not boot, acronis os selector not found the new os, and not found it on manual.

Link to comment
Share on other sites

@PGHammer: .kexts are "packages" - which is to say that they're directories. You'll need to cd into the .kext before you edit anything. Poke around inside the package and see if you can't find the right file to edit. I'd point you to the exact file, but I'm at work on a PC and don't recall at the moment. It should be obvious.

Link to comment
Share on other sites



You have to cd into the kext as it is indeed a directory. You probably need to do the following:


sudo nano name-of-kext/Contents/Info.plist


Then edit and save and the usual chown and chmod to give the kext the right access properties.

Link to comment
Share on other sites


  • Create New...