Jump to content

asapreta

Members
  • Content count

    682
  • Joined

  • Last visited

About asapreta

  • Rank
    InsanelyMac Legend
  1. asapreta

    [GUIDE] USB Fix El Capitan 10.11

    Hi guys. when I installed El Capitan, I was surprised my USB ports weren't working after the system booted. I managed to find which were and I was able to attach the mouse and keyboard. I tried some things then realized that, for some unknown reason my DSDT (I use it since Lion - with some improvements over the years) was preventing the USB ports to work I decided to let Clover get the DSDT and I selected the patches I needed to get the system working and got more USB ports working, but due to that my system won't shutdown or restart properly, I need to do that via Terminal, but this messes the Software Update, I miss all them. I tried to fix, following the guide on the first post but I noticed my ports (even with EHC1 and EHC2 present) are named UHC1... UHC6 in DSDT as in the picture below: Without the DSDT, booting El Capitan with the one created by Clover and patched on-the-fly they look like the picture below: I wasn't able to fix the dummy file or make the ports working by removing the ports restrictions. When I boot with my DSDT the USBs look like this in the System Report: And, if I boot without the DSDT, they are like this: I'm attaching my DSDT to see if someone can help me. On El Capitan, Clover sets my Mac as an iMac10,1. On Yosemite (where everything works) I have it set in Clover Config file as a clone of my Macmini5,3. I hope fixing the USBs will fix the Restart and Shutdown too as I`ll be able to use the DSDT again. And, my machine is still the same in the signature (Gigabyte EP45-UD3R...) Thanks in advance. DSDT.dsl.zip
  2. Thanks for the tip but I think it generates the same log as I have on boot.log on ~\Library\Logs\CloverEFI No signs of the last Kernel Panic message.
  3. Hello all! Just had two kernel panics in a row and as I did some minor changes (mostly related to make iMessage work), I wanna to track it down. But, or am I wrong, or the logs are store in a different place. I tried on ~\Library\Logs\DiagnosticReports and also on Apple Menu > About This Mac > System Report > Software > Logs (then read kernel.log) but no traces of the error on these locations. Running Yosemite DP6 with Clover (also tried the Clover Folder on \Library\Logs) on the the machine of the signature. Has it changed place?
  4. asapreta

    Imessage and facetime Public Beta 2

    Besides the number generated on the problem - customer code - (once I had the problem with my MacBook Pro) they ask for the product serial number.
  5. This may help: http://www.insanelymac.com/forum/topic/300020-imessage-and-facetime-misbehaving-again/
  6. asapreta

    Full Resolution at Clover

    Reading this topic, I grabbed the necessary data to see how it would be to have Clover full res on boot. It doesn't bother me to have just the center of the screen with BIOS/Clover. But I gave a try. I didn't used Windows to get EDID data, I followed this instructions, using IORegExplorer: http://www.insanelymac.com/forum/topic/208410-fixing-scrambledstretched-or-wrong-resolution-laptop-display-problems/ So I got this: <00 ff ff ff ff ff ff 00 4d d9 01 dc 01 01 01 01 01 14 01 03 08 a0 5a 78 0a 0d c9 a0 57 47 98 27 12 48 4c 21 08 00 81 c0 01 01 01 01 01 01 01 01 01 01 01 01 01 01 66 21 50 b0 51 00 1b 30 40 70 36 00 40 84 63 00 00 1e 0e 1f 00 80 51 00 1e 30 40 80 37 00 40 84 63 00 00 1c 00 00 00 fd 00 39 3f 1e 31 09 00 0a 20 20 20 20 20 20 00 00 00 fc 00 53 4f 4e 59 20 54 56 0a 20 20 20 20 20 00 4d> Converted to this: AP///////wBN2QHcAQEBAQEUAQMIoFp4Cg3JoFdHmCcSSEwhCACBwAEBAQEBAQEBAQEBAQEBZiFQsFEAGzBAcDYAQIRjAAAeDh8AgFEAHjBAgDcAQIRjAAAcAAAA/QA5Px4xCQAKICAgICAgAAAA/ABTT05ZIFRWCiAgICAgAE0= And added these lines to config.plist in Clover: <key>InjectEDID</key> <true/> <key>CustomEDID</key> <data>AP///////wBN2QHcAQEBAQEUAQMIoFp4Cg3JoFdHmCcSSEwhCACBwAEBAQEBAQEBAQEBAQEBZiFQsFEAGzBAcDYAQIRjAAAeDh8AgFEAHjBAgDcAQIRjAAAcAAAA/QA5Px4xCQAKICAgICAgAAAA/ABTT05ZIFRWCiAgICAgAE0=</data> Also changed the PatchBios settings to </true> When the boot reached Clover a message on the TV screen said: Incompatible Resolution, check input. But a few moments later the Apple logo appeared and system entered. As I boot verbose (-v) this part was with a resolution TV wasn't able to handle. After the system booted I noticed this: It says my TV has 71'' but it has only 32'' And here the data is correct about resolution: EDID is wrong? Am I doing something wrong? The only thing I remember not being able to use now was DVI>HDMI cable. TV and Hack are connected via VGA Cable. The system is the one on the signature, using latest Clover (downloaded today) and 10.10 DP6.
  7. asapreta

    iMessage and FaceTime - misbehaving again!

    Oh, okay. Thanks for the answer. I'll try the solution mentioned here regarding MLB and ROM and other stuff. EDIT: Using MLB and ROM like described before, iMessage worked.
  8. asapreta

    iMessage and FaceTime - misbehaving again!

    I'll give a try using my mac mini info but I also would like to know about this " package v1.2 " you're talking about. What is it?
  9. asapreta

    iMessage & Facetime is not working

    I'll try to find what I've done before that worked. It was something like this: 1. Go to system preferences, network, click on the Ethernet network adapter, click the minus button at the bottom, hit apply. 2. Go to /Library/Preferences/System Configuration/NetworkInterfaces.Plist and delete it or move it somewhere else. (just in case) 3. Open up EFI studio, change device to Ethernet, then click add device. Click write to com.apple.boot.plist then put the app to the side for now. 4. Copy this: <key>device-properties</key> <string></string> 5. Paste that in your org.Chameleon.boot.plist file which is located in /extra/org.chameleon.boot.plist. The key and the string match up with the others. Go back to the EFI Studio editor. 6. Copy the long number at the bottom and paste it in between the two strings in your chameleon boot plist file. 7. Save & Restart 8. Go in to system preferences, then network, then click the plus button at the bottom. 9. Click add in the window that pops up. It should say "Ethernet". If it has "en1" or "en0" after it, then repeat the above steps. 10. After adding that hit apply and restart one last time. 11. Go to Safari to check that you're getting internet connectivity, then continue signing into iCloud and/or the App Store! Enjoy! But as I'm on Clover I added these lines to config.plist: <key>Inject</key> <true/> <key>Properties</key> <string>my data from EFI Studio</string> But if the line is present the computer restarts upon boot
  10. asapreta

    iMessage & Facetime is not working

    I'm trying to learn and have more fun using Clover with Yosemite. And I confirmed nvram is not enabled: 37:181 0:000 Searching volumes for latest nvram.plist ... 37:181 0:000 3. Volume 'EFI', GUID = BABB544F-011F-455F-A9D7-50244469261F - no nvram.plist - skipping! 37:181 0:000 4. Volume 'Snow Leopard', GUID = 9D8F397F-8E44-4B8C-AA59-5FF784D5F891 - no nvram.plist - skipping! 37:193 0:012 5. Volume 'EFI', GUID = F9A0C493-88F4-418E-B304-3EF00739AB19 - no nvram.plist - skipping! 37:193 0:000 6. Volume 'Mavericks HD', GUID = 73F400A0-FA46-4A69-8DB4-CC593CF273ED - no nvram.plist - skipping! 37:193 0:000 7. Volume 'Recovery HD', GUID = 3F441BB4-A24F-4424-82A9-B45645135090 - no nvram.plist - skipping! 37:193 0:000 8. Volume 'OS X Base System', GUID = 4C09CFC2-68EF-4AA4-9B27-342E82E3508E - no nvram.plist - skipping! 37:193 0:000 16. Volume 'EFI', GUID = 2DDF482B-2A3F-4A58-9FAC-0BED2925EC8C - no nvram.plist - skipping! 37:193 0:000 17. Volume 'Yosemite', GUID = FF85F8FB-BB3A-4C9D-954A-6128F294459F - no nvram.plist - skipping! 37:193 0:000 18. Volume 'Recovery HD', GUID = FD7B8968-5A67-4A9A-9480-40DB1181CAF8 - no nvram.plist - skipping! 37:193 0:000 nvram.plist not found! 37:193 0:000 PutNvramPlistToRtVars: nvram.plist not found
  11. asapreta

    iMessage & Facetime is not working

    This is my question too. How to have nvram with Clover on legacy bios? I'm still in this quest just because I had it working and just tried to have a "clean" install this week and it doesn't work anymore. Also in the same guide is mentioned to click on "builtin" on DPCI Manager, but, at least in my rig, it isn't clickable.
  12. asapreta

    iMessage "!Not Delivered" issue

    Yeah, I know that. But I managed to make it work until last weekend. Reinstalled all to see how would behave the new Clover and "clean" my install and voilá, its broken.
  13. asapreta

    iMessage "!Not Delivered" issue

    Will do but as I´m new to Clover, just started using it to test Yosemite, I noticed, although it should make my ethernet builtin, it never did: Or, even after reading a lot about Clover, I missed how to make/use a command to set it builtin Tried. No go. And on the same computer all my other OSX (Snow, Lion, MTLion and Mavericks) I´m able to use iCloud, iMessage or AppStore.
  14. asapreta

    iMessage "!Not Delivered" issue

    You may have the same problem I have, your ethernet is not recognised as builtin. Also, the ethernet adaptor must be appear as Ethernet, not Ethernet Adaptor (en0) or something like that. Once I was able to make it work but now, no luck.
  15. asapreta

    Visualizador de DSDT

    Pessoal, Bom dia Existe algum programa que eu possa abrir a DSDT e ver as suasconfigurações num modo mais interativo? A pergunta se deve por conta de querer comparar a DSDT que tenho há anos e nunca me deu problema (obrigado oldnapalm e Mald0n) com a gerada pelo Clover automaticamente. Ontem tive um pequeno problema que, a princípio, foi por conta dessa DSDT.
×