Jump to content

[pre-release] macOS Ventura


1,307 posts in this topic

Recommended Posts

Posted (edited)

All the strange things happen to me .. 😁

I completed the installation normally, and I'm stuck on the first configuration screen

I have the latest editions lilu and wed i try too with and without -lilubetaall

Any ideas ? (OC 78)

 

 

Spoiler

IMG_20220607_102350.thumb.jpg.608fca692f6c27b115930518aa33fcf7.jpg

 

Edited by Moviemakergr
Link to comment
Share on other sites

Posted (edited)
32 minutes ago, Cyberdevs said:

My installation got canceled halfway through the first stage because of the installation package damage error so no luck on my end yet

Maybe we need the latest OC or updated Kexts 😥

Edited by surenmunoo
Link to comment
Share on other sites

1 minute ago, surenmunoo said:

Maybe we need the latest OC or updated Kexts 😥

I was using the latest OC and updated kexts but I had to go to work so I’ll give it another try when I get back.

  • Like 3
Link to comment
Share on other sites

Posted (edited)
9 hours ago, voll@ said:

Thanks for the help with this quirk. Great. 

But… do we lose native NVRAM with it as I understand from a @vit9696 comment?

 

EDIT: maybe alexahinmiha was the first? I am not sure. 

Edited by miliuco
Link to comment
Share on other sites

After running a few tests, I’ve come to the conclusion that macOS 13.b1 installer actually requires AvoidRuntimeDefrag quirk enabled for successful completion of installation. Users looking to clean install macOS 13 will come across issues at the moment until OC and kexts has been patched to fix the boot init issue.
 

Upgrading volume to macOS 13 via Software update is the only possible installation route for now; you’ll need to ensure the quirk is enabled during the initial installation phase and disabled when system restarts to complete the final stages. Also, use latest commit of VirtualSMC that was pushed sometime back.

  • Like 2
Link to comment
Share on other sites

Posted (edited)

I just finished watching that video from Tech Labs, and I have doubts if it is legit or not, but in the end he didn't have bluetooth working... 

On another note I updated my real Mac mini 2018 at work and the update is bigger than in my hack...

Captura de ecrã 2022-06-07, às 10.19.41.png

Edited by MorenoAv
Link to comment
Share on other sites

28 minutes ago, lucas ferreira brandao said:

successfully updated, Lenovo 330 i5 8250u, OC 0.8.1.

 

AvoidRuntimeDefrag (false)

 

-lilubetaall

 

 

 

Can you upload your efi folder you used for venture?

Thank you in advance.

Link to comment
Share on other sites

Well, I already did some more tests with my Hacks..

 

12400F------- Everything works except i225v

 

Ryzentosh---- Not working (obviously)

 

Lenovo T430--- Will not boot even with AvoidRuntimeDefrag disabled

 

Lenovo 520s--- It is installing and everything is fine, but Intel wifi is not working

Link to comment
Share on other sites

Posted (edited)

Right away, I have to say: the System Prefs menu is horrible. It's the window-fication of macOS!

 

@PoMpIs I225V works for me. But I am using a custom firmware for it. I have a T530. When I first tested I had no luck but'll try again

 

Python 3 = working

OCAT = working

Edited by 5T33Z0
  • Like 1
  • Thanks 1
Link to comment
Share on other sites

1 hour ago, Hectorsky said:

Anyone had luck with 6th gen CPU?

I stuck on no port micro and reboot instantly...


Yup, was able to successfully "upgrade" pre-installed volume (macOS 12) to macOS 13 on my Dell-Skylake laptop, however no Skylake iGPU graphic acceleration, of course, which is a real eye-sore tbh 😅

 

image.png.82f8d65eac288dd44b32c771d680a1f7.png

Link to comment
Share on other sites

Has anyone been able to do a clean install on any device? I even can't install it on a 2017 iMac it ends up with the damaged installer error. I'm re-downloading the installer right now.

  • Sad 3
Link to comment
Share on other sites

1 minute ago, Cyberdevs said:

Has anyone been able to do a clean install on any device?

That's my next move because utilising all the posted recommendations has led me to no where but constant reboots and false hopes after getting past an earlier screenshot where it stops without progress.

  • Sad 3
Link to comment
Share on other sites

×
×
  • Create New...