Jump to content

[pre-release] macOS Ventura


1,467 posts in this topic

Recommended Posts

Posted (edited)

image.thumb.png.00d8883e83bd368b4b30613b137b1f5c.png

 

Disable AvoidRuntimeDefrag, enable '-lilubetaall' in boot-args.  We have lift off.  

 

Works but definitely is an early beta. Sleep/wake works.  Fenvi Bluetooth and Wifi work, but upon wake from sleep, wifi card seems to not wake up and needs to be toggled.  Interface looks mostly similar to Monterey with the exception of the new Settings app as well as Stage Manager.  Thunderbolt hot plug is working.  

Edited by dehjomz
  • Like 2
Link to comment
Share on other sites

Just a FYI, disabling the AvoidRuntimeDefrag quirk does not work for macOS as a VM on KVM+Qemu.

  • Like 3
Link to comment
Share on other sites

19 minutes ago, PropoFlexWX4 said:

Lilubetaal is not needed?

 

It is working perfectly for me without -lilubetaall

 

........

 

I already have it installed on the 12400f, I'm happy, but the intel i225v network doesn't work..

 



C62Balf.png

 

p1olHpH.png

 

ExMLt9X.png

 

tThRNxE.png

 

 

it seems that everything works, only the i225v is missing

  • Like 5
Link to comment
Share on other sites

48 minutes ago, MaLd0n said:

The trick

 

Will the latest version of Whatevergreen 1.5.9 work or does it have to be 1.6.0?  I'm having errors compiling 1.6.0.

Link to comment
Share on other sites

Now that someone confirms that Lilu still works, Darwin version 22 will be included as of https://github.com/acidanthera/Lilu/commit/250b65cbb4e9c3aced2673b71ac359b5d6771cfe.

 

Please note, that I have not added compatibilities with plugins (e.g. AppleALC and/or WhateverGreen); so be careful! I would like to hear more about these now.

 

Also, it is a pity that Skylake is completely dropped; many older kexts including AppleIntelCPUPowerManagement are gone as well :( 

  • Like 4
  • Thanks 3
Link to comment
Share on other sites

Posted (edited)

Interestingly, while most legacy kexts have been dropped on 13.0 b1, IOPlatformPluginFamily.kext/Contents/PlugIns/ACPI_SMC_PlatformPlugin.kext still remains. Though, the binaries are gone. This means, that CPUFriend will stop working. I am looking into it.

 

EDIT: Sorry! I was wrong. CPUFriend should continue working. Instead, now binaries are only available in KC. Thanks @dhinakg for pointing it out.

Edited by PMheart
  • Like 1
  • Thanks 2
Link to comment
Share on other sites

10 minutes ago, PMheart said:

Also, it is a pity that Skylake is completely dropped; many older kexts including AppleIntelCPUPowerManagement are gone as well :( 

Pour one out for Skylake 6700K.  Was a beast back in its day.  Long live Skylake and long live z170.

  • Like 1
Link to comment
Share on other sites

Posted (edited)

i am stuck at [PCI configuration end] with x99 running on an haswell ep xeon 2680 v3.

Edited by ITzTravelInTime
Link to comment
Share on other sites

Posted (edited)

So I managed to successfully boot the installer on my Mac Pro 5,1 from 2010 which is a socket 1366 machine (mine specifically is a single cpu machine and I am using it with a xeon x5680) so can I pretty much deny that the new os requires AVX2, it could boot if you don’t have any AVX extensions. 
 

Other news is that I can also confirm that the latest release of the TINU app (which is a very easy to use app to make macOS usb installers) works with macOS 13 Ventura out of the box, so no update is needed.
 

More about the app here if you are curious: github.com/ITzTravelInTime/TINU

 

 

 

D9DE08CE-7A4E-47AB-AEEE-FA19D58A66C2.jpeg

D2DDC934-D1C8-41F4-80B1-9F7DB3B5B966.jpeg

Edited by ITzTravelInTime
  • Like 4
  • Thanks 2
Link to comment
Share on other sites

image.thumb.png.f6aa7e007d9f9172fc205098705ed7ce.png

 

Got that error in second phase installation. First installation was smooth, but when boot in to second phase i got that error notification.

I have tried with SMBIOS iMacPro1,1. iMac19,1, MacPro7.1.

Full installer from GibmacOS command

Link to comment
Share on other sites

For those trying the small update to macOS 13 (MSU_UPDATE_22A5266r_patch_13.0 with 3,67 GB) and getting an error message after download, you may want to disable your Bluetooth kexts beforehand. install.log was showing the following error messages for me.

 

softwareupdated[352]: SUOSUMobileSoftwareUpdateController: Download finished: Error Domain=SUMacControllerError Code=7740 "[SUMacControllerErrorPrepareFailed=7740] Failed to perform Prepare operation: [MobileSoftwareUpdateErrorDomain(MSU):MSU_ERR_FILESYSTEM_DOESNT_VERIFY(3)_1_MobileSoftwareUpdateBOMErrorDomain:1|FullReplacementRequired|]" UserInfo={SUMacControllerErrorIndicationsSummary=|FullReplacementRequired|, SUMacControllerErrorIndicationsMask=2, NSLocalizedDescription=ソフトウェア・アップデートの準備ができませんでした。やり直してみてください。, SUMacControllerErrorIndicationsDescription=-> Full replacement is required [as opposed to incremental patch]., NSDebugDescription=[SUMacControllerErrorPrepareFailed=7740] Failed to perform Prepare operation: [MobileSoftwareUpdateErrorDomain(MSU):MSU_ERR_FILESYSTEM_DOESNT_VERIFY(3)_1_MobileSoftwareUpdateBOMErrorDomain:1|FullReplacementRequired|], NSUnderlyingError=0x7f7aea364b50 {Error Domain=MobileSoftwareUpdateErrorDomain Code=3 "'./usr/sbin/BlueTool' does not verify" UserInfo={target_update=22A5266r, MSUFullReplacementRecommened=true, NSLocalizedDescription='./usr/sbin/BlueTool' does not verify, NSUnderlyingError=0x7f7aea3cdfe0 {Error Domain=MobileSoftwareUpdateBOMErrorDomain Code=1 "contents of '/usr/sbin/BlueTool' don't match bom (65653050 vs cd6e3fa1)" UserInfo={NSLocalizedDescription=contents of '/usr/sbin/BlueTool' don't match bom (65653050 vs cd6e3fa1)}}}}}
SoftwareUpdateNotificationManager[983]: SUOSUUpdateController: Download error: Error Domain=SUMacControllerError Code=7740 "[SUMacControllerErrorPrepareFailed=7740] Failed to perform Prepare operation: [MobileSoftwareUpdateErrorDomain(MSU):MSU_ERR_FILESYSTEM_DOESNT_VERIFY(3)_1_MobileSoftwareUpdateBOMErrorDomain:1|FullReplacementRequired|]" UserInfo={SUMacControllerErrorIndicationsSummary=|FullReplacementRequired|, SUMacControllerErrorIndicationsMask=2, SUMacControllerErrorIndicationsDescription=-> Full replacement is required [as opposed to incremental patch]., NSUnderlyingError=0x7f8a7ee06640 {Error Domain=MobileSoftwareUpdateErrorDomain Code=3 "'./usr/sbin/BlueTool' does not verify" UserInfo={target_update=22A5266r, NSLocalizedDescription='./usr/sbin/BlueTool' does not verify, NSUnderlyingError=0x7f8a7ee05ec0 {Error Domain=MobileSoftwareUpdateBOMErrorDomain Code=1 "contents of '/usr/sbin/BlueTool' don't match bom (65653050 vs cd6e3fa1)" UserInfo={NSLocalizedDescription=contents of '/usr/sbin/BlueTool' don't match bom (65653050 vs cd6e3fa1)}}, MSUFullReplacementRecommened=true}}, NSDebugDescription=[SUMacControllerErrorPrepareFailed=7740] Failed to perform Prepare operation: [MobileSoftwareUpdateErrorDomain(MSU):MSU_ERR_FILESYSTEM_DOESNT_VERIFY(3)_1_MobileSoftwareUpdateBOMErrorDomain:1|FullReplacementRequired|], NSLocalizedDescription=ソフトウェア・アップデートの準備ができませんでした。やり直してみてください。}

I'm still stuck after reboot. Starting the installer from the boot menu results in a reboot, regardless of AvoidRuntimeDefrag set or not.

  • Like 1
Link to comment
Share on other sites

39 minutes ago, Shikumo said:

For those trying the small update to macOS 13 (MSU_UPDATE_22A5266r_patch_13.0 with 3,67 GB) and getting an error message after download, you may want to disable your Bluetooth kexts beforehand. install.log was showing the following error messages for me.

 

softwareupdated[352]: SUOSUMobileSoftwareUpdateController: Download finished: Error Domain=SUMacControllerError Code=7740 "[SUMacControllerErrorPrepareFailed=7740] Failed to perform Prepare operation: [MobileSoftwareUpdateErrorDomain(MSU):MSU_ERR_FILESYSTEM_DOESNT_VERIFY(3)_1_MobileSoftwareUpdateBOMErrorDomain:1|FullReplacementRequired|]" UserInfo={SUMacControllerErrorIndicationsSummary=|FullReplacementRequired|, SUMacControllerErrorIndicationsMask=2, NSLocalizedDescription=ソフトウェア・アップデートの準備ができませんでした。やり直してみてください。, SUMacControllerErrorIndicationsDescription=-> Full replacement is required [as opposed to incremental patch]., NSDebugDescription=[SUMacControllerErrorPrepareFailed=7740] Failed to perform Prepare operation: [MobileSoftwareUpdateErrorDomain(MSU):MSU_ERR_FILESYSTEM_DOESNT_VERIFY(3)_1_MobileSoftwareUpdateBOMErrorDomain:1|FullReplacementRequired|], NSUnderlyingError=0x7f7aea364b50 {Error Domain=MobileSoftwareUpdateErrorDomain Code=3 "'./usr/sbin/BlueTool' does not verify" UserInfo={target_update=22A5266r, MSUFullReplacementRecommened=true, NSLocalizedDescription='./usr/sbin/BlueTool' does not verify, NSUnderlyingError=0x7f7aea3cdfe0 {Error Domain=MobileSoftwareUpdateBOMErrorDomain Code=1 "contents of '/usr/sbin/BlueTool' don't match bom (65653050 vs cd6e3fa1)" UserInfo={NSLocalizedDescription=contents of '/usr/sbin/BlueTool' don't match bom (65653050 vs cd6e3fa1)}}}}}
SoftwareUpdateNotificationManager[983]: SUOSUUpdateController: Download error: Error Domain=SUMacControllerError Code=7740 "[SUMacControllerErrorPrepareFailed=7740] Failed to perform Prepare operation: [MobileSoftwareUpdateErrorDomain(MSU):MSU_ERR_FILESYSTEM_DOESNT_VERIFY(3)_1_MobileSoftwareUpdateBOMErrorDomain:1|FullReplacementRequired|]" UserInfo={SUMacControllerErrorIndicationsSummary=|FullReplacementRequired|, SUMacControllerErrorIndicationsMask=2, SUMacControllerErrorIndicationsDescription=-> Full replacement is required [as opposed to incremental patch]., NSUnderlyingError=0x7f8a7ee06640 {Error Domain=MobileSoftwareUpdateErrorDomain Code=3 "'./usr/sbin/BlueTool' does not verify" UserInfo={target_update=22A5266r, NSLocalizedDescription='./usr/sbin/BlueTool' does not verify, NSUnderlyingError=0x7f8a7ee05ec0 {Error Domain=MobileSoftwareUpdateBOMErrorDomain Code=1 "contents of '/usr/sbin/BlueTool' don't match bom (65653050 vs cd6e3fa1)" UserInfo={NSLocalizedDescription=contents of '/usr/sbin/BlueTool' don't match bom (65653050 vs cd6e3fa1)}}, MSUFullReplacementRecommened=true}}, NSDebugDescription=[SUMacControllerErrorPrepareFailed=7740] Failed to perform Prepare operation: [MobileSoftwareUpdateErrorDomain(MSU):MSU_ERR_FILESYSTEM_DOESNT_VERIFY(3)_1_MobileSoftwareUpdateBOMErrorDomain:1|FullReplacementRequired|], NSLocalizedDescription=ソフトウェア・アップデートの準備ができませんでした。やり直してみてください。}

I'm still stuck after reboot. Starting the installer from the boot menu results in a reboot, regardless of AvoidRuntimeDefrag set or not.

Thanks for the warning, I'm waiting for the update to complete and will give feedback shortly

1 minute ago, Takiller said:

Thanks for the warning, I'm waiting for the update to complete and will give feedback shortly

Unfortunately got "failed to prepare the update properly" and now downloading the full installer 😔

Link to comment
Share on other sites

Posted (edited)

1890199878_Bildschirmfoto2022-06-07um08_36_26.png.58401601ea7e5c55c01296c794db0356.png

Trying to install on my Ivy Bridge Laptop. Trying figure out if OCLPs Board-Id VMM Spoof and Chris1111's Intel HD4000 are still working. ;)

 

EDIT

  •  Board VMM spoof doesn't work
  • There's also another error abot IOHIDFamily. Could be the old VoodooPS2ControllerTrackpad Kext, I guess

 

20220607_093924_HDR.thumb.jpg.d454dfdf844d4eebced5b983b06abdf4.jpg

 

Edited by 5T33Z0
  • Like 2
Link to comment
Share on other sites

Posted (edited)

Tried install from an USB installer with the modifications and kexts updated and it boots but stays in the Apple logo, no progress bar...

Back to stage one, but later I'll persist... 😃

Edited by MorenoAv
Link to comment
Share on other sites

3 minutes ago, MorenoAv said:

Tried install from an USB installer with the modifications and kexts updated and it boots but stays in the Apple logo, no progress bar...

Back to stage one, but later I'll persist... 😃

Boot in verbose to see where it stalls.

  • Like 1
Link to comment
Share on other sites

Posted (edited)

I'll do that later, right now, work is calling me... but I remember when I updated Lilu it says "Allow loading on macOS 13 without `-lilubetaall`", for that reason I removed lilubetall...

Edited by MorenoAv
Link to comment
Share on other sites

3 minutes ago, surenmunoo said:

Anyone get it working on AlderLake yet

My installation got canceled halfway through the first stage because of the installation package damage error so no luck on my end yet

Link to comment
Share on other sites

Posted (edited)

AvoidRuntimeDefrag false

-lilubetaall

Whatevergreen 1.6.0

opencore 0.8.1

 

image.thumb.png.8c412c1791c21c15a851833363904c16.png

 

installed applications run correctly

image.thumb.png.d4cb48a609a1be70217ad754e8037409.png

 

Edited by Derty
  • Like 6
Link to comment
Share on other sites

×
×
  • Create New...