Jump to content

AMD High Sierra Kernel Release and Testing


1,119 posts in this topic

Recommended Posts

On Maverick in Parrallell Desktop 10.13 HS ...

In Parallel Desktop normal works applications...

attachicon.gifHS_10.13.png

 

On real AMD i gets problem color :

attachicon.gifHS_problem_video.mov

This is a well-known color issue of AMD 5700 & 6870 at both 10.12 & 10.13.

It can be fixed easily by SwitchResX as below photo: change to Millions of colors instead of Billion of color !

post-70188-0-72520900-1507420004_thumb.png

  • Like 4
Link to comment
Share on other sites

had this when i was using my ati hd 5450. adding "-rad24" to clover boot options fixed it for me.

no luck ...

This is a well-known color issue of AMD 5700 & 6870 at both 10.12 & 10.13.

It can be fixed easily by SwitchResX as below photo: change to Millions of colors instead of Billion of color !

This is works for me ! Thanks ! )))

  • Like 1
Link to comment
Share on other sites

just curious. would you guys use APFS on additional SSDs in the system? ive heard its not good for a hackintosh to have the boot drive apfs formatted, but i guess this doesnt count for additional drives?

ive not made any benchmarks yet, but just formatted an SSD with APFS and it seems to work just fine.

Link to comment
Share on other sites

just curious. would you guys use APFS on additional SSDs in the system? ive heard its not good for a hackintosh to have the boot drive apfs formatted, but i guess this doesnt count for additional drives?

ive not made any benchmarks yet, but just formatted an SSD with APFS and it seems to work just fine.

What happens is the boot drive or bootloader doesn’t recognize non APFS drives so you only have one boot option for the APFS drive.

Link to comment
Share on other sites

no luck ...

This is works for me ! Thanks ! )))

Glad to know that works for you.

Have you got working VMware in your FX hackintosh ?

In both my FX-6300 & Ryzen 1700X hackintoshs there is no audio output and icon glitchy issues of 10.11 came back at 10.12.6 by VMware player again !

  • Like 1
Link to comment
Share on other sites

Glad to know that works for you.

Have you got working VMware in your FX hackintosh ?

In both my FX-6300 & Ryzen 1700X hackintoshs there is no audio output and icon glitchy issues of 10.11 came back at 10.12.6 by VMware player again !

 

Have you tried this I use it in Clover kexts other folder.    

VoodooHDA.kext.zip

  • Like 1
Link to comment
Share on other sites

in my 10.12.3 i installed module apfs and works opening dmg with APFS )))


Glad to know that works for you.

Have you got working VMware in your FX hackintosh ?

In both my FX-6300 & Ryzen 1700X hackintoshs there is no audio output and icon glitchy issues of 10.11 came back at 10.12.6 by VMware player again !

I need try install and use VMware ! 


I tried install in Parallels Desktop and works installer 10.13 ! 

This metod install : 

1) open install.app and install on hdd partition ;

2) replace prelinkedkernel in folder "/macOS Install Data/Locked Files/Boot Files/"

3) reboot and Enjoy ! ))

post-31928-0-44340900-1507429117_thumb.png

  • Like 4
Link to comment
Share on other sites

in my 10.12.3 i installed module apfs and works opening dmg with APFS )))

I need try install and use VMware ! 

I tried install in Parallels Desktop and works installer 10.13 ! 

attachicon.gifinstall_HS.png

Do you mean that at 10.12.3 you can install 10.13 by Parallel Desktop ?

What I prefer is that at Windows 10 or 8.1 to install 10.12.x or 10.13 by VMware Player.

At this moment installed 10.12.6 got glitchy icon and absence of audio input/output.

No such issues in my Intel hackintosh.

Link to comment
Share on other sites

Do you mean that at 10.12.3 you can install 10.13 by Parallel Desktop ?

What I prefer is that at Windows 10 or 8.1 to install 10.12.x or 10.13 by VMware Player.

At this moment installed 10.12.6 got glitchy icon and absence of audio input/output.

No such issues in my Intel hackintosh.

I have Maverick 10.9.5 and Parallels Desktop , and i installed 10.13 on Maverick ! )))

I have other 10.12.3 and i can open files.dmg with APFS . 

  • Like 2
Link to comment
Share on other sites

@Bronya, you have unlocked Ryzen!    Check this out!    AMD Ryzen 7 1700, AMD RX 480 8gb openCL and openGl test results at high frequency settings.   I have run multiple benches in each of these apps without crashes at these sudo high frequencies.    My RX 480 is performing like a Vega card.

 

There seems to be a few minor issues mainly sleep/wake (= restart), Bluetooth ( wifi card compatibility-USB?), and Audio stability.   Your Sierra 12.6 kernel allowes for Audio and sleep/wake functions but this one doesn't yet.   Great job!    Your kernel and the lilu and whatever green kexts are making this system run better than in windows.

post-1753549-0-79972300-1507483075_thumb.png

post-1753549-0-40372600-1507483106_thumb.png

post-1753549-0-16388700-1507483140_thumb.png

post-1753549-0-09663600-1507483255_thumb.png

post-1753549-0-90058400-1507483276_thumb.png

  • Like 2
Link to comment
Share on other sites

@Bronya, you have unlocked Ryzen!    Check this out!    AMD Ryzen 7 1700, AMD RX 480 8gb openCL and openGl test results at high frequency settings.   I have run multiple benches in each of these apps without crashes at these sudo high frequencies.    My RX 480 is performing like a Vega card.

 

There seems to be a few minor issues mainly sleep/wake (= restart), Bluetooth ( wifi card compatibility-USB?), and Audio stability.   Your Sierra 12.6 kernel allowes for Audio and sleep/wake functions but this one doesn't yet.   Great job!    Your kernel and the lily and whatever green kexts are making this system run better than in windows.

I think there's a timing issue going on. Your CPU score seems unrealistically high. Did you run that after waking from sleep or something?

 

Mine also scores higher, although, not as high as yours. This is my 1800x at 3.9.

 

GC6IRWc.png

Link to comment
Share on other sites

I think there's a timing issue going on. Your CPU score seems unrealistically high. Did you run that after waking from sleep or something?

 

Mine also scores higher, although, not as high as yours. This is my 1800x at 3.9.

 

 

 

Its a turbo loophole!    My first impressions were the same but after running several apps it is holding.   I've never seen anyone cheat Luxmark, Geekbench and Cinebench maybe.    Like I said its like a sudo overclock but it is playing out across oenCL and openGl apps (Unigine Valley and Heaven).   Another interesting observation is that AMD RX Vega cards won't run Uningine benches without crashing unless you drop the 30 bit color ARBG2101010 to 24 bit ARBG888888 format (Intel Chipsets).    Mine is able to run with 30bit color on Ryzen.  

Link to comment
Share on other sites

Its a turbo loophole!    My first impressions were the same but after running several apps it is holding.   I've never seen anyone cheat Luxmark, Geekbench and Cinebench maybe.    Like I said its like a sudo overclock but it is playing out across oenCL and openGl apps (Unigine Valley and Heaven).   Another interesting observation is that AMD RX Vega cards won't run Uningine benches without crashing unless you drop the 30 bit color ARBG2101010 to 24 bit ARBG888888 format (Intel Chipsets).    Mine is able to run with 30bit color on Ryzen.  

Interesting. I was only commenting on the CB bench since I don't really understand how OSX handles graphics. Are you running the CPU at stock and do you use the busratio flag?

 

Do you need to turn off AA to get Heaven to work with Vega? I haven't tested it but will in a bit. It's a bit of a pain though because I have to change the bios

 

Also, do you have any issue with Chrome? I turned off hardware acceleration but my mouse turns into a buggy mess. Perhaps my eth kext is messing with things. I need to see if I have a TP wireless card in one of my boxes.

 

Lastly, I can't use the system.kext provided by Bronya, the system will never fully boot. Your system.kext works fine though.

Link to comment
Share on other sites

Fresh install. I had to use a VM to build the USB stick which was a bit tricky. I created a 10.12 installer then replaced relevant files with 10.13 ones. Once I was able to install I had to figure out a way to mount my SSD in the VM. I ended up using an external docking station. Lastly,

 

I'm running an 1800x and Vega 64.

Would you mind breaking this down into steps. Can't even get to the installer. I figure I'm missing a step. I'm running the same CPU/GPU as you.

Link to comment
Share on other sites

 

Interesting. I was only commenting on the CB bench since I don't really understand how OSX handles graphics. Are you running the CPU at stock and do you use the busratio flag?

 

Do you need to turn off AA to get Heaven to work with Vega? I haven't tested it but will in a bit. It's a bit of a pain though because I have to change the bios

 

Also, do you have any issue with Chrome? I turned off hardware acceleration but my mouse turns into a buggy mess. Perhaps my eth kext is messing with things. I need to see if I have a TP wireless card in one of my boxes.

 

Lastly, I can't use the system.kext provided by Bronya, the system will never fully boot. Your system.kext works fine though.

 

I need to disable AA anti-Aliasing as well Vega drivers are still not complete, especially for openGl apps.

 

We had timing issues with Ryzen in early testing but systems ran unstable and most apps would crash the system.    This is holding up and it scales nicely (perfectly) its hard to imagine this is just a synthetic benefit since it applies to openGl and openCl.   look at this scaling of the RX 480 in Uningine Valley (openGL).

post-1753549-0-64112000-1507491941_thumb.png

post-1753549-0-09977700-1507491969_thumb.png

post-1753549-0-66732700-1507492006_thumb.png

post-1753549-0-92071900-1507492049_thumb.png

post-1753549-0-93147700-1507492073_thumb.png

Link to comment
Share on other sites

I need to disable AA anti-Aliasing as well Vega drivers are still not complete, especially for openGl apps.

 

We had timing issues with Ryzen in early testing but systems ran unstable and most apps would crash the system.    This is holding up and it scales nicely (perfectly) its hard to imagine this is just a synthetic benefit since it applies to openGl and openCl.   look at this scaling of the RX 480 in Uningine Valley (openGL).

I don't understand how you're getting your clock that high.

Link to comment
Share on other sites

×
×
  • Create New...