Jump to content

AMD High Sierra Kernel Release and Testing


1,119 posts in this topic

Recommended Posts

Need to be fresh install necessarily? Gigamaxx.

I have Sierra. I can just install over it? Back-up is so annoying.

 

PS. I will make a full copy of the SSD on Clonezilla as a precaution.

 

Cheers.

 

No, I have installed on a few existing build drives for Intel.   Its just cleaner to instal on fresh copy but not necessary.

  • Like 1
Link to comment
Share on other sites

POkJN7.png

 

| AMD Ryzen 3 - 1200 | MSI A320M PRO-VH PLUS | CORSAIR 8GB Vengeance RED DDR4 2400MHz XMP 2.0 CL16 | Gigabyte Nvidia GT1030 GDDR5 | OCZ 240GB TL100 Series 240GB SSD Sata 3.0 | Seagate 2.5" 500GB HDD Barracuda Sata 3.0 128MB Cache 5400Rpm | macOS High Sierra 10.13 | macOS Sierra 10.12.6 | Windows 10 Pro x64 |

  • Like 3
Link to comment
Share on other sites

So Giga, i added all the stuff to a new installation with updated clover and updates whatever and lilu. whats next? 

 

It says "This Version of Macosx is not supportet by your system" i will now edit the plist with macpro 6.1

 

Update: Kernel Cache again... wtf.. why? 

 

Edit 2: Done it all again - kernel cache error again

Link to comment
Share on other sites

I think its your kernel bronya (the ryzen one) 

 

On page 12 i posted photos of the error 

 

This  #239 ??

I no see kernel cache error ... Where ??

Please reinstall 10.13 and install kexts :

FakeSMC, AppleATIATA.kext,DummyUSBEHCIPCI.kext,DummyUSBXHCIPCI.kext,GenericUSBXHCI.kext,NullCPUPowerManagement.kext,VoodooHDA.kext ! 

And repair permissions !

And TRY ! 

  • Like 2
Link to comment
Share on other sites

Hi! 

 

Thanks for the kernel, good work! Although sometimes it starts again randomly!

I have not yet come to know when and why.
macOS High Sierra works with Gigabyte RX 460 4 GB without auxiliary card! (Lilu.kext and WhateverGreen.kext)
Works with HDMI port and Displayport too! (I guess thanks to AppleALC.kext) HDMIAudio.kext
Testing in progress!
 
post-1166679-0-97222400-1507736954_thumb.png
 
post-1166679-0-85574700-1507737001_thumb.png
 
Geekbench CPU Result (That could be better): https://browser.geekbench.com/v4/cpu/4410138
  • Like 1
Link to comment
Share on other sites

I got spam of AppleAHCI..Control. (Try Boot to Installer). Try Clover / Enoch the same problem. Don't use any of kext but try with... try different boot flag still nothing.

 

Check bios settings HXCI enabled, and Sata AHCI mode.

So Giga, i added all the stuff to a new installation with updated clover and updates whatever and lilu. whats next? 

 

It says "This Version of Macosx is not supportet by your system" i will now edit the plist with macpro 6.1

 

Update: Kernel Cache again... wtf.. why? 

 

Edit 2: Done it all again - kernel cache error again

Ca you post your config.plist?

Hi! 

 

Thanks for the kernel, good work! Although sometimes it starts again randomly!

I have not yet come to know when and why.

macOS High Sierra works with Gigabyte RX 460 4 GB without auxiliary card! (Lilu.kext and WhateverGreen.kext)

Works with HDMI port and Displayport too! (I guess thanks to AppleALC.kext)

Testing in progress!

 

attachicon.gifKépernyőfotó 2017-10-11 - 17.38.58.png

 

attachicon.gifKépernyőfotó 2017-10-11 - 17.49.41.png

 

Geekbench CPU Result (That could be better): https://browser.geekbench.com/v4/cpu/4410138

Geekbench GPU Result: https://browser.geekbench.com/v4/compute/1233664

Try downloading and running “kext utility” app. After it’s booted. It works better than kext wizzard but only allows rebuild on working disk.

  • Like 1
Link to comment
Share on other sites

Check bios settings HXCI enabled, and Sata AHCI mode.

 

Ca you post your config.plist?

 

Try downloading and running “kext utility” app. After it’s booted. It works better than kext wizzard but only allows rebuild on working disk.

 

I use Enoch bootloader because the Clover bootloader only works on the monitor (Displayport)! TV is not (HDMI).
It could be Clover r2230! I'll try the newer version!
 
Attached to config.plist:
Link to comment
Share on other sites

I use Enoch bootloader because the Clover bootloader only works on the monitor (Displayport)! TV is not (HDMI).

It could be Clover r2230! I'll try the newer version!

It could be the clover settings, clover has much more adjustments available than Enoch. In graphics try setting dual link to 1, and in GUI set screen resolution.

Link to comment
Share on other sites

Check bios settings HXCI enabled, and Sata AHCI mode.

 

Ca you post your config.plist?

 

Try downloading and running “kext utility” app. After it’s booted. It works better than kext wizzard but only allows rebuild on working disk.

 

 

I have Enable all of this. I try install with that method :

 

 

installing highsirera with the original BaseSystem

 

1 download the high sierra installer on Apple Store 

 

2 instal on your usb with this command

sudo /Applications/Install\ macOS\ High\ Sierra.app/Contents/Resources/createinstallmedia --volume /Volumes/usb

 

3 take one prelinkedkernel of one cheated highsierra amd installed

 

http://www85.zippyshare.com/v/n0n2aHIe/file.html

 

4 put your prelinkedkernel on

./IABootFile/

/System/Library/PrelinkedKernels/

 

5 install clover and reboot for enter in the installer

 

6 install the high sierra 

 

7 enter in Sierra for edit the second part of installation

 

8 copy your prelinkedkernel for /Macos Install data/Locked Files/Boot Files/

 

9 edit the file /Macos Install data/Locked Files/Boot Files/com.apple.Boot.plist

<key>Kernel Flags</key>

<string>-rootdmg-ramdisk auth-root-dmg=file:///macOS%20Install%20Data/BaseSystem.dmg</string>

 

for

 

<key>Kernel Flags</key>

<string>-rootdmg-ramdisk root-dmg=file:///macOS%20Install%20Data/BaseSystem.dmg</string>

 

10 reboot your system and return the installation

 

11 enjoy with the HighSierra

 

 

PS

in the part 10  

on the first boot error and reboot

on the second boot my NVIDIA gave black screen

on the third boot the HS installed normal

 

 

 

I'm stuck on 6 part. AppleUSBAHCI Loop. 

 

EDIT: AppleUSBHost:HardwareExpectionThreadCallGated

(idk maybe 6 - 8 lines in 1 s)

and another is AppleUSBEHCI something with recovery... 2 lines.

And thats messages going all the time. 

Link to comment
Share on other sites

I have Enable all of this. I try install with that method :

 

 

 

 

I'm stuck on 6 part. AppleUSBAHCI Loop. 

 

EDIT: AppleUSBHost:HardwareExpectionThreadCallGated

(idk maybe 6 - 8 lines in 1 s)

and another is AppleUSBEHCI something with recovery... 2 lines.

And thats messages going all the time. 

 

u need these usb kexts 

http://www.insanelymac.com/forum/topic/325514-amd-high-sierra-kernel-release-and-testing/?p=2510264

 

Link to comment
Share on other sites

For those having trouble check to see if you have a EFI Backup folder on main partition and remove it.   If it has a different config.plist or other kexts they may create problems for booting.

 

post-1753549-0-45721200-1507746355_thumb.png

 

 

For placement of the recommended USB and other kexts they go in your EFI partition in Clover Kexts folder Other.    There are also Clover settings for USB that may help.    I'm using High Current for USB 3.1.

 

post-1753549-0-45961900-1507746450_thumb.pngpost-1753549-0-14071300-1507754515_thumb.png

 

 

As you can see I'm not using any USB fixes for my Motherboard Gigabyte AX370 as my setup is not requiring it.   I have USB 3.0 and 3.1 listed in about this Mac, and they al work except my case USB2.0 slots.  If you have the USB fix kexts in Other folder try removing them and see if you get past the USB error.    For modern Ryzen boards they may not be required in High Sierra.   In sierra I use them.

 

If your getting the error that your system is incompatible or can't be installed on this system check your clover MLB number.    It needs to be 17 digits long for Mac Pro 6.1 definition.    An easy fix for this is to take your serial number and paste it there and then add more letters or numbers to reach 17 total.    

 

post-1753549-0-47085600-1507747483_thumb.pngpost-1753549-0-82550500-1507747518_thumb.png

 

Also, in order for your Kexts to inject you should set inject kexts in Clover System preferences section. It also has the option to create a UUID number as well.

 

post-1753549-0-98506800-1507747550_thumb.png

 

To use Clover Configurator open it and select "Mount EFi" choose the disk you want ton open and hit tab.   Close Configurator and look on desktop for the EFi folder or disk symbol open it and open Clover folder and right click on config.plist and select open with Clover Configurator.    you can make all these changes and then save at close.

 

Link to comment
Share on other sites

Still that problem... idk. 

I have all the time problem with that USB. On current version 10.12.6 - 4  I must put usb to any port and get out and finely  put that usb to any port (but can't put to the same port ) then... my usb load ;d Or just put usb on booting system.. then I don't need to that trick . Anyway I still have that loop messages. I put correct kext and set InjectKext in Clover. Anyway in bios I can't set XHCI to Enable(Don't have that Option). But I set it on BootFlag. I Have msi-970a-g43.

 

 

Give up. F!#$ this. It's impossible. Or just @Shaneee that USBFIX won't work anymore for all. I tried all methods, configs. Still USB don't give me access to first part of installation . Back to Linux.

Link to comment
Share on other sites

Not working for me - ACPI Error etc.. but maybe because this is not for ryzen? 

 

Or is this maybe of false settings on mainboard? 

 

1)why do not you listen to me ? 
Try In the BIOS to change "ide" on "AHCI" ! 
 
2) You need install kext AppleATIATA - this if "ide"
  • Like 2
Link to comment
Share on other sites

I dont have IDE in Bios under SATA i can change between RAID and AHCI

 

 

SATA Mode [AHCI Mode]

Sets the operation mode of the onboard SATA controller.

[AHCI Mode] Specify the AHCI mode for SATA storage devices. AHCI (Advanced Host Controller Interface) offers some advanced features to enhance the speed and performance of SATA storage device, such as Native Command Queuing (NCQ) and hot-plugging.

[RAID Mode] Enables RAID function for SATA storage devices

Link to comment
Share on other sites

×
×
  • Create New...