Jump to content

AMD High Sierra Kernel Release and Testing


1,119 posts in this topic

Recommended Posts

Got Kernel Panic. 

 

1. Installed HS on Drive about Macbook Pro 

2. Installed Clover newst (with some options) 

3. Changed Liberary Files (kernel etc) 

4. Used the Efi with changed numbers from Gigamaxx

5. Kext Wizard 

 

6. Kernel Panic .. what do i'm wrong? I think i got sometimes error copying the Frameworks (can i use the ryzen patcher when i replace the files?) 

Link to comment
Share on other sites

Got Kernel Panic. 

 

1. Installed HS on Drive about Macbook Pro 

2. Installed Clover newst (with some options) 

3. Changed Liberary Files (kernel etc) 

4. Used the Efi with changed numbers from Gigamaxx

5. Kext Wizard 

 

6. Kernel Panic .. what do i'm wrong? I think i got sometimes error copying the Frameworks (can i use the ryzen patcher when i replace the files?) 

 

No rysen patcher that is for Sierra.     For Frameworks files I choose "merge" option.    It can only be done the first time or on a fresh install.

Link to comment
Share on other sites

Example ... Mac pro 5.1 to IMac and etc ...

didnt work !

i changed it to iMac 14,2 but it still give the error "OSInstall.mpkg is missing or or damaged" (as shown in the above image) : (

 

That was the common issue if u installing in uefi,according to cyberdevs just delete the emuvarible_64uefi on efi/clover/uefi64 folder to bypass that error

tried that too but didnt work !

Link to comment
Share on other sites

didnt work !

i changed it to iMac 14,2 but it still give the error "OSInstall.mpkg is missing or or damaged" (as shown in the above image) : (

 

tried that too but didnt work !

 

Restoring 10.13 BaseSystem doesn't work anymore. Apple changed it to a sort of two stage install. 

Link to comment
Share on other sites

So after i Install HS on My HDD (500GB) i give in my data to setup the system.

than i shutdown the system boot on my macbook and replace or merge the files on the HS System right?

Yes, make a fresh or cloned copy then edit the files, and run kext wizzard ( check the proper target disk before you hit run).

Then install clover and switch out config.plist and kext folder 10.13, and remove the dsdt in Clover ACPI folder in “ patcher” folder.

 

Hit space bar at boot and select verbose, don’t reboot on panic, and keepsymbols.

Link to comment
Share on other sites

Thank you Gigamaxx,

 

but when i try to merge the files its always tell me that there are already some of the data or unkown failure - do you have a hint how to go trough it?

 

You may have trouble if the files are the running system (MacBook drive). If the disk for the edit is attached by USB to Sata connection it should work. It needs to be an exterior disk unless you have more than one Sata connection on your system.

 

I made a video some time back doing the same procedure but for Sierra. Check out the disk edit video. Just google Ryzen Hackintosh and look for the low quality boring videos I made.

http://www.insanelymac.com/forum/topic/324392-ryzen-clover-installation-guide-macos-sierra/

Link to comment
Share on other sites

Did you check out the new clover boot manager settings? I noticed there are more options in the graphics settings, especially for Nvidia.

 

Which settings?

 

I made my Installer with the Sierra restore. Used Pandora's box to restore a 10.12 installer then replace the Packages folder with the 10.13 one and replace BaseSystem.dmg, AppleDiagnostics.dmg and the two chunklist files. Added the 10.12 kernel to the installer and any kexts I needed and installed. Once installed I copied the 10.13 kernel to the newly installed HDD and installed Clover.

 

The Frameworks aren't required to run the kernel. Best to leave them.

Link to comment
Share on other sites

Which settings?

 

I made my Installer with the Sierra restore. Used Pandora's box to restore a 10.12 installer then replace the Packages folder with the 10.13 one and replace BaseSystem.dmg, AppleDiagnostics.dmg and the two chunklist files. Added the 10.12 kernel to the installer and any kexts I needed and installed. Once installed I copied the 10.13 kernel to the newly installed HDD and installed Clover.

 

The Frameworks aren't required to run the kernel. Best to leave them.

I’m using clover bootloader 4220, it has new clover boot screen menu options for Nvidia. I was tinkering with them at first and got further along then I changed to r7 265. After it booted I rebuilt caches and now all my AMD cards work. I will try tonight to get gt 210 working. A lot of people are having issues with older Nvidia cards in HS with Intel hacks as well. Some brands (Vbios?) are working but other users can’t get similar cards to work.

 

This is true, only the kernel and system kext need to be used. Merging the frameworks did work for me as it was a fresh install. Once merged they can only be replaced after which doesn’t work well. For Ryzen, when I don’t include frameworks my system runs a little buggy and crashes more often in various apps.

Link to comment
Share on other sites

Hello Shaneee and Gigamaxx,

 

i do the following: 

 

1. Installed HS (new) on HDD with my Macbook

2. Installed Clover

3. Changed the both Files (kext and kernel) 

4. take the files from gigamaxx efi (10.13 kexts) 

5. kext wizzard 

 

than on my hackintosh instantly says:

Error allocating 0x182d pages at... 

error loading kernel cache (0x9) 

Boot failed 

Link to comment
Share on other sites

Hello Shaneee and Gigamaxx,

 

i do the following:

 

1. Installed HS (new) on HDD with my Macbook

2. Installed Clover

3. Changed the both Files (kext and kernel)

4. take the files from gigamaxx efi (10.13 kexts)

5. kext wizzard

 

than on my hackintosh instantly says:

Error allocating 0x182d pages at...

error loading kernel cache (0x9)

Boot failed

 

The kernel is not loading. Try replace kernel again and run Kextwizzard (specify correct target disk).

 

You can also try using Disk Utility and “repair” the Ryzen disk after the kext wizzard.

Link to comment
Share on other sites

Did that - still the same error. :(

 

The system.kext will copyed from the HS Ryzen Files to System/Libary/Extentions/ or? 

 

Update: Tryed it again - doesnt work. Always boot failing.. 

 

OsxAptioFix2Drv: Starting iverrides for /System/Library/CoreServices/boot.efi

Using reloc block: no, hibernate wake: no

Error loading kernel cache (ox1)

Boot failed, sleeping for 10 Seconds before exiting 

 

 

Is it possible that i checked the false things at clover install? 

 

My EFI:

 

UPDATE QUESTION - maybe i use the wrong version of clover? Using 4233

EFI.zip

Link to comment
Share on other sites

Today I tested a bit more with my ryzen setup along side my pascal card, with the webdrivers all I can get is a blackscreen instead of the login screen, is there anyone else here who have tested ryzen and pascal combo?

Thx!

Link to comment
Share on other sites

Did that - still the same error. :(

 

The system.kext will copyed from the HS Ryzen Files to System/Libary/Extentions/ or? 

 

Update: Tryed it again - doesnt work. Always boot failing.. 

 

OsxAptioFix2Drv: Starting iverrides for /System/Library/CoreServices/boot.efi

Using reloc block: no, hibernate wake: no

Error loading kernel cache (ox1)

Boot failed, sleeping for 10 Seconds before exiting 

 

 

Is it possible that i checked the false things at clover install? 

 

My EFI:

Do this:

 

First method :-

  • boot with -no-zp  boot flag 

    and check if it boots or not.

    if not then try the second method.

Second method (should work ! ):-

and then boot again.

Today I tested a bit more with my ryzen setup along side my pascal card, with the webdrivers all I can get is a blackscreen instead of the login screen, is there anyone else here who have tested ryzen and pascal combo?

Thx!

 are you booting with nv_disable=1 boot flag ?

Link to comment
Share on other sites

Today I tested a bit more with my ryzen setup along side my pascal card, with the webdrivers all I can get is a blackscreen instead of the login screen, is there anyone else here who have tested ryzen and pascal combo?

Thx!

Boot arg. Lilubeta ?

Link to comment
Share on other sites

×
×
  • Create New...