Jump to content

[pre-release] macOS High Sierra


3,752 posts in this topic

Recommended Posts

Here is the full list of AMD GPUs Device IDs for anyone who's interested:

AMD5000
ATY,Hoolock, ATY,Langur, ATY,Orangutan, ATY,Zonalis
0x68981002 0x68991002 0x68E01002 0x68E11002 0x68D81002 0x68C01002 0x68C11002 0x68D91002 0x68B81002 0x68B01002 0x68B11002 0x68A01002 0x68A11002 

AMD6000
ATY,Gibba, ATY,Lotus, ATY,Muskgrass
0x67681002 0x67701002 0x67791002 0x67601002 0x67611002 0x67501002 0x67581002 0x67591002 0x67401002 0x67411002 0x67451002 0x67381002 0x67391002 0x67201002 0x67221002 0x67181002 0x67191002 0x68401002 0x68411002 0x67041002

AMD7000
ATY,Hamachi, ATY,Ikura, ATY,IkuraS, ATY,Kani, ATY,KaniS, ATY,Maguro, ATY,MaguroS, ATY,Namako, ATY,Ramen, ATY,Tako
0x26001002 0x22001002 0x67901002 0x67981002 0x679A1002 0x679E1002 0x67801002 0x68201002 0x68211002 0x68231002 0x68251002 0x68271002 0x682B1002 0x682D1002 0x682F1002 0x68351002 0x68391002 0x683B1002 0x683D1002 0x683F1002 0x68001002 0x68011002 0x68061002 0x68081002 0x68101002 0x68181002 0x68191002

AMD8000
ATY,Exmoor
0x45001002 0x46001002 0x66401002 0x66411002 0x66461002 0x66471002 0x66501002 0x66511002 0x665C1002 0x665D1002 0x67B01002

AMD9000
ATY,Basset, ATY,Labrador
0x69201002 0x69211002 0x69301002 0x69381002 0x69391002 0X73001002


AMD9300
ATY,FleuveSWIP, ATY,Maltese, ATY,MalteseS
0X73001002

AMD9500
ATY,Acre, ATY,Berbice, ATY,Caroni, ATY,Dayman, ATY,Elqui, ATY,Florin, ATY,Guariba,ATY,Huallaga,ATY,Orinoco
0x67E01002 0x67EF1002 0x67FF1002 0x67C01002 0x67DF1002

AMD9510
ATY,Berbice
0x67EF1002

AMD9515
ATY,Longavi, ATY,Mazaruni
0x67EF1002

AMD9520
ATY,Caroni, ATY,Elqui, ATY,Florin
0x67E01002 0x67EF1002 0x67FF1002 0x67C01002 0x67DF1002

AMD10000
ATY,Iriri, ATY,Japura, ATY,Kamarang
0x68601002 0x68671002 0x687F1002


AMDRadeonX3000
AMDBartsGraphicsAccelerator
0x67381002 0x67391002 0x67201002 0x67221002

AMDCaicosGraphicsAccelerator
0x67681002 0x67701002 0x67791002 0x67601002 0x67611002

AMDCaymanGraphicsAccelerator
0x67181002 0x67191002 0x67041002

AMDCedarGraphicsAccelerator
0x68E01002

AMDCypressGraphicsAccelerator
0x68981002 0x68991002

AMDJuniperGraphicsAccelerator
0x68B81002 0x68B01002 0x68B11002 0x68A01002 0x68A11002

AMDLombokGraphicsAccelerator
0x68401002 0x68411002

AMDRedwoodGraphicsAccelerator
0x68D81002 0x68C01002 0x68C11002 0x68D91002

AMDTurksGraphicsAccelerator
0x67501002 0x67581002 0x67591002 0x67401002 0x67411002 0x67451002


AMDRadeonX4000
AMDBonaireGraphicsAccelerator
0x66401002 0x66411002 0x66461002 0x66471002 0x66501002 0x66511002 0x665C1002 0x665D1002

AMDHawaiiGraphicsAccelerator
0x67B01002

AMDPitcairnGraphicsAccelerator
0x68001002 0x68011002 0x68061002 0x68081002 0x68101002 0x68181002 0x68191002

AMDTahitiGraphicsAccelerator
0x67901002 0x67981002 0x679A1002 0x679E1002 0x67801002

AMDTongaGraphicsAccelerator
0x69201002 0x69211002 0x69301002 0x69381002 0x69391002

AMDVerdeGraphicsAccelerator
0x68201002 0x68211002 0x68231002 0x68251002 0x68271002 0x682B1002 0x682D1002 0x682F1002 0x68351002 0x68391002 0x683B1002 0x683D1002 0x683F1002


AMDRadeonX4100
AMDBaffinGraphicsAccelerator
0x67E01002 0x67FF1002 0x67EF1002

AMDRadeonX4150
AMDBaffinGraphicsAccelerator
0x67E01002 0x67FF1002 0x67EF1002

AMDRadeonX4200
AMDBaffinGraphicsAccelerator
0x67EF1002 0x67FF1002

AMDEllesmereGraphicsAccelerator
0x67DF1002 0x67C01002

AMDRadeonX4250
AMDBaffinGraphicsAccelerator
0x67E01002 0x67E31002 0x67E81002 0x67EB1002 0x67EF1002 0x67FF1002 0x67E11002 0x67E71002 0x67E91002

AMDEllesmereGraphicsAccelerator
0x67C01002 0x67C11002 0x67C21002 0x67C41002 0x67C71002 0x67DF1002 0x67D01002 0x67C81002 0x67C91002 0x67CA1002 0x67CC1002 0x67CF1002

AMDRadeonX5000
AMDVega10GraphicsAccelerator
0x68601002 0x68671002 0x687F1002

ah,,,ok

my card ati 7750 with hight sierra dp1 no work....with sierra 10.12 work with verde.kext

next week when i go to work i try with higt sierra dp2

Link to comment
Share on other sites

ah,,,ok

my card ati 7750 with hight sierra dp1 no work....with sierra 10.12 work with verde.kext

next week when i go to work i try with higt sierra dp2

Well, with macOS High Sierra DP 2 they changed something and I'm not sure what. but there are several things that don't work anymore. For example I had sound working with DP1 on my Asus P8H77 mobo and now with DP 2 it doesn't work.

I think the "verde.kext" is not gonna work with DP 2 as well, but it'll be good if you can test it and give us the results. I hope I'm wrong and it works :D

Link to comment
Share on other sites

It might be off topic but I like to share that with clover 4079 I can boot into El Capitan 10.11.6, macOS Sierra 10.12.5 and macOS High Sierra DP 2 with a single config.plist file and the same kexts placed under "Other" folder.

  • Like 1
Link to comment
Share on other sites

I made an attempt at installing high sierra today but failed. I was able to get the installer on the USB and I used clove r4091. Clover did say it was incompatible and I used standard install. The USB would not boot and would just give me a black screen. Any ideas?

Link to comment
Share on other sites

I made an attempt at installing high sierra today but failed. I was able to get the installer on the USB and I used clove r4091. Clover did say it was incompatible and I used standard install. The USB would not boot and would just give me a black screen. Any ideas?

No infos hardware, no Infos about méthode 

Hard to help

  • Like 1
Link to comment
Share on other sites

I downloaded HS from the app store and then used terminal to install it to my USB. I then used Clover r4091 and I selected Install for UEFI only, Install in the ESP,

and OsxAptioFixDrv64. 

Link to comment
Share on other sites

I successfully installed High Sierra onto my Kaby Lake Lenovo v510, however I'm struggling with graphics - what is the proper ig-platform-id I should be using to load the kaby lake graphics drivers? I completed the installation with a bogus ig-platform-id since I wasn't sure which one to use and it would kp otherwise. 

 

i5-7200u, Intel HD 620.

 

my first guess would be 0x59160000, is this correct?

  • Like 1
Link to comment
Share on other sites

I successfully installed High Sierra onto my Kaby Lake Lenovo v510, however I'm struggling with graphics - what is the proper ig-platform-id I should be using to load the kaby lake graphics drivers? I completed the installation with a bogus ig-platform-id since I wasn't sure which one to use and it would kp otherwise. 

 

i5-7200u, Intel HD 620.

 

Which version of clover did you use? Also are you using beta 1 or 2? Last did you do a standard or custom install of Clover. Im new with this stuff.

Link to comment
Share on other sites

Which version of clover did you use? Also are you using beta 1 or 2? Last did you do a standard or custom install of Clover. Im new with this stuff.

Clover 4097. High Sierra dp2

 

install for uefi booting only

install clover in the esp

 

themes - bgm

drivers64uefi - emuvariableuefi-64

drivers64uefi - osxaptiofixdrv-64

 

then placed apfs.efi and hfsplus.efi into drivers64uefi

 

make sure you chose the correct install location for clover

also you need to place all the essential kexts into clover/kexts/other folder (fakesmc, etc).

  • Like 1
Link to comment
Share on other sites

Hmmm... my BCM94352HMB is working without any patches (just using FakePCIID kexts)

I havnt tried without any patches but will do today and report back. No patches and just kexts would be a great step forward.

 

Well my BCM94352HMB works also in HS without any patches using your FakePCIID kexts.

 

Sent from my SM-G930F using Tapatalk

  • Like 1
Link to comment
Share on other sites

Clover 4097. High Sierra dp2

 

install for uefi booting only

install clover in the esp

 

themes - bgm

drivers64uefi - emuvariableuefi-64

drivers64uefi - osxaptiofixdrv-64

 

then placed apfs.efi and hfsplus.efi into drivers64uefi

 

make sure you chose the correct install location for clover

also you need to place all the essential kexts into clover/kexts/other folder (fakesmc, etc)

Well that explains a lot. i didn't do anything after esp. Where can i get or learnt to make the required files/kexts? Thanks again

Link to comment
Share on other sites

So, with 10.13 Beta 2 (17A291j) update; my native Nvidia driver for GeForce GT 520M works OOTB and no longer crashed WindowServer (Patched DSM method for GFX0 on DSDT, or InjectNvidia=True), with Cursor disappears though. Anyone with GT 610 which is same Fermi GF119?  :)

post-826765-0-04858000-1498448539_thumb.png

  • Like 2
Link to comment
Share on other sites

So, with 10.13 Beta 2 (17A291j) update; my native Nvidia driver for GeForce GT 520M works OOTB and no longer crashed WindowServer (Patched DSM method for GFX0 on DSDT, or InjectNvidia=True), with Cursor disappears though. Anyone with GT 610 which is same Fermi GF119?  :)

Hi, I confirm that with the High Sierra beta 2 the Geforce GT610 works OOTB, I do not have the problem of the mouse cursor, but unfortunately in case of logout or restart or shutdown I have the system locks.

  • Like 1
Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
×
×
  • Create New...