Jump to content

HWSensors

FakeSMC Plugins Hardware Monitoring Sensors SuperIO Temperature Voltage Tachometer Frequency

  • Please log in to reply
1026 replies to this topic

#901
oswaldini

oswaldini

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 143 posts
  • Gender:Male
  • Location:Cracow, Poland

Hi Kozlek, I made an update Polish translation, please add to new revision.

 

Attached Files



#902
AppleGeek

AppleGeek

    InsanelyMac Protégé

  • Members
  • Pip
  • 21 posts
Hello kozlek it's me again.I really love new changes in HWSensors but I have difficulties with the latest GPUSensors.kext (radeon HD5770)
I have to remove GPUSensors.kext to boot normally.
Attached File  IMG_2305.JPG   279.19KB   20 downloads
But overall everything is OK
Attached File  Screen Shot 2013-08-04 at 12.34.50 AM.png   113.42KB   23 downloads

#903
shiecldk

shiecldk

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 222 posts
  • Gender:Male
  • Location:Taiwan

Hi kozlek,

I can't build the newest version. I encounter several errors in Xcode:

oVvhz7m.png



#904
mitch_de

mitch_de

    InsanelyMacaholic

  • Local Moderators
  • 2,879 posts
  • Gender:Male
  • Location:Stuttgart / Germany

Q: I have Nvidia GT 440 card / OS X 10.8.4. No freeze problem, OpenGL runs well.

HWMonitor (with Fakesmc, GPUSensor) works until i start some OpenGL task (like bench, windowed, which puts much load on the gpu) the screen gets white and pc stalls. No kp.

I tested newer and older versions - same happens. 

Can it be that the timing of reading out the gpu sensors makes trouble (interacts with OpengL tasks)?



#905
Riley Freeman

Riley Freeman

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 819 posts
  • Gender:Male
  • Location:The Streets

I'm running on my sig config, and with the last two HWSensors versions, i can't get to the boot screen, i'm using .678 now and i't all running great.

 

I get this in verbose on the latest HWSensors : 7/30/13 7:34:16.000 PM kernel[0]: FakeSMC: [Fatal] forbidding start on Apple hardware

 

Updated to .755 and still got this. So I took a look on github. You need to boot with -fakesmc-force-start in these newer builds. Perhaps it's just a testing phase and soon we can go back to booting normally.



#906
philip_petev

philip_petev

    InsanelyMac Protégé

  • Members
  • PipPip
  • 72 posts
  • Gender:Male
  • Location:Haskovo, Bulgaria

Hi, Kozlek,

Yesterday I tested the change from commit 44fca66e39d745b53141fa7fc860f1e3e6743b1e to see if it works for my board, Gigabyte H77N-WiFi (which is basicly the twin brother of Z77N-WiFi, regarding the chipset) and it works. May I ask you to add a copy of the same profile to the same file, but named "H77N-WIFI"? Thanks in advance.



#907
Alex Auditore

Alex Auditore

    InsanelyMac Legend

  • Donators
  • 698 posts
  • Gender:Male

Important information.

For non-Clover bootloaders, we must use the key -fakesmc-force-start at KernelFlags or boot-args with the last versions of HWSensors 5.2.755 and higher



#908
RehabMan

RehabMan

    InsanelyMac Legend

  • Coders
  • 1,096 posts
  • Gender:Male
  • Location:Bellingham, WA
  • Interests:skiing, software, classic cars

Important information.

For non-Clover bootloaders, we must use the key -fakesmc-force-start at KernelFlags or boot-args with the last versions of HWSensors 5.2.755 and higher

What boot loader are you using?  I'm using Chameleon svn-r2255 and I don't have to use that flag and latest FakeSMC built from sources (from my repo, but in this regard it should be identical).  That flag is only if firmware vendor is detected as Apple.



#909
Alex Auditore

Alex Auditore

    InsanelyMac Legend

  • Donators
  • 698 posts
  • Gender:Male

What boot loader are you using?  I'm using Chameleon svn-r2255 and I don't have to use that flag and latest FakeSMC built from sources (from my repo, but in this regard it should be identical).  That flag is only if firmware vendor is detected as Apple.

I have that problem only with bareBoot and XPC and only with the last version of HWSensors. I checked it. With Clover that's ok. XPC and bareBoot damand this special key.

There is good that Chameleon works without that key as well as Clover.



#910
Riley Freeman

Riley Freeman

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 819 posts
  • Gender:Male
  • Location:The Streets

I was having that issue with ErmaC's Enoch branch. Happened last night with .755 and Enoch r2254. I switched to Chameleon r2255 today and just now removed that flag. Booted fine.



#911
magnifico

magnifico

    InsanelyMac Deity

  • Donators
  • 2,294 posts
  • Gender:Male
I have a problem , with clover uefi , my pc restart and not work.
But if use branch Slice , work perfect.

Why ?

#912
naidb

naidb

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 180 posts
  • Gender:Male
  • Location:ThaiLand
  • Interests:mainboards gigabyte GA-Z87X-UD3H
    CPU intel HasWell Core i5 4670K
    Gell 16Gb 1866

See, CPU Core is 0.036V that is very wrong. It must be about 1V

Hello
I think it was then that it is in power save mode cpu.


#913
oswaldini

oswaldini

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 143 posts
  • Gender:Male
  • Location:Cracow, Poland

Next polish translation for 5.2.755. Kozlek can you send me full english template of Localizable.strings ?

 

Attached File  pl.lproj.zip   4.61KB   3 downloads



#914
VCH888

VCH888

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 585 posts

Hi kozlek

 

 

Could you add Z77X-UP5TH profile in your HWSensors?

 

Thanks.

 

source: Attached File  Z77X-UP5TH.zip   63.48KB   21 downloads



#915
TimeWalker75a

TimeWalker75a

    InsanelyMac Legend

  • Gurus
  • 918 posts
  • Gender:Male

Built latest sources, kexts don't seem to be loading properly due to signatures and/or versioning?

Aug 11 16:28:19 localhost kernel[0]: Kext org.netkas.driver.FakeSMC error - CFBundleVersion bad value ''.
Aug 11 16:28:19 localhost kernel[0]: Kext org.hwsensors.driver.CPUSensors error - CFBundleVersion bad value ''.
Aug 11 16:28:19 localhost kernel[0]: Kext org.hwsensors.driver.GPUSensors error - CFBundleVersion bad value ''.
Aug 11 16:28:19 localhost kernel[0]: Kext org.hwsensors.driver.LPCSensors error - CFBundleVersion bad value ''.

and because of that:

Aug 11 16:26:27 Dmitrys-MacBook-Air.local com.apple.kextd[12]: Can't load FakeSMC.kext - validation problems.
Aug 11 16:26:27 Dmitrys-MacBook-Air.local com.apple.kextd[12]: Load org.netkas.driver.FakeSMC failed; removing personalities from kernel.
Aug 11 16:26:27 Dmitrys-MacBook-Air.local com.apple.kextd[12]: Can't load CPUSensors.kext - validation problems.
Aug 11 16:26:27 Dmitrys-MacBook-Air.local com.apple.kextd[12]: Load org.hwsensors.driver.CPUSensors failed; removing personalities from kernel.
Aug 11 16:26:27 Dmitrys-MacBook-Air.local com.apple.kextd[12]: Can't load LPCSensors.kext - validation problems.
Aug 11 16:26:27 Dmitrys-MacBook-Air.local com.apple.kextd[12]: Load org.hwsensors.driver.LPCSensors failed; removing personalities from kernel.
 
Aug 11 16:26:28 Dmitrys-MacBook-Air.local com.apple.kextd[12]: Can't create kext: invalid CFBundleVersion in identifier cache entry entry 175.
Aug 11 16:26:28 Dmitrys-MacBook-Air.local com.apple.kextd[12]: Can't create kext: invalid CFBundleVersion in identifier cache entry entry 176.
Aug 11 16:26:28 Dmitrys-MacBook-Air.local com.apple.kextd[12]: Can't create kext: invalid CFBundleVersion in identifier cache entry entry 177.
Aug 11 16:26:28 Dmitrys-MacBook-Air.local com.apple.kextd[12]: Can't create kext: invalid CFBundleVersion in identifier cache entry entry 178.


#916
qwerty12

qwerty12

    InsanelyMac Protégé

  • Members
  • Pip
  • 49 posts
  • Gender:Male
  • Location:UK

Built latest sources, kexts don't seem to be loading properly due to signatures and/or versioning?


Is this under Xcode 4? Just curious. Under Xcode 5 at least, it won't build saying version.h is not to be found, but after looking, I see that Scripts/PreBuild.sh creates this file - the script should've been run by Xcode as part of the build process but does not for some reason - but it also sets the version number that is later inserted into the plists.

I did this before building in XCode (svnversion always returns "Unversioned directory" for me):
/usr/bin/sed -i '' 's/sc_revision=$(svnversion)/sc_revision="exported"/' Scripts/PreBuild.sh
sh Scripts/PreBuild.sh
and I got this in the resulting Info.plist inside FakeSMC.kext:
	<key>CFBundleVersion</key>
	<string>761</string>
which looks right to me since the FakeSMC.kext (installed from the official installer) inside my /S/L/E has a CFBundleVersion of 755

#917
TimeWalker75a

TimeWalker75a

    InsanelyMac Legend

  • Gurus
  • 918 posts
  • Gender:Male

Yup, thanks, that did the trick!

3ZqqE.png

No GPU monitoring for HD4600 yet though, but I guess this will some as the times goes.



#918
Slice

Slice

    InsanelyMacaholic

  • Local Moderators
  • 2,844 posts
  • Gender:Male
  • Location:Moscow

There is no "GPU" HD4600. There is CPU.



#919
TimeWalker75a

TimeWalker75a

    InsanelyMac Legend

  • Gurus
  • 918 posts
  • Gender:Male

There is no "GPU" HD4600. There is CPU.

Aida shows GT Core temp, so there's obviously some kind of GPU temperature even though it may not necessarily be a GPU as we assume it.

Sensors do show Graphics package wattage, so I presume there is also a register where temp for it is stored. This is a wild guess from the top of my head ofc, but this is as logical as it gets.



#920
Slice

Slice

    InsanelyMacaholic

  • Local Moderators
  • 2,844 posts
  • Gender:Male
  • Location:Moscow

All Intel's hardware specifications are open.







Also tagged with one or more of these keywords: FakeSMC, Plugins, Hardware Monitoring, Sensors, SuperIO, Temperature, Voltage, Tachometer, Frequency


1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy