Jump to content

Awesome Donkey

Members
  • Content count

    227
  • Joined

  • Last visited

1 Follower

About Awesome Donkey

  • Rank
    InsanelyMac Geek

Profile Information

  • Gender
    Male
  • Location
    United States

Recent Profile Visitors

3,499 profile views
  1. Awesome Donkey

    Site Issues

    Yep, randomly happening here as well, even after clearing browser cache and cookies along with flushing the DNS.
  2. Awesome Donkey

    Clover Themes

    The DarkBootX theme's main entries are off-center. Clover bug?
  3. Awesome Donkey

    Gigabyte Aorus Gaming 7 Bios F5e

    There's a F11 UEFI BIOS now. Haven't had time to try flashing it.
  4. Awesome Donkey

    Clover Themes

    Ahhh, noticed this myself and was coming in to report it, but it looks like you guys already know. Yeah, it's kinda annoying, but I can live with it until its fixed.
  5. Awesome Donkey

    Gigabyte Aorus Gaming 7 Bios F5e

    I guess the second attempt was the charm, the update to F10 worked this time around with no issues. @kaneske thanks for the patch info, looks like my USB 3.0 Bus and 3.1 Bus is showing under System Report - I *think* it's working correctly, but I could be wrong. @MaLd0n Do I need a new DSDT.aml since updating from the F7 to the F10 UEFI BIOS? I've dumped the stuff via Clover again just in case: Send me iMac.zip Thanks, as always. You guys are amazing!
  6. Awesome Donkey

    Gigabyte Aorus Gaming 7 Bios F5e

    @kaneske thanks a lot for the USB port patching info! No, I don't use EmuVariableUefi or RC scripts as I was under the assumption they weren't needed, especially since I'm using AptioMemoryFix and native NVRAM *seems* to be working fine. Nonetheless, I added them for the time being to see if there's any difference. If I notice issues, I'll probably remove them. I'll try updating to F10 again, and see if it works without the issues I experienced with every OS when booting. Maybe it was just a bad flash or something? We'll see...
  7. Awesome Donkey

    Gigabyte Aorus Gaming 7 Bios F5e

    Greetings @MaLd0n I've updated to 10.14.1 without issue... except for the last week or so I've randomly noticed an issue where wifi doesn't correctly work on some boots (like one boot out of ten). Is there anything wrong with my setup? I've tried to keep up with the latest kext/driver updates: Send me iMac.zip Also, how do you exclude unused ports to get USB 3.0 working without the USB limit patch? How's F10 working for you? I tried updating to it and everything went haywire with countless issues.
  8. Awesome Donkey

    Gigabyte Aorus Gaming 7 Bios F5e

    There's a F10 BIOS now, but I wouldn't recommend updating to it. It seems to mess up boot/display for everything so I downgraded back to F7.
  9. Awesome Donkey

    Gigabyte Aorus Gaming 7 Bios F5e

    An update to this, I haven't been able to get the HDMI 2.0 output working yet with my new Pixio PX277h monitor and the Sapphire RX 580 PULSE GPU. Some findings; - Having the latest Lilu+WhateverGreen doesn't make any difference, when it *should*. - Using the -cdfon boot-arg (and not using it for testing) for all of the tests. - Also tried removing/disabling WhateverGreen and manually using a framebuffer (Orinoco in this case). - In addition to using the Orinoco framebuffer I tried using RadeonDeinit = true, InjectATI = true and a kext patch for AppleGraphicsDevicePolicy that disables the board-id check that the 18,3 SMBIOS seems to do (which WhateverGreen, as far as I know, should do too). - DisplayPort and the HDMI 1.4 port work fine but the HDMI 1.4 port naturally doesn't give me 144hz under macOS (only 60hz). - The HDMI 2.0 port does work if I unplug it and replug it. Seems a bit cumbersome though. - I've extracted the EDID from Windows via the Custom Resolution Utility (CRU) app on Windows. Doesn't seem to make a difference. I've matched the EDID hex to what's seen under Linux as well, and it matches. Should I report this to the WhateverGreen thread? P.S. Another oddity that's semi-related I've noticed is, I can't get 144hz working under Linux (using Mesa+amdgpu) with DisplayPort either (and adding 144hz via xrandr results in a failure). Though I suspect this might be a Mesa/amdgpu bug, I'll have to look into that one at another date.
  10. Awesome Donkey

    Gigabyte Aorus Gaming 7 Bios F5e

    Greetings @MaLd0n I received a new monitor yesterday (a Pixio PX277h FreeSync 2 monitor) and while it works fine with DisplayPort, HDMI is another story. What happens is after the first stage of the boot, the monitor will go into sleep (and lose the signal). However if I unplug and replug the HDMI cable, it works fine then. Of course, I've already tried updating by building the latest Git commit of Lilu+WhateverGreen but that didn't work. I also tried using the -cdfon boot-arg and that didn't work either. CSM is turned off in the UEFI BIOS (and enabling CSM doesn't make a difference). Any ideas?
  11. Awesome Donkey

    Gigabyte Aorus Gaming 7 Bios F5e

    @MaLd0n it looks like you've done it again! It looks like everything is working again, including those ethernet kexts without KPs. Here's another dump to double check and see if I screwed anything up... Send me Michaels-iMac.zip
  12. Awesome Donkey

    Gigabyte Aorus Gaming 7 Bios F5e

    @MaLd0n So, I've updated to macOS Mojave... but it wasn't without any issues. When trying to upgrade (and then finally doing the first boot after upgrading) I noticed macOS would kernel panic almost immediately. My first thought was to manually disable kexts in Clover until it finally booted... and it did. It seems IntelMausiEthernet.kext and/or AtherosE2200Ethernet.kext was causing the kernel panic, as when removing both the kernel panics went away. So I removed those from my Clover kexts folder in the meantime. So I'm thinking there's probably something broken in my system somewhere. Otherwise, the other changes I've made since the last time was switching from FakeSMC to VirtualSMC, which seems to be working just fine. But who knows, it might be the cause, not sure. Just in case I did a new dump after booting into Mojave, would you mind looking and seeing if there's any issues, especially issues which might be the cause of those driver kexts kernel panicking? Thanks! Send me Michaels-iMac.zip EDIT: Also did a new DSDT dump with Clover just in case: DSDTDump.zip
  13. Awesome Donkey

    Gigabyte Aorus Gaming 7 Bios F5e

    Are you using a HDD or SSD for the macOS boot drive? If SSD, do you have TRIM enabled and using APFS? That can cause a slow boot with an SSD last I read. Though, @MaLd0n with Mojave can we enable TRIM again or does it still cause slower boot times with APFS and SSDs?
  14. Awesome Donkey

    VirtualSMC — SMC Emulator

    Just in case it's needed, here's my smcread -s dump from the system in my signature. macOS 10.13.6 (17G65) Public keys (103): [#KEY] type [ui32] 75693332 len [ 4] attr [80] -> 00000067 [$Adr] type [ui32] 75693332 len [ 4] attr [80] -> 00000300 [$Num] type [ui8 ] 75693820 len [ 1] attr [D0] -> 01 [BATP] type [flag] 666C6167 len [ 1] attr [80] -> 00 [BEMB] type [flag] 666C6167 len [ 1] attr [80] -> 00 [CLKH] type [{clh] 7B636C68 len [ 8] attr [D0] -> 0000708000011940 [CLKT] type [ui32] 75693332 len [ 4] attr [D0] -> 00009272 [CLWK] type [ui16] 75693136 len [ 2] attr [D0] -> FFFF [CRCA] type [ui32] 75693332 len [ 4] attr [80] -> 74D4B72F [CRCB] type [ui32] 75693332 len [ 4] attr [80] -> 13092CFA [CRCC] type [ui32] 75693332 len [ 4] attr [80] -> 713C1A60 [CRCF] type [ui32] 75693332 len [ 4] attr [90] -> 0319A5D5 [CRCK] type [ui32] 75693332 len [ 4] attr [90] -> 00000000 [CRCR] type [ui32] 75693332 len [ 4] attr [80] -> 050F16EE [CRCU] type [ui32] 75693332 len [ 4] attr [80] -> 097DAEE7 [CRCa] type [ui32] 75693332 len [ 4] attr [90] -> 74D4B72F [CRCb] type [ui32] 75693332 len [ 4] attr [90] -> 13092CFA [CRCc] type [ui32] 75693332 len [ 4] attr [90] -> 713C1A60 [CRCr] type [ui32] 75693332 len [ 4] attr [90] -> 050F16EE [CRCu] type [ui32] 75693332 len [ 4] attr [90] -> 097DAEE7 [DPLM] type [{lim] 7B6C696D len [ 5] attr [51] -> NOT READABLE, code 85 [DUSR] type [ui8 ] 75693820 len [ 1] attr [40] -> NOT READABLE, code 85 [EFBM] type [ui8 ] 75693820 len [ 1] attr [C0] -> 00 [EFBP] type [ui8 ] 75693820 len [ 1] attr [C0] -> 00 [EFBS] type [ui8 ] 75693820 len [ 1] attr [D0] -> 0D [EPCI] type [ui32] 75693332 len [ 4] attr [80] -> 0810F000 [EVCT] type [hex_] 6865785F len [ 2] attr [D0] -> 0000 [EVHF] type [ch8*] 6368382A len [28] attr [90] -> 00000000000000000000000000000000000000000000000000000000 [EVRD] type [ch8*] 6368382A len [32] attr [90] -> 0000000000000000000000000000000000000000000000000000000000000000 [FAC0] type [ui8 ] 75693820 len [ 1] attr [C0] -> 00 [FNum] type [ui8 ] 75693820 len [ 1] attr [80] -> 00 [HBKP] type [ch8*] 6368382A len [32] attr [C0] -> 0000000000000000000000000000000000000000000000000000000000000000 [LDKN] type [ui8 ] 75693820 len [ 1] attr [80] -> 02 [LDLG] type [ch8*] 6368382A len [ 1] attr [50] -> NOT READABLE, code 85 [LDSP] type [flag] 666C6167 len [ 1] attr [40] -> NOT READABLE, code 85 [LsNM] type [ui8 ] 75693820 len [ 1] attr [80] -> 00 [MSDW] type [flag] 666C6167 len [ 1] attr [50] -> NOT READABLE, code 85 [MSFW] type [flag] 666C6167 len [ 1] attr [C0] -> 00 [MSPC] type [ui8 ] 75693820 len [ 1] attr [D0] -> 19 [MSPP] type [ui8 ] 75693820 len [ 1] attr [80] -> 00 [MSPR] type [ui8 ] 75693820 len [ 2] attr [80] -> 0001 [MSPS] type [hex_] 6865785F len [ 2] attr [80] -> 0004 [MSQC] type [ui8 ] 75693820 len [ 1] attr [80] -> 00 [MSSD] type [si8 ] 73693820 len [ 1] attr [D0] -> 05 [MSSP] type [si8 ] 73693820 len [ 1] attr [C0] -> 05 [MSSW] type [flag] 666C6167 len [ 1] attr [C0] -> 00 [MSTc] type [ui8 ] 75693820 len [ 1] attr [80] -> 00 [MSTe] type [ui8 ] 75693820 len [ 1] attr [80] -> 00 [MSTf] type [ui8 ] 75693820 len [ 1] attr [80] -> 00 [MSTi] type [ui8 ] 75693820 len [ 1] attr [80] -> 00 [MSTj] type [ui8 ] 75693820 len [ 1] attr [80] -> 00 [MSTm] type [ui8 ] 75693820 len [ 1] attr [80] -> 00 [MSWr] type [ui8 ] 75693820 len [ 1] attr [80] -> 00 [NATJ] type [ui8 ] 75693820 len [ 1] attr [C0] -> 00 [NATi] type [ui16] 75693136 len [ 2] attr [C0] -> 0000 [NTOK] type [ui8 ] 75693820 len [ 1] attr [50] -> NOT READABLE, code 85 [OSWD] type [ui16] 75693136 len [ 2] attr [C0] -> 0017 [RBr ] type [ch8*] 6368382A len [ 8] attr [80] -> 6A3133335F345F00 [REV ] type [{rev] 7B726576 len [ 6] attr [90] -> 02410F000001 [RGEN] type [ui8 ] 75693820 len [ 1] attr [80] -> 02 [RMAC] type [ch8*] 6368382A len [ 6] attr [C4] -> E0D55E29F724 [RMSN] type [ch8*] 6368382A len [17] attr [C4] -> 4330323033323130395235444337373148 [RMde] type [char] 63686172 len [ 1] attr [80] -> 41 [RPlt] type [ch8*] 6368382A len [ 8] attr [80] -> 6A31333500000000 [RSSN] type [ch8*] 6368382A len [16] attr [C4] -> 43303254463231574A31474A00000000 [RVBF] type [{rev] 7B726576 len [ 6] attr [90] -> 02280F000007 [RVCR] type [{rev] 7B726576 len [ 6] attr [90] -> FFFFFFFFFFFF [RVUF] type [{rev] 7B726576 len [ 6] attr [90] -> 02280F000007 [WKTP] type [ui8 ] 75693820 len [ 1] attr [D0] -> 00 [PC0C] type [sp96] 73703936 len [ 2] attr [80] -> 0666 [PC0G] type [sp96] 73703936 len [ 2] attr [80] -> 0000 [PC0R] type [sp96] 73703936 len [ 2] attr [80] -> 0666 [PC3C] type [flt ] 666C7420 len [ 4] attr [80] -> 00000000 [PCAM] type [flt ] 666C7420 len [ 4] attr [80] -> 4CDECC41 [PCEC] type [flt ] 666C7420 len [ 4] attr [80] -> 00000000 [PCGC] type [flt ] 666C7420 len [ 4] attr [80] -> 00000000 [PCGM] type [flt ] 666C7420 len [ 4] attr [80] -> 00000000 [PCPC] type [sp96] 73703936 len [ 2] attr [80] -> 0666 [PCPG] type [sp96] 73703936 len [ 2] attr [80] -> 0000 [PCPR] type [sp96] 73703936 len [ 2] attr [80] -> 0807 [PCPT] type [sp96] 73703936 len [ 2] attr [80] -> 0807 [PCTR] type [sp96] 73703936 len [ 2] attr [80] -> 0807 [TC0C] type [sp78] 73703738 len [ 2] attr [80] -> 2600 [TC0D] type [sp78] 73703738 len [ 2] attr [80] -> 2A00 [TC0E] type [sp78] 73703738 len [ 2] attr [80] -> 2A00 [TC0F] type [sp78] 73703738 len [ 2] attr [80] -> 2A00 [TC0G] type [sp78] 73703738 len [ 2] attr [80] -> 0000 [TC0H] type [sp78] 73703738 len [ 2] attr [80] -> 2A00 [TC0J] type [sp78] 73703738 len [ 2] attr [80] -> 0000 [TC0P] type [sp78] 73703738 len [ 2] attr [80] -> 2A00 [TC0c] type [sp78] 73703738 len [ 2] attr [80] -> 2600 [TC0p] type [sp78] 73703738 len [ 2] attr [80] -> 2A00 [TC1C] type [sp78] 73703738 len [ 2] attr [80] -> 2700 [TC1c] type [sp78] 73703738 len [ 2] attr [80] -> 2700 [TC2C] type [sp78] 73703738 len [ 2] attr [80] -> 2700 [TC2c] type [sp78] 73703738 len [ 2] attr [80] -> 2700 [TC3C] type [sp78] 73703738 len [ 2] attr [80] -> 2600 [TC3c] type [sp78] 73703738 len [ 2] attr [80] -> 2600 [TC4C] type [sp78] 73703738 len [ 2] attr [80] -> 2600 [TC4c] type [sp78] 73703738 len [ 2] attr [80] -> 2600 [TC5C] type [sp78] 73703738 len [ 2] attr [80] -> 2A00 [TC5c] type [sp78] 73703738 len [ 2] attr [80] -> 2A00 [VC0C] type [sp3c] 73703363 len [ 2] attr [80] -> 0A51 Hidden keys (?): [____] type [flag] 666C6167 len [ 1] attr [80] -> 01 [OSK0] type [ch8*] 6368382A len [32] attr [90] -> 6F757268617264776F726B62797468657365776F72647367756172646564706C [OSK1] type [ch8*] 6368382A len [32] attr [90] -> 65617365646F6E74737465616C2863294170706C65436F6D7075746572496E63 [KPPW] type [ch8*] 6368382A len [32] attr [50] -> NOT READABLE [KPST] type [ui8 ] 75693820 len [ 1] attr [80] -> 00
  15. Wait, so you don't need to add AppleImageLoader.efi and it'll still work fine?
×