Jump to content
InsanelyMac Forum
bilbo

[Guide 2018] Z820 - SIERRA, The great guide (Sucess)

Recommended Posts


THE GREAT GUIDE

 

SIERRA + Z820

 

screen1.pngscreen2.jpg

 

 

 

***

02/17/2018

 

(from El capitan's guide)

 

 

Introduction:

 

Hi everybody.

Yes I know. Maybe it is a little late for Sierra but I need a stable system and I always go to for final release. In my opinion, High Sierra is a beta. Anyway, yes, it’s late, but I didn’t have too much time last year.

 

WORK- Everything except Sleep and common graphical issues related with non-supported graphic cards and nvidia drivers.

 

Some important topics:

 

1. The update.

Some procedures are now easier and shorter, and with the help of DSDT patched, an/or DSDT auto-patches, I hope it will be easier for everybody. This is a guide DSDT-centric. If you have the right bios version, you will be able to get it quick and easy. If not, I’ve described how do it anyway. But I strongly recommend update the bios to 3.91. It´s a safe process from windows.

 

2. Credits.

I’m not an expert. Best improves of this guide has been possible thanks to some people. All credit for them.

 

-Thanks for the audio fix for macpeet and Rockey12

-Thanks for the Lsi driver patched for Sierra to despeinao

-Thanks for DSDT patching to Maldon

-Thanks for SSDT patching info for 26x7 and 26x3 models to Hugodlc

 

3. Please, help to improve this guide.

Consider any part of this guide open to discuss. If you see something wrong, or which could be improved, please, just say it, and I’ll fix it.

English is not my native language. If you can’t understand some step, or something could be best written, please, just say it (via pm if you want ) and I’ll fix it too ;)

 

4. Some important considerations about hardware:

In short, there are V1 versions (for E5-Xeons V1, Sandy Bridge) and V2 (for E5-Xeons V2, Ivy bridge). Both of them are identical in generic specs (audio, usb, ethernet, pci, etc), but their bios are slightly different. Remember that DSDT is related to bios version. And SSDT is related to CPU model. Don’t exchange them. I provided DSDTs for 3.91 in V1 and V2 versions. If you have other version, and you don’t want or you can’t update, just follow the full guide to patch your DSDT.

Anyway, with patches, edit DSDT is easy. But, I’m still recommeding extract your DSDT and SSDT and patch them.

 

IMPORTANT WARNING FOR 26x7 and 26x3 USERS!!!. These models have a special cpu definitions in SSDT, causing the “Should have XX threads but only found YY” error. Please, go to Appendix (under construction).

 

5. And please, (this is for "anonymous" users) don't PM me with questions. No need for that. Any question can be answered openly.

 

 

Ok, let’s go.

 

________________________________________________________________________________________________________________________

 

PART I

 

1-BIOS SETUP

 

 

This guide is for UEFI systems. This is not important to follow this guide except in Clover installation section. Keep in mind it to adapt some settings if you need it, use legacy-bios mode.

 

If you don’t need any special option, and you have been playing with options, reset the bios to default settings.

 

6. The main BIOS options are:

 

In storage options:

set ACHI mode (IMPORTANT).                                                         Set boot order. UEFI first, (for me), USB first and HD second.

 

screen3.jpg          screen4.jpg

 

 

 

Security options:

Device Security: I like disable unused devices (scu controller        Disable Vt-d.  IMPORTANT

and serial port). Optional

 

screen5.jpg          screen6.jpg

 

 

 

Disable Secure boot. Enabled. (For boot with non signed OS).     In power options:

I use UEFI boot, but I keep legacy support active.                           Set Runtime power management to Enabled.This option will allow Power

(This is optional.)                                                                        Management later.

 

screen7.jpg           screen8.jpg

 

 

In power options:                                                                         In Advanced:

About the rest of options, I’m not sure of the impact in                    Set PXE, Storage and Video to EFI. (for me).

performance.                                                                                  If you have a graphic card non EFI-compliant, you can set video

in Legacy, keeping an UEFI boot.

Don’t forget set thunderbolt policy in Legacy mode.

 

screen9.jpg           screen10.jpg

 

 

________________________________________________________________________________________________________________________

 

 

PART II:

INSTALLATION

 

7- MEDIA CREATION

 

(This guide assume you have a MacOs running. I have no idea how do it on PC)

 

-Important: Download Sierra dmg only from Apple. Don´t use suspicious dmgs or Isos. It’s not longer available to search in Apple Store, but you can find one link to download it from Apple Store. ("get os mac os sierra" link) It’s 10.12.6. Let the file in Applications folder. (and keep one compressed copy for future attempts).

 

-Download my stuff folder with all necessary stuff.

-Format one USB stick with common settings:

 

screen11.jpg

 

Go to erase tab, select GUID partition table in options, and Mac Os Extended (Journaled) as Filesystem. Name the partition as “USB”. Ok to Apply.

 

-On a terminal window, type (copy and paste) :

sudo /Applications/Install\ macOS\ Sierra.app/Contents/Resources/createinstallmedia --volume /Volumes/USB --applicationpath /Applications/Install\ macOS\ Sierra.app --nointeraction

-Enter and type your admin password. It will take 10-15 minutes. (When it finish, you’ll see the prompt again)

 

8. INSTALL CLOVER.

 

-Download Clover from here . Version used to make this guide: Clover_v2.4k_r4359 ((Sierra requires r3994 or newer) )

-Download Clover Configurator from here. It makes easier edit config.plist file

-Download plisteditor pro demo for edit info.plist files.

-Download additional tools for install kexts, fix permissions and rebuild cache. I use Kext helper from rampage’s dmg, although I need always forcequit. An alternative is Kext Utility.

-Maybe EFI mounter (from download sections). CloverConfigurator mounts EFI too, but maybe with this utility is easier.

 

-Install Clover in the USB. On first screen, don’t forget change the install location in order to do not install on your Internal HD. Select your USB stick.

-Click on Customize.

-Choose “Install for UEFI booting only” and “Install Clover in the ESP” as main options (if your system is UEFI-based)

-This is optional: choose your favorite Theme.

-In Drivers64UEFI select: / EmuVariableUefi-64 / OsxAptionFix2Drv


screen12.jpg

 

Let the rest of option unselected and Click on Install.

 

 

9- CONFIGURE CLOVER

 

When clover finish, It will mount EFI partition. Time to modify it. You’ll find all necessary files in my folder. There are three things to modify: config.plist, drivers, and kexts

-Owners of CPU models 26x7 or 26x3 see appendix 2. (It’s not finished yet)

 

9.1 Config.plist

 

The default config.plist is not useful for us. Replace it by mine (folder n.2)

But take a look to options (with clover configurator) to understand my options in order to be able to adapt them for your specs or your preferences. It’s a basic config.plist. I could add more options or fixes. but is a good idea install with minimum options.

 

Acpi.

All fixes in ACPI section has been removed except some minor fixes in 2 subsection, smart ups option, etc. SmartUps it’s not important now, but it will be later. So I prefer activate this option.

The most important, The rename usb devices patches are included.

 

screen13.jpg
 

 

Boot

Bootflags needed are only -v and npci=0x2000. Of course -v is optional only to see the boot process. You can deactivate it when you finish.

 

screen14.jpg

 

Any option activated in Boot Graphics/ Cpu/Device/Disable driver

 

 

Gui options. These are only personal preferences.

 

screen15.jpg

 

 

Graphics. Any Graphic injection and any option activated. At least, no needed for my 1080ti card. Check it out for your card video.

 

An essential section. Kernels Patches needed

 

Screen17.jpg

 

 

RT Variables booterConfig, and Csr to deactivate security policy in Sierra. The info values are taken from smbios.

 

Screen18.jpg

 

 

One important change from El cap’s guide. SMBIOS is set to Mac Pro 6,1. We will be able to avoid the black screen later, with the right kexts.

 

Screen19.jpg


IMPORTANT—> press “generate new” repeatedly to get one random fresh serial number

 

System parameter:


Screen20.jpg

 

 

9.2 -Drivers64UEFI folder.

 

You’ll see more drivers installed than you selected. That is because some of them are mandatories. That is fine.

As usual, delete VBoxHfs-64 driver and replace it by HFSPlus.efi. (from my folder).

 

screen21.jpg

 

9.3 Kexts:

 

Add Kexts from my stuff to /EFI/CLOVER/Kexts/10.12

 

They are:

 

screen22.png

 

-FakeSMC.kext ,(from rampagdev, dual cpu dmg or X79 ) Without lpc sensor plugin. This plugin sometimes causes KP

 

-VoodooTSCync.kext, to avoid boot with -x (from rampagdev, dual cpu dmg or X79.dmg)

You’ll find several versions into my folder. One generic version ans several for every core number. I haven’t noticed any change using the generic or the specific version. I think that is not important for our platform. I provided the generic version and customized versions for every cpu.

 

Anyway, try if you want.The customize method is:

Spoiler

Find out the right number: (([Number of cores] x 2) x [number of cpus] -1).

Two examples:

-for single six-core. (6X2)-1 = 11

-for double octo-core: ((8x2)x2)-1 = 31

-And opening the info.plist into VoodooTSCync.kext. search this:

 

<dict>
<key>IOCPUNumber</key>
<integer>1</integer>
</dict>

 

-change the “1” by the number.

The default VoodooTSCync.kext has 1 as the value. Is the recommended value for some cpu models (non Xeon).

Anyway, I provided of all VoodooTSCync.kext versions already patched.

 

-IntelMausiEthernet.kext. One better kext for the ethernet card from rehabman. (2017-0914 version)

 

-UsbInjectall, for USB2 from rehabman ( 2017-1214 version)

 

 

And add to /EFI/CLOVER/Kexts/others

 

 

screen23.png

 

-Lilu kext (from here , 1.2.0 version  1.2.2 version)

 

-NvidiaGraphicsFixup.kext ( from here , 1.2.1)

 

This couple of kexts avoid black screen booting with 6,1 smbios. Is quite important keep in mind the versions of these kexts. 1.2.1 works only with lilu 1.2.0. In a future, is important keep the right versions among this kexts.

 

Thats all. We have our usb installer ready. Copy in a folder all stuff necessary to repeat the process and copy it to the USB stick. You will have it available after first boot.

 

Reboot from the USB stick and install Sierra.

 

10- INSTALLATION

 

Some advices:

-The internal HD have to be connected to grey internal sata connectors labeled as AHCI 6Gb/s into HP's doc.

-Use only USB2 ports, and only in the front USB2 port.

-Don’t use USB hubs, or cable extenders… (personal issues)

-Unplug any other usb device

-The boot process may be slow, (and with terrible and apocalyptic errors). Be patient

-Maybe, the boot stucks with the error “consideredRebuildKernel …. blabla”. Just reboot again.

-If you have two monitors, shutdown one can help with graphical errors.

-Plug your graphic card in PCI Slot 2.

-For inexperienced users, to install: On first screen, go to disk utility and erase the Volume. (Mac Os Extended (Journaled) and GPT). Quit the utility and return to first screen. Choose Install.

-Now the process is splitted in two steps. The first step promises take only 8 minutes. Nope. It will take 30-40 minutes. Move the mouse from time to time to refresh the screen. Again, be patience.

-After this first reboot, select in clover the new internal sierra installer partition, not the usb installer. It will finish the process. This step, yes, takes 10min aprox (using a SSD)

-To boot again, keep booting from USB but choose internal HD as boot volume.

 

________________________________________________________________________________________________________________________

 

 

PART III:

FIRST BOOT

 

11. Optional updates.

If you are interested in install security updates, now is the right moment. If not, jump to next point.

There are two security update for 10.12.6 : "2017-002" and "2018-001".

Forget completely the 2018-001. It’s probably that it causes KP. ( I tried and I screw up it).  You can use this update using versionn 1.2.2 of LILO kext. (version updated in the sutff folder.)

You can install the 2017-002. thought it’s not longer available in Apple store. But there is a direct link to download it. Just open it, reboot, wait for the process, and you will be back at the same point.

With this update, the Mac OS Version is 16G1114 . Anyway, I repeat it , it's optional.

 

12- Install Clover.

On first reboot, install clover again on HDD, repeating same process and same options than with the USB installer , but keep in mind you have to add some options on clover’s screen install:

 

Screen24.png

 

-Install RC scripts on target volume

-Optional RC scripts

-Install Clover Preference Panel.

… and install clovermanager.app. This is optional but it’s the best way to manage the themes and find a good theme, because the default themes are… well, I have no words. In my folder you´ll find mine (a customized version from El Capitan’s theme). Bootcamp is another theme for those who doesn’t like the clover’s catalogue. And maybe the most appropriate for a professional environment. Of course, left this for later.

 

Install clover and add same files used on the USB: config.plist , hfsplus driver and kexts. Reboot. You can now extract the USB installer and reboot from the internal HDD.

After boot, go to clover preference panel and set it to auto mount EFI partition. It will be useful along this process. Disable this when you finish and you get stable your system.

 

 

Edited by bilbo

Share this post


Link to post
Share on other sites
Advertisement

PART IV:

FIXING (I)

 

13- GRAPHICS.

If you use a Nvidia card, sure that first what you want is install webdrivers. Some cards works out of the box but the most of them need the nvidia drivers. But if with El Capitan the big headache was the usb ports, with Sierra (and High Sierra) the big pain in the ass is the graphic card. The issues with graphics are out of the purpose of this guide, not the discuss, of course. I can only explain the steps for install the drivers which work for me..

I don’t have AMD cards. I don’t know nothing about AMD issues. If you are a AMD owner, post your tip to complete the guide.

 

-The first recommended step is enable SIP temporally: Open your config.plist with clover configurator and set 0x00 in CsrActiveConfig field.

-Reboot

- Go to nvidia webpage and download the right web driver version. Remember that every update changes the driver version.

 

378.05.05.25f06 --> build 16G1212    ////    378.05.05.25f04 --> build 16G1114 

378.05.05.25f03 --> build 16G1036   ////     378.05.05.25f01 --> build 16G29

 

(To find out the number version, go to About this mac and click under MacOs Sierra, next to “version 10.12.6”)


-Open the installer and install the webdriver. Not reboot. Activate nvidiaweb option in System Parameters section in Clover.

 

screen25.png

 

-And set again SIP: 0x67 in CsrActiveConfig field.

-Just in case, select nvda_drv=1 bootflag . It is deprecated in Sierra as bootflag. It only needs to be permanent present in nvram, and the nvidia’s installer do the work adding this flag to nvram. But I’m not sure. People still activating it as bootflag. So, just do it. Reboot and cross your finger to not get a black screen.


If you have any problem, reboot and activate nv_disable=1 in clover boot screen, to reboot and to try to fix the problem. There are several threats with info and guides for fix problems.

Also, if you have two monitors, (like me) and one is connected via DVI port, probably you will have problems. Booting with both monitors,maybe you get a black screen. The fix is turn off the other monitor during the boot. The conflict is DVI port + any other port. ( in my case, the other one is connected via DP ). I fixed it buying one (cheap) dvi to hdmi adapter.

 

If your reboot is successfully, check in nvidia control panel if you have the driver selected. Maybe you have to select it and reboot again.

 

14- Go to nvidia website and download and install cuda drivers. Optional. Useful if you use apps which use cuda co-process.

 

 

________________________________________________________________________________________________________________________

 

 

 

PART IV:

FIXING (II)

 

15- AUDIO / FIREWIRE / USB / INTERNAL SATA LSI.

This section is now easier and quicker. The DSDT is now automatically-patched. Anyway, in my stuff you’ll find a repository with different DSDT from last bios versions, and their different patched versions. So, you can skip the patching of DSDT file. If you don´t have last bios version, or you want to know how do it (good thing) the next steps will show you.

 

The steps are: extract DSDT, use MacIASL and apply patches, basic DSDT patching, specific patching, and install appropriate kexts. (Don´t reboot until the end of the section)

 

16- DSDT extraction:

On your current system, reboot and press F4 on clover screen. Then, boot normally. You will find your original DSDT on EFI/CLOVER/ACPI/Origin (there will be more tables. Keep DSDT and SSDT files, and delete the rest of them). Preserve a copy of original file. I like compress the original files to preserve them of changes.

 

17- MacIASL

Download MacIASL Important. Don’t use official 1.4 version. Use this port released by rehabman. (last version). 1.31 (252.3) version in info screen.

 

-Check the preferences. In sources options, this version include main repositories. Include additional if you have some favorites.

 

screen28.jpg

 

-In general options, deselect “open system DSDT by default”. This is only to avoid misunderstandings for inexpert people with “what I am exactly patching”.

 

screen26.png

 

-In iASL, Active ACPI 4.0. Deselect all options about errors.

 

screen27.jpg

 

18. Cleaning. Fixing syntax errors.

Copy your original DSDT to /CLOVER/ACPI/PATCHED, and open it with MacIASL, and click compile. You’ll see the errors. (If you click over the error, you’ll jump to the right line)

These are syntax error of my original DSDT-bios 3.90. In 3.91 there is one error more.

 

screen29.jpg

 

 

Let’s go to fix them. In my folder (DSDT/patches) there are several patches. To apply them, you can use two ways.

 

screen30.jpg

 

- Click patch (1). Then click open (2) , and choose the patch file. Click “Apply”, “Close” and then “Compile”.

 

-Instead open a file, you can copy and paste the whole code, or one extract , take a look to code, edit it, etc, if you are testing: Click patch (1), open the patch file as text file (3) (it’s a txt file), select the code section, (4) copy it (5). Go back to maciASL and paste the code (6). Apply (7) and compile.

 

 

From my folder n.4/DSDT/PATCHES apply patch for syntax errors: “SYNTAX ERRORS”, (in ACPI 4,0 and ACPI 6,1). After apply this patch and compile it, the error windows is clean. Save it.

 

19. Fixing IRQ and HDEF in DSDT

Fix IRQ conflict allows work to firewire. Fix IRQ and add-HDEF device allows work to audio.

 

- Open the DSDT with MacIASL. Set ACPI to 6.1. We’ll use 6.1 for the rest of the guide.

 

-Apply patch “IRQ_and_HDEF”. The code is ready for fix IRQ conflict and add the right HDEF for our Audio Card (thanks to macpeet again). Ignore any other HDEF's code that you can find, including the code from El Cap’ guide. That’s all. This step saves the loooong step from el Cap’s guide.

 

-Compile and save it.

 

20-Firewire

After our DSDT patching (and reboot), firewire will work. But don’t reboot yet.

If you don’t have any Firewire peripheral, maybe is not important, but checking Firewire state, we check if IRQ conflict has been fixed.

 

21- Fixing Audio

This topic is now easier!!!. After DSDT patch, we only have to add a couple of Kexts: CodecCommander and appleALC: (updated... only AppleALC)

From Folder n. 3 / Audio:

          AppleALC:

AppleALC is a nice project for support codecs without any filesystem modifications. Recently, in the z800 thread, macpeet added the codec definitions to this Kext for our audio card. After a few tests and feedbacks, we can say that this kext is ready for z820. The macpeet’s patch has been incorporated to last revision, 1.2.3.

But this version has not been released. For the moment, use the AppleALC kext from in my stuff. I guess that it will be officially released soon.  1.2.3 version has been released. It has been updated in the stuff folder.  With this official version, codeccommander is not needed anymore.

 

-Copy AppleALC to /EFI/CLOVER/kexts/other

          

           -Copy codeccommander (from rehabman project (2017-0501 version) to /EFI/CLOVER/kexts/10.12    <<---- This kext is not needed anymore with the        official release of AppleALC 1.2.3 and newer

 

USE only these versions !! The versions among codeccommander, AppleALC, Lilu and NvidiaGraphicsFixup.kext are interrelated. Don’t update none of them until you are sure that the it will be compatible with the rest of them.

 

-Open your config.plist with clover configurator, and in audio injection section set it to 28. Save.

 

screen31.jpg

 

 

… and that’s all!!!

 

 

22. Fixing USB2 and USB3

 

First: Forget the steps from El Cap’s Guide. It’s completely obsolete.

So far we have:

- A clover rename patch for USB2

-USBInjectAll kext.

 

For USB2:

For more consistency in future DSDT patches, I prefer apply all patches to DSDT:

 

-Open your DSDT, and apply the “rename USB devices” patch file. This patch rename native USB2 and USB3 to standard names. Compile and save it.

-With this patch, the clover’s patches are redundant. So, Delete patches from clover.

 

Screen32.png

 

 

The next step would be add the clover patch  "raise the port limit". Everybody use this patch. Rehabman says and says that this patch shouldn’t be used in long term. Only for test. Because it applies a kind of brute injection. And he’s right (of course ;) ) Sometimes, testing, I’ve noticed weird things using this patch.

 

So I followed the long guide to create a custom SSDT. This SSDT override the info.plist of USBInjectAll kext and inject only used usb ports. In this way, we don’t fall in limit ports problem. And we don’t have to use the limit-port’s patch. This SSDT can be used for all Z820 models. If anyone wants detailed info about that, just comment it. After this log explanation , we only have to:

 

-Copy the SSDT (“SSDT-UIAC-ALL”) (from folder n3/fixes/usb) to EFI/CLOVER/ACPI/patched/

 

That’s all about USB2

 

For USB3:

 

One of the part more expected. Now USB3 works!!. Thanks to shamman which tell us about this kext.

 

-Just, copy mXHCD.kext to 10.2 folder of clover. Again, that’s all!!!!

 

23. Fixing LSI 2308 internal SAS controller.

 

It works too. Several user reported that the kexts from El Capitan caused KP in Sierra. But thanks to despeinao, we have these kext patched for Sierra.

 

-Copy the kext to /EFI/CLOVER/kexts/10.12. They work as well as in El Capitan. Thank very very much to despeinao, because to have the internal sata card working is one of the keys of this project.

 

24. Thunderbolt PCI

Thunderbolt is still working out of the box.

 

 

With this ton of fixes, reboot, and check that everything works. Check in systemprofiler, Firewire, Audio, internal Hard Disks plugin to LSI, USB2 and USB3 ports…

We have our system almost 100% working.

Edited by bilbo

Share this post


Link to post
Share on other sites

PART V:

Power Management

 

The funniest topic  :P  . It’s essentially same as in El Capitan. Now is a bit easier because current clover’s versions inject native SDDT ‘s names better than previous clover versions. So, we avoid the “No ACPI Processor declarations found in the DSDT! “. No need to copy SSDT code to DSDT anymore  update: It seems this is not completely true. See

 

 

Some things are updated. Anyway, if you are an inexpert user, don’t be afraid. It’s easier that you can think. It takes me longer in explain it than do it.

 

25. Setting up the scenario.

-Install HWsensors. Be careful and deselect fakesmc or plugins on installation screen. Launch the app. Set your favorite icons and info to show on bar menu. Set the app to launch on every boot.

-Check that you have activated "smart ups" option in ACPI section in clover. This means "system type 3 (workstation)" to manage PM.

-Reboot.

 

-Now you can see the cpu speed. It’s still running at speed stock. We don’t have PM yet

 

26. Now we are going to install the tool to check our C and P – states. Unfortunately, the log mechanism in Sierra is new and absolutely insane and makes the use of AppleIntelCPUPowerManagementInfo.kext useless. The “new” player is AppleIntelInfo.kext of PIKE.

 

BUT (a big but):

 

First: following PIKE’s instructions, everyone has to compile the kext by himself. I’m not sure if this is strictly needed and if the kext compiled can be shared.

 

Second: The kext compiled “as is” give us a KP

 

I patched it to fix the KP. And I have this kext correctly compiled in my stuff folder. So you can:

 

A -Use my kext. It’s compiled under 10.12.6 16G1114. But maybe you get a KP.

B -Compile the kext yourself (it’s very easy!!!!)

 

27. To compile AppleIntelInfo.kext

 

-Download and install Xcode from Applestore.

-Go to Piker GitHub page, and download the project:

 

screen33.png

 

-Extract the .zip, open the folder, and run the Xcode project opening the AppleIntelInfo.xcodeproj file file with Xcode. Locate the Report MSR section.. that is the reason of KP !!! It took me hours of tries.

 

screen34.png

 

-Set it to 0, to disable it.

-To compile the kext, just click on the play icon (at the top of the window)

That’s all. The kext compiled is in (Your User)/Library/Developer/Xcode/ DerivedData/AppleIntelInfo/Build/Products/Debug/AppleIntelInfo.kext  ( :huh:

This Kext is not for install!!. Just keep it in your favorite place.

 

-Fix permissions:

cd /Path to AppleIntelInfo (whatever you left it)
sudo chown -R root:wheel AppleIntelInfo.kext
sudo chmod -R 755 AppleIntelInfo.kext

-To test if it causes KP, load it:

sudo kextload AppleIntelInfo.kext

It all is OK, no shouldn’t have KP. Enough because we don’t have PM yet.

To disable it:

sudo kextunload AppleIntelInfo.kext

Next step is patch the AICPUPM kext. I provide of original and patched files in stuff folder (Warning, patched for only Ivy Bridge) Again, if you can take the risk and skip the whole step 28, but keep in mind that this kext goes to S/L/E, and it’s hard recover a system with a wrong extension .

If not, or you have a V1 cpu, follow next step. It exactly as in El Capitan. Just you have to follow the updated threat.

 

28- First part. The original instructions are here:

 

- back up original appleintelpowermagement.kext from extensions folder.

 

- If your CPU is V1 (Sandy Bridge E), follow step 1 of stinga11 (not the link to omni, only the stinga11 instructions.). V1 needs this extra patch. I recommend patch the kext directly. (not use clover patches).

It’s easy. Download 10.12 aicpm patch . Unzip the file, double click and enter password.

 

- For V1 and V2 cpus, follow step 2. It’s about the known MSR bit locked problem. Our bios is MSR bit-locked. The original how-to is in olarilla's website linked by stinga11 .

 

It's easy too. Just download the file, unzip the patch file, and follow next commands in terminal: (copied from original instructions)

cd ~/Downloads/AICPMPatch

..or where you downloaded it

type: (copy - paste)

perl AICPMPatch.pl /System/Library/Extensions/AppleIntelCPUPowerManagement.kext/Contents/MacOS/AppleIntelCPUPowerManagement

The output of the first command (only to check) should be:

 

 

 

 

delta: 1

0000000000009efd movl $0x000000e2,%ecx

0000000000009f02 wrmsr

 

delta: 1

0000000000009fb0 movl $0x000000e2,%ecx

0000000000009fb5 wrmsr

 

delta: 1

0000000000009fc6 movl $0x000000e2,%ecx

0000000000009fcb wrmsr

 

delta: 1

000000000000a0e2 movl $0x000000e2,%ecx

000000000000a0e7 wrmsr

 

delta: 1

000000000000aa5e movl $0x000000e2,%ecx

000000000000aa63 wrmsr

 

delta: 1

000000000000b4d6 movl $0x000000e2,%ecx

000000000000b4db wrmsr

 

delta: 1

000000000000b8f3 movl $0x000000e2,%ecx

000000000000b8f8 wrmsr

 

delta: 1

00000000000114e4 movl $0x000000e2,%ecx

00000000000114e9 wrmsr

 

delta: 1

0000000000012969 movl $0x000000e2,%ecx

000000000001296e wrmsr

 

delta: 1

0000000000013b13 movl $0x000000e2,%ecx

0000000000013b18 wrmsr

 

 

 

-To execute the patch:

sudo perl AICPMPatch.pl /System/Library/Extensions/AppleIntelCPUPowerManagement.kext/Contents/MacOS/AppleIntelCPUPowerManagement --patch

The output:

 

 

 

 

found wrmsr at 9f02, patched

found wrmsr at 9fb5, patched

found wrmsr at 9fcb, patched

found wrmsr at a0e7, patched

found wrmsr at aa63, patched

found wrmsr at b4db, patched

found wrmsr at b8f8, patched

found wrmsr at 114e9, patched

found wrmsr at 1296e, patched

found wrmsr at 13b18, patched

wrmsr found: 10

wrmsr ignored: 0

 

 

 

 

-Repeat first perl command to check it. It should returns no delta events because the code has ben patched.

 

-Now we have our AICPUPM patched.

 

– One last step, Download and install the 10.11 X79PlatformPlugin.kext of the link. (or from my stuff) to S/L/E , with your favorite utility. (It works for 10.12, of course)

 

-That’s all. Ignore step 4 and step 5 from the link.

 

IMPORTANT >>>>> Fix permissions and rebuild cache with your favorite utility <<<<<

 

-The clover patch, “Asus AICPUMP kernel patch“ is now redundant. So deselect it in clover.

 

-Reboot.

 

29- Last Step!!. Generate the SSDT with ssdtPRGen.sh.

 

I had some weird issues with the script about syntax, info, help…. I think that a corrupt download was the culprit. So I recommend follow the off-line method. This is a copy-paste from the pike’s site:

 

In terminal, execute:

curl -o ~/Library/ssdtPRGen.zip https://codeload.github.com/Piker-Alpha/ssdtPRGen.sh/zip/Beta
unzip -qu ~/Library/ssdtPRGen.zip -d ~/Library/
mv ~/Library/ssdtPRGen.sh-Beta ~/Library/ssdtPRGen
rm ~/Library/ssdtPRGen.zip

This download all configuration data. The folder of the script is in /YourUser/Library.

cd /Users/your-user/Library/ssdtPRGen

and set permission.

chmod +x ~/ssdtPRGen.sh

As I said, with last clover’s versions, the SSDT with the ACPI Processor declarations is now well defined. So pike’s script no returns the error “No ACPI Processor declarations found in the DSDT!”. The step to fix this, to copy the ssdt code to DSDT now is not necessary.

 

30- The Pike’s script has changed from the days of El Cap’s guide: There is an important argument with a different syntax.

 

The script is now (for me).

 

./ssdtPRGen.sh -p 'E5-2690 v2' -b Mac-F60DEB81FF30ACF6 -c 3 -x 1 -cpus 2 -l 40

 

The argument -w is now -c. Silly, but with the corruption of the script, this almost drives me crazy to figure out. With the old argument, the script gave me a KP)

 

You have to adapt the -p cpu model, (open Ivybridge or Sandybridge cfg file into ssdtPRGen folder to find the right syntax of the model), and the right -cpus (cpu numbers, 1 or 2) and -l (the number of cores). c is for a “workaround” to generate the script. For me, if it’s not “3” I get a KP. And x (xcpm) is 1 for our platform, but I’m not sure 100%

 

I can’t say if this is the best. Maybe other settings could work better. But at least, this works for me. This is completely open to discuss.

 

About Sandy Bridge, the approach could be different. In Ivy bridge, PM resides in X86platformPlugin. In Sandy Bridge resides in AppleIntelCPUPowerManagement.kext (that it the reason of the extra-step in AICPUPM patching). So maybe, the c or x argument need another parameters. I would need reports from people with this cpu.

 

-So define your script, and Press enter to generate the ssdt Check the terminal output. We don’t should see any error. Select “No” for the last script’s option. The ssdt is in /YourUser/Library/ssdtPRGen/. Delete the ssdt.dsl version. Copy the ssdt.aml to EFI/CLOVER/ACPI/patched.

 

For those with "No ACPI Processor declarations found in DSDT"  error: Those processor declarations are in one of the native SSDT. Extract your original tables if you didn't it (see step 16). The bios has 3 SSDT. Go back where you extracted the original tables at first of this guide. To identify it, open every ssdt with maciasl until see one with SCK0 / SCK1… (and so on) branchs. The tip is search the word "processor" into the code. Normally. the ssdt is the number 2. Select all code of the ssdt (except the comments) and copy it to the end of your current dsdt. Be careful with "}" symbol and don’t break the right end of the dsdt.

 

screen30.jpg

 

click in compile to check if dsdt has been appropriate edited.

Reboot to activate this change into dsdt. And repeat the script.

(Note: When you were happy with the PM, and you don't need more this script, you can delete this ssdt code from the dsdt if you want)

 

31- Enable on clover “-xcpm” flag, or “-xcpm_ipi” custom flag, if you have a dual cpu, as the script recommends.

 

 

 

Reboot. Now, finally, we should have PM like in El Capitan. Check HM monitors info. The cpu should move between lower state in idle, to stock speed clock, and reaching higher values under heavy work requirement.

 

-To check the states using AppleIntelInfo.kext:

cd /Path to AppleIntelInfo

 (whatever you left it)

 

-To load it:

sudo kextload AppleIntelInfo.kext

-Do something, play a video, compress files, watch a video in Youtube, run tests, etc… After that, cancel the kext process:

-And now, to check the results, run this command:

sudo cat /tmp/AppleIntelInfo.dat

If you see only two states, something is wrong. You should see different p and c states. 12, 14, 16, 18 …. 26, 28 and so on.., they are the multipliers (12x 1200, 14x 1400, 16 x 1600 ghz... Check it if they are around the minimum , stock, and turbo clocks of your cpu model. Test performance with apps as geekbench (check my folder) ;)

If you continue testing, to refresh, just re-execute the command (use up-cursor key to recall the last command)

 

-Don’t forget stop the kext when you finish. To disable it:

sudo kextunload AppleIntelInfo.kext

Post your results to compare. ;)

Mine:

 

SIERRA ---------- WIN10

 

screen35.pngscreen36.jpg

 

 

As in El Cap, single core is higher than in Win10. The low result in multi in Win10, doesn’t make sense.

 

 

screen37.pngscreen38.jpg

 

 

Graphic test speak by itself. I know that test mac is OpenGL and win is Direct3D. But anyway… is disappointing.

Edited by bilbo

Share this post


Link to post
Share on other sites

PART V:

DSDT refining

Based in Maldon’s specific fixes, (thanks to maldon again) I built the patches to apply some interesting extra-patches. They are splitted in 2 parts. First, add cosmetic PCI devices. These patches add the info needed for be shown in Apple System Profiler :) . See the picture. Don´t forget that is only cosmetic, but anyway, is awesome that the system profiler shows this:

 

screen39.png

 

Note that the patch use the _DSM method. I’ve read some thing about that, and it seems that this method is being questioned increasingly (it can be replaced with extra SDDT) . Of course, they work.The patchs are in folder n.4 "DSDT"

The second part adds some extra patching into DSDT. Change a few extra rename devices. More info into the patch. I hope update it with more improves or with your feedback.

I think that all of them are reliable fixes. Anyway, please report if you see unexpected issues.

 

APPENDIX

 

CPU MODELS 26x7 or 26x3 EXTRA- PATCHING

Under construction.

 

 

 

 

END OF THE GUIDE AND CONCUSSIONS.

 

The guide is long and maybe intimidating , especially for unexperience user. Don't panic. Just follow it little by little focusing in every section with patience. Maybe, it could be shorter, just drag&drop files from the begin of the process (except PM section). I do not recommend it until you understand completely the process. Later, maybe it could work. I never did it. Anyway, I left in my folder a section called FINAL. Use it under your risk. Be careful.

 

Good things:

- We have FINALLY!!! our system working almost 100%. Including nantive USB3. From Mavericks’s years, this is almost a dream.

 

Things to improve.

-Maybe PM performance could be better. I’m happy, but maybe we can make something to improve it.

-I have KP from every and now when I boot. (also in El Capitan). But it seems now are more often. Sometimes with kernel cache, and sometimes with Fakesmc and some sensor plugin. Just re-booting again and all is Ok again. But it is annoying. I have tried with several versions of fakesmc without success. I expect reports :)

-GPU sensors doesn’t work, but maybe is related only to my Pascal Card

 

Bad things

- Graphic performance is definitely crappy. I updated to Sierra only because I bought a Pascal card. But it’s terrible. First, nvidia drivers are really bad. Second If you have a “native card”, maybe you have a better reliability (I had a K5000, and yes, indeed) But anyway, the performance is pretty low. I don’t know any way to set PM for graphic cards. Maybe the key is High Sierra and lasts driver version, but seeing the feedback of the people, I don’t wanna be close to HighSierra until final release.

- No Sleep.

 

 

That’s all. I hope it helps to Z820 users. I expect comments, tests, fixes, and improvements.

 

 

 

 

End of the guide

 

 

 

 

UPDATES ----------

 

02/28/18 ---stuff folder updated to V02 , only for make minor changes to simplify the kexts attached

03/03/18 --- guide fixed to fix several format errors after forum update. Added fixes about lilu, applealc and codeccomader kext versions. See step 11 "optional updates" and step 21, "fixing audio".  Stuff folder updated to v03 in order to update this changes.

03/03/18 --- step 30, ssdt generation with ssdtPRGen , updated to skip "No ACPI Processor declarations found in DSDT" error.

>>>>TEMPORALLY LINK TO STUFF FOLDER <<<<<

 

 

Edited by bilbo

Share this post


Link to post
Share on other sites

You're the man Bilbo !

 

Great work :)

 

 

 

The guide is long and maybe intimidating , especially for unexperience user. Don't panic. Just follow it little by little focusing in every section with patience.

 

That really is the key to success.

 

I want to point out that the only reason i bought my z820 was Bilbo's guide to get El Capitan working.

 

Having a guide for Sierra is very exciting news !

 

Thanks for Your effort  :) :) :) :)

Share this post


Link to post
Share on other sites

Hi Bilbo

 

Congratulation very nice such a great Guide and very Detailed Information on each topic

 

 i can only say enjoy your HACK good job  :thumbsup_anim:  :thumbsup_anim:  :thumbsup_anim:  :thumbsup_anim:  :thumbsup_anim:  :thumbsup_anim:  :thumbsup_anim:

Share this post


Link to post
Share on other sites

Great Guide, thanx for that.

 

I only have 1 problem with my Z820. I setup the bios but i don't get the uefi usb boot drive.

 

What can be the problem.

Share this post


Link to post
Share on other sites

Great Guide, thanx for that.

 

I only have 1 problem with my Z820. I setup the bios but i don't get the uefi usb boot drive.

 

What can be the problem.

Hi Godfather 35

 

Try the Usb 2 ports on the back (the black ones !)

Share this post


Link to post
Share on other sites

i found the problem, was my own mistake.

But now it's not working, i did everything in the guide, the install starts, get code for 10 seconds and then the machine reboots.

I have a Z820 with 2 x E5-2670 V2 in it, 32 GB and a Quadro 2000 videocard.

 

BTW i used High Sierra and put all the files in the 10.13 folder instead of the 10.12 folder.

Share this post


Link to post
Share on other sites

i found the problem, was my own mistake.

But now it's not working, i did everything in the guide, the install starts, get code for 10 seconds and then the machine reboots.

I have a Z820 with 2 x E5-2670 V2 in it, 32 GB and a Quadro 2000 videocard.

 

BTW i used High Sierra and put all the files in the 10.13 folder instead of the 10.12 folder.

 

Sorry , I don't understand. Where do you have actually the kexts installed? Did you have High Sierra installed in your z820? :huh: 

 

Try to take a photo of the reboot moment.

Share this post


Link to post
Share on other sites

Your macos drive (the one you want to install macos into) needs to be plugged into one of the two grey ahci native ports.

Share this post


Link to post
Share on other sites

Hi, friends.

 

My five cents to common depot.

 

Forget completely the 2018-001. It’s probably that it causes KP. ( I tried and I screw up it)

 

Why? No reasons to forget about it ;)

KP is caused by old version of Lilu.kext. Just replace it with ver. 1.2.2, cross your fingers and get it.
AppleALC and NvidiaGraphicsFixup work with Lilu 1.2.2, so you will not lose nothing.
 
Screen_Shot_2018_02_28_at_22_10_57.png
 
Screen_Shot_2018_02_28_at_22_09_39.png
 
 
So pike’s script no returns the error “No ACPI Processor declarations found in the DSDT!”.
 
Not for me… I send to script (2 CPUs x 10 cores on each)
./ssdtPRGen.sh -p 'E5-2660 v2' -b Mac-F60DEB81FF30ACF6 -c 3 -x 1 -cpus 2 -l 40
 
…and get nothing…
Screen_Shot_2018_02_27_at_22_46_26.png
 
So I need to try later again or seek for other ways…

Share this post


Link to post
Share on other sites

Dear Bilbo,

   Just for reference. Could you provide your results of this command? 

 

$ kextstat |grep USB

 

Here is:

   19   13 0xffffff7f80d1d000 0x69000    0x69000    com.apple.iokit.IOUSBHostFamily (1.1) 896273C6-36AE-30AC-9274-1BCB7C9A4062 <18 7 6 5 4 3 1>
   31    0 0xffffff7f833c8000 0x4000     0x4000     com.rehabman.driver.USBInjectAll (0.5.17) 99003E98-4591-37FA-9885-3B51950B765C <12 11 4 3>
   51    1 0xffffff7f81e0b000 0x3d000    0x3d000    com.apple.driver.usb.AppleUSBEHCI (1.1) CC5812B3-E187-3737-BB79-6C58211224C8 <19 11 7 6 5 4 3 1>
   52    0 0xffffff7f81eea000 0xe000     0xe000     com.apple.driver.usb.AppleUSBEHCIPCI (1.1) 48BD8A21-B99B-3D70-9FEA-32B381CCAA54 <51 19 12 11 7 6 5 4 3 1>
   58    1 0xffffff7f81d8c000 0x41000    0x41000    com.apple.driver.usb.AppleUSBXHCI (1.1) 7DBE53B6-8BED-3DD3-984C-7AAAA20C484C <19 11 7 6 5 4 3 1>
   59    0 0xffffff7f81dd3000 0x2d000    0x2d000    com.apple.driver.usb.AppleUSBXHCIPCI (1.1) 65795D1D-0F6C-3648-81CB-8C7CDE52270C <58 19 12 11 7 6 5 4 3 1>
   64    5 0xffffff7f80d8e000 0x9a000    0x9a000    com.apple.iokit.IOUSBFamily (900.4.1) 1B35F2B8-7EB1-3F3A-86DD-35F07996E335 <19 12 7 5 4 3 1>
   74    0 0xffffff7f81ed5000 0x5000     0x5000     com.apple.driver.usb.AppleUSBHostPacketFilter (1.0) 0FEE9916-40A3-3F33-B125-103191A1611A <19 7 6 5 4 3 1>
   82    0 0xffffff7f81e9f000 0x2e000    0x2e000    com.apple.driver.usb.AppleUSBHub (1.1) 60EE9D2B-FFB8-3035-8A63-F46B1D75D128 <19 11 5 4 3 1>
   83    0 0xffffff7f81eda000 0x4000     0x4000     com.apple.driver.AppleUSBHostMergeProperties (1.1) 71CBFC55-80B2-34DF-B1F4-B3255F5F901B <4 3 1>
   87    1 0xffffff7f81ede000 0x8000     0x8000     com.apple.driver.usb.AppleUSBHostCompositeDevice (1.1) 93FCA7CE-F6C1-3229-8425-7E4B664231BD <19 5 4 3 1>
   90    0 0xffffff7f81d81000 0xb000     0xb000     com.apple.driver.usb.IOUSBHostHIDDevice (1.1) 8C7C5296-D36F-3304-90FE-2A6DD1B0DED8 <46 19 5 4 3 1>
   91    1 0xffffff7f80e3a000 0xa000     0xa000     com.apple.iokit.IOUSBHIDDriver (900.4.1) 00FA3E2D-73DB-3778-88DD-681AEB05EF22 <64 46 5 4 3 1>
   93    0 0xffffff7f81f1b000 0x19000    0x19000    com.apple.driver.AppleUSBLegacyHub (900.4.1) 9A7D1ED3-0899-37DF-AB39-A4A476D65F17 <64 5 4 3 1>

Do you have problems with USB's ?

 

Hi, friends.

 

My five cents to common depot.

 

Great shamman!!! That is what I expect  :yes:

 

First... Thanks for your finding. I read something about lilu version and update security, but I followed "If it works, don't touch it!!". Please report if you see some kind of drop in performance.

 

About the error about "processor declarations" error , please check:

 

-Your clover version

-boot and use F4 to save the original tables and check if the SSDT tables are "SSDT-1 / SSDT-2/ SSDT-3" or "SSDT-1-CpuDef / SSDT-2-CpuPm "... and so.

-Report

 

If your native ssdt are like first example, you'll have to update clover and try.

 

Anyway remember that you can follow the same tip than in El Cap's guide. But I'd like you try first my advice. Just for the nfo ;)

Share this post


Link to post
Share on other sites

I have a problem and can't find where to fix it, i have a 75hz monitor but the graphics card can't display 75hz, in setting i set it to 75hz and now i have no screen anymore.

I booted without the nividia k2000 drivers, then i have screen, but where to undo that setting, i can't find it.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.



  • Similar Content

    • By MaLd0n
      Nehalem, SandyBridge, IvyBridge, Haswell, Broadwell     Skylake, Kabylake and Coffeelake is here http://www.insanelymac.com/forum/topic/321872-guide-sierra-on-gigabyte-mobos-serie-200-kabylake-dsdt/   First...   ***Update bios to last available version!***   If you need a full patched DSDT...  -Extract tables with F4 key in Clover boot screen! -Run it and send me files! RunMe.app   Installation   --Create a bootable copy of macOS Sierra Check out the link http://www.insanelymac.com/forum/files/file/559-flash-drive-maker/   --Create a bootable copy of macOS HighSierra Check out the link http://diskmakerx.com/   --Install Clover in USB stick https://sourceforge.net/projects/cloverefiboot/files/Installer/   --Replace with my Clover folder CLOVER Install.zip   --Install Sierra/High Sierra and boot into system!   Post Installation --Install Clover and replace with my folder CLOVER Post Install.zip   --Reboot and activate video!   Bingo!   Now you need a fine tune! DSDT time!   --DSDT   Patches -FIX ERRORS AND WARNINGS -HPET -SATA -DMAC -SLPB -DARWIN -LPC -XHCI -PLUGIN TYPE -XXXX to HDEF -HDEF -RTC -IRQs -SBUS -BUS1 -MCHC -ALS0 -SHUTDOWN -LAN -USBX -PMCR -EC -PNLF -HDMI
       
      --Power Management
      - 1 Generation Intel Processors, use Generate P and C States in config.plist
      - 2 and 3 Generations Intel Processors, Generate SSDT with Piker script and drop CpuPm and Cpu0Ist SSDTs
      ssdtPRGen.command.zip
      Credits-https://github.com/Piker-Alpha/ssdtPRGen.sh
      - 4 Generation+ Intel Processors, use PluginType=1 in DSDT, SSDT or Clover config.plist
       
      for check Power, Frequency, Temperature and Utilization, use it
      Install Intel Power Gadget.pkg.zip
       
      --Brightness
      Install .app, select the required permission and reboot. Work in F1 / F2 keys!
      NativeDisplayBrightness.app.zip


      https://github.com/Bensge/NativeDisplayBrightness/releases
      *in some cases .app don't work, check patches in config.plist inside Clover folder Post Install
       
      --Clover
       
      https://sourceforge.net/projects/cloverefiboot/files/Installer/
       
      --AUDIO
       
      Use DSDT + AppleAlc
       
      --install Lan driver by Mieze
        -Atheros http://www.insanelymac.com/forum/files/file/313-atherose2200ethernet/   -Intel http://www.insanelymac.com/forum/files/file/396-intelmausiethernet/   -Realtek http://www.insanelymac.com/forum/files/file/88-realtekrtl8111-binary/   --Links   -FakeSMC https://bitbucket.org/RehabMan/os-x-fakesmc-kozlek   -Audio https://github.com/vit9696/AppleALC http://www.insanelymac.com/forum/topic/314406-voodoohda-289/   -USB https://bitbucket.org/RehabMan/os-x-usb-inject-all/downloads   It's time to Rock   -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!   Apple, Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad and many, many, many others!   We're all here to have fun and learn from each other!  
    • By MaLd0n
      First... If you need DSDT edits... -Extract tables with F4 key in Clover boot screen! -Run it and send me files! RunMe.app   Installation --Create a bootable copy of El Capitan and Sierra Check out the link http://www.insanelymac.com/forum/files/file/559-flash-drive-maker/   --Create a bootable copy of macOS HighSierra Check out the link http://diskmakerx.com/   --Install Clover in USB stick https://sourceforge.net/projects/cloverefiboot/files/Installer/   --Replace with my Clover folder CLOVER Install.zip   --Install EL Capitan / Sierra / High Sierra and boot into system! for Sierra/High Sierra you need a Processor with SSE4.1 instruction   Post Installation --Install Clover and replace with my folder CLOVER Post Install.zip   --Reboot and activate video!   Bingo! Now you need a fine tune! DSDT Time! -Post your full Clover folder with original tables in Origin folder(Extract with F4 in Clover boot screen) and tell me what your hardware! -Post Ioreg, extract with Ioreg Explorer http://www.insanelymac.com/forum/index.php?app=core&module=attach&section=attach&attach_id=222606 -Run it, post files generate in your desktop http://www.insanelymac.com/forum/index.php?app=core&module=attach&section=attach&attach_id=222609    My DSDT GA P35-DS3 DSDT.MaLd0n LGA775.zip   Patches -FIX ERRORS AND WARNINGS -HPET -SATA -SLPB -DARWIN -LPC -HDEF -RTC -EHCI -UHCI -IRQs -SBUS -BUS1 -MCHC -ALS0 -SHUTDOWN -LAN -EC -PNLF --Native Power Management
       
      Use Clover, check Generate P and C States
       
      --Brightness
      Install .app, select the required permission and reboot. Work in F1 / F2 keys!
      NativeDisplayBrightness.app.zip


      https://github.com/Bensge/NativeDisplayBrightness/releases
      *in some cases .app don't work, check patches in config.plist inside Clover folder Post Install
       
      --AUDIO
       
      Device HDEF + AppleAlc + Lilu
       
      --install Lan driver by Mieze
        -Atheros http://www.insanelymac.com/forum/files/file/313-atherose2200ethernet/   -Intel http://www.insanelymac.com/forum/files/file/396-intelmausiethernet/   -Realtek http://www.insanelymac.com/forum/files/file/88-realtekrtl8111-binary/   --Links   -FakeSMC https://bitbucket.org/RehabMan/os-x-fakesmc-kozlek   -Audio https://github.com/vit9696/AppleALC http://www.insanelymac.com/forum/topic/293863-applehda-patch-requests/   -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!   Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad and many, many, many others!   We're all here to have fun and learn from each other!   ENJOY!  
    • By fantomas1
      Hi InsanelyMacaholics   

      Use this thread to link / talk about of the future Nvidia Web Driver updates for macOS Sierra.
       
      10.12.6
      Nvidia Web Driver - 378.02.02.25f08 --> build 16G1314 (thanks to BreBo)  New!
      Nvidia Web Driver - 378.02.02.25f07 --> build 16G1314 (thanks to haring)
      Nvidia Web Driver - 378.05.05.25f06 --> build 16G1212 (thanks to WeBeRiO)
      Nvidia Web Driver - 378.05.05.25f04 --> build 16G1114 (thanks to lukazm)
      Nvidia Web Driver - 378.05.05.25f03 --> build 16G1036 (thanks to Gradou)
      Nvidia Web Driver - 378.05.05.25f01 --> build 16G29 (thanks to Badruzeus)
       
       
      10.12.5
      Nvidia Web Driver - 378.05.05.15f01 --> build 16F73 (see this post)
       
       
      10.12.4
      Nvidia Web Driver - 378.05.05.05f02 --> build 16E195(thanks to crachmaster4999)
      Nvidia Web Driver - 378.05.05.05f01 --> build 16E195 (thanks to Moviemakergr)  Pascal support!!!
      Nvidia Web Driver - 367.15.10.45f01 --> build 16E195 (thanks to Lanc)
       
       
      10.12.3

      Nvidia Web Driver - 367.15.10.35f01 --> build 16D32 (thanks to shatterhenner)
       
       
      10.12.2
      Nvidia Web Driver - 367.15.10.25f02 --> build 16C68 (see this post)
      Nvidia Web Driver - 367.15.10.25f01 --> build 16C67 (see this post)
      Nvidia Web Driver - 367.15.10.25b06 --> build 16C60b/16C63a (see this post)
       
       
      10.12.1
      Nvidia Web Driver - 367.15.10.15f03 --> build 16B2657/16B2659 (thanks to Moviemakergr).
      Nvidia Web Driver - 367.15.10.15f01 --> build 16B2555 (thanks to Moviemakergr)
       
       
      10.12.0
      Nvidia Web Driver - 367.15.10.05f01 --> build 16A323 (thanks to phi777)
       
       
      GM
      Nvidia Web Driver - 367.10.10.05b01 --> build 16A323 (same driver since DP4/PB3)
      Nvidia Web Driver - 367.10.10.05b01 --> build 16A322 (see this post)
      Nvidia Web Driver - 367.10.10.05b01 --> build 16A320 (see this post)
       
       
      DP/PB
      Nvidia Web Driver - 367.10.10.05b01 --> build 16A313a (DP8 & PB7) (see this post)
      Nvidia Web Driver - 367.10.10.05b01 --> build 16A304a (DP7 & PB6) (see this post)
      Nvidia Web Driver - 367.10.10.05b01 --> build 16A294a (DP6 & PB5) (see this post)
      Nvidia Web Driver - 367.10.10.05b01 --> build 16A286a (DP5 & PB4) (see this post)
      Nvidia Web Driver - 367.10.10.05b01 --> build 16A270f (DP4 & PB3) (thanks to TheRacerMaster)
      Nvidia Web Driver - 367.05.10.05b07 --> build 16A254g (DP3 & PB2) (see this post)
      Nvidia Web Driver - 367.05.10.05b07 --> build 16A238m (PB1) (thanks to Faun) 
      Nvidia Web Driver - 367.05.10.05b07 --> build 16A239j (DP2) (thanks to Faun)
      Nvidia Web Driver - 367.05.10.05b03 --> build 16A201w (DP1) (thanks to Xmedik)
       
    • By fwood
      Ciao ragazzi, torno a voi dopo moltissimo tempo per chiedere un aiuto.
      Sierra 10.12.6 - motherboard z68xp-ud4 - i7 2600k - Gigabyte gtx 780 FE 3072mb - imac 14,2  - ultimo clover e clover configurator.
      La scheda 780 viene vista con una lunghezza pcilane di 1X,  il clock ed powermanagement tuttavia sembrano correti e funzionare ( anche se il powermanagement è abbastanza lento).
      Il kext Apple GraphicsPowermanagement non viene caricato, Cercando AGPM nella consolle non trova nulla, a volte unknown platform.
      Ho provato sia con che senza cuda, sia con che senza webdriver ( con relativi flag nel config.plist).
      Ho provato ad iniettare l'id 10de_1004  al posto di quello 10de_119e ( gtx 780m) nel kext AGPm alla sezione della board relativa ad imac 14,2 , sia mettendo un doppione del kext nella EFi, sia sostituendolo direttamente in s/l/e.
      Ho provato anche a mettere il fix GFX0 to IGPU con il clover configurator.
      Ho provato a mettere il fake id delal 780m direttamente con clover configurator.
      NULLA tutto invariato.
      Ora mi chiedo.. pensate che sia una questione estetica, oppure ho la scheda semi-difettosa ( comprata da un privato 5gg fa) ?
      Grazie a chi mi aiuta.
      Come detot In generale la scheda sembra andare bene , come detto sopra, solo vedo 1x, agpm non caricato ( ma il clock è dinamico) e scalda abbastanza anche solo nella navigazione con firefox ( che ha accellerazione hardware  attiva) arrivando a volte durante la navidazione anche a 52 gradi..
      Il metal viene riconosciuto dal profiler.
      Help.
       
       
    • By Rajan Pandit
      I have successfully installed siera os on my i52500k, GA-Z68 AP-D3, Nvidia GTS 450, 8 GB Ram, Hitachi HD
      I activate my nvidia card using Nvidia Inject in [url=&quot;http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/&quot;]#####[/url]. I also select Realtek RTL8111E from mutibeast.
      but no success.... I install NULLCPUMANAGEMENT because I have to use cpus=1 bootflag...

      but now after login or sometime after some more time.. it freeze and restart..
      please help..

      and also help me to resolve Realtek RTL8111E chip.. before installing [url=&quot;http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/&quot;]#####[/url], it was working..

      please help
×