Jump to content

[Guide] macOS High Sierra 10.13 - Dell Optiplex 780 (760) (755) (790) (990)


MacPeet
672 posts in this topic

Recommended Posts

34 minutes ago, MacPeet said:

Audio is activated in the BIOS ???

 

DSDT.aml is in EFI/Clover/ACPI/patched/ ???

 

Check System Information Extensions in Utilities:

check.thumb.png.ee15072152d170aaecfd7f23cd004cc6.png

 

Let KextUtility run again for cache rebuild

 

BIOS? I can't understand why it wouldn't be, but, I'll have to check that later as I'm not physically close to the machine now.

 

I checked System Information and found AppleHDA listed and there is a "No" in the Loaded? column.

 

AppleHDAController was also listed -- 3 times.... and also with "No" in the "Loaded?" column.

 

IMG_0890.PNG.e1390ec0357853b94ad08cedc79f6841.PNG

 

Yes - DSDT.aml is in EFI/Clover/ACPI/patched/

 

KextUtility is busy repairing permissions and rebuilding cache......

 

kextstat now shows AppleHDA!!!!!! 

 

I now have an audio output option!!!! 

image.thumb.png.62b8694a512318e763a0f670dc0f90a2.png

Thank you!! Thank you!! Thank you!! Thank you!! Thank you!! Thank you!! Thank you!! Thank you!! Thank you!! Thank you!! Thank you!! 

Danke Schön!! Danke Schön!! Danke Schön!! Danke Schön!! Danke Schön!! Danke Schön!! Danke Schön!! Danke Schön!! Danke Schön!! 

Link to comment
Share on other sites

and as soon as I tried a restart, it was all bad news.  it was caught in a reboot loop so I started up into the recovery partition and installed from a Time Machine backup taken just before I made the changes earlier.  I'll carefully try again and report back.

Link to comment
Share on other sites

very beautiful

LayoutID 13 is configured in Auto-SwitchMode
Green at the back is LineOut (configured as internal speaker)
Front-out is headphones

If headphones are not plugged in, then LineOut back is active.

Have fun with the audio.

 

Edit:

Time Machine replaces the kext.
Do the rollback again.

Edited by MacPeet
Link to comment
Share on other sites

13 hours ago, MacPeet said:

Edit:

Time Machine replaces the kext.
Do the rollback again.

 

before I'd seen your edit, I tried KextUtility and a reboot and the same thing happened - mid way through booting it started again and kept looping.

 

I'll try

1) Recover from a backup using Time Machine

2) Ensure the files from DSDT.aml_layoutID13.zipconfig.plist.zip and AppleALC1.2.6_und_Lilu1.2.3.RELEASE.zip are in the right spot

2) Rollback using your AppleHDA.kext_rollback10.13.3.zip kexts

3) Boot into Hackintosh, run KextUtil

4) Shut down

5) Hopefully it restarts without the reboot loop

 

 

 

Link to comment
Share on other sites

17 hours ago, MacPeet said:

I do not understand what you are doing wrong.
KextUtility is currently the last version?
Old versions do not work with HS and destroy the kernel.

 

I wish I knew

 

the latest version of KextUtility I can find is 2.6.6. Is that the most recent?

 

so according to this, 2.6.6 only supports up to 10.12.  Where can I find a 10.13 compatible version?

 

http://cvad-mac.narod.ru/index/0-4

 

I'll try [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] and RepairPermissions instead.  They appear to be 10.13 compatible.

 

https://www.tonymacx86.com/resources/[url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url]-2-0-1.310/

https://www.firewolf.science/2016/07/repairpermissions-v3-now-supports-repairing-permissions-on-macos-sierra/#more-552

 

 

Edited by unrealpants
Link to comment
Share on other sites

I remove my last post,

my app kext installer macOS install only in Library/Extensions

edit *** now release V2 works for /S/L/E

Edited by chris1111
Link to comment
Share on other sites

On 5/22/2018 at 7:24 AM, MacPeet said:

Let KextUtility run again for cache rebuild

 

Vielen Dank MacPeet, I missed this step before. Now I have audio as well :thumbsup_anim:. Fortunately I have no boot loop problems.
 

Some other stuff if someone would face similar problems:

 

I reported recently a shutdown problem: I was not able to completely shutdown my hackintosh. Fyi it was caused by adding a second SSD.. for some unknown reasons. I replaced this SDD with another, now it works perfectly. 

 

I had also a weird mouse lagging problem, a really annoying one. I have found out that it was caused by an usb wifi adapter, it was probably to close to the usb receiver of the mouse. I placed the wifi adapter to the front usb plug and the mouse works again.

 

 

  • Thanks 1
Link to comment
Share on other sites

This is my first post in this forum so ... hello!
I got a free mobo from old Dell 790 SFF (bios A21). I added i5 2400, 4x4gb RAM and old PCI-e GT210 512mb and SSD. The installer starts, but the computer restarts after about 70% of the installation process. I have read this thread and unfortunately it looks like I can't prepare the HS (17E202) stick correctly. Will anyone share contents of EFI folder? Can I ask for preparation for GT210 gpu?
Please help, this is my first hakintosh.

Link to comment
Share on other sites

2 minutes ago, sebar25 said:

This is my first post in this forum so ... hello!
I got a free mobo from old Dell 790 SFF (bios A21). I added i5 2400, 4x4gb RAM and old PCI-e GT210 512mb and SSD. The installer starts, but the computer restarts after about 70% of the installation process. I have read this thread and unfortunately it looks like I can't prepare the HS (17E202) stick correctly. Will anyone share contents of EFI folder? Can I ask for preparation for GT210 gpu?
Please help, this is my first hakintosh.

i don't think Geforce GT 210 is support in HS

but I am not sure

Link to comment
Share on other sites

so the news is that it .... worked!

 

I don't know what I did "wrong" earlier or "right" this time but I re-applied all steps carefully and now I have an Optiplex 780 booting quite happily *with* audio.

 

I still have weird lock-up issues that I'm trying to work around that *seem* to be related to the network adapter.  I've tried setting a reboot schedule just after midnight every day but even that doesn't work because some apps won't close so I'm investigating what options I have to force a reset.....

 

Many thanks to MacPeet and morpheusman and all others who have assisted.

 

Cheers 

Link to comment
Share on other sites

Hi folks,

   Has anyone had any issues with updating clover on their 10.13.5 hackintosh ? I have 2 machines and when I have updated to clover version r4522 on both machines, it broke Imessage. It gives a activation error on imessage and facetime. When I rolled clover back to r4428 both services worked again.

Link to comment
Share on other sites

Anyone with a C2D or C2Q who installed Mojave on it? People installed Mojave on their C2D-based macs so in theory it should be possible.

I'm trying on my Optiplex 755, but no luck so far. It panics on CPU 

Link to comment
Share on other sites

On 6/11/2018 at 12:23 PM, Deanor30 said:

Hi folks,

   Has anyone had any issues with updating clover on their 10.13.5 hackintosh ? I have 2 machines and when I have updated to clover version r4522 on both machines, it broke Imessage. It gives a activation error on imessage and facetime. When I rolled clover back to r4428 both services worked again.

 

Thanks, you made my day. I had the same issue and tried nearly anything and was about to give up. Rolling back to clover 4428 made iMessage work again here too.

Link to comment
Share on other sites

Hi MacPeet needs new topic for macOS Mojave 10.14 :lol:

For couple of days macOS Mojave is installed on my Main DELL Optiplex 790

everything's work like High Sierra :wink_anim:

Audio AppleALC

Graphics Geforce GT 710

Wifi Atheros 5B193

USB 3.0 

Network Intel 82579LM PCI Express Gigabit Ethernet :IntelMausi

146018824_Capturedcran.thumb.png.2a787cff89d35feb568ab96496963bd0.png

 

  • Like 1
Link to comment
Share on other sites

@chris1111 Can you open Stocks.app for me? 
I have issues with Metal with the GT 710. Transparency issues in light mode, Apps that require metal (i.e. Stocks.app) do not load their UI et cetera

 

Nevermind. Just installed DP2, which fixed the issue

Edited by ricoc90
Link to comment
Share on other sites

11 hours ago, ricoc90 said:

@chris1111 Can you open Stocks.app for me? 
I have issues with Metal with the GT 710. Transparency issues in light mode, Apps that require metal (i.e. Stocks.app) do not load their UI et cetera

 

Nevermind. Just installed DP2, which fixed the issue

ok good

Link to comment
Share on other sites

On 6/19/2018 at 4:59 PM, chris1111 said:

Hi MacPeet needs new topic for macOS Mojave 10.14 :lol:

For couple of days macOS Mojave is installed on my Main DELL Optiplex 790

everything's work like High Sierra :wink_anim:

Audio AppleALC

Graphics Geforce GT 710

Wifi Atheros 5B193

USB 3.0 

Network Intel 82579LM PCI Express Gigabit Ethernet :IntelMausi

146018824_Capturedcran.thumb.png.2a787cff89d35feb568ab96496963bd0.png

 

 

no way :no:
I do not have a Dell Optiplex 790 or newer! You have to open a new thread yourself.
Optiplex 780 has C2D or C2Q, so far no solution for SSE4.2!

Link to comment
Share on other sites

22 minutes ago, MacPeet said:

 

no way :no:
I do not have a Dell Optiplex 790 or newer! You have to open a new thread yourself.
Optiplex 780 has C2D or C2Q, so far no solution for SSE4.2!

This is really sad for you guys :| :(

Edit **

so this is the end of 755/760/780 Dell Optilex series on Hackintosh  :(

Edited by chris1111
Link to comment
Share on other sites

On 6/24/2018 at 3:39 PM, MacPeet said:

Optiplex 780 has C2D or C2Q, so far no solution for SSE4.2!


 

Quote

Core 2 Duo/nVidia MCP79/89/i965-based systems will kernel panic on boot. The cause of this kernel panic has yet to be determined. It is NOT caused by USB drivers or a lack of SSE4.2. It does not occur in virtual machines.


I still have hope for my 755 :blush:

 

Link to comment
Share on other sites

  • 2 weeks later...

Core2 users: 

 

Replace com.apple.telemetry.plugin in S/L/UserEventPlugins with the High Sierra version for Mojave to run

  • Like 1
Link to comment
Share on other sites

×
×
  • Create New...