Jump to content

AMD High Sierra Kernel Release and Testing


1,119 posts in this topic

Recommended Posts

Thank you very much !

Without Shaneee's kernel/System.kext and your Clover's config.plist I can not boot to desktop at 10.13GM(17A365).

Good news:

The same kernel/System.kext and config.plist are still working at 10.13.1 beta (17B25c).

But networking and Safari/Firefox are not working yet due to download failed.

post-70188-0-99669300-1507113216_thumb.png

post-70188-0-58045900-1507113222_thumb.png

 

If you're able to boot into your Recovery HD, you can convert your HFS+ installation to APFS from there

diskutil ap convert /dev/diskxsx

Thanks ! that worked 

Booted to recovery and converted to APFS. 

 

 

@XCiLNZ

 

You still can install these drivers with 'Pacifist' or extract them and install manually.   ;)

Already tried that and it doesnt work. 

After installing nvidia web driver and and booting with nvidia web option in clover (SIP DISABLED)

it always get stucks at this screen:

 

_-oTXrDjRLiqOREUthDTpA.jpg

 

And i cannot boot with SIP ENABLED too.

 

so what actually worked for me was the Lilu + NVWebDriverLibValFix.kext 

now it doesnt get stuck at the above screen .

 

Uwmk0QfCTmKYRfAzQDHpeg.png

 

 

No luck at all. Tried Sierra roll back of kexts and frameworks with no success.

do you get stuck at this screen ?

 

Y_3x0r3ITVCjcJ0n_X1Z8Q.jpg

 

If not then can you send a pic of the screen where you get stuck at ?

 

Good news:

The same kernel/System.kext and config.plist are still working at 10.13.1 beta (17B25c).

But networking and Safari/Firefox are not working yet due to download failed.

how is the performance on it ?

 

  • Like 1

Just open terminal and cd to your dir where xnu-builder is and run:

sh ./xnu-builder.sh

Thanks for the reply, my xnu builder is in the root wheel with the other Dtrace and lib folders. They all end up in “users” do I need to specify root wheel?

 

Also, should I run this before or after compiling?

 

Thanks again, I appreciate it and hopefully we can get a Ryzen kernel for testing soon.

Yeah that's where it gets stuck.

ok do this :

 

- boot to safe mode 

- then go to S/L/E and delete the following files that starts with "GeF" and "NVD".

- now reboot to HS HDD without using inject_nvidia or Nvidia web option in clover config , and you will be able to boot to the desktop.

- Now install the latest nvidia web driver for HS and ignore if any alert pop up comes while installing. AND DONT REBOOT YET.

-now put Lilu.kext.kext and NVWebDriverLibValFix.kext in the Clover/kexts/others folder. 

http://www95.zippyshare.com/v/6HrJWEnB/file.html

-now boot with nvidia web option enabled in clover config.

 

Thanks for the reply, my xnu builder is in the root wheel with the other Dtrace and lib folders. They all end up in “users” do I need to specify root wheel?

 

Also, should I run this before or after compiling?

 

Thanks again, I appreciate it and hopefully we can get a Ryzen kernel for testing soon.

Hi !

You no can get kernel for Ryzen from builder .

You need modified and add support ryzen in xnu ...

I created kernel and works fine... 

But i get problem graphics accelerator and desktop color ... <-- i think that problem videocard or driver ...

post-31928-0-77711500-1507138676_thumb.png

 

Send me your 10.12.6 source and I'll port to 10.13.. All credit to you of course.

 

Sorry , no ! 

I no will give to you . 

  • Like 3

Hi !

You no can get kernel for Ryzen from builder .

You need modified and add support ryzen in xnu ...

I created kernel and works fine... 

But i get problem graphics accelerator and desktop color ... <-- i think that problem videocard or driver ...

attachicon.gifDesktop.png

 

 

Sorry , no ! 

I no will give to you . 

can you share your 10.13 kernel ?

Thanks : )

You unliked me post? )))

lol sorry my bad !  happened by mistake while clicking on quote button I guess.

 

On High Sierra right now and the safari is taking time for loading discord and insanely Mac properly sometimes  and I don't know why : (

  • Like 1

btw how did you install HS ?

 

by Cloning HS from an intel HDD ?

 

 

 

I created kernel_10.13 from sierra 10.12.6 and Xcode 9. 

I no sure . 

Then i want created kernel_10.13 from 10.13 =)...

by Cloning HS from an intel HDD ?

 

 

 

No . On AMD i installed HS =)

  • Like 2

I created kernel_10.13 from sierra 10.12.6 and Xcode 9. 

I no sure . 

Then i want created kernel_10.13 from 10.13 =)...

No . On AMD i installed HS =)

through normal HS USB installer ?

 

 

 

 

Last time I checked the xnu was open source and so are any modifications made to it...

i gived to you , but you no writed that this by me xnu. 
And you speaked that you searched and found for ryzen ... me no liked ... 
  • Like 1

ok do this :

 

- boot to safe mode 

- then go to S/L/E and delete the following files that starts with "GeF" and "NVD".

- now reboot to HS HDD without using inject_nvidia or Nvidia web option in clover config , and you will be able to boot to the desktop.

- Now install the latest nvidia web driver for HS and ignore if any alert pop up comes while installing. AND DONT REBOOT YET.

-now put Lilu.kext.kext and NVWebDriverLibValFix.kext in the Clover/kexts/others folder. 

http://www95.zippyshare.com/v/6HrJWEnB/file.html

-now boot with nvidia web option enabled in clover config.

 

 

Thanks for the suggestion but same issue. Stuck on IOConsoleUsers :(

 

 

i gived to you , but you no writed that this by me xnu. 
And you speaked that you searched and found for ryzen ... me no liked ... 

 

 

Dude I'm not here to steal your code. Anything of yours I add will be credited but I want to learn from it that's all. 

@Shaneee

 

did you try my config to boot ? and using clover  right ?

 

 

Yeah your full folder.

 

@Bronya, can you send me your compiled kernel please. My GPU may not be working due to an error in my code.

Shaneee your latest kernel and system.kext are working flawless for me. No problems what so ever. USB 3.0 is working normal. Nvidia drivers etc all working flawless. I cant get voodooTSCsync.kext to work properly yet, so for now voodoopstate seem to be working much better. Many Thanks!! 

post-1420666-0-13035600-1507149423_thumb.png

post-1420666-0-48737200-1507149441_thumb.png

CLOVER.zip

  • Like 1

Kernel by shanee for me is bad , i get opemu error . 

 

AppleTyMCEDriver removed? I'll test on my machine. My kernel blacklists the kext to stop that happening.

×
×
  • Create New...