Jump to content

AMD High Sierra Kernel Release and Testing


1,119 posts in this topic

Recommended Posts

i have one notebook with intel processor , I instal high Sierra

 

I installed highsierra on an intel notebook, after seeing your kernel I got it and put it in my pc amd fx8350 to see if it worked.

now I'm trying to boot from the installer

Ahh ok. I couldn't get installer to run so ran it directly from Sierra but I think it got corrupt that way. My Intel machine doesn't support it unfortunately.

Here you go guys. I'm still having issues with the graphics but it might not be the kernel. No Ryzen support added I'm afraid. 

Thanks for this new kernel which can not login to desktop in FX-6300 hackintosh because of too many OPEMU errors during booting by Enoch/Bronya.

Using previously working Intel partition of 10.13GM(17A365) and replaced it in /System/Library/Kernels, then repair permission & rebuilt prelinkedkernel.

Made a new one that builds libfirehose_kernel.a from source. (read the comments on the builder)

 

Do I need to add a dev path in local?   Its moving along through most of steps without errors until the end.    Ryzen 7 1700 using Sierra 12,5.

post-1753549-0-21761600-1506753555_thumb.png

Made a new one that builds libfirehose_kernel.a from source. (read the comments on the builder)

 

Didn't complete on my system. 10.12.6 with Xcode 9. My build script has the libdispatch already complied and just installs to the relevant place.

2017-09-30 11:00:46.580 xcodebuild[21465:46871]  DVTAssertions: Warning in /Library/Caches/com.apple.xbs/Sources/IDEXcode3ProjectSupport/IDEXcode3ProjectSupport-13203/Xcode3Core/LegacyProjects/Frameworks/DevToolsCore/DevToolsCore/BuildSystem/Runtime/PBXTargetBuildContext.mm:757
Details:  unexpected successful exit code from cancelled command <C0009:'PBXCp tsd.h':P6>
Object:   <PBXTargetBuildContext: 0x7ff0904a60f0>
Method:   -createCommandInvocationRecordFromInvocation:
Thread:   <NSThread: 0x7ff09079d670>{number = 14, name = (null)}
Please file a bug at http://bugreport.apple.com with this warning message and any useful information you can provide.
** INSTALL HEADERS FAILED **

Do I need to add a dev path in local?   Its moving along through most of steps without errors until the end.    Ryzen 7 1700 using Sierra 12,5.

kernel header is not installed properly for firehose.  This https://github.com/PureDarwin/Building-XNU-16.5_3789.51.2should still work to build firehose first.

-Made a bootable High Sierra usb .

-Placed your kernel

-used chameleon as the bootloader.

-And when at initial boot to usb, it throws some OPEMU error.

 

https://streamable.com/8a8yh

That's a legit x86 instruction.  The warning says ip (instruction pointer) is not valid.

  • Like 2

kernel header is not installed properly for firehose.  This https://github.com/PureDarwin/Building-XNU-16.5_3789.51.2should still work to build firehose first.

That's a legit x86 instruction.  The warning says ip (instruction pointer) is not valid.

 

I'm getting a CPU error?    

kernel header is not installed properly for firehose.  This https://github.com/PureDarwin/Building-XNU-16.5_3789.51.2should still work to build firehose first.

That's a legit x86 instruction.  The warning says ip (instruction pointer) is not valid.

 

I'm getting a CPU Number error?    

post-1753549-0-26969500-1506793453_thumb.png

Something is seriously wrong.  You can make another USB and try agaib just to rule out corrupt data on USB.

 

re-created the high sierra bootable usb but still no luck ,

it throws the same OPEMU error continously . 

 

 

re-created the high sierra bootable usb but still no luck ,

it throws the same OPEMU error continously .

 

Have you tried a copied version os High Sierra and adding the kernel to it? Do you have a Intel system that can load High Sierra or a Mac that you can copy a disk from?

Have you tried a copied version os High Sierra and adding the kernel to it? Do you have a Intel system that can load High Sierra or a Mac that you can copy a disk from?

nope !

i dont have any intel system , though may be i can find a intel laptop .

so basically i have to install hs on a intel pc then move its HDD that to an AMD system and use the Shaneee HS kernel on it , right ?

I'm getting a CPU error?    

 

I'm getting a CPU Number error?    

Xcode cannot find this file  https://opensource.apple.com/source/xnu/xnu-4570.1.46/osfmk/machine/cpu_number.h.auto.html.  Kernel header is not installed correctly.

How do u make your osx usb installer ?

I used pandora's box for Sierra.  Never tried High Sierra.  If you use Apple Instaler.app, it probably does not work.

Have you tried a copied version os High Sierra and adding the kernel to it? Do you have a Intel system that can load High Sierra or a Mac that you can copy a disk from?

Im about to try it now. Cloning my Intel hack and gonna try and boot with shanees kernel

  • Like 1

Ive tried the pandora installer process. Added the latest AMD usb fix and also added the latest AppleAHCIPort.kext to fix the "waiting for root device" error and i also get "Invalid opemu" Im about to try a cloned intel hack and swapping kernels. 

Ive tried the pandora installer process. Added the latest AMD usb fix and also added the latest AppleAHCIPort.kext to fix the "waiting for root device" error and i also get "Invalid opemu" Im about to try a cloned intel hack and swapping kernels. 

 

My El Capitan/Sierra USB fix works on 10.13 too. Can upload here if needed.

  • Like 1

My El Capitan/Sierra USB fix works on 10.13 too. Can upload here if needed.

Thats the one im using currently. So far i still cant boot. Im getting passed the opemu error. But i get to a point now and it just reboots.

I may need to disconnect all my other drives and see if it makes any difference

post-1420666-0-93592800-1506869617_thumb.jpg

post-1420666-0-08185400-1506869643_thumb.jpg

Have you installed the web drivers yet?

Good point. They are installed on that cloned drive. Im using enoch to boot this drive currently. whats the current boot flag for nvidia web in enoch??

Good point. They are installed on that cloned drive. Im using enoch to boot this drive currently. whats the current boot flag for nvidia web in enoch??

 

If they are installed it's NVIDIAWebDrv=Yes

 

Got 10.13 installed using USB but still my GT430 won't work :( Can only boot in safe mode currently.

  • Like 2
×
×
  • Create New...