Jump to content

[Guide] macOS Sierra 10.12 - Dell Optiplex 780 (760) (755) (790) (990)


MacPeet
 Share

1,596 posts in this topic

Recommended Posts

HI MacPeet, can I ask you to Edit the layout in my DSDT attached so I can use the apple ALC audio method on my 760. 
 
 
 
 
 
 
 

The alternative:
 
I use on my Dell Optiplex already AppleALC method:
 
attachicon.gifAppleALC_1.0.14.RELEASE.zip or later (LayoutID 11 for Dell Optiplex 780/760)
 
1. Install back the original AppleHDA to S/L/E
2. Install the AppleALC to S/L/E
3. Delete all AppleHDA Kext-to-patch entries in Clover
4. delete realtekALC.kext of Clovers kext folder
5. add bootflag -alcbeta
attachicon.gifalcbeta.png
6. Change LayoutID of 1 to 11 (DSDT HDEF 0B)
7. rebuild cache and reboot
 
Edit:
With AppleALC 1.0.16.Release and macOS-Final the bootflag -alcbeta is no longer necessary.

DSDT.aml.zip

Link to comment
Share on other sites

I was able to get native sound on my 780 with AppleALC.kext just by changing the layout to 11 in dsdt. I have AppleALC kext inside kext folder 10.11 and I didn't have to add the alcbeta in config.plist. What are the advantages of having AppleALC inside S/L/E?

Link to comment
Share on other sites

I also wish all users, especially Optiplex users beautiful Christmas.

 
:wub:

 

 

2kx1Bbn.png

 

 

 

:D

 

 

 

I was able to get native sound on my 780 with AppleALC.kext just by changing the layout to 11 in dsdt. I have AppleALC kext inside kext folder 10.11 and I didn't have to add the alcbeta in config.plist. What are the advantages of having AppleALC inside S/L/E?

 

And it works with Sierra 10.12.x ??

 

Should be in 10.12 or Other.

Link to comment
Share on other sites

I haven't updated to Sierra 10.12 yet but I'm sure it will work just the same. Joyeux Noël a tous!

 

I haven't updated to Sierra 10.12 yet but I'm sure it will work just the same. Joyeux Noël a tous!

Hi Blaggah, I remember your video card in Dell  780 SFF is Asus HD 5450 -1G, am I right? I have the same situation with you (780 SFF and Asus HD5450 and El capitan 10.11.6), but my video card can't wake from sleep, Can you tell me how did you make it work? Thank you and Merry Christmas.

Link to comment
Share on other sites

 

2kx1Bbn.png

 

 

 

:D

 

 

 

 

And it works with Sierra 10.12.x ??

 

Should be in 10.12 or Other.

 

 

thank you

 

Yes
If the 10.12 is present, then there.
The others folder only works if the 10.12 folder is not available.
Link to comment
Share on other sites

HELLO everyone and merry christmas, i need some help with making clover work on an optiplex 780 with sierra but it will need to be a complete simple guide (i have mac booted but its off a temporary drive so i need it on my main hdd but when i tried and rebooted it took me to a black screen (darwin x86??)with the drives so when i hit enter the boot screen was white with grey apple and black loading bar and when it booted it was just a grey/white screen with a sort of no entry icon or a circle with a line through it which is why i am asking for help today)as i am not pro at hackingtosh's so i would appreciate any help possible, thanks  :)  :)  :)  :rolleyes:   and just to note it has 8gb ddr3, hd5450 graphics card 1gb(asus), 250gb hdd, and a core 2 duo cpu @2.93Ghz  

post-1926693-0-13991800-1482492472.jpeg

Link to comment
Share on other sites

If your Install Sierra is booting from the USB, then Install Clover on the Sierra HDD and copy all your Kext's, config.plist, DSDT from the Clover USB to Clover HDD.

Clover can not boot a large 4K HDD.
 
Please always ask in the thread, not via private mail!
Link to comment
Share on other sites

Hi Blaggah, I remember your video card in Dell  780 SFF is Asus HD 5450 -1G, am I right? I have the same situation with you (780 SFF and Asus HD5450 and El capitan 10.11.6), but my video card can't wake from sleep, Can you tell me how did you make it work? Thank you and Merry Christmas.

Well that problem was an issue due to me using a USB wifi dongle to connect to Internet. As soon as I stopped using that, sleep/wake worked as it should for me. Sometimes even wireless mouse and and keyboard receiver does the same thing but not all the time. So make sure you don't have any usb wifi dongle plugged in and try and test sleep/wake again. My last experience with the 790 sff I couldn't get full graphics acceleration to work because the Asus 5450 I was using has a different chip so it wouldn't work with the dsdt. As soon as I switched to an nvidia based card, I was able to get graphics to work. Good luck and merry Christmas.

Link to comment
Share on other sites

 

Which TPL wireless card exactly?
 
Update:
macOS Sierra DP Beta 4 16C53a works without problems

 

I was having stability issues with the TP-LINK TL-WDN4800, however it looks like I keep losing network conductivity at some point even without it in...Not sure why, I'm trying to troubleshoot now.

Link to comment
Share on other sites

Well that problem was an issue due to me using a USB wifi dongle to connect to Internet. As soon as I stopped using that, sleep/wake worked as it should for me. Sometimes even wireless mouse and and keyboard receiver does the same thing but not all the time. So make sure you don't have any usb wifi dongle plugged in and try and test sleep/wake again. My last experience with the 790 sff I couldn't get full graphics acceleration to work because the Asus 5450 I was using has a different chip so it wouldn't work with the dsdt. As soon as I switched to an nvidia based card, I was able to get graphics to work. Good luck and merry Christmas.

Thanks for your reply. My Video Card problem solved by replace HD 5450 to GT610. Wake from sleep works very well(OOB). That is. Will not update to Sierra. 

  • Like 1
Link to comment
Share on other sites

Thanks for your reply. My Video Card problem solved by replace HD 5450 to GT610. Wake from sleep works very well(OOB). That is. Will not update to Sierra. 

I'm glad it all worked out for you.. I've found that this system is by far one of the most stable ones out of my hackintoshes i have in the house.  I will be adding a core 2 quad on mine in the near future and dual boot on a single drive while the other drive will be used for Backup and storage.

Link to comment
Share on other sites

XFX HD5450 works with Vanilla DSDT patch.

Please ask for more information! What computer? More details please!

My computer is a HP conquer 8200 elite small form factor. The specs are Intel core i3 2100 3.10ghz with 4gb of RAM ddr3, 500gb hard drive and XFX hd 5450. Everything installed fine I don't have to use any boot flags to boot everything is working but the graphics card I try fake ID for clover configurator and editing kext does not work. I had not tried dsdt I don't know how to edit those.
Link to comment
Share on other sites

Everything installed fine I don't have to use any boot flags to boot everything is working but the graphics card I try fake ID for clover configurator and editing kext does not work. I had not tried dsdt I don't know how to edit those.

 

What FakeID did you tried ? Did you ckecked Inject ATI also ?

 

Also, remember that you can't use both FakeID and modded AMDRadeonX3000.kext + AMD5000Controller.kext at the same time.

Link to comment
Share on other sites

What FakeID did you tried ? Did you ckecked Inject ATI also ?

 

Also, remember that you can't use both FakeID and modded AMDRadeonX3000.kext + AMD5000Controller.kext at the same time.

 

I use 68E01002 id from this guide and yes i did check Inject ATI https://www.tonymacx86.com/threads/guide-enabling-ati-radeon-hd-5450.180817/ 

Ok, then post your clean DSDT (as zip file) and poste pictures from the DPCIManager from the tab "Status" and "PCIList" !!! I'll see what I can do. Ioreg would be good too.

 

How do i upload those to here?

Link to comment
Share on other sites

  • Allan unpinned this topic
 Share

×
×
  • Create New...