Jump to content

[Guide] macOS Sierra 10.12 - Dell Optiplex 780 (760) (755) (790) (990)


MacPeet
 Share

1,596 posts in this topic

Recommended Posts

I played a bit comparing Resources/Ad1984A.

I started comparing it with ad1984 (for Thinkpad 61)

Differences are on the CodecID 6474 (instead of 6532 for Thinkpad) and following patches:

ixnUEQ replaced by ShnUEQ (Thinkpad replaces ixnUEQ by hBnUEQ).

 

1) Is codec ID for AD1984A unique or it depends also from Motherboard? 

2) How those replacement values can be found? Is there a range/set I can play with?

Thanks


@vdv I was referring to the 790 because it has the same codec id as your t3500. I have a 755 also but i havent touched it in a long time. Try the AppleALC.kext and use layout ID 11 with your speakers plug into the headphone port in the front and for sure you will get audio. Just try it out and let me know.


780/760 has AD1984A

755 has AD1984
790 has ALC269Q
T3500 has ???
 
@vdv
Please make a codec_dump with a linux-live, example with Ubuntu and post this here. Then I look.
 
Boot with Linux live, then in the terminal:
cd ~/Desktop && mkdir CodecDump && for c in /proc/asound/card*/codec#*; do f="${c/\/*card/card}"; cat "$c" > CodecDump/${f//\//-}.txt; done && zip -r CodecDump.zip CodecDump

post here output for this

 

And please fill out your forum signature (hardware, components and current system) !!!


I stand corrected MacPeet, I apologize for the wrong information.  I was just going from memory about the 790 audio codec.  It was the last system I worked on back in December which gave me that issue with audio. 


I just finally gotten El Capitan on my xw8600 workstation after almost 3  years of possessing this machine.  Strange thing is, the same thing with audio is happening with it. I could only get audio to work if i plug speakers on headphone port in the front of the machine.  


@vdv

 
Your codec is somewhat different from Dell Optiplex780.
 
Change LayoutID 11 to 28 (1C) in your DSDT (HDEF) and try this:
 
 
Note: Original (vanilla) AppleHDA use with AppleALC!
 
 
@Blaggah
What device? Has the xw8600 same codec as HP Z800 / 600 ...?

No sound either on headphones or on standard out (I have volume control and sound preferences).

Just to check no stupid mistakes.

 

I installed with Kext Wizard your new AppleALC.kext in S/L/E.

Than permission repair.

Than reboot.

 

DSDT patched as follow

 

           Device (HDEF)

            {
                Name (_ADR, 0x001B0000)
                Method (_DSM, 4, NotSerialized)
                {
                    Store (Package (0x08)
                        {
                            "built-in", 
                            Buffer (One)
                            {
                                0x00
                            }, 
 
                            "layout-id", 
                            Buffer (0x04)
                            {
                                0x1C, 0x00, 0x00, 0x00
                            }, 
 
                            "PinConfigurations", 
                            Buffer (Zero) {}, 
                            "hda-gfx", 
                            Buffer (0x0A)
                            {
                                "onboard-1"
                            }
                        }, Local0)
                    DTGP (Arg0, Arg1, Arg2, Arg3, RefOf (Local0))
                    Return (Local0)
                }
            }
 
0X67 as CsrActiveConfig

@vdv do you happen to use applehdadisabler.kext? If so remove it from your kext folder. MacPeet, I forgot to check but I will check again later. I already did the codec dump, I will upload it on the the thread for the xw8600 thread that was revived the other day. You should see my last post on it on the complete desktops.


No applehdadisabler.kext. Just a fresh installation. No patches or modification. Should I cancel older applealc.kext from S/L/E before installing new one? I just installed with kext wizard (over the previous one).


Do you guys find that the mic input volume is pretty low, even adjust at Max. 

I tried both front and back ports, no luck.

How can I fix it.

The Mic that I use already test on the other PC, it works well.

 

BTW, I use method #1 On the fly.

 

 

try this:

 

trial_on_the_fly_Paket_Dell_Optiplex_780_(760)_10.12_Sierra_276_26.zip

 

I added a boost for Mic.


Devices can be seen, however, under System Settings/Sound and SystemInfo?

 

The original AppleHDA is also in the system? No patched AppleHDA?


Made my 10.12.2 clone finally and tried it with the backup Optiplex 780.

It took a little time to get to the desktop but is working fine.

 

post-762190-0-93848300-1485008310_thumb.png

 

If some body is wanting to buy such a card, here it is.

Definitely not high end, but all right for the money. A DMS59 twin port cable is needed to use it though.

http://www.ebay.de/itm/AMD-ATI-Radeon-HD-6350-Low-Profile-512MB-DDR3-DMS-59-/361835553800?hash=item543f146408:g:t0AAAOSw-0xYNGoB

 

I am suspecting that such cards are rebranded 5450s. Same specs, same frame buffer.

The marketing guys probably just needed a higher HD6XXX number to offer their customers.

  • Like 2

Devices can be seen either under System Setting / Sound, either under SystemInfo (devices).

They are not seen under High Definition Intel Audio (just 1/8" Jack).

 

Looking into Ioreg, I'm not sure 100% is working.

 

I've done a fresh install (to avoid old patches).

Original AppleHDA. Not touched.

I installed AppleALC into S/L/E, repairing permissions.

 

Do I need to put it into AppleALC kext/10.2?

 

 

post-237819-0-84432200-1485007888_thumb.png

Diego’s Mac Pro.zip

post-237819-0-03641800-1485008444_thumb.png


I do not understand. All devices are there. Is sound enabled in bios?

 

Cable connected?
LineOut is green at the back.
HP is at the front of the green connector.
 
Works LineIn or Mic?

I don't understand ad well.

 

All AppleALC I tried (for 780 you made and the 2 you did for T3500) give me control on output but no sound.

 

I tried Line In and Mic, not working.

 

If I boot with Win10 or linux no problem on Audio (so speaker are plugged correctly, in the green).

 

Do you think HDA codec graphic tool could help you? I could give you a diagram like this one for my board.

 

Do you need my DSDT / config.plist?

 

1984A hp-compaq-6530b.zip


I have these files already from CodecDump.

On LineOut is an EAPD: 02 for sound activation, which I have poked with 01270C02.
Actually, everything is right. All devices are also displayed. I'm a bit helpless.
 
see: Archiv.zip
 
try this:

@MacPeet. No sound. 

Less control (no possibility to select front speaker).

 

Best revision seem 2.

 

I'll start from scratch.

New install, recheck all DSDT, Config.plist. and try again all your files.

 

Thanks anyway.

I'll study your archive a bit and than come back.

 

In the meantime, if you'll have any Idea, please let me know.


  • Allan unpinned this topic
 Share

×
×
  • Create New...