Jump to content

Lenovo ThinkPad T420 with UEFI Only


Go to solution Solved by tluck,
5,244 posts in this topic

Recommended Posts

 

 

2) Tap to click works - if you set it the TrackPad Preferences 1st tab.

 

@Tophaholic

what happens if you eliminate IntelBacklight.kext?

you could try the config.1600x900.plist - edit it and set DualLink = 0. this one will inject a different EDID to see if that make a difference.

Issue resolved. I just wiped out the EFI folder on the HDD and replaced with the EFI folder in your build package. I think something messed up when I installed the latest clover package. All is good now. Thanks for all the support!

Just in case it is of interest for anyone. Updated my sister´s (my old) T420 with a Intel Core i7 2720QM 2.2GHz Quad. 

 

Temperatures at idle is 36-40º C

Never exceeded 91º C at intensive use

 

Used artic clean thermal remover, surface puriface and Silver 5

Hi trifero!

 

What was the previous CPU and what temps did you get with that one?

Thanks.

Thanks for your benchmarks!

I was thinking of a 2720QM the other day. May I ask how much cash you had to throw for it?

 

From the days of my MacII I learned that one would hardly notice a cpu upgrade in everyday work unless you would roughly gain the double benchmark wise.

A 2720QM is worth a thought it seems. (Hope this won't spoil second hand prices totally now.)

Agreed, thats a reasonable price. I don´t see anything similar either except from Latvia or so.

And I kind of hesitate to buy from "foreign" countries.

That and my T420 would be mostly just "waiting faster" thinking of the tasks I throw on it. :)

 

Nice specs tluck, Skylake-U may be the way to go once some affordable leasing returns show up.

Can you still read the forum postings at 1920x1080, fourteen inch? (just kidding)

yeah! double the performance is pretty good. especially for the price - they seem to be about $75 US on eBay. i have moved on to focus on my T460 right now.

Hey tluck!

 

Does that mean we'll soon lose your support for the T420?

How's the T460 doing with macOS?

no such luck  :wink_anim: My 8yr old son is still using a T420 ... and I will keep my T420 around for a backup. 

my T460 has a decent full HD LCD.  but since I replaced my T420 orig LCD with a Glossy LG LCD, that screen is much better! seems brighter and whiter. and i prefer 1600 vs 1920 native res on 14inch screen!

HD300 software "upgrade"?

As many here are using the unlocked T420 BIOS, did anybody manage to assign 512MB RAM to the HD3000?

There is a setting for it in UEFI/BIOS, but I´m clueless how to tell the OS to grab 512MB instead of 384.

Could be a Clover tweaking as well.

Just curiosity on my side, whether 512MB would somehow better things compared to 384.

HD300 software "upgrade"?

As many here are using the unlocked T420 BIOS, did anybody manage to assign 512MB RAM to the HD3000?

There is a setting for it in UEFI/BIOS, but I´m clueless how to tell the OS to grab 512MB instead of 384.

Could be a Clover tweaking as well.

Just curiosity on my side, whether 512MB would somehow better things compared to 384.

Upgrade your RAM to 8GB

HD300 software "upgrade"?

As many here are using the unlocked T420 BIOS, did anybody manage to assign 512MB RAM to the HD3000?

There is a setting for it in UEFI/BIOS, but I´m clueless how to tell the OS to grab 512MB instead of 384.

Could be a Clover tweaking as well.

Just curiosity on my side, whether 512MB would somehow better things compared to 384.

 

Or better, to 16GB.

@goodguess - here is a clover kext patch that give you 512MB with 4GB of memory - I do this on my son's box that only has 4GB

<dict>
    <key>Comment</key>
    <string>HD3000 384 to 512</string>
    <key>Find</key>
    <data>
    x0W8AAAAGA==
    </data>
    <key>Name</key>
    <string>AppleIntelSNBGraphicsFB</string>
    <key>Replace</key>
    <data>
    x0W8AAAAIA==
    </data>
   </dict>

Many thanks for your guide!

 

After having converted two Lenovo X220's (without any troubles following the instructions at http://x220.mcdonnelltech.com),I now started converting my own T520, following this guide, since the hardware seems to be nearly identical. As with the X220, I got a BIOS with removed whitelist, and replaced the WiFi with a Dell 1510. Installation was easy thanks to the provided files, thanks again!

 

Only place where I had to get away from the tutorial was where it came to the screen resolution - I renamed config.1600x900.plist, but updated it inside to 1920x1080 (using the standard plist editor on my iMac, replaced resolution in two places).

 

Now the T520 is up and running, with just a "tiny" but highly visual problem: my desktop appears multiple times on my screen!

Clover is showing 1920x1080, the monitor system settings do show 1920x1080 as well, and switching resolutions will only switch resolution in their existing "frame".

 

post-1940124-0-35637900-1483651809_thumb.jpg

 

Any idea what I can do about this would be quite welcome :)

@CCRDude - the difference between the config.1600 and config.1366 files are 2 things:

 

1) 1600 = injects a custom EDID to fix a problem with bios T420 EDID

2) 1600 = has DualLink =1

 

so restart start with the 1366 config and then if you need DualLink=1 edit and reboot.

Could anyone please tell me how do I go about removing the whitelist from bios on a T430? I like the laptop but can't seem to do anything with it yet because of the whitelist. Also if this guide for the T420 is identical in order to get the OS to install on the T430? Thanks in advance guys.

Thanks for the ultra fast answer, tluck!

 

I copied the 1366 config. but only got what I also had when booting from my X220 pre-configured USB stick. I get the left half of the desktop filling my whole screen, with some psychedelic colours:

 

post-1940124-0-71210200-1483652942_thumb.jpg

 

post-1940124-0-51253300-1483652947_thumb.jpg

 

(btw, the 1920x1080 resolution works fine from Windows boot stick and Ubuntu boot stick, so I'm sure the display specs are correct)

@CCRdude - so now that you removed the bogus EDID from the 1600 config, you probably need change DualLink=0 to DualLink=1

 

@Blaggah - T430 bios - prolly need find one at the T430 guide or from Bios-Mods.com? most of the steps are the same except not all kexts will work - for example Audio and GFX will be different.

Is there a T430 guide on here? I'd love to take a dab at it soon. The laptop is just there collecting dust.

No, but you can take reference on here. I still have the files for the T430, including the modded bios file. For bios mod, you have to use external programmer to mod it though

no such luck  :wink_anim: My 8yr old son is still using a T420 ... and I will keep my T420 around for a backup. 

my T460 has a decent full HD LCD.  but since I replaced my T420 orig LCD with a Glossy LG LCD, that screen is much better! seems brighter and whiter. and i prefer 1600 vs 1920 native res on 14inch screen!

 

Thanks for your continued support tluck!

I also prefer the 1600 over the 1920 resolution LCD at 14" screen size. My company Dell machine is at 1920 and it's very tiring to look at.

I guess you forgot to reply to my question about how does Sierra perform on the T460. Was the intentional? :) I'm truly interested.

if you are seeing weird/glitchy menu colors on LCD when using 2 external monitor.  i think the answer is to use a modified EDID to remove non-RGB profiles. i will post a new zip soon with the EDID modified for T420 LCD.  working for me!

 

@Somez - Not intentional to avoid your query on T460.

 

short story: After a rocky start with El Capitan on the T460, recently over the last month with Sierra the box came together for me. These problems are all history. Now in fact I replaced my tried-and-true trusty T420 and docking station with the T460 and its docking station. Bottom line - and time will tell - it is pretty solid. The ClickPad is nicer than and the TrackPoint is reliable. I really like the USB3 ports on the Dock so now i can truly just click it out the dock and go without a lot of hassle. with my T420 i was using a FL PCI for USB3 etc etc.

 

Other TP sites and references

 

T430
- site: http://www.insanelymac.com/forum/topic/293762-thinkpad-t430-mavericks-109x-yosemite-1010/
- may be somewhat neglected - but has some good 430 specific info

 

T440s
- ludacrivsp and others have a good thread on this on another hack site

- i tested one out recently but decided to return it - but it worked ok.

 

T450

- shmillee site: - https://github.com/shmilee/T450-Hackintosh

- a great repo on GitHub which was a huge bonus to me to get the T460 going

 

T460
- http://www.insanelymac.com/forum/topic/315451-guide-lenovo-t460-macos-with-clover/

- i originally posted a "work in progress" guide last September to solicit help
- and now with luck, encouragement, and some work from a small band of T460/T560 user and enthusiasts,  we have a pretty solid guide and zip file now!

×
×
  • Create New...