Jump to content

Kalyway 10.5.2 DVD Intel_Amd (sse2/sse3) EFI V8


1,087 posts in this topic

Recommended Posts

Hey all, I'm new in this so please forgvive me for being stupid if it sounds that way...

I downloaded the Kalyway Mac OS X 10.5.2 install DVD. When I try to boot of the DVD from startup, the Darwin loader starts correctly, it gives me the option to boot from the DVD or type in advanced options. When I select to boot from the DVD, it starts to install, but about a second into the disk spinning up, my screen displays a list of details that end in


"dependencies found for both com.apple.kernel and com.apple.kpi; please select one."

and the disk stops and I'm stuck there. It doesn't let me type anything and I have to turn my computer off. Is it required to type an adnvanced option at the Darwin loader?


Please help. It is much appreciated... :)


My specs are:


Dell XPS M1330

BIOS Revision A09

Intel ICH8M Chipset Family

2.20 GHz Intel Core Duo Processor

3 GB DDR2 Dual-Channel RAM

250 GB Toshiba HDD w/ Windows Vista Ultimate x32

Matishta DVD-R/+R Burner; CD-R/RW Burner Combo Drive

Realtek SigmaTel STAC 9228 C-Major HD Audio

Nvidia GeForce 8400GS 128 Graphics Card

Intel PROSet Wireless 3695agb/4659agn Network Card

Link to comment
Share on other sites

Hi there!

I can't boot DVD for installation... it's got freezed and appears:


"Waiting for boot volume, with UIDD XXXXXXXXXXX"



Anybody can help me?


My spec are:


Acer Aspire 4720

Pentium Dual Core 1,46

Wireless Atheros AR5007EG

160 GB hard disk

Link to comment
Share on other sites



Top work, booted first time into OSX on my aging AMD Athlon 3500.

Question though. The screen is running at some poor resolution and I don't seem to be able to change it. I've got a NVIDIA GeForce 7800 GS. Which option should I be picking for the graphics ?


Much appreciated. Just need to find a driver for my WiFi USB.... Had one working a long time ago on my old 10.4.x install so can't be that hard to get it working again.


Yay OSX on my AMD ;)


Just compliments my Mini !!!

Link to comment
Share on other sites

hi kaly,


sorry for not giving feedback earlier, working a bit too much these days, having to neglect my contributions to the community .. ;)


what I am asking you is to include orbyte's generic ehci kext right into the mkext for the DVD loading, and to delete Apple's ehci kext out of the IOUSBFamily.kext before you generate the mkext.


the reason is that that would enable so many of us to install onto an external USB drive - which is not possible right now with *any* of the releases because their mkexts all include the IOUSBFamily.kext with Apple's EHCI kext (which is quite a bit of a bummer) ..


Apart from that it is very wise to delete Apple's IOPCCardFamily.kext *completely* before building the mkext for the DVD, because it causes most Laptops to crash ..


Thanks for everything you do for the community :angel: !!





PS: your PM is full, and no way to get hold of you on IRC .. hm .. :)

Link to comment
Share on other sites

Ok this release works almost flawlessly. USB Bluetooth stick works, PCI FireWire card works, all my NTFS hard disks are even accessible.

Thank you Kalyway!


Only issues left:

Sleep works, but reboot and shutdown don't... Everything starts to shut down, I believe hard disks also get disconnected (*click) but at the end I am left with the PSU and all my fans still on. Also my case power button doesn't work anymore. Have to use the power switch on my PSU. Should I try a different kernel than Vanilla? Or has this still something to do with my sound card? (alc889a_shutdown_support)


EDIT: After sleep my internet connection is gone and doesn't come back. Sometimes it shuts down properly... Guess I will try a different kernel...


Also tried kabyl kernel, shutdown and restart work properly, but animation looks less fluid and sound doesn't work. Found a driver to get the sound working, but it had a lot of strange noises coming with it.


Now trying kernel_sleep...


EDIT2: kernel_sleep didn't have sound... Installed Vanilla again, and also no sound anymore HUH?!


Going to kernel_sleep again because of the sleep, reboot and shut down working right...


Customization first used:













Mobo chipsets:










Other patches:


Link to comment
Share on other sites

Hello Everyone,


Finally downloaded Kalway 10.5.2, tried installing, but it just goes in a reboot loop. Tried the various -x, -s, -x v, and so on. But same results. I have disabled Legacy USB support and many other recommended components in the BIOS.



ASROCK K8 Upgrade motherboard February 2006

AMD Sempron 1.6 GHz (64-Bit Enabled) SSE 2, SSE 3

512 MBs of DDR RAM

15 GB Partition



I currently have 10.4.8 Jas on the partition and have installed successfully.

the Kalway ISO was burnt at the lowest speed possible (1x)

Gonna try 4 x, but would love some suggestions why this reboot loop keeps happening.


I notice reboot does not occur on my laptop and goes really far.


Thanks for your help

Link to comment
Share on other sites

Looking for a bit of help with the Kaly install. Looking for the step that I might be missing:


I have the Kalyway10_5_2.iso burned to disc, however this is a newly built 'puter with no OS or formatted drives etc yet.


Am I looking for a bootloader to install first to get me to a place where I can mount the .iso file?


If I just boot up the 'puter with the .iso disc, I get the "NO BOOT DISK" error.


Thanks :)


Specs: nForce650i Ultra, Intel CoreDuo 1.8 Ghz, 2 Gb 667 DDR2 RAM, nVidia e-GeForce 8400 GS, Seagate 250 Gb SATA, Lite-On DVD SATA, PCI Firewire/USB card.


EDIT: Installed XP on a 20Gb partition. Obviously discovered you don't mount the .iso. No luck with booting to Kalyway .iso as of yet.

Link to comment
Share on other sites

Okay, I ran "Format and make HD bootable for Leopard". Then I installed the Kalyway 10.5.2 OSX. Everything installed, but when I restarted I entered the first-start mac screen where you select your preferences, a trouble arose. When it asked me if I wanted to transfer data from another Mac, I selected no and then Continue. But then the loading pointer started spinning and then the start up video started playing (the one where it says "Welcome" in various languages). I tried it again but got stuck in the same point and got returned to the Welcome video. Any ideas?


Hello everybody! Have EXACTLY the same situation!!!

my wanna-B-macOS DELL:

inspiron 9400,

C2D 2Ghz, 2GB 667mhz RAM,

GF go7900gs 256, 1920x1200

440 NIC, intell Wifi (both off in BIOS)

2200 sound

installing on external USB(wire/adapter) barracuda 40GB HDD...


Tryed Installation:


vanilla or speedstep kernels

NVinjectGO (looks like it's working, i have 1920x1200 on 1st 3 windows b4 it's rescreening "welcome" video)


AppleBCM440XEthernet or nothing

NO wifi driver

all mobo chipsets (as suggested)


all extra programs




cpus=1 flag or without it






None of suggested to mahen.s9 is working 4me... Not the NIC off in BIOS, not 640x480 (its just boots w 1920x1200), not all the -s -x ... passwrd ... AppleSetupDone .... and so...

Booting with shift keep me forever on grey apple...

Bootinfg itself is ok, with vanilla it's going to sleep, but having black screen when back, on speedstep it's even coming back from sleep well... Donnow about the sound - my minijack socket is broken - notebooks speakers are silent, didn't tryed external  ones yet... Twice kernel panicd, once laptop lost AC adaptor error (never seen b4 smthng like this), once it didn't find boot record, b4 of each of this errors i was shutingdown the system w

ile it was doing smthing...


I will continue experimenting with install options, if any1 can help - please let me know!

Link to comment
Share on other sites

Just finished again with kabyl_kernel, everything works fine now...


Only one thing... I have this USB Bluetooth stick and it installed fine. Worked like a charm. But I had to unplug it... Plugged it back in, but OSX doesn't find it anymore... Rebooting doesn't help... I am left with a broken Bluetooth logo in the topbar... Is there a way to reactivate it, but not installing Leopard all over again?



Link to comment
Share on other sites

Everything works beautifully out of the install for me except for 2 items..


One I can fix, the other....I have no clue.


The first is I use a geforcego 7300 and the dual monitor didn't work. Thankfully I had a kext that did and just replaced.


The second is....NO USB At ALL. Anybody have a clue about this?


My Specs Are:


Inspiron E1505/6400

Intel Core Duo T2500 (2 ghz)

2 gig of Ram

Sigmatel STAC9200 Audio

Dell Wireless Broadcom 1500 N

Hitachi 200 gig 7200rpm (100 gig for Mac 100 gig for Windows)

USB - Intel 82801GBM ICH7-M

Link to comment
Share on other sites

hey guys i got amd sempron 3000+ (1,80 ghz), ati radeon 9600 pro (128mb, AGP) and i got faxconn nf3250k8 nforce3 250 chipset socket 754, drr400, agp 8x, sata disk motherboard. I allready tries to instal the mac OS X 10.5.1 Leo and 10.4.9 Tiger and none of then isn't working ... so i wonder if there is any solution couse my brother runs hackintosh on his intel core 2 duo and i love it ...

So when I instal the hackintosh everything works well and the instaler finish and then the comp is reboted. When it tries to boot it it stucks on the main screen ( the white backgound with apple and the loader ) and then the error shows up that i need to restart the comp. If i remember well the 10.5.1 instaler didn't finisher ... it seems like it stucked and then ut just rebot ... the final result is allways the same .. the error shows up .. i never get into the OS .

Is there anything i need to choose when i'm instaling or I can't have mac on my comp ? .. the processor supports SSE2 and SSE3 . Thanks in advacne

o and i allmost forgot .. i got 1gb ram ... tomorow i'll upgrade it to 2gb.

sorry for my bad english

Link to comment
Share on other sites

Kalyway 10.5.2 + ASUS P5W DH = works out-of-the-box :ninja:


Installed on Sata drive with GUID partition (when I choose MBR the install DVD is needed to boot, b0 error)


The Natit drivers inside doesn't work in my PCI-E GECUBE RADEON HD2600PRO 512MB :P

Link to comment
Share on other sites

Just wondering, but it seems that 10.5.2 is causing lots of problems related to...






Perhaps we need to stay at 10.5.1 until 10.5.3 comes out ?



Well...Im hoping someone has a usb fix for this...cause this is the first build that allowed my computer to have sound AND be able to shutdown. Usually the patcher I use for the sound causes shutdown to stop.


USB fix anyone??? Anyone? Bueller? Bueller?

Link to comment
Share on other sites

Can someone help me on the dual setup?


I was able to install the 10.5.2 but here I have 2 problems:


1. I have to boot from DVD

2. I have a WinXP installed already (with C/D/E logic drives on a 500GB HD and Leopard is the last partition on that drive)


I don't see the option in the customize to choose "MBR or GUID" or anything. Can someone who does dual boot shed some light on how I should do it?


Thanks a lot!

Link to comment
Share on other sites

The solution for the welcomescreen problem is all over the net:


boot with -s


then do:


mount -uw /

touch /var/db/.AppleSetupDone

passwd root

enter a root password now


type exit


Then login with user root



THANX A LOT - it works perfectly for me... previous post with same instructions was not clear %P

Now just having different instability problems, so will experiment with kernels/kext's/patches...

sorry - i newby to Mac, but my 1st computer was Macintosh in late 80's (i was a kid then), now I so happy to go back :P:P:P

Link to comment
Share on other sites


I don't see the option in the customize to choose "MBR or GUID" or anything. Can someone who does dual boot shed some light on how I should do it?



I have the same question.


I looked everywhere but simply don't see this option.


It must be something simple I'm missing. If someone could please walk me through the exact steps to find this setting in the 10.5.2 install I'd be much obliged.

Link to comment
Share on other sites



I just tried to install this version on my Lenovo y510 specs below:

CPU: Intel 1.6 Core 2 Duo


HDD: 150GB

GFX: Intel 965 Express (X3100)

Audio: ALC888 onboard



And i keep getting this error no matter what kernel or options i try. See pic attached.



Thanks in advance.



I'm having the same problem! Does anyone have a solution?


Link to comment
Share on other sites

i do not know why you guys are having problems 'cuase my is the worst of them all {hp pavilion amd}, and it install every time i put this disk - my dvd drive is even ide and hard drive is sata.


both core detected and the graphics is just incredible.

Link to comment
Share on other sites


  • Create New...