Jump to content

New AMD DVD for leopard


2,431 posts in this topic

Recommended Posts

I just wanted to share my success with Leopard on my AMD system using "Mac OS X Leopard 10.5.1 for AMD SSE2/SSE3 (32bits)"


My Specs:

ASUS M2N-SLI Deluxe Mobo w/ nForce 570 SLI

AMD Athlon 64 X2 5200+ CPU


Integrated NVidia nForce Dual Gigabit LAN (not working)

IBM 10/100 Etherjet PCI Adapter

SoundMax Integrated Digital HD 7.1

Logitech QuickCam Pro 5000 Webcam

3GB DDR2 800 Ram


Sapphire Radeon x1550 Pci-e 16x w/256mb DDR2


After installing this DVD (which worked without a hitch), on first reboot it gave me a kernel panic on the built-in Geforce kexts that came with this release. Obviously because I don't have a Geforce. So I booted in Safe Mode by adding -x at startup. That allowed me to at least run Leopard but with no video acceleration or sound. CPU, HDs (including my windows partitions, both Vista & XP), Internet (the IBM ethernet card), webcam w/microphone, and burner were all recognized right away. The solutions:


Sound: I dug out my old Mac OS X 10.4.9 Uphuck v1.3 that I had used before. I inserted it while Leapord was running and I found the Azalia Kext in the installation folder and ran the installer. Rebooted and my sound works fine (2-channel of course). I also took that chance to install Office 2004


Video: On the same DVD, I also found the Natit x1300 kext that worked for me back with Tiger. Back then, It didn't give me any acceleration, but this time I get full acceleration on everything.


One time it started and the internet didn't work, but after a reboot it worked fine. Basically everything running very smooth. Thank you Zephyroth for posting this.

Link to comment
Share on other sites

Thanks go out to Zephyroth for an amazing piece of work!!


Im working on a troubleshooting guide for this as too many people are asking the same questions. Hopefully this will help everyone get to the same stage.


I have been on Tiger 10.4.9 couldnt get to 10 but its good that i can now play with Leopard.


My only problem is when i get to the migration assistant, click continue without migration it takes me back to the keyboard selection screen everytime. Im using a usb keyboard and mouse and both are reconised.



Any ideas???


Troubleshooting guide to follow shortly.


Sorted, i just copied over my previous account from Tiger and all is well. Internet working but Safari freezes when trying to download.

Link to comment
Share on other sites

Hey guys,


So I successfully installed the dvd. At first my install was stuck at "About 1 minute" but I rebooted the install dvd and did the install again and it said that the Install Succeded. My next steps were:


1) Made my drive bootable using fdisk

2) Deleted NV* and Ge* kexts

3) Moved kexts from leo_nvidia_kexts.zip into Extensions

4) Repaired permissions


Rebooted... my mac booted and my vid card was recognized and I even saw the welcome video. It looked like everything was working.


I got to the Welcome Screen and I've tried this twice (reinstalled Leopard) and I have the same problem which maybe someone can shed some light on. I go through the Welcome Screen, detect my keyboard, say I have ethernet (I tried saying I dont), entering some bogus info, and at the end where it says create account, I type in the info and click continue, and my Leopard HANGS on "Creating your account...". I get the beach ball and it never stops spinning. Help!? I tried this is normal mode and safe mode, same result.


When I repair permissions, I get the following messages


ACL found but not expected on "System/Library/User Template/English.lproj/* (On a bunch of subfolders/files) Maybe this is causing the problem? How do I stop this problem or How do I bypass the Welcome Screen (Can I manually create a user account)?




My specs:


Gigabyte S939 nForce 430 6150 board

AMD 3800 X2


160GB Segate IDE

Nvidia GeForce 7300 LE (works using Natit)

Link to comment
Share on other sites

- ACL found but not expected ----> don't worry about this, it's nothing.


- freezes with forcedeth ----> it appends not only on this release but it's an issue with Leopard (must wait for new driver)


- Waiting for root device ----> I forgot some kexts in IOATAFamily


- No PS2 mouse or keyboard ----> It's related to IOACPIFamily (check on google to find a fix)

Link to comment
Share on other sites

Sorry for not responding for a while i've been a bit busy, but anyway..


After booting with cpus=1 i've not had any random crashes either its just iLife 08 doesn't work. iMovie instantly crashes and iPhoto crashes when trying to import photos.

Link to comment
Share on other sites

Let me know if I'm wrong, but the kernel used is 9.1.0 speedstep/intel/amd/sse3 kernel, aka ToH's kernel. Definitely it is not for my SSE2 CPU.

I've already got a kernel supposedly suitable for me. The problem is that i don't find a right method to replace the mach_kernel file. I've tryied with MagicISO but the resulting ISO image is not bootable :-(

Any help to do this task will me appreciated.


Link to comment
Share on other sites

I have spent hours trying to fix my problem of not having a touchpad or keyboard. I tried to find a resolution using the IOACPIFamily criteria, and have tried several boot options such as cpus=1 and many others. There are no BIOS options that pertain to this problem.


Any suggestions?

Link to comment
Share on other sites

Im not sure if this applies to leopard but tiger would never recognize my usb keyboard/mouse so what i did was plug in a PS/2 keyboard/mouse and just hid them under my desk, then with the PS/2 mouse/keyboard plugged in it recognized my USB keyboard and mouse as well.

Link to comment
Share on other sites

Im not sure if this applies to leopard but tiger would never recognize my usb keyboard/mouse so what i did was plug in a PS/2 keyboard/mouse and just hid them under my desk, then with the PS/2 mouse/keyboard plugged in it recognized my USB keyboard and mouse as well.



Was that just for the install? If so I believe I'll just stick with Ubuntu. If not then I am game to give it a go!

Let me know


Link to comment
Share on other sites

Thanks you Zephyroth !!!


Great AMD version of leopard works ok for me on Athlon X2 4200 and nforce4 board. My 8800GTS 640 work with QE AND Dual screen recognized ! Actually all works except some randoms freeze when using integrated network.


For those who might want an image of their fresh installed leopard, they can use GHOST to make the image. I first installed leopard on a separate HD (pata) with 1 partition and then run ghost to transfert the partition on another hd (sata). I've found that you must use -ia switch with ghost to prevent b-tree error at boot. My destination sata drive contain 4 primary partitions:

1- fat32 XP (active)

2- fat16 XP for testing purposes with EWF

3- MacOS X Leopard

4- NTFS Data partition


I use xp boot.ini with chain0 to load OSX -> works great


The darwin boot menu however show all the partitions but the default selected is the first one, not leopard partition. if anyone has a tip to make leopard (disk1s3) default...

Link to comment
Share on other sites


how to you get the 3rd party dvd working. mine's a liteon and it's not being seen. looked up patchburn that isn't going to work.


OK i saw that another person just put it on the same IDE channel and that's what worked for me as well, all is good...

Link to comment
Share on other sites

So I finally have a bootable installation of Leopard using this Latest AMD patched DVD. I installed to an external USB PATA drive due to the conflict with nForce 4 MCP51 and SATA. Installation went well, but I couldn't boot from the drive afterwards. I installed the v5 EFI bootloader and now it boots.


The problem is, when I get to the initial setup upon first boot, I cannot proceed past the "Create Your Account" screen. I enter my user information, hit continue, and the waiting wheel just continues to spin infinitely without progressing to the next step. I read in another thread that this may be related to the loginwindow.app not being correctly patched.


Can anyone confirm that the loginwindow.app is what launches immediately after the Account Creation? If if that's the app for this screen? Booting into safe-mode, I can look at /Users and I see the accounts have been created.


Any ideas? I've tried booting with "-v", "-v platform=X86PC", "-x -v platform=X86PC", "-v -f platform=X86PC" ... all to no avail.


I'm so close!


HP dv9000z

AMD Turion X2 TL-56

NVidia nForce 430 (MCP51)

NVidia GeForce 7600 Go


1 External USB PATA drive (running leo)

1 SATA drive (not working with osx and nForce ...)

Leopard 10.5.1 zephyroth AMD patched DVD

Link to comment
Share on other sites

Does anyone have any thoughts on getting AC97 digital output working? Don't get me wrong, the AC97 analog sound output is working fine. I don't have HD sound on the motherboard, just AC97 (7.1 surround) from Realtek 650 chipset, but I'm thinking Dolbey Digital (spdif) from DVD's would be nice.



I managed to install OpenOffice 2.3 for Macosx Tiger (intel), which seems to have better compatability with MS Office 2003 docs than iWorks 08, or at least it opened one document for me that Pages refused. Apart from that, iWorks is much faster, and seems quite stable on my setup.



Video support is great. I'm running 2 Lcd screens (Dell and Samsung). Watched a couple of hours of video last night, dvd and divx, sometimes at the same time... no freezes ( amd64 x2 4600, 2 cores running).



Thanks again zeph for your work.

Link to comment
Share on other sites

ok so I still have the same problem getting leopard to boot after install


I did the fdisk -e /dev/rdisk0s1 (if that isn't completely right it is because I am at school right now and I am writing from memory)




f 1








and when I reboot I press -x and it goes through the process and then reboots in the installer which obviously means that it's not booting off Leopard How do I fix this??


Sata2 Vista

Sata2 XP

(both are disconnected right now)

ATA: 2 partitions 1st Leopard 2nd Data

so my ATA hdd is the only one connected and I don't know why I can't get it to boot. Any Suggestions??

Link to comment
Share on other sites

I seem to be stuck at the last minute or so of the install with it just sitting there and not doing anything?

Been like that for over 25 minutes or so.

This the third time trying it . it never gets past that and when i reboot it I have to start over again.

Mouse moves around the screen, but thats it.

Link to comment
Share on other sites


  • Create New...