Jump to content

New AMD DVD for leopard


2,431 posts in this topic

Recommended Posts

The fix for the "About This Mac" crash that worked for me was replacing the AppleSMBIOS.kext in the Extensions folder with the one from this post: http://forum.insanelymac.com/index.php?s=&...st&p=499132 (scroll to bottom & get Patch.zip).


Repaired permissions, rebooted, and no more crashing/logging out when clicking on "About This Mac".


Hope it helps.


P.S. thanks zephyroth for your time in coming up with an easy solution for AMD Leopard.


Edit: Fixed link. For some reason I can't paste in hyperlinks.

Link to comment
Share on other sites




After installing leopard, I too ran into the problem that necessitated the boot fix zephyroth outlined earlier, and though the commands listed completed successfully, I was still unable to boot to the leopard hard drive. Eventually I conquered it in another way. This is what worked for me:


1.) Since I had several hard drives in my computer, I unplugged them all except for the hard drive I planned on installing leopard to.


2.) Started computer with install disk and proceeded to install. After the language selector came up on the disc, I opened Disk Utility program and erased the volume (I have two partitions on this particular hard drive) that I planned on installing leopard to.


3.) Then i quit Disk Utility and installed Leopard to the volume/disk (I used the custom install deselecting everything but X11). After install completed, I turned off my computer.


4.) Rebooted and removed Install DVD from disc drive. I was then greeted with Darwin Bootloader prompt and booted into safe mode using -x flag. After going through the setup assistant (skipped transfer of Tiger account which was on another unplugged hard drive) I created a dummy account and once on the desktop I deleted the GeForce* and NV* kexts, repaired permissions, and shutdown the computer.


5.) Plugged back in my previously disconnected hard drives, restarted and at the darwin boot prompt, booted into leopard without any flags. Once back on the desktop (you'll be in VGA mode) I transferred my settings from Tiger using Migration Assistant, installed the leopard video kexts posted earlier in this thread, repaired only those kexts' permissions and restarted. Once I was back in leopard I logged into my new (old Tiger) account, deleted dummy account, fixed "About This Mac" (see my earlier post), and was good to go (complete with full QE/CI support on my 6800GT, which though it's AGP, has to be set as PCI in the bios for full support).


Once again these steps worked for me. I can't guarentee they'll work for you. Good luck.

Link to comment
Share on other sites

No luck for me...


System 1:

AMD x2 4200+

BIOSTAR nForce 4 AM2

2GB DDR2 667

Sapphire ATI x1650 512MB (kernel panic)

160GB SATA works here...NICE


System 2:

AMD x2 5600+

2GB DDR2 800

Asrock CrossFire 480x

ASUS X1950 PRO (don't know)

160GB SATA2 (Can't setup)


Im definitely going for Intel...AMD is at least 15% slower than Intel for the same price...

Link to comment
Share on other sites

is there a way to delete the GeForce* and NV* kexts after booting from the dvd using F8 -s


i tried the fdisk commands for booting, but they didn't do the trick - and i don't mind booting from the dvd for now - but get kernel panics.


thanks in advance

Link to comment
Share on other sites

Of course, there is a way.


1. Boot as usual from DVD (no -s required)

2. In menu select Terminal and type:

mount -uw /
cd /Volumes/your_partition_name_here/System/Library/Extensions/
rm -rf GeForce*.kext NVDA*.kext

3. Reboot

Link to comment
Share on other sites

thanks E@syVG


but it doesn't seem to work - i just get the no such file or directory line - i know the path is correct - i can see and mount in ubuntu (but i accidently made it hfs+) i also named the drive with lower and uppercase and numbers - not sure if thats the problem. im going for a reinstall - with an all lower cased name - and an unjournaled hfs filesystem (one that linux can modify)


thanks again

Link to comment
Share on other sites

  • CPU: AMD Athlon™ 64 3700+ 2.20 GHz | SSE2, SSE3, x86-64
  • MoBo: Brand: ASUS A8V Deluxe | Chipset: K8T800 Pro | Southbridge: VT8237 | Bios Version: 1017.002
  • RAM: 3.0-GB (1.024 + 1.024 + 512 + 512) MB DDR400 RAM (667 MHz)
  • HDD: *Seagate 300-GB SATA-ll SCSI /NTFS | **Maxtor-6 250-GB SATA150 SCSI /HFS+ | ***WD 90-GB IDE /HFS+
  • Optical: NEC DVD-DL Super-multidrive | Pioneer DVD-SL (worked best with Tiger install disks)
  • Net: Atheros AR5004 Wireless
  • Screen: Sceptre = 20.1" 16:10 wide WSXGA TFT HD (HDCP) LCD @ 1680x1050
  • GFX: NVIDIA GeForce FX 5950 Ultra | Bios version =
  • OS: *Vista Ultimate-64, XP-sp2 (parted) | **Tiger X.4.9 (will replace with Leopard) | ***Tiger X.4.8 (used to restore OSx86 installs)

Status: Downloading = 92.4% completed | ETA: 1h 06m ~Will post results :P

Link to comment
Share on other sites

Forcedeth fix anybody? The computer always freezes at some point when I surf the internet :/

Tried to install the older kext from the 10.4.9 uphuck, didn't do the trick...


DHCP is off, IP is fixed...Dunno what to doooo ._.

Everything else runs great :P


Temporary fix is to boot with the flag: cpus=1


You can add this to your com.apple.Boot.plist so you don't have to enter it in every time you restart.

Link to comment
Share on other sites


Try with forcedeth-nockd.kext. It works perfect for me.

And btw, if you use Windows and switch from it to OSX, you first must power off your PC (even from the electric cable) and wait one minute. Then plug the power cable again, restart and boot into Leopard. If you don't do this, the MAC Address will be wrong and the forcedeth-nockd driver will not work.

Link to comment
Share on other sites

@ Sergiales -


Regarding forcedeth-nockd.kext: Is that a boot flag or an actual kext? If it's a kext where did you get it? I would love to have both cores working.




*Edit* - Nevermind I found the kext with a search. Trying it out now.

Edited by Dabluest
Link to comment
Share on other sites



I'm a nerd. I just needed to set the correct permissions (chown, chmod). Now it works flawesly!!!. Thanks!!.




Nice! :)




anyway (maybe it's a noob question) anyone knows if is there a way to add a language?



Link to comment
Share on other sites


  • Create New...