Jump to content

[Guide] macOS Sierra 10.12 - Dell Optiplex 780 (760) (755) (790) (990)


MacPeet
 Share

1,596 posts in this topic

Recommended Posts

 

RealtekALC.kext deleted from on-the-fly?

Kext-To-Patch entries deleted from the on-the-fly in the Clover?
0B (11) in DSDT?

 

 

 Was a fresh install of Sierra, but used Time Machine backup to restore apps. I thought the AppleHDA.kext would be clean?

 

No edits in Kexts-To-Patch, DSDT is 0B. System settings confirms LayoutID 11.

 

AppleALC.kext from link on first page, here....  http://www.insanelym...-3#entry2284794

 

About to give up and use_the_fly. lol

 

Thought AppleALC was supposed to be easier?  :lol:

Link to comment
Share on other sites

Now another big bug that I have had before.  Sleep Issues. 

 

Computer sleeps, but the it wakes from sleep, their is no video.  :censored:   :wallbash: :wallbash: :wallbash:

 

I am using HDMI.

 

Using DSDT.aml from Post #1, and Clover.config from post #1.  No Video when waking from sleep.

 

Tried other DSDT I have used before, ..... No Video when waking from sleep . :wallbash: :wallbash:

Link to comment
Share on other sites

Hi! IDK if this is offtopic but I have a radeon 5450 graphics card and a MSI H61m-p31/w8 mobo. Can I get this to work in sierra by using your configs and DSDT?

DSDT is hardware specific as it's extracted directly from Bios so in short : No.

 

You'd better follow this topic to enable your HD 5450 : http://www.insanelymac.com/forum/topic/293049-guide-mavericks-yosemite-amd-radeon-hd5450/

 

Good luck !

Link to comment
Share on other sites

 

 

 
 
 
@morpheousman
Sleep works great for me.
Have you tried with your old DSDT and config.plist of the Capitan thread?

 

 

 

Yes. I have tried that, tried the original DSDT from jake lo that we started with. Tried a couple that polyzargone edited for me. Tried your DSDT.

 

This is the 780 that I use for my media center. It never had El Capitan on it. It has the exact same video card as the one that I had El Capitan on, Saphire  Radeon HD5450 1GB.

 

780 that I had El Capitan on is gone now, and replaced by my 790, but I took the Video card out before I sold it, and it is in my 790.

 

Both 780's were twins, exact same box, CPU, memory, same Video Card.

 

This 780 I upgraded from Yosemite to Sierra. It will go into sleep,  power shuts down all the way until power light is flashing. It will wake from bluetooth. Just no video when it wakes.

 

With all the different DSDT's and settings in Clover that I have tried, it has not had video even one time after waking from sleep, and I have tried dozens of times

 

I just put the Yosemite hard drive back on it, and it sleeps and wakes with no problems.

 

So now I have a hard drive for it with a fresh install of Sierra, but I cannot use it because it has no video when it wakes from sleep.

Link to comment
Share on other sites

Yes. at that time I changed Darkwake=1. I tried That. Tried different darkwake settings. Computer will sleep with almost every DSDT i have used, or clover settings. No problem going to sleep, just no video when it wakes.

Strange, because I have read that for the most part, the HD5450 are not supposed to have this problem. I remember with El Capitan, I tried frame buffer "Eulmur", and had the same problem, but Shrike worked.

Not sure what I should try next?

Generic DSDT and check to inject ATI?

Generic DDST and manual edit the kexts?

Try injecting a fake ID? 

 

My cards are twins, but one was purchased about a year later. I don't think they changed the firmware? Last firmware version I could find for Saphire Radeon HD5450 is around 2012. 

I saw that problems with other cards were solved by setting built in graphics as primary, set 32mb memory, and CSM set to always.

 

Also saw a post where a user made a guide for Saphire Radeon HD5450. Had issues solved in El Capitan, but could not solve problems in Sierra, and now downgraded to El Capitan. 

 

https://www.tonymacx86.com/threads/guide-enabling-ati-radeon-hd-5450.180817/

 

No problems with my 790 sleep function, 

Link to comment
Share on other sites

 

@HazemTarek

The error is known. Make settings and restart. Repeat until it is accepted.
 
 
@ For all 780/760/790 users
New release AppleALC 1.0.19 !!!
Now also officially integrated Optiplex790 with LayoutID 15.  :thumbsup_anim:
 
download 1.0.19.RELEASE.zip here: https://github.com/vit9696/AppleALC/releases

 

 

 

Awesome stuff!  :D

 

My 790/990 DSDT

 

DSDT.aml.zip

Link to comment
Share on other sites

No problem here with currently Beta 2

avi, mkv, mv4, mp4, mpeg, all works with vlc
This error is in your system!
 
More information please!
Please fill in your forum signature!!!
More information on the DSDT, config.plist and graphics card, please!
Link to comment
Share on other sites

 

germany forum hackintosh to same problem..vlc no works in 10.12.4..My devices: dell optiplex755 ,gt630 2gb full CI,webdriver - ok, 8GB Ram ,ssd 240gb plus ssd 120gb, smbios -iMac 10,1,works very fine Sierra 10.12.3 6D32 ,clover 4003, sound usb2 ext,dsdt is General this forum pages 1 and config. the strange thing is that it works great 10.12.3.Move started very long time ,,only weryfikation and weryfikation and weryfikation... :( . Sorry my english

 

 

 

Link to comment
Share on other sites

Vielleicht liegts an den Webtreibern oder am USB Audio.

Arbeitet die GT630 nicht ohne Webtreiber?
Ich habe die HD5450, Audio mit AppleALC und Clover ist noch auf Version 3985 und bei mir arbeitet alles. Keinerlei Probleme mit VLC.

 

Maybe it's the webdrivers or the USB audio.

Does the GT630 not work without a webdriver?
I have the HD5450, audio with AppleALC and Clover is still on version 3985 and with me everything works.
Link to comment
Share on other sites

  • Allan unpinned this topic
 Share

×
×
  • Create New...