Jump to content

HELP TOPIC - [AMD] OS X El Capitan (10.11)


719 posts in this topic

Recommended Posts

Here is the next iteration of the El Capitan 10.11.0 AMD kernel.  Install on a clean system; otherwise, your mileage may vary.

 

attachicon.gif10110R2.zip

 

I haven't updated my system to 10.11.2 but it's good to know that the previous kernel is working on that as system as well.  

Thanks for such an excellent new AMD kernel which works for Phenom x4 9850 CPU in Asus M3A MB at 10.11.2 (15C40a).

I have to disable USB 2.0 in BIOS to prevent multiple errors related to AppleUSBEHCI during booting even I have modified DSDT to EHC1/EHC2.

Need to figure out the best solution for my Hackintosh at El Capitan.

unfortunately with the same Opcode problem as with kernel r1.

I'd really like build my old kernel patch into El Capitan kernel but unfortunately I get still the same error message when i compile the kernel.

unfortunately with the same Opcode problem as with kernel r1.

 

Do you have EvoReboot installed?

 

 

I also confirm that EVOReboot.kext cause opcode errors (at least on my system).

I can't even install the os because of kernel panic nanoseconds.

Anybody that has a amd fx processor that have the 10.11.2 running with this kernel? And also the same yosemite kext in extra folder works with El Capitan?

Can anyone help me how can I install OS X El Capitan on my amd fx 4100 computer?

I don't think the kernel is compatible with amd fx because I have try it and it doesn't work and no one has confirmed that works on amd fx

I don't think the kernel is compatible with amd fx because I have try it and it doesn't work and no one has confirmed that works on amd fx

I'm going to try on mt FX 6300, will report back.

BTW this is my 600th post

Rebooting to try installing El Cappy, ptay for me. :)

Edited by XtremeHacker
  • Like 5

I'm going to try on mt FX 6300, will report back.

BTW this is my 600th post

Rebooting to try installing El Cappy, ptay for me. :)

I can never get the installer to the actual installer, all I get is the stuff Enoch shows pre-booting the actaull installer.

P.S. Thanks for likes.

Edited by XtremeHacker
  • Like 1

Hey i just want to know, what i have to do with this. After this pc just restarting. And el capitan is not the only one. I tried to install yosemite 10.10.5 using clover uefi but same issue here. I used to installed yosemite with chameleon but when i changed my motherboard i don't wanna waste the uefi option. Thanks for the kernel by the way.

post-1263390-0-32294700-1449791578_thumb.jpg

no clover there?

Whenever I use clover my mouse doesn't work, not in clover or OS X I have tried the mouse drivers.

Yeah I don't think the kernel works with amd fx processors!! I guess we have to wait and see!

I'm going to try the first kernel (Been testing the 2nd) and report back.

@Shanee what did you need to do so that you could install El Cappy?

Thanks for such an excellent new AMD kernel which works for Phenom x4 9850 CPU in Asus M3A MB at 10.11.2 (15C40a).

I have to disable USB 2.0 in BIOS to prevent multiple errors related to AppleUSBEHCI during booting even I have modified DSDT to EHC1/EHC2.

Need to figure out the best solution for my Hackintosh at El Capitan.

Applied this 10.11R2 new kernel for Athlon 64 x2 6000+ in Asus M4A78 Plus MB got very similar results:

1. Need disable USB 2.0 in BIOS

2. Finder & System Preferences seem a little bit slow responding and easily crashed

3. Invisible Apple icon on the left top corner and missing some icons on the top row of Finder in Nvidia GTX 680 with newest Web Nvidia Driver

I don't know whether these are related to AMD kernel or not, but there is no such abnormalities in Bronya's 10.10.5RC3 kernel with Yosemite 10.10.5

2. Finder & System Preferences seem a little bit slow responding and easily crashed

 

Have you installed VoodooTSCSyncAMD.kext ? That kext fixed a lot (not all) of those issues on my system (ASRock N68-S Athlon 64 x2 5600+).

 

this kernel does not work with amd fx I punched a lot of ways but nothing helps a kernel panic or Problem appleusbehci

 

If a problem occurs with AppleUSBEHCI, you may have to fix and bypass the damned new USB management under OS X 10.11 :unsure:… Have a look here or here.

  • Like 1

Have you installed VoodooTSCSyncAMD.kext ? That kext fixed a lot (not all) of those issues on my system (ASRock N68-S Athlon 64 x2 5600+).

 

 

If a problem occurs with AppleUSBEHCI, you may have to fix and bypass the damned new USB management under OS X 10.11 :unsure:… Have a look here or here.

 

Thank you. I'm going to try now

I created latest clover on a flash drive, with 10.11.2 , copied kernel R2 on a root of the flash, Bios is setted up for Hackintosh, since I'm already using Yosemite.

Restarted, choose boot from flash, select USB Installer, boot verbose, and only got "_" on a top left on the screen.

 

What I'm doing wrong?  tried with various of boot flags like npci=0x2000, rootless=0 or 1 ......

Every time is the same, nothing happends...

 

I know that stupid questions are borred to you guys, but I asking someone to help me start El Cappy.... maybe where to put Kernel, some boot flags, and staf like that :)

 

Thanx everyone for helping me in advance

 

here are my spec

Phenom2 960t, ati 6850, 8 gb ram, and legacy bios

I created latest clover on a flash drive, with 10.11.2 , copied kernel R2 on a root of the flash, Bios is setted up for Hackintosh, since I'm already using Yosemite.

Restarted, choose boot from flash, select USB Installer, boot verbose, and only got "_" on a top left on the screen.

 

What I'm doing wrong?  tried with various of boot flags like npci=0x2000, rootless=0 or 1 ......

Every time is the same, nothing happends...

 

I know that stupid questions are borred to you guys, but I asking someone to help me start El Cappy.... maybe where to put Kernel, some boot flags, and staf like that :)

 

I didn't had any success so far trying to use Clover for booting a USB pen or the El Capitan partition when installed.

 

It looks like latest Clover version (r3330) is unable to boot anything AMD on my system. No Yos, No Cap, no nothing :shock:.

 

At least, the r3259 (which is the first one fully compatible with El Capitan) is able to boot Yosemite. But again, El Cap = NO WAY !!! Same as you : "_" on a top left on the screen.

 

This is just incomprehensible. I tried every relevant installing methods with no luck.

 

So I would recommend to stick to latest Enoch r2775 which works fine as long as you configure your Extra folder correctly. See here and here.

 

PS : Put kernel in root or use this boot-flag (assuming you put it in Extra folder) :

<key>Kernel</key>
<string>/Extra/kernel</string>
  • Like 2

 

I didn't had any success so far trying to use Clover for booting a USB pen or the El Capitan partition when installed.

 

It looks like latest Clover version (r3330) is unable to boot anything AMD on my system. No Yos, No Cap, no nothing :shock:.

 

At least, the r3259 (which is the first one fully compatible with El Capitan) is able to boot Yosemite. But again, El Cap = NO WAY !!! Same as you : "_" on a top left on the screen.

 

This is just incomprehensible. I tried every relevant installing methods with no luck.

 

So I would recommend to stick to latest Enoch r2775 which works fine as long as you configure your Extra folder correctly. See here and here.

 

PS : Put kernel in root or use this boot-flag (assuming you put it in Extra folder) :

<key>Kernel</key>
<string>/Extra/kernel</string>

 

Thank you, ill try it tomorrow

×
×
  • Create New...