Jump to content

[Guide] El Capitan 10.11.X - Dell Optiplex 780 (760) 755 (790) (990)


morpheousman
1,158 posts in this topic

Recommended Posts

Monitor says no connection and then shuts down?

Did you try to install OS X without graphics card?

You'll have picture without QE/CI and fixed resolution, but you could install and boot into OS X and then fix it from there (at least you'll do something until heavy artillery comes to help :) ). 

 

Btw, I'm sorry i can't help, never had Radeon GFX, only know how to fix nVidia (chameleon or clover), but you should have full graphics with DSDT provided.

Link to comment
Share on other sites

I used chris111's v5 tool

I've just thought I tried to do my friends laptop and there was a guide to do it with clover and I got the same problem I have on my dell pc so could it be the computer I'm making the usb off or just a coincidence

Link to comment
Share on other sites

You can still follow [Guide] Yosemite 10.10.X - Dell Optiplex 780 (760) post #2 for creation of install USB stick. The method is the same, it's just the EFI folder provided here in post #1 that has changed ;).

 

That said, I'm not sure it will fix anything. This is another problem IMO…

Link to comment
Share on other sites

Well if this happens with all 3 guides, it has something to do with the GFX. Is this the same model you"re using from the beginning or another one ? Did you tried with another or NVIDIA models.

 

We have several examples here of success with the EFI folder provided and AMD Radeon HD 5450 series…

 

In a last attempts, you could edit AMDRadeonX3000.kext and AMD5000Controller.kext to match you dev/vendor ID following those steps (part 2- Add the device id of your GPU to the appropriate kexts).

 

BTW, you didn't provided informations asked here :P.

Link to comment
Share on other sites

Yes same model as last time but a new one and I haven't got windows on it any more I've got this niresh distro to see if it works (not to keep as I don't agree with distros) but the distro does work but is there a way to vet the info that I didn't give in yosemite ?

Link to comment
Share on other sites

This is NOT an AMD Radeon HD 5450…

 

ATI (0x1002)
Identifiant du périphérique : 0x6779

 

This serie is managed OOB by the AMD6000Controller.kext and AMDRadeonX3000.kext so it's completely normal that the DSDT fails and also that a Niresh distro succeed because the card is native under OS X :P.

 

Please, run this in a terminal :

 

 

ioreg | grep AMD

 

Well, the good news is that it's a better Radeon HD model than the 5450.

 

Now, using the Generic DSDT should work since it has no specific device/vendor ID for any particular models…

  • Like 1
Link to comment
Share on other sites

hi teeodor

 

755 is different 780

 

see from post #191 and following  191-199

 

and then report to me

 

for HDMI:

 

attachicon.gifhdau.png

attachicon.gifhdef.png

I wrong yesterday.

I had voodoohda.

Now I have deleted voodoo and hda disabler and I installed applehda from post 197 and I have no sound device.

I try also with the zip with the same results

Link to comment
Share on other sites

HDAdisnabler deleted?

 

? for Inject in DSDT:   (or via HDAEnabler1.kext)

Device (HDEF)            {
                Name (_ADR, 0x001B0000)
                Method (_DSM, 4, NotSerialized)
                {
                    Store (Package (0x08)
                        {
                            "built-in", 
                            Buffer (One)
                            {
                                0x00
                            }, 
                            "layout-id", 
                            Buffer (0x04)
                            {
                                0x01, 0x00, 0x00, 0x00
                            }, 
                            "PinConfigurations", 
                            Buffer (Zero) {}, 
                            "hda-gfx", 
                            Buffer (0x0A)
                            {
                                "onboard-1"
                            }
                        }, Local0)
                    DTGP (Arg0, Arg1, Arg2, Arg3, RefOf (Local0))
                    Return (Local0)
                }
            }

v1 and v2 not?

Link to comment
Share on other sites

OMG I ACTUALLY LOVE YOU IT WORKS WITH THE GENERIC DSDT

 

still confused why the box has hd5450 on it lol

 

I had the same "problem"… well sort of :D.

 

The HD 5450 appeared to be an AMD Radeon HD 6300M which is basically the same chipset but re-branded. Fortunately, vendor/device ID was pretty much the same too so the DSDT worked on it.

 

That said, I'm not sure it was a good deal for me since it's a mobile GFX and not a desktop class. But who cares, I wasn't expecting to play GTA V with it anyway :hysterical:.

Link to comment
Share on other sites

×
×
  • Create New...