Jump to content

[Guide] El Capitan 10.11.X - Dell Optiplex 780 (760) 755 (790) (990)

1,158 posts in this topic

Recommended Posts

Has anyone had issues signing in the app store I cant seem to sign in for some reason everything else works except App Store, iCloud and iTunes Store


You are not using Chameleon are you?


Should all work if using Clover, with a valid Apple ID and password.  Maybe a serial number issue?


Did you open clover config with clover configurator and generate a random serial number?


Also, if you have any other i-devices,  you might want to sign out of iCloud and app store. Then wait a few minutes, sign back in, and then see if you can sign in with 760-780.




Make sure that your ethernet is "en0".


Go to, about this Mac, System Report, Click on Ethernet Cards in Left Panel, in right side, see if BSD name = en0.


If not en0,


Remove all network devices from System Preferences/Network.


Delete in library>preferences>system configuration> NetworkInterfaces.plist file.


Reboot, then go to System Preferences/Network add devices. Click (Ethernet) FIRST!! Then add the other adapters you use to connect to the internet or Bluetooth.


Recheck in Sten Report, make sure ethernet is BSD = enO.


Then see if you can sign in to app store.


And lastly, after your issue is resolved, consider coming back and helping some others. ;)

Right guys thanks for all your help I honestly really appreciate it and I've come to a thought where I'm gonna sell this pc to a friend and just buy another one around the same price to see if I still get the issue but I'm gonna get a 780 with core 2 duo processor this time haha


Again thanks alot guys, this is an awesome community

@jakeyg1, i had the same problem, but using CLOVER folder from the attachment fixed it. You said earlier that you copied folder so why just don't buy Core2Duo for few bucks?


Optiplex 755 update


So i deleted Yosemite and am using only El Capitan, the only way to completely focus myself on it. :D


Have FakeSMC and Intel82566MM in EFI/CLOVER/kexts/10.11 and AppleHDA (v3), HDAEnabler1 and USB_Injector in S/L/E installed (repaired permissions and rebuilt cache). 

I still don't have HDA in System Preferences/Sound, but it is not important for me, since I'm using USB Audio Interface. It would be nice to fix it for some other folks who rely on integrated sound though. 

And still, 3 USB ports on the back are not working. 


Pictures as evidence :)

USB ports that are not working are red, working are green




Audio options showing only in System Report 



Never had this before, suppose its due to DSDT fix to see my internal drives



But there is always this error in SATA controllers 


I can see HD in Storage only



All in all, it is working 100% as far as i am concerned, but if anyone haven idea how to fix those problems I'm here as a test subject. :thumbsup_anim:


Ill try to get my own DSDT patched for all ICH9s to be recognized as ICH10, but it will take some time... :whistle:  


P.S. How do i delete Recovery partition from my previous Test HD partition that is still showing in Clover boot menu, since Disk Utility still doesn't have debug option?

I was considering that but I want ddr3 ram instead of ddr2 I know not much difference in performance but I just would like ddr3 instead and I copied the clover file but still doesn't work


I was considering that but I want ddr3 ram instead of ddr2 I know not much difference in performance but I just would like ddr3 instead and I copied the clover file but still doesn't work


Yes, but would it not be better to find the solution to this problem first? A Core 2 Duo is only $5 - $20 US. 


You could keep the CPU for your 780 anyways, or just sell the 769 for a couple dollars more when you do sell it.


What happens if you wait till you get your 780, and you still have the same problem?


Have you checked all of the settings in your BIOS? 


Under "Performance" settings in bios, is Multi-Core Support Enabled?


"Primary Video" set to Auto?




You can still get audio working with VoodoHDA Sound.   Maybe not as nice as AppleHDA with HDMI, but still onboard sound.


Little recap :




Well, that's too bad you removed Yosemite since USB ports issue should have been easier to fix :(. It's likely because Optiplex 755 has a different port mapping than 760/780 (don't know for 790) series.


Now, you could use this app from this thread to fix it by yourself. But you'll need Windows for that…


For audio issues, as Morpheousman said, 755 models seems also different on this and AppleHDA patch never worked. As he also said, you can still use VoodooHDA.kext but not HDAEnabler.kext which is useless when using it. By contrast, you have to use AppleHDADisabler.kext which is strongly recommended to avoid kernel panic due to conflicts between AppleHDA.kext and VoodooHDA.kext. Sorry, I read too fast the last post of Morpheousman :blush:




upgrading from DDR2 to DDR3 won't fix your graphic problem at all. The same goes for changing Pentium Dual Core to Core2Duo processor.


In a last attempt, you may try to set FB Name to Radeon which is the default one and should work for any AMD Radeon HD series… Also, try with and w/o InjectATI.


BTW, you can change almost every settings in Clover before it boots OS X. Just type O like Options in Clover boot menu and go to Graphics Injector Menu. Most of the settings you see in Clover Configurator are here too ;).


Ultimately, you could try with an NVIDIA card or another AMD model. This is a cheaper way than buying a new computer.

I have the same exact graphics card. (Sapphire Radeon 1GB). 


I really don't thinks it is a Graphic card issue. CPU issue? Probably not.  What's left? 


USB installer problem?  Installer correctly configured? Clover folder attached to post #1 works.  


Must be changing some settings in Clover Boot Menu already, because config in attachment is not set for Verbose. :)

And it all works when I remove the graphics card



It all works, meaning exactly what, a successful complete install?  The installation completes, reboots into Hard Drive, and you get the message to Setup and Start Using your new mac?

  • Create New...