Jump to content

[Guide] El Capitan 10.11.X - Dell Optiplex 780 (760) 755 (790) (990)


morpheousman
1,158 posts in this topic

Recommended Posts

Good to hear ;).

 

You certainly mess up with config.plist because I've just check and the required patch is in the .zip supplied in post #1.

 

Just remember that in order to have full USB support, DSDT, DSDT patch in config.plist AND USB_Injector.kext are mandatory. Remove one of those and you'll loose it ;).

 

BTW, you should also remove all fixes in config.plist (Old way & New way), just above DSDT patch. Should enable full sleep/wake support as well in case it wasn't working…

  • Like 1
Link to comment
Share on other sites

You're right, i don't know from where did i take this config.plist... Maybe from previous Yosemite installation...? Really not sure.

 

post-1517990-0-34029600-1444762633_thumb.png

 

Should i edit other things in acpi section then too to look like the one from attachment (uncheck fixes and add SSDT tables)?

 

Edit:

Ok, will do, but i have full sleep/wake since you gave me edited generic DSDT.

Link to comment
Share on other sites

@jakeyg1, No prob!

 

@polyzargone (or anyone else with enough knowledge :D )

When i first booted into ElCap with "stock" config.plist i had system report and HWmonitor saying that i have 3 ghz quad core proc.

HW monitor was also reporting right frequencies up to 3ghz with stepping from 6 to 9. Temperatures were about the same as with 2,4ghz stock. 

Was it only cosmetics, or was it actually overclocked to 3 ghz and can i try it again without messing with anything?

I mean, just to copy back info from CPU option from CC (that i just saw you removed from config.plist :lol: )?

Link to comment
Share on other sites

Post your "customized" config.plist here so we can have a look at it. I'll check if I see anything possibly wrong or incorrect. AFAIK, there's no way to overclock anything on Dell's system so I guess you just set some settings in CPU fields in CC :unsure:.

 

It's useless, Clover/OS X will auto detect the correct freq. It won't harm the hardware since it's just cosmetic IMO but I cannot guaranty it.

 

Reading the FrequencyMHz section in Clover wiki you can see this statement :

 

 


A wrong value can cause system instability - synchronisation issues, slowness etc. It is recommended not use this parameter at all.

Link to comment
Share on other sites

Ok, I'm attaching it! 

config.plist.zip

 

I knew that System report was showing 2.99 ghz because that is Core2Duo from THE Optiplex in first post, but it got my attention when HWmonitor showed it also. Im asking just because of that.

 

You are right about overclocking Dell. It is kind of doable, but not worth the effort (and i saw people do it only in Windows).

 

 

EDIT: I just saw that DSDT is edited for AppleHDA five days ago. Is generic DSDT also edited and can i try it (just so you have input from 775)?

Link to comment
Share on other sites

Both DSDT are AppleHDA "ready".

 

Just checked your config.plist. Looks OK but I did some clean up. Feel free to compare yours and my attached one to see what I've changed/removed/set.

 

Anyway, here they are :

 

• Removed fixes in ACPI > fixes > New way

 

• Removed kext-dev-mode=1 in Boot > Arguments (this arg is useless on El Capitan but mandatory on Yosemite so you may have to set it again in case you're still using OS X 10.10)

 

• Device > Audio > added 1 to enable AppleHDA and also removed HighCurrent in USB (not sure about this one. If you have problems with USB devices saying they need more power, you may want to add it again)

 

• Deleted useless entries in GUI > Hide Volume

 

• Deleted Asus AICPUPM in Kernel and Kexts patches (as the name states, it's for Asus mobos)

 

• Deleted Backight Level entries in System Parameters and set Inject Kexts to Yes

 

That's it.

config.plist_ owbp.zip

  • Like 1
Link to comment
Share on other sites

Thank you again palyzargone!

I've replaced config.plist with one you just uploaded. 

Don't know if I'm tripping or what, but it seems that El Capitan starts smoother from the reboot...

Anyway, cleaner config.plist is always better, thats what my grandmother used to say!  :)

 

I don't use Yosemite anymore, but i have it still at one partition, since you told me to do it for USB fixing. If i am to dual boot, it'll be Mavericks. For now, ill keep only El Cap on Dell.

 

Regarding Apple HDA, I've tried now with new DSDT and this config.plist to enable it with both AppleHDA v3 and AppleHDA v3 with HDAEnabler1 and no luck.

Then i tried VoodooHDA v2.8.8. and it works. I cannot test HDMI, but all Dell's audio ports are ok.

 

post-1517990-0-23994000-1444770312_thumb.pngpost-1517990-0-80742200-1444770322_thumb.png

post-1517990-0-91179200-1444770332_thumb.pngpost-1517990-0-51119000-1444770343_thumb.png

 

Link to comment
Share on other sites

@owbp

 

First, remove HDAEnabler1.kext + VoodooHDA.kext + AppleHDADisabler.kext from S/L/E.

 

Second, make sure you have 1 in Device > Audio.

 

Rebuild kernel cache using this commands in terminal :

sudo chmod -R 755 /Library/Extensions

sudo chown -R 0:0 /Library/Extensions

sudo chmod -R 755 /System/Library/Extensions

sudo chown -R 0:0 /System/Library/Extensions

sudo touch /System/Library/Extensions

sudo kextcache -Boot -U /

Or use attached script.

 

Reboot.

 

Laslty, install AppleHDA v3 kext in S/L/E (nowhere else especially in /EFI/CLOVER/kexts/10.11 folder. Whatever it is, AppleHDA.kext must be installed in S/L/E) using Kext Wizard.

 

Last but not least, rebuild the cache using the same commands above or again, use the script.

 

Reboot and you should be OK

 

PS : HMDI audio won't work with VoodooHDA.kext anyway ;).

system_caches_rebuild.command.zip

Link to comment
Share on other sites

Ok, will do it right now. I have done that already but used kext wizard to rebuild caches and fix permissions.

 

Btw, only one thing confuses me:

 

 

Second, make sure you have 1 in Device > Audio.

You mean this

post-1517990-0-91453900-1444826510_thumb.png

?

Link to comment
Share on other sites

Nothing, same as before VoodooHDA. 

UseIntelHDMI wasn't checked on the first run in CC so i tried again with it and the result is the same.

 

Downloaded AppleHDA version 3 from the first post of this topic and followed your instructions to every word.

 

P.S. I have written before, I have USB audio interface, this is just for the topic. AFAIK El Cap works 100% for me, after USB fix. 

Link to comment
Share on other sites

Oh sorry, I didn't see your sig :blush:

 

Optiplex 755 = no AppleHDA AFAIK. Needs a specific patch that currently doesn't exist :(.

 

So that's no surprise, you have to stay with VoodooHDA till it's available… If possible :unsure:.

 

Uninstall everything and reinstall AppleHDADisabler.kext and VoodooHDA.kext (HDAEnabler1.kext is useless anyway, patched AppleHDA or VoodooHDA).

 

Lastly run the script and reboot.

Link to comment
Share on other sites

:thumbsup_anim: Its ok, i was keeping my mouth shout and doing whatever you told me for other folks with 755's. :hysterical:

Thanks for you effort and help!

 

@MacPet, 

As soon as i find my Linux Live CD, give me few minutes!

 

 

Edit:

I extracted nVidia HDMI too, just in case...

 

codec-dump#0-755MT-AD1984.txt.zip

 

codec-dump#1-755MT-nVidiaHDMI.txt.zip

  • Like 1
Link to comment
Share on other sites

 You the man! :dance_24:  B)

Line Out and Headphones are working, clean and clear!

I cannot test Line Ins since i only have full size jacks and XLR mics at my house, but ill try to get or borrow desktop mic or something to test it soon as i can.

Link to comment
Share on other sites

If other users with Optiplex 755, then please report if Mic and LineIn also work well and are regulated  :construction: ???

 

Beta testers wanted!!!

 

thanks

 

 

morpheousman@

Now it is a Guide for 780 (760,755,790...........................................)   :hysterical:  :hysterical:  :hysterical:  :wub:

 

 

@pepto

HDMI has no audio control
it is a digital terminal, and the value is standardized
  • Like 2
Link to comment
Share on other sites

×
×
  • Create New...