Jump to content

[USB Wifi] Updated Ralink/Mediatek RT2870/ RT2770/ RT3X7X/ RT537X/ RT5572


441 posts in this topic

Recommended Posts

I've just used the following method to successfully install an Alpha AWUS 051NH with a Ralink RT2770 chipset.

The standard Ralink Utility didn't work here either but it works with the DLink pref pane perfectly.

 

Thanks!

Hi can you make a tutor with awus051NH because i try all and Dlink pref pane open well but it not show any network connection, and panel pref has the loading icon all the time

 

Updated Ralink/Mediatek drivers for USB dongles released at 29/11/2013.

MAVERICKS AND YOSEMITE COMPATIBLE

 

 

Drivers downloaded from http://www.mediatek.com/en/downloads/usb-rt2870rt2770rt3x7xrt537xrt5572/

 

I made a zip file with oficial drivers and a preference pane from dlink that replace the oficial ralink wireless utility.

 

This solve the problematic Ralink Wireless Utility that simply does not work on yosemite and the package doesn´t install the maverick kext in yosemite.

 

 

 

ZIP CONTENTS

 

10744eg.jpg

 

 

 

DLINK PREFERENCE PANE

 

288siec.jpg

 

 

INSTALATION

 

 

Copy preference pane to \System\Library\PreferencePanes\

 

Copy kext for your MacOS version (use Maverick for Yosemite) to folder \System\Library\Extensions\

Repair permissions

Rebuild kext cache

Reboot.

 

 

Thanks. I am now able to use my Belkin F5D8053 on Yosemite 10.10

  • 3 weeks later...

I have an Alfa Tube-U(N) (RT3070) which I am trying to install on Yosemite. I have tried all of the methods and drivers in this post but none of them work.

 

Interestingly, the guy from Alfa support sent me to this thread!

 

Any help would be much appreciated as I am tearing my hair out with this.

Hi all!

 

I've got an Edimax EW-7711MAC and tried all the said on the first post and it still without working. When I copy the Kext to its folder, I've got an error message that tells me "The system extension /System/Library/Extensions/RT2870USBWirelessDriver.kext doesn't installed properly, so It can't be used. Try reinstall or contact with the manufacturer"Any ideas? According with Edimax, till late January, there will be no Yosemite driver.

Hi all!

 

I've got an Edimax EW-7711MAC and tried all the said on the first post and it still without working. When I copy the Kext to its folder, I've got an error message that tells me "The system extension /System/Library/Extensions/RT2870USBWirelessDriver.kext doesn't installed properly, so It can't be used. Try reinstall or contact with the manufacturer"Any ideas? According with Edimax, till late January, there will be no Yosemite driver.

you have to fix permissions too, just copying wouldn't work.

 

Instead, download Kext Wizard and install kexts using that.

  • 2 weeks later...

This is fantastic. Great job! First page instructions worked on my A1342 Macbook with Yosemite and the Edimax EW7711 Mac 802.11 AC USB. After I had installed Mavericks, it never recognized the onboard card so I had no wifi. The Edimax worked, until I upgraded to Yosemite. I see elsewhere Edimax says it just doesn't work.

 

It does with this solution!

 

Bravo!

 

 

  • 2 weeks later...

Updated RT2870USBWirelessDriver for OSX 10.10 : version 5.0.1.22

http://www.mediatek.com/en/downloads/mt7610u/

 

For 230 types of IOKitPersonalities ! list here under

Chipsets : RT2770;RT2870; RT3070; RT3071;RT3072; RT3370;RT3572 ;RT3573; RT5370;5372;RT5572;MT7610;MT7612;MT7650; MT7662; ;RT8070;RT9707

PCI - 3072;PCI - 7610;

 

post-305243-0-21983000-1422116389_thumb.png

:)

 

230 types-IOKitPersonalities.html

I can not use that with alfa AWUS051NH, if anyone does, please explain how do you do that

thanks

Your chipset is RT 2770 or RT2750   http://www.alfa.com.tw/products_show.php?pc=67&ps=23

 

Didn't saw compatibility for RT 2750 !

 

Do you know your idProduct and vendor ?

 

Look in the compatibility list if yours is there !  If not, you could try to add yours in to the info.plist inside the kext !

 

After installing the kext to did a permissions update and rebuild your cache ?

 

Update: I saw there are v1(Product ID: 0312402914NP)  and v2 (with RT3572 chipset) models !  https://wikidevi.com/wiki/ALFA_Network_AWUS051NH

http://askubuntu.com/questions/571695/alfa-awus051nh-v-2-doesnt-work-on-ubuntu-14-04

Your chipset is RT 2770 or RT2750   http://www.alfa.com.tw/products_show.php?pc=67&ps=23

 

Didn't saw compatibility for RT 2750 !

 

Do you know your idProduct and vendor ?

 

Look in the compatibility list if yours is there !  If not, you could try to add yours in to the info.plist inside the kext !

 

After installing the kext to did a permissions update and rebuild your cache ?

Hi, could you tell me how to take the idProduct and vendor? I think it is RT2750

Can you write a complete tutorial about that info.plist, permissions, etc...

I tried some tutorials on previous pages but nothing works it detects my card but dont work

I have this info:

Model: AWUS051NH

FCC ID: UQ2051NH

S/N: 1306051NH02932

 

Thanks

It should work if you follow this tutorial:

 

http://www.insanelymac.com/forum/topic/299948-usb-wifi-updated-ralinkmediatek-rt2870-rt2770-rt3x7x-rt537x-rt5572/?do=findComment&comment=2064234

 

Verify if your kext is version 5.0.1.22 in S/L/E !

 

And the Dlink prefpane 2.6.4 is optionnal but recommended !

 

You find everything in the folder attached !

 

Good luck

 

Folder for v5.0.1.22.zip

It should work if you follow this tutorial:

 

http://www.insanelymac.com/forum/topic/299948-usb-wifi-updated-ralinkmediatek-rt2870-rt2770-rt3x7x-rt537x-rt5572/?do=findComment&comment=2064234

 

Verify if your kext is version 5.0.1.22 in S/L/E !

 

And the Dlink prefpane 2.6.4 is optionnal but recommended !

 

You find everything in the folder attached !

 

Good luck

 

attachicon.gifFolder for v5.0.1.22.zip

 

I LOVE YOU

Finally it works with alfa AWUS051NH

2 month waiting this moment, thanks a lot bro!!!

It should work if you follow this tutorial:

 

http://www.insanelymac.com/forum/topic/299948-usb-wifi-updated-ralinkmediatek-rt2870-rt2770-rt3x7x-rt537x-rt5572/?do=findComment&comment=2064234

 

Verify if your kext is version 5.0.1.22 in S/L/E !

 

And the Dlink prefpane 2.6.4 is optionnal but recommended !

 

You find everything in the folder attached !

 

Good luck

 

attachicon.gifFolder for v5.0.1.22.zip

 

Hi Rob, do you have kext for RT7650 ?

 

its really strange, the ID for my device is 7610 :

    Device Descriptor   
        Descriptor Version Number:   0x0201
        Device Class:   0   (Composite)
        Device Subclass:   0
        Device Protocol:   0
        Device MaxPacketSize:   64
        Device VendorID/ProductID:   0x0E8D/0x7610   (MediaTek Inc.)
        Device Version Number:   0x0100
        Number of Configurations:   1
        Manufacturer String:   1 "MediaTek"
        Product String:   2 "WiFi"
        Serial Number String:   3 "1.0"

but the driver is in this thread not working, i do really follow the procedure, but the driver was not work :(

Hi Rob, do you have kext for RT7650 ?

 

its really strange, the ID for my device is 7610 :

    Device Descriptor   
        Descriptor Version Number:   0x0201
        Device Class:   0   (Composite)
        Device Subclass:   0
        Device Protocol:   0
        Device MaxPacketSize:   64
        Device VendorID/ProductID:   0x0E8D/0x7610   (MediaTek Inc.)
        Device Version Number:   0x0100
        Number of Configurations:   1
        Manufacturer String:   1 "MediaTek"
        Product String:   2 "WiFi"
        Serial Number String:   3 "1.0"

but the driver is in this thread not working, i do really follow the procedure, but the driver was not work :(

 

Hi,

 

You have "Device VendorID/ProductID: 0x0E8D/0x7610 (= hexedecimal) " wich means you have in decimal: Vendor ID: 3725 = MediaTek (MTK)

and your Product ID = 30224  (MT-7610 chip)

 

So if you look into the 230 types-IOKitPersonalities.html ( from info.plist inside the kext ) post 85 in this topic  (http://www.insanelymac.com/forum/index.php?app=core&module=attach&section=attach&attach_id=156925)

 

You will find that it matches what is described in "MTK - MT7610 -2" key from RT2870USBWirelessDriver.kext  info.plist  !

 

So it should work !  Look for my tutorial in this topic post 90 and verify there in nothing else from an old install left ; install all pieces in their place  + repair permissions and rebuild kernel cache and reboot !

 

Good luck ! ;)

Thanks  :)

 

got my Tenda W311M usb adapter working on Mavericks.

Though I couldn't find an option to disconnect from network or turn wi-fi off.

Have to unplug it.  :worried_anim:

Yes that's right ! There is no good utility for Yosemite for the moment to do this !

:huh:

So I was looking further to get the wi-fi off option. (btw, the chipset for my device is Ralink RT5370)

 

Since I'm running mavericks, the latest driver from mediatek worked for me (USB (RT2870/ RT2770/ RT3X7X/ RT537X/ RT5572))

and it installed wirelessutility.app 

 

The app does have the 'Wi-Fi on/off" option, but isn't able to connect to network (don't know why, tried both wpa and wpa2 networks).

So basically it was useless.

Until I reinstalled the d-link preference pane, and surprisingly the preference pane could be used to connect to network and changes were being reflected in the app.

 

The app doesn't have a dock icon and is accessible only from the menubar.

post-1300896-0-66784000-1422378209.png post-1300896-0-09984400-1422378212.png

 

post-1300896-0-93043300-1422381207_thumb.png

 

I also stumbled upon bearextender drivers from one of the posts on tony's site (drivers link).

The package had wirelessutility.app (and contents similar to medaitek package).

 

Now this app has an advantage that it shows signal strength in the menubar icon. post-1300896-0-56175600-1422378952.png

Rest is quite similar to Ralink wireless utility (not connecting to networks, at least for me)

 

post-1300896-0-52548700-1422379002_thumb.png

 

I'll keep looking for some app that does the job better. If you find one, do let me know.

Meanwhile I customized the d-link package contents to look a little better.  :)

post-1300896-0-72428400-1422379598_thumb.png

 

---- Update ----

 

I used a different wi-fi router, and the bearextender app is connecting to it.

But the ralink app isn't.

I've spent the last days trying to load the kext for my adapter on yosemite, which seems to have an RT5370 chip

 

http://www.dx.com/p/k11-mini-ieee-802-11-b-g-n-150mbps-wi-fi-usb-2-0-dongle-black-147188#.VMuhhmiG8wA

 

unfortunately i'm still stuck with "no wireless device connected" on the DW140 control panel

 

Any idea on how i should load the kext?

I've used kext wizard to install them and tho repair permissions and rebuild the cache

 

In the attached file you could see what i actually have in my system info page

 

 

 

EDIT: after re-reading the 3d for the 1000th time i've found that the franweork was missing fromo the packages that i was installing

post-490020-0-52992200-1422631768_thumb.jpg

Your ID Product=0x7601 in decimal this is 30209. And idVendor = 0x148f and in décimal this 5263

 

If you look in the 230 types-IOKitPersonalities.html (post #93) you'll find the MTK - MT7601

So you it should work !

 

Did you instal the all the other updates (prefpane, startup items, API,  ?  from my folder and Tutorial here:  http://www.insanelymac.com/forum/topic/299948-usb-wifi-updated-ralinkmediatek-rt2870-rt2770-rt3x7x-rt537x-rt5572/page-5?do=findComment&comment=2105486

 

Good luck !

I repack package installer from D-Link to OS X 10.10 Yosemite:

Driver version 4.2.9.4, UI version 2.6.4.0

 

http://www.mediafire.com/download/6qdmtavwnkygtvj/D-Link_Fix_Yosemite_Driver4.2.9.4_UI2.6.4.0.dmg

 

 

In this Package automaticaly:

1. Disable driver signature verification (kext-dev-mode=1)

2. Fix install kext for OS X 10.10 Yosemite

It works !!!!!! Thank you ! :D  My WiFi Go on my ASUS Z87 PRO can't work on Yosemite, by the way, I've taken back from black my old USB D-Link DWA-125 !  GREAT JOB !

It works !!!!!! Thank you ! :D  My WiFi Go on my ASUS Z87 PRO can't work on Yosemite, by the way, I've taken back from black my old USB D-Link DWA-125 !  GREAT JOB !

Glad it works for you !,  but:

The newest driver is version 5.0.1.22 and made for Yosemite !  kernelflag (kext-dev-mode=1) is mandatory for instal in Yosemite and should be made in bootloader anyway !!

×
×
  • Create New...