Jump to content

[USB Wifi] Updated Ralink/Mediatek RT2870/ RT2770/ RT3X7X/ RT537X/ RT5572


rodrigocunha
476 posts in this topic

Recommended Posts

5 minutes ago, ghost8282 said:

yeah that's what I meant, sorry if I wasn't clear.

The panel is a no go: apple doesn't allow to run things within the panel itself.

So I asked for a Wireless utility, but as far as I know all are 32 bit and it's impossible to convert without source code.

I think it's a no go...super angry with the ralink/mediatek/dlink developers....why they abandoned the app and went for the prefpane?Couldn't they convert the app to 64 bit too?if it was, now we had working devices with scan functions...

Here some wifi scaner

https://github.com/pkruk/osx-wifi-scanner

A lots of thing exist on Github for that

 

Google scan macOS WIFI Github :D

 

Dont know why Mediatek they abandoned the app

Edited by chris1111
Link to comment
Share on other sites

25 minutes ago, ghost8282 said:

no way, it's for devices using itlwm driver (intel) :blowup:

The Clover panel works in BS and Monterey so its possible to make Dlink panel working

Edited by chris1111
  • Like 1
Link to comment
Share on other sites

16 minutes ago, chris1111 said:

The Clover panel works in BS

mmm yes, you are right...I will try to understand why the dlink panel only shows to me error windows :hysterical:

 

It's only one year that I'm trying to understand how to implement that damn scan function: you may think: go to that damn store and buy a new compatible adapter, it's only 20$-30$!!

NO!!!!:blowup:

Link to comment
Share on other sites

13 minutes ago, ghost8282 said:

mmm yes, you are right...I will try to understand why the dlink panel only shows to me error windows :hysterical:

 

It's only one year that I'm trying to understand how to implement that damn scan function: you may think: go to that damn store and buy a new compatible adapter, it's only 20$-30$!!

NO!!!!:blowup:

I try to also understand the error panel :guitar:

We have a short cut with a scan fonction here

https://github.com/FivePixels/dwa140shortcut

 

You need Apple developer ID to modify the build 

Edited by chris1111
  • Like 1
Link to comment
Share on other sites

8 hours ago, chris1111 said:

The strange thing is de DW160 Panel open no error if the adapter is not plug :frantics:

 

1100820530_ScreenShot2021-07-01at5_19_14PM.thumb.png.99fb2b14d1d8ef73d471cb536b77b360.png

Do you have a link to this?

I tried the prefpane v.2.6.2.0 (DWA-160) but same error

 

Update: ok, it's not the panel, it's the kext, when the kext isn't loaded the panel opens without errors, but obviously it can't read anything...back to checking the kext

Edited by ghost8282
  • Like 1
Link to comment
Share on other sites

On 7/2/2021 at 2:21 AM, chris1111 said:

The strange thing is de DW160 Panel open no error if the adapter is not plug :frantics:

 

Only solution that worked for me is moving kext to S/L/E, pane works fine with kext loaded and shows/connect to available networks.

Edited by MNSiw
  • Like 1
Link to comment
Share on other sites

9 hours ago, MNSiw said:

 

Only solution that worked for me is moving kext to S/L/E, pane works fine with kext loaded and shows/connect to available networks.

Yes I tried that too in the past (first betas of big sur)...but how you managed updates?

I have no problems in breaking the seal, but with a broken seal you cannot update the os anymore...so, are you doing something different to have a broken seal and manage system updates?

  • Like 1
Link to comment
Share on other sites

1 hour ago, ghost8282 said:

Yes I tried that too in the past (first betas of big sur)...but how you managed updates?

I have no problems in breaking the seal, but with a broken seal you cannot update the os anymore...so, are you doing something different to have a broken seal and manage system updates?

I try ant the panel Open but nothings appens, the adapter not blinked , no signal

same in Monterey

Link to comment
Share on other sites

2 hours ago, chris1111 said:

I try ant the panel Open but nothings appens, the adapter not blinked , no signal

same in Monterey

With my device, breaking the seal works, and you have a fully functional device with scan function, but as said above, breaking the seal is a mess; as far as I remember, I always injected the kext with opencore and copied an additional copy of the kext into S/L/E to have the panel working; the panel was also installed in /system/Library/PreferencePanes.

Link to comment
Share on other sites

4 hours ago, ghost8282 said:

With my device, breaking the seal works, and you have a fully functional device with scan function, but as said above, breaking the seal is a mess; as far as I remember, I always injected the kext with opencore and copied an additional copy of the kext into S/L/E to have the panel working; the panel was also installed in /system/Library/PreferencePanes.

Anyway I dont need the panel My program is sufisant for me, it work great OC OR L/E

No solution exist for the panel

Edited by chris1111
Link to comment
Share on other sites

16 hours ago, ghost8282 said:

Good, curious how you did it :D

I'm sure it can be done without messing too much, I'm just missing the very last step ahah

Its done my freind Follow instruttion :guitar: 

Dont use with a existing D-LinkUtility or with a bootloader inject kext, remove previous install before:wink_anim:

DWA-160Wireless Utility

Tell me what you think about it

Edited by chris1111
  • Like 1
Link to comment
Share on other sites

On 7/3/2021 at 7:08 PM, ghost8282 said:

Yes I tried that too in the past (first betas of big sur)...but how you managed updates?

I have no problems in breaking the seal, but with a broken seal you cannot update the os anymore...so, are you doing something different to have a broken seal and manage system updates?

 

What about enabling csrutil and authenticated-root after installing kext and talking snapshot, does update works this way? I haven't checked/tried it yet.

Link to comment
Share on other sites

HA HA HA  :guitar: Now new app is integrate to Edit the plist file,

no more manually editing  :hyper: really proud of it, its the first app capable editing a plist file for macOS B)

 

1143871426_Capturedecranle2021-07-08a12_29_46.png.4dbd328144fe2f67bbf9757c0b75c94c.png

  • Like 3
Link to comment
Share on other sites

On 7/8/2021 at 6:33 PM, chris1111 said:

(...) really proud of it, its the first app capable editing a plist file for macOS B)

Not quite...

 

You forgot Clover with its plist patching facility and I can remember Axel-Erfurt's app back in early 2014 that did similar things...

https://osxlatitude.com/forums/topic/6044-edit-plist-inside-a-kext/

 

In your case, it's just packaged and tuned for a more/very specific sole purpose.

Link to comment
Share on other sites

  • 5 weeks later...

Works good.

I have a new issue, not sure if it's an issue related to Mac OS or what...

It's time for me to begin tests with Monterey, I downloaded the beta 4, and the minitaskusb doesn't launch, it fails with "segmentation fault".

Every app in the D-LinkUtility folder fails with segmentation fault (and) bad cpu type.

I know that in beta 4 there were some reports about segmentation fault errors related to opencore compilation, so I hope this is related to this, and I'm currently upgrading to beta 5 to test it out.

Any of you experiencing the same issue with beta 4?

 

All is working as expected in Big Sur 11.5.2,

Edited by ghost8282
Link to comment
Share on other sites

  • 4 months later...
×
×
  • Create New...