Jump to content

Airport-like app for Ralink 2870

144 posts in this topic

Recommended Posts

This is working for me in 10.6.4 with a Tenda W322U V2.0 (RT3072) but with a couple of issues.


1. Doesn't reconnect automatically on login. Have to access the control panel and manually activate a profile or replug the device to connect.


2. Is there any way of determining the wifi link speed? Network Utility shows 0 Mbit/s and the "TX Speed" display from the ralink drivers is missing. I had the ralink offical driver installed and I couldn't get it to connect above 54Mbps even though it is a 300Mbps 802.11n card. I was hoping this driver might be better but I can't see any way to check.

I recall it took me sometime to get it working properly as well. The best thing is to start clean, you have to get rid of any Ralink software and startup items, leave just the kext in the S/L/E.
After that install the prefPane I've attached in the previous message.
It is working ok for me, the only drawback is that it takes around 30 seconds to connect after SO startup and it doesn't display anything before 20-25 seconds. This might be happening to you, or it is not starting at all, what happened to me also when there were some "remains" of other wireless softwares.

As for the connection speed I really don't have a clue as mine one is much slower and old-fashioned than yours.

  • 2 weeks later...
  • 2 weeks later...

Ok does connect at startup after a small delay. Throws iChat out which complains about no internet connection after a reboot but that's no biggy.


Still can't seem to get a connection above 54bmps. I have a 802.11g dlink pci card (atheros) which was working great as airport extreme with device id's but it wasn't fast enough to stream 720p movies over the network. So I upgraded my router to 802.11n and bought a this Tenda W322U USB (300mbps 802.11n Ralink 3072) as there were offical ralink drivers for 10.6.


Works great in Windows 7, connects to my router at 300mbps but It will only connect at 54mbps with the ralink drivers.


Can anyone report connecting to 802.11n networks with and of the ralink devices in snow leopard?

  • 5 months later...

WORKS IN LION with newer next :D




I have a Sitecom 608 branded usb wifi stick, added Ralinks official latest drivers ( 32+64bit ) and used their "utility". Sadly this has issues with Lions Fullscreen mode featue, the utility activates itself, pops up in front of a app and disconnects the connection.


So until ralink makes a Lion compatible utilty I searched for som small ap that will just let me choose my profile. I found this topic here and lucky I am - it works in Lion (GM).


the prefpane is 32bit only, but that is no real problem - it just asks you to launch in 32bit mode.


need to delete the original ralink utility from Startupitems, else the both confuse each other.


SL/LION working KEXT 32/64 inlcluded for Rt2870, Rt2770, Rt3X7X , Rt537X



  • 2 weeks later...
  • 5 months later...
  • 2 months later...
  • 1 month later...

Thanks Aqua-mac, maybe here i reinstalled the default driver included in iatkos s3-v2, because is work when installed :moil: , but when restart the mac, that kext dont work (only says ... is not conected)...

but, its works (Diamond Network360000N - Ralink 3070)


i post the kext, if anybody wants to try it..

and Again Thanks Aqua-mac


  • 1 month later...
  • 3 months later...
  • 1 month later...
  • 1 month later...

Hey aqua-mac! Loved the airport mod, but it took a bit of modding myself to get it to work. At the moment i'm using ralink's ui, instead of your prefpane, because on mountain lion; sysprefs has to quit and restart to use your pref-pane(32bit), which is a pain upon rebooting.

  • 1 month later...

Same thing happened here, I tried many installers from different vendors on 10.8.2.

I have a cheap Protronix device with the Ralink 3070 chip.


Uninstall what you have (run the uninstaller on the .dmg) and try this package, it worked for me.


Only, instead of the kext in that package, use this one ( for Mountain Lion, extracted from the latest Ralink installer):



Follow the instructions given, but don't use Kext Utility, install the kernel extension manually like this:


Drag it to /System/Library/Extensions, ignore any warning, run Terminal and type this:

sudo -s (enter your password)
chown -R root:wheel /System/Library/Extensions/RT2870USBWirelessDriver.kext
chmod -R go=u-w /System/Library/Extensions/RT2870USBWirelessDriver.kext
touch /System/Library/Extensions

And reboot.

thanks for the tip Gringo Vermelho

i add















in RT2870USBWirelessDriver.kext/Info.plist


Identifiant du produit : 0x2573 9587

Identifiant du fournisseur : 0x148f 5263


the led of the "emtec ekcowidu1" wifi stick is green :)

but is not detected with .prefpane neither by .app

  • 2 months later...
  • 2 weeks later...

Can anyone tell me why the heck the first time I install official ralink drivers RTUSB D2870- UI- the first time I reboot I can see networks and connect to them but after a reboot the Ralink Wireless Utility appears for 10ms and closes instantly? Running it from the Applications folder does the same. Manually running as (even root ) from the ..Utility.app/Contents/MacOS folder the executable shows in log **CFMessageportRemote loggout exit.... After a quick googling it i reach here http://developer.apple.com/library/mac/#documentation/CoreFoundation/Reference/CFMessagePortRef/Reference/reference.html. SO anyone knows of a good Mac OSX reversing tool like ida pro? I know that the target process is a binary in the ralink driver resources but other than that it cant connect to it nothing.. :P

  • 3 weeks later...

I confirm that it works fine on ML 10.8.4 as described below by onelove.

Thank you very much aqua-mac for the good work.


hey aqua-mac thanks for creating the Ralink system pref and making the Ralink AirPort menu icon work with 2870.


Anyhow I am currently using your RalinkAirport.app and rename it to USBWirelessUtility.app in Application Folder, also install your Ralink system pref and use this latest driver from Ralink website: http://www.ralinktec.../Macintosh.html


Which I just extract and install two file using Pacifist as you can see below:





After doing this I notice that I don't have to add RalinkAirport.app to the login items, if you just rename RalinkAirport.app to USBWirelessUtility.app and install the WiUtilityUSBStartUp, it will auto connect to WiFi when you startup your mac or if you remove USB dongle and reinsert or vice-versa.

  • 4 months later...

Thanks aqua-mac

Works great on 10.9 Mavericks GM with my Aztech WL552USB !!!

I followed onelove steps installtion method and I had to replaced the kext with the offical Ralink\MediaTek driver

from here:


USB(RT2870/RT2770/RT3X7X/RT537X) V4.2.6.0


I just try and test your Aquamac_Wireless_Ralink_Drivers.zip aka aquamac ralink wireless drivers v5
and notice that your WiUtilityUSBStartUp did not work... And this is what I found out...

1. Notice that Ralinkairport.app is in /Applications/Ralink/RalinkAirport.app and "AppDaemonUSB" (Which is in WiUtilityUSBStartup) look for USBWirelessUtility.app in /Applications/USBWirelessUtility.app only, that why I rename Ralinkairport.app to USBWirelessUtility.app.

2. In WiUtilityUSBStartUp folder is missing one more file which is call WiUtilityUSBStartUp or you could just rename AppDaemonUSB to WiUtilityUSBStartUp instead of adding original WiUtilityUSBStartUp file and also it need chmod 755 and chown root:wheel permissions to make it work..

Anyhow I have provide a zip version and a installer script I just made so that you can test it out...

Anyhow you will notice I don't have to add "RalinkAirport" and "USBWirelessUtility" to login items as WiUtilityUSBStartUp just startup Ralinkairport for me when I turn on mac after I setup the profile in RalinkWireless System Preferences as it really work for me. So I don't need to use your mod USBWirelessUtility version to make it work.



I extracted the pkg and took out the driver and replaced onelove's kext, at  ralinkinstalltion/root/System/Library/Extenstion/

for anyone intersted in the driver only, i uploaded it in this link




The only thing needed to make this better, is to fix the preference panle restart when using RalinkWireless, im gussing as @Gwion Smith said it's 32-bit.

screenshots below








Thanks for your answer, I don't want anyone to do basic research for my hardware and that's not the point of my post.
A Lot of users are not very familiar with the hardware specifications or which parameters we have to look for, which are the correct ones for the whole thing to search.
Maybe for you is easy but i read the post and didin't get the point of the mediatek chip.I thought that Belkin is another adapter,different story with modifications.
We are not all experts you know, or native english speakers.
Whatever,thanks for your help,i will go search for the chip thing and not get you tired.

  • Create New...