Jump to content

Airport-like app for Ralink 2870

144 posts in this topic

Recommended Posts

Over at aquamac forums, a member jadran, posted an application to get the authentic looking airport icon up in the menubar for Ralink RT73 chip.


Well I have managed to edit the app so it works with the RT 2870. I include it below with the RT 2870 kext and new PreferencePane.


Here is an Installer. Could somebody please test, thanks.


Manual Install

1. Use kexthelper b7 to install the kext. Place the RalinkAirport pref pane in System/Library/PreferencePanes (it must be this location as if you double click it it will be installed elsewhere and not work).


2. Repair permissions.


Place the Ralink Airport app in your Applications folder and set it to load at startup in the Accounts Pref Pane.



This is for RT2870 Only.






The original App for the RT 73 based USB dongles can be found here:



Thanks for sharing this work.


At first it looked like it was working, but it only works if I don't remove the Ralink USB Wireless Utiilty. That is, it only works if it runs in tandem with what I already installed to get the Linksys WUSB600N working on my D945GCLF Atom board (10.5.7 vanilla retail w/ Chameleon 2RC1), not as a replacement.


I would love for this new app to run by itself, so I can have the nice Airport menu icon and lose the fugly Ralink dock icon. Any thoughts? FWIW I followed your instructions to the letter.

I am working on this, but in the meantime, download this:




Place the contained file in your Applications folder and remove the unsightly RT app. Set both the apps in the download folder to open at startup. You can either delete or keep the Ralink app you already have as the one in the folder is the same.


Basically I cleaned up the RT app and set it to run hidden in the background so it cannot be seen. It should work though. Let me know how it goes. If it works for you I will add it to the installer and clean things up.

Much better, thank you for taking the time to do this! Now there's no dock icon for Ralink Wireless utility, the airport menu icon looks stock, and it not only connects to the wifi network at boot but reconnects automatically when the system wakes from sleep.


Thank you, thank you, thank you.


System this mod is installed on:

Intel Atom D945GCLF

Retail 10.5.7 w/ vanilla kernel

Chameleon 2RC1

Linksys WUSB600N wifi adapter

hey aqua-mac thanks for creating the Ralink system pref and making the Ralink AirPort menu icon work with 2870.


Anyhow I am currently using your RalinkAirport.app and rename it to USBWirelessUtility.app in Application Folder, also install your Ralink system pref and use this latest driver from Ralink website: http://www.ralinktech.com/ralink/Home/Support/Macintosh.html


Which I just extract and install two file using Pacifist as you can see below:





After doing this I notice that I don't have to add RalinkAirport.app to the login items, if you just rename RalinkAirport.app to USBWirelessUtility.app and install the WiUtilityUSBStartUp, it will auto connect to WiFi when you startup your mac or if you remove USB dongle and reinsert or vice-versa.


anyhow i am currently using this file with your RalinkAirPort mod: http://www.ralinktech.com.tw/data/drivers/..._2009_03_10.dmg


BTW i haven't figure out what this app (AwakeRalinkUI.app) does but it install in the login items.. anyway I remove this from the login items and application folder... and it stilll work with your RalinkAirPort mod and WiUtilityUSBStartup... but for what ever reason your driver did not work with mine usb wifi dongle so I have to use whatever it was in the RTUSB D2870- UI-



Hi Onelove,


Probably, the new Ralink driver is supporting more USB dongles as it is a newer release. I will be incorporating this into the final release along with the new app.




Thanks for the encouragement!



I just try and test your Aquamac_Wireless_Ralink_Drivers.zip aka aquamac ralink wireless drivers v5

and notice that your WiUtilityUSBStartUp did not work... And this is what I found out...


1. Notice that Ralinkairport.app is in /Applications/Ralink/RalinkAirport.app and "AppDaemonUSB" (Which is in WiUtilityUSBStartup) look for USBWirelessUtility.app in /Applications/USBWirelessUtility.app only, that why I rename Ralinkairport.app to USBWirelessUtility.app.


2. In WiUtilityUSBStartUp folder is missing one more file which is call WiUtilityUSBStartUp or you could just rename AppDaemonUSB to WiUtilityUSBStartUp instead of adding original WiUtilityUSBStartUp file and also it need chmod 755 and chown root:wheel permissions to make it work..


Anyhow I have provide a zip version and a installer script I just made so that you can test it out...


Anyhow you will notice I don't have to add "RalinkAirport" and "USBWirelessUtility" to login items as WiUtilityUSBStartUp just startup Ralinkairport for me when I turn on mac after I setup the profile in RalinkWireless System Preferences as it really work for me. So I don't need to use your mod USBWirelessUtility version to make it work.




Hey, that's pretty sweet. I tried it out with a RokN adapter, which uses the RT2870 chip. I got it working fine. This is on a laptop running iAtkos 10.5. I browsed the web for about 20 minutes, then left the computer idle. After about 10 minutes of being idle, a message came up saying I had to press the power button to shut off the PC, and I could not do anything else. I think this is because it is not running on an actual Mac probably. I am going to try it on an eMac with Leopard this weekend and see what happens. Great idea!

Hey aqua-mac, firstly I would like to add my concrats to your project.


I have a WUSB600N working here via your installer.

The only thing that needed to work for me was 2 changes:

1) in /System/Library/Extensions/RT2870USBWirelessDriver.kext/Contents/Info.plist under Linksys had to change from <integer>112</integer>

to <integer>113</integer>


2) in /System/Library/Extensions/RT2870USBWirelessDriver.kext/Contents/Resources/Info.plist under Linksys againd had to change from

<integer>0x0070</integer> to <integer>0x0071</integer>


All changes were made after your installation and after reboot.

The kext was edit on desktop (copy from original location) and install it back using kexthelper b7.

  • 2 weeks later...

Thanks for this aqua-mac, onelove and others. It's a huge improvement over the ugly Ralink USBWirelessUtility.app and it almost works for me, but not quite.


I was using the latest official Ralink rt2870 driver, like onelove because earlier ones suffer from the replug problem.


I've tried the 2870 .kext from the latest official package with aqua-mac's Ralink Airport.app plus preference pane, and later the other modified versions here.


The Ralink Airport.app autostarts, briefly displays [Connecting] then always [Disconnected]. In every case bringing up the Ralink prefpane causes an instant connection, which continues to work, and the Ralink Airport.app menuitem shows signal strength properly (though it reports strenght, probably a typo somewhere).


The genuine and ugly Ralink USBWirelessUtility.app always works and always connects for me first and every time, but it looks so horrible. What's interesting is that the prefpane co-exists quite happily with this, showing the same information, but once USBWirelessUtility.app has connected, if I fire up Ralink Airport.app this doesn't show the current connection but immediately disconnects it, again showing [Disconnected]. Oncemore, opening the Prefpane will immediately make a connection.


I'm at a loss why Ralink Airport.app alone always fails to make a connection, but as soon as the preference pane runs the connection is made perfectly.


If I can find a way to auto-connect with Ralink Airport.app, without having to run the prefpane every time, then I'll abandon USBWirelessUtility.app forever!


Anyway, thanks again for this.

If I can find a way to auto-connect with Ralink Airport.app, without having to run the prefpane every time, then I'll abandon USBWirelessUtility.app forever!


Anyway, thanks again for this.

Well I've sort of got it working, just by changing the loading order.


I made a new StartupItem to load RalinkAirport.app before USBWirelessUtility.app loads. I ensured this by setting its OrderPreference to "Late" while that for USBWirelessUtility.app is "Last".


RalinkAirport.app loads in the menubar, briefly shows [Connecting] then fails and shows [Disconnected]. Just after this, USBWirelessUtility.app loads and makes the connection correctly, so the already running RalinkAirport.app updates its status to reflect this, without the PrefPane having to be run. Now USBWirelessUtility.app can be hidden or quit.


I tried lots of ways to hide USBWirelessUtility.app as its running, including using NSUIElement/LSUIElement and LSBackgroundOnly in its .plist but this only partially worked. In the end I used a modified version of an applescript someone else created to auto-hide USBWirelessUtility.app by selecting its "hide" menuitem. The disadvantage of this is that it requires "Enable Access for Assistive Devices" to be turned on.


I've ended up with something that looks far more mac-like and works well, although behind the scenes it's a bit untidy!


Thanks again aqua-mac.

I just came across this while bungling with my WUBR-505 Wireless-N USB Adapter http://www.oxfordtec.com/us/p196/SparkLAN-...oduct_info.html which has the distinction of having the RT2870 and a 5gHz option. I plugged it into the back of my mac mini server hoping to share my ethernet connection at draft-N speeds. Downloaded and installed everything in the posts above. Got it all up and running on 10.5 server. Pop open the new pane in system prefs. and see the card is recognized, active, and can see the networks around me. So all is fine until...


Then I try to create a network in the Profile Drawer. I hit "ADD" start filling things in then my system hangs, won't let me click "OK." If I hit cancel system prefs crashes (first time I've sen that.) I've tried switching between the "Infrastructure" and "802.11 Ad Hoc" settings with no security and then every one of the other encryption choices on the list. No dice. Doesn't even save my profile. I check my network settings and the adapter is assigned en2 but states that a cable is unplugged even though it is working. I also have airport off so not to conflict with the internal card, so I guess no status bar feature.


Anyone got any ideas how to finish the update my home network?

  • 2 weeks later...
  • 4 weeks later...

Any new updates?


I tried all of the above with some luck. I have to go to the prefpane on start-up to connect, but then after that, my Hac reconnects automatically after sleep. Also, the airport icon disappears after wake-up...


I have used aqua-mac's original package and also with the latest Ralink drivers for the 2870 (RT28xx: from 3/10/09)





  • 3 weeks later...
  • 2 weeks later...

First thing I want to say is THANK YOU to Aqua-Mac for making this package, as I too am sick of seeing the default Ralink app in the dock. I have been for a long time now been using the default Ralink app in conjunction with another app, which displays a fully working Airport icon in the menubar (http://www.brandon-holland.com/software.html) (scroll down this webpage to the 3rd item & it's there.), and that's the closest I've got to getting a "Stock" Wifi setup.

I uninstalled the original Ralink installation & the Ralink Airport icon I had installed before I installed your package.

The problem I have with this new solution (like some others) is that I can only get a wifi connection if i open the RalinkWireless PrefPane. Using the RalinkAirport does nothing for me (again, like some others) except flash "[Connecting]" for maybe a second & then it disappears. I don't ever see the Airport icon... ever ! I've tried the various workaround's that Aqua-Mac/Onelove/Pharillion have suggested, but with no luck.

The only way around this problem I've found, is to add to my login items the RalinkWireless PrefPane & the Ralink Airport icon. It just means closing the PrefPane down once the connection is made, and then it carries on working with no problems.

Any ideas anyone on how to fix this, or has there been anymore work done on this ?





  • Create New...