Jump to content

[Compilation] Dell XPS M1330, M1530, Vostro 1400, 1700, Inspiron 1420, 1520, 1720

* * * * * 2 votes

  • Please log in to reply
4331 replies to this topic

#2781
rokhoe

rokhoe

    InsanelyMac Protégé

  • Members
  • Pip
  • 22 posts
  • Gender:Male
  • Location:Braunschweig, Germany
When I try to open trackpad.prefpane under s/l/preferencepanes, it tells me that it´s not available at this time and that I probably need to connect the device. Do real macbooks have different trackpads than normal pc's? It´s quite strange that the trackpad section in "mouse and keyboard" has disappeared after the update. But it´s no big deal, because most of the settings can be edited through the ffscroll property list. What I´d like to know is whether there are improvements in the new trackpad.prefpane, because as I can see it´s quite a large file. It´s behind the network.prefpane, one of the largest in the folder.

#2782
C-Lo

C-Lo

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
  • Gender:Male
  • Location:Kentucky
Need some help.

I have a Dell XPS m1330 and I installed iAtkos 5i with the following settings:
nVida Laptop
Intel AHCI SATA
Laptop Battery
Apple Decrypt
SMBIOS EFI Air
PS2
Broadcom 44xx

Everything was working short of the wired ethernet, the audio, and shutdown/restart.

I fixed the audio using a posted dump file and the AppleHDAPatcher_v1.16.

Then I was working to see if there was any possible fix for the wired ethernet when the wireless stopped working. I believe the computer may have gone to sleep while I was searching on another machine for the solution.

I just did a clean reinstall, just like I did when it worked and the wireless is still not working.

Any suggestions?



EDIT

Ok, this is embarrassing, but after looking for over a day I found that it was the switch on the laptop had somehow gotten flipped. Thus the wireless would not enable. If anyone does know of fixes for the wired ethernet or the shutdown/restart issue I would appreciate the help, but I'm pretty sure there are no fixes as of now.

#2783
Chrysaor

Chrysaor

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 525 posts
  • Gender:Male
Trackpad has been moved into its own prefpane on all Apple notebooks. It requires a device with certain id to be present in order to show up.

Easy way:
If you want to get the new trackpad prefpane, remove /System/Library/PreferencePanes/Trackpad.prefpane and put this into /Library/PreferencePanes.
Attached File  Trackpad.prefPane.zip   210.13KB   4224 downloads (removed the useless gesture videos, so it takes less space)

Explanation:
Basically what you need to remove is NSPrefPaneIOServiceAttributesToMatch and NSPrefPaneIOServiceToMatch keys in Info.plist.

#2784
rokhoe

rokhoe

    InsanelyMac Protégé

  • Members
  • Pip
  • 22 posts
  • Gender:Male
  • Location:Braunschweig, Germany
Thanks, that solved my problem.

#2785
wingrunr21

wingrunr21

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 496 posts

If anyone does know of fixes for the wired ethernet or the shutdown/restart issue I would appreciate the help, but I'm pretty sure there are no fixes as of now.


No fixes yet for either.

#2786
oSxFr33k

oSxFr33k

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPipPip
  • 1,094 posts
  • Gender:Male
  • Interests:Sound and Graphic Design. Electronics in general.

First and foremost 10.5.6 is NOT Snow Leopard. Snow Leopard is the next version of OS X that is due out next year (meaning it will be version 10.6.0 NOT 10.5.6). Thus you shouldn't be using ANY of Superhai's Snow Leopard kexts.

On your machine you should be using vanilla AppleACPIPlatform (meaning the one installed by the combo updates). Then you get SMBIOSResolver from Superhai, the aforementioned link to AppleACPIPS2Nub, and ApplePS2Controller (should already have been installed by iAtkos).

Despite the fact that talisman and myself already told you what you need to do post update, I'll repeat it again:

  • EHCISleepEnabler needs to be re-applied via Superhai's instructions on his website
  • AppleHDA needs to be moved back
  • If you do not use AppleACPIPS2Nub and instead use ACPIPS2Nub then you need to change the AppleACPIPlatform key in ACPIPS2Nub's OSBundleLibraries to the newest version of AppleACPIPlatform (or just download the kext that talisman was kind enough to attach a few posts up).
Your last two errors are because you are using Snow Leopard kexts and you don't have Snow Leopard installed. Use the Leopard kexts.

As for a guide there is one in my signature.




I am sorry about that. What about System.kext? I want the System.kext I backed up if using the latest Voodoo right which is 9.5. DId 10.5.6 update to a newer kernel thus newer system.kext

#2787
wingrunr21

wingrunr21

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 496 posts

I am sorry about that. What about System.kext? I want the System.kext I backed up if using the latest Voodoo right which is 9.5. DId 10.5.6 update to a newer kernel thus newer system.kext


Yes probably. I'd re-apply the 10.5.6 combo update just to be sure.

#2788
Donald-Duck

Donald-Duck

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
Hi,

I've a Dell XPS 1530 and I used the iDeneb v1.3 (10.5.5). I can boot into Leopard fine but my keyboard and mouse don't work. I tried replacing the kext using the below instructions with one I found on these forums

Open the terminal (application>utilities>terminal>
type "sudo -s" and then press enter
type chown -R root:wheel /system/library/extensions/appleps2controller.kext
type chmod -R 755 /System/Library/Extensions/appleps2controller.kext
type rm -r /System/Library/Extensions.kextcache
type rm -r /System/Library/Extensions.mkext
type exit
Restart osx and hopefully it will work.


But that didn't fix it, my external USB mouse and keyboard work fine.

Shutdown/Restart work fine too
Edit2: Also tried ApplePS2ControllerANSI, didn't work either

The mouse is always stuck in the top left corner.

Edit: Tried using the kexts in the PS2_Batt_Working.zip file using KextHelper but that didn't solve it either.

EDIT: SOLVED

I was using kexthelper wrong :wacko: I special.

#2789
oSxFr33k

oSxFr33k

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPipPip
  • 1,094 posts
  • Gender:Male
  • Interests:Sound and Graphic Design. Electronics in general.

Yes probably. I'd re-apply the 10.5.6 combo update just to be sure.


I re-ran the update and made necessary changes. Removed what I thought were snow leopard updates and put back the proper superhai updates.
My link for the voodo0 kernel is broken ? When I run the command "ls -al" I no longer see a link to the mach_kernel_voodoo. I see a 10.5.6 vanilla kernel yet when I do uname -a it sais voodoo etc etc.


Can I make a fresh link again? "ln -s mach_kernel mach_kernel_voodoo"? Or is it this way, "ln -s mach_kernel_voodoo mach_kernel "? Could the link still exist? I can't explain how the voodoo kernel is loading when the vanilla kernel is in place and the ln -s link to the voodoo kernel is broke or missing?



I am getting Kernel panics when I try to actually re-install the voodoo package or any package?



As MacGirl and CHrysaor have reported I also have the left side USB non functional. I removed the DSDT after the 10.5.6 update and still have USB working for keyboard and mouse on left side now. USB FLash drives on either side do not work? Maybe its a system.kext thing not sure? Or related to this kernel linking?



Here are some kernel messages I am concerned with maybe you can help?



Darwin Kernel Version 9.5.0: Sat Dec 6 19:39:54 IST 2008; Voodoo; Release 1.0 :xnu-1228.7.58/BUILD/obj/RELEASE_I386
standard timeslicing quantum is 10000 us
vm_page_bootstrap: 973904 free pages and 74672 wired pages
mig_table_max_displ = 79
Skipping duplicate extension "com.apple.iokit.IOATAFamily" with older/same version (2.0.0 -> 9.9.9).
Skipping duplicate extension "com.apple.iokit.IOATABlockStorage" with older/same version (2.0.5 -> 9.9.9).
Skipping duplicate extension "com.apple.iokit.IOATAPIProtocolTransport" with older/same version (1.5.0 -> 9.9.9).
Skipping duplicate extension "com.apple.iokit.IOAHCISerialATAPI" with older/same version (1.1.1 -> 9.9.9).
Skipping duplicate extension "com.apple.driver.AppleIntelPIIXATA" with older/same version (2.0.0 -> 9.9.9).
Skipping duplicate extension "com.apple.driver.AppleAHCIPort" with older/same version (1.5.2 -> 9.9.9).
Skipping duplicate extension "com.apple.iokit.IOAHCIFamily" with older/same version (1.5.0 -> 9.9.9).
Skipping duplicate extension "com.apple.driver.AppleGenericPCATA" with older/same version (1.3 -> 9.9).
Skipping duplicate extension "com.apple.iokit.IOAHCIBlockStorage" with older/same version (1.2.0 -> 9.9.9).
Skipping duplicate extension "com.apple.driver.AppleOnboardPCATA" with older/same version (1.0.0d1 -> 9.9.9).
com.apple.kpi.unsupported: Undefined in symbol set: _sha1_



ACPI_SMC_PlatformPlugin::start - waitForService(resourceMatching(AppleIntelCPUPowerManagement) timed out
ACPI_SMC_PlatformPlugin::registerLPCDriver - WARNING - LPC device initialization failed: C-state power management not initialized
ISAB: family specific matching fails
AirPort: Link Down on en1
0 [Time 1229475487] [Message System Sleep
Wake reason = PBTN LID
[TSC] delta: 86, skipping synchronization. (CPU1)
System Wake
USB (UHCI):Port 1 on bus 0x3d connected or disconnected
USB (UHCI):Port 2 on bus 0x5d connected or disconnected
USB (UHCI):Port 1 on bus 0x1a connected or disconnected
USB (UHCI):Port 2 on bus 0x1a connected or disconnected
[InterruptReadHandler] Received kIODeviceNotResponding error - retrying: 1.
E:[AppleUSBBluetoothHCIController]WARNING !!!! [DeviceRequestCompleteHandler] error e00002ed




Auth result for: 00:14:bf:c4:24:32 MAC AUTH succeeded
AirPort: Link Up on en1
[[0x62fd000] Req OpCode 0c03 from: kernel_task (0) status: 0 state: 2 timeout: 5000] Bluetooth warning: An HCI Req timeout occurred.
[CompletePowerStateChange] Failed to resetDevice 00000010
E:[AppleUSBBluetoothHCIController]WARNING !!!! [DeviceRequestCompleteHandler] error e00002ed

[[0x65d3000] Req OpCode 0c3f from: kernel_task (0) status: 0 state: 2 timeout: 10000] Bluetooth warning: An HCI Req timeout occurred.
E:[AppleUSBBluetoothHCIController]WARNING !!!! [DeviceRequestCompleteHandler] error e00002ed

[[0x62fd000] Req OpCode 0c3f from: kernel_task (0) status: 0 state: 2 timeout: 10000] Bluetooth warning: An HCI Req timeout occurred.
[handleAirPortChangesChannelWL] Failed to set new range 00000010
IOBluetoothHCIController::terminateWL .. done
[HCIController][configurePM] power parent ready after 1 tries




Ok To sum this up:


What is the command to create a new symlink for the voodoo kernel?
WHat could be the problem with my USB Flash Drives not being recognized now. DO I need to update the EHCI enabler OSBUndle Versions as we did for Nub PS2?
Are these first few kernel warning about duplicates common to other users or do I need to remove those kexts?
What are the rest of those warnings? Is that what is breaking USB flash drives?


Thanks for all the help and hope you can answer these questions!!



EDITED:

Googled searched it, does this look correct?

lrwxr-xr-x 1 root admin 19 Dec 16 19:28 mach_kernel -> /mach_kernel.voodoo

#2790
wingrunr21

wingrunr21

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 496 posts

Shutdown/Restart work fine too


Do you have QE/CI working and is your screen at the correct resolution? I'm going to guess no which is why shutdown/restart are working.

What is the command to create a new symlink for the voodoo kernel?
WHat could be the problem with my USB Flash Drives not being recognized now. DO I need to update the EHCI enabler OSBUndle Versions as we did for Nub PS2?
Are these first few kernel warning about duplicates common to other users or do I need to remove those kexts?
What are the rest of those warnings? Is that what is breaking USB flash drives?


First check the current status of your symlinks:

ls -la /

Look for mach_kernel. If it says mach_kernel -> mach_kernel_voodoo (or whatever the voodoo kernel is named) then your symlink is intact. What probably happened, however, is that the new update installed a new kernel. In that case, issue these commands:

sudo mv /mach_kernel /mach_kernel_back
sudo ln -s mach_kernel_voodoo mach_kernel

This will backup your vanilla kernel and symlink the voodoo kernel.

EHCISleepEnabler should be fine so long as you follow Superhai's directions. Nothing else needs to be changed except the Info.plist in AppleUSBEHCI.kext. Based on those kernel messages it appears that your IOUSBFamily.kext is a bit screwed up. Here is what I'd do:
  • Download the 10.5.6 Combo Update from Apple if you have no already done so (you probably have)
  • Download Pacifist
  • DELETE the entire IOUSBFamily.kext
  • Open the 10.5.6 Combo Update in Pacifist and extract the IOUSBFamily.kext from there
  • Install IOUSBFamily.kext as you normally would
  • Redo the EHCISleepEnabler modifications that Superhai requires for it to work


#2791
oSxFr33k

oSxFr33k

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPipPip
  • 1,094 posts
  • Gender:Male
  • Interests:Sound and Graphic Design. Electronics in general.

Do you have QE/CI working and is your screen at the correct resolution? I'm going to guess no which is why shutdown/restart are working.



First check the current status of your symlinks:

ls -la /

Look for mach_kernel. If it says mach_kernel -> mach_kernel_voodoo (or whatever the voodoo kernel is named) then your symlink is intact. What probably happened, however, is that the new update installed a new kernel. In that case, issue these commands:

sudo mv /mach_kernel /mach_kernel_back
 sudo ln -s mach_kernel_voodoo mach_kernel



FIxed it with putting in the System.kext associated with the voodoo kernel. USB FLash drives work now. SLeep works. I did grab a fresh IOUSB.kext from 10.5.6 yet since I beleive it working now.

What about those messages in the beggining of the kernel boot about skipping?


Here is the crash message I see when I try to re-install the voodoo package or even for example the 10.5.6 package installer I get a voodoo kernel panic? Could this be because I uninstalled the FIngerprint software it causing this?

It sais something about security at the end of the crash. Have to find where the crash reporter log is?

This will backup your vanilla kernel and symlink the voodoo kernel.

EHCISleepEnabler should be fine so long as you follow Superhai's directions. Nothing else needs to be changed except the Info.plist in AppleUSBEHCI.kext. Based on those kernel messages it appears that your IOUSBFamily.kext is a bit screwed up. Here is what I'd do:
  • Download the 10.5.6 Combo Update from Apple if you have no already done so (you probably have)
  • Download Pacifist
  • DELETE the entire IOUSBFamily.kext
  • Open the 10.5.6 Combo Update in Pacifist and extract the IOUSBFamily.kext from there
  • Install IOUSBFamily.kext as you normally would
  • Redo the EHCISleepEnabler modifications that Superhai requires for it to work





Sorry about that last reply I did not scroll down far enough after the last "Quote"

Latest Voodoo Kernel


I am getting a Kernel panic whenever I try to install any software that has DMG or MPKG?

I noticed this issue happened after I uninstalled UPEK protector suite for Mac. I uninstalled it because I was getting some error about USB finger print device not found which I until it was too late I fixed. I uninstalled the software using the uninstaller. I also had installed the Xcode for 10.5.5 before the 10.5.6 update.

This error may not be related at all to this uninstall or this UPEK software?

I don't know where the crash reporter log is but here are some of the messages after the dump:

No Mapping exists for frame pointer.
Backtrace terminated- Invalid Frame Pointer 0xb00809c8
Kernel Loadable Modules in backtrace (with Dependancies)
com.apple.security.seatbelt (107.10)@.... etc etc
BSD Process name corresponding to the current thread: Diskimages-helper



EDITED:

The mach_kernel.voodoo has wrong permissions. it was root:user. The link has an "l" in from of the rw?

I did a Repair Permissions here are some messages but this does not seem to fix this kernel crashing?

Repairing permissions for “Leop2”
Reading permissions database.
Reading the permissions database can take several minutes.

Group differs on "home", should be 20, group is 0.
Group differs on "net", should be 20, group is 0.
Permissions differ on "System/Library/Extensions/Caches/com.apple.kext.info", should be -rwxr-xr-x , they are -rw-r--r-- .
Group differs on "mach_kernel", should be 0, group is 80.
Permissions differ on "mach_kernel", should be -rw-r--r-- , they are lrwxr-xr-x .



Can anyone help me with this please?




EDITED AGAIN:

After some research I found out about this "Daring FIreball" Exploit issue in Safari. I am wondering when I downloaded the 10.5.6 from apple something weird happened. I normal click on save and save it to my desktop or my download folder but instead of the save window it was an open window. I am wondering if my system got exploited when I grabbed this file from Apple somehow?

Anyhow whenever I extract a DMG I get a kernel panic read above. It happens right7after I see "Verifying" then I see "Mounting" and its right them I get the Kernel Panic.

Is anyone else seeing this with 10.5.6? How can I fix this if this is an Exploit of some kind? I still cannot understand how this could have happened?

#2792
talisman

talisman

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 380 posts

You have an XPS 1330. Superhai has already created a proper DSDT.aml for our systems. Click on the link in my sig, go to my guide, and read the "Updating to 10.5.6" section.


Using someone else's DSDT patch might cause update to panic. It happened to me. I use Chrysaor's who has a different processor and it panicked. I later updated the DSDT and reinstalled the update and everything went smooth. I suggest: make your own DSDT.aml. Its just a double click with fassl's patcher....attached below

correct me if I am wrong....

Shutdown/Restart work fine too
Edit2: Also tried ApplePS2ControllerANSI, didn't work either


Ok... do you have full video resolution and are using using Nvidia driver?? If you are not then shutdown and reboot will work but you will not have full resolution or hardware acceleration.

If you have Nvidia working perfectly and have restart and shutdown working.... you need to publish it IMMEDIATELY.... All I can say is that youll be hailed a legend....!!! Seriously....

Attached Files



#2793
Chrysaor

Chrysaor

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 525 posts
  • Gender:Male

Using someone else's DSDT patch might cause update to panic. It happened to me. I use Chrysaor's who has a different processor and it panicked. I later updated the DSDT and reinstalled the update and everything went smooth. I suggest: make your own DSDT.aml. Its just a double click with fassl's patcher....attached below


Your KP is caused by not having AppleIntelCPUPM (or Disabler) loaded when you were updating, Installer kextloaded AICPUPM and system paniced, nothing to do with using someone else's DSDT.
You don't even need DSDT (it even makes things worse) so no need to bother with it.

#2794
talisman

talisman

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 380 posts

Trackpad has been moved into its own prefpane on all Apple notebooks. It requires a device with certain id to be present in order to show up.

Easy way:
If you want to get the new trackpad prefpane, remove /System/Library/PreferencePanes/Trackpad.prefpane and put this into /Library/PreferencePanes.
Attached File  Trackpad.prefPane.zip   210.13KB   4224 downloads (removed the useless gesture videos, so it takes less space)

Explanation:
Basically what you need to remove is NSPrefPaneIOServiceAttributesToMatch and NSPrefPaneIOServiceToMatch keys in Info.plist.


Works.... got a separate trackpad pref pane now in sys pref.... Thanks Chrysaor...

AppleHPET.kext also won't load.

Replace your ACPIPS2Nub with the one in this thread: http://forum.insanel...howtopic=114578

You should be good to go.


Do I need AppleHPET.kext to load?? Coz in tin-can it doesn't even load. Or do i want it to not load??

Has anyone done an update without a DSDT patch?? i know it is useless after the update but can the update be done without it??

#2795
sammydavis

sammydavis

    InsanelyMac Protégé

  • Members
  • Pip
  • 45 posts

Can us newbies get a quick guide on what to do to upgrade from 10.5.5 to 10.5.6 if we used iatkos5?


I have 10.5.6 up and running on my 1330. I don't have a working trackpad and keyboard now though. I have tried installing the acpips2nub kekt but this didn't solve my problem. I have Chameleon 1.0.12, I patched the DSDT with an autopatcher. Any suggestions? I have deleted the power management kext.

#2796
talisman

talisman

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 380 posts

I have 10.5.6 up and running on my 1330. I don't have a working trackpad and keyboard now though. I have tried installing the acpips2nub kekt but this didn't solve my problem. I have Chameleon 1.0.12, I patched the DSDT with an autopatcher. Any suggestions? I have deleted the power management kext.


Did you use the acpips2nub that was linked in pg 139 of this post both by me and wingrunr21?

Delete the DSDT.aml file. It is useless.

#2797
sammydavis

sammydavis

    InsanelyMac Protégé

  • Members
  • Pip
  • 45 posts
Yeah I tried the nub a few times now. no luck. Very odd. Such an easy problem to solve that just won't work. I may have to reload Iatkos 5 and go back to 10.5.5 as I am running out of ideas.

#2798
M Y Awan

M Y Awan

    InsanelyMac Protégé

  • Members
  • Pip
  • 48 posts
I am using Sonton's dell package for using the british keyboard. the problem is that whenever i reboot, the keyboard is deselected and it is gone from the main taskbar list. i have to go to preferences again, choose my us-pc keyboard again and then select it from the main task list. this is really annoying. can someone please help me with that if there is any fix available?

Dell m1530 2.2GHZ 3 GB RAM nvidia 256MB VGA Card

#2799
fdsafdsa

fdsafdsa

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts
did anyone get QE to work on nvidia cards?

#2800
talisman

talisman

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 380 posts

did anyone get QE to work on nvidia cards?


Yes, QE/CI/QGL works completely with hardware acceleration..... Have a look at this:

http://forum.insanel...&...st&p=930144


Also have a look at wingrunr21's guide:

http://forum.insanel...howtopic=119654





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2016 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy