Jump to content

Chameleon 2.2svn Official PKG Installer & Binaries

Bootloader Chameleon

  • Please log in to reply
2435 replies to this topic

#121
kdawg

kdawg

    InsanelyMac Legend

  • Donators
  • 508 posts
  • Gender:Male
  • Location:Boston, MA

Here it is. With new Configuration choices:

Note: bdmesg was already in the previous installer (/usr/sbin/bdmesg) :)

The installer crashes when trying to install. Only makes it past the first screen.

#122
taga

taga

    InsanelyMac Protégé

  • Members
  • Pip
  • 25 posts
  • Gender:Male
Please KP Chameleon-2.0-RC5-r518 ....



Posted Image



Snow 10.6.4 Retail


ok removed AppleIntelCPUPowerManagement

Still witing root device
:(

#123
XLR

XLR

    2cores1cpu.mov

  • Donators
  • 889 posts
  • Location:חולון

The installer crashes when trying to install. Only makes it past the first screen.

I've managed to pass more screens, but still:
Posted Image

Please KP Chameleon-2.0-RC5-r518 ....

Judging by this picture, it looks like you have {censored}loads of other problems that have nothing to do with Chameleon.

#124
MacFanatic76

MacFanatic76

    InsanelyMac Protégé

  • Members
  • PipPip
  • 62 posts
  • Gender:Male
About the vbios-rom loading issue...i think i managed to solve it somehow :)

Here's what i did :
0. Downloaded latest svn-trunk version, compiled it and installed it to /EFI
1. Booted into Win 7 (God, i hate it so much when forced to )
2. Downloaded the Gigabyte GVFLASH-utility (@BIOS was the name, i think)
3. Saved the current (original) BIOS file of my GV-N285UD-1GH
4. Booted back into 10.6.4 and renamed the saved bios file to 10de_05e3.rom
5. Placed the rom-file in /EFI/Extra/
6. Added the following keys to my /EFI/Extra/com.apple.Boot.plist :

<key>GraphicsEnabler</key>
		  <string>Yes</string>
		  <key>UseNvidiaROM</key>
		  <string>Yes</string>				
		  <key>VBIOS</key>
		  <string>Yes</string>

7. Result - finally, System Profiler says "ROM Revision: /Extra/10de_05e3.rom" ;)
Don't ask me, how this works - i tried any possible method so far, and couldn't get passed
either "ROM Revision: 0x00" or "xxx.xxx.xxx.-internal". I used all current trunk versions of Chameleon
prior to this one - r530, and with them i couldn't manage to solve this "issue" ;)

Well, now it loads not only my own original rom-file, but also mkvtech-later versions,
which wasn't possible before ^^

Now that i am also trying to make myself an updated Chameleon Boot-CD (Retail DVD-Loader),
i can't get why this very same method doesn't work with it, but only on an installed 10.6.4 :blink:
The verbose boot says as always "NVDANV50HAL loaded and registered", but ends up in a black screen
with blinking monitor LED...

Anyone has any idea or solution, why this doesn't work for a Chameleon Boot-CD ?!
This question might be lame but - Is there really a full/native resolution with QE/CI at all,
during Mac OS X installation - after having loaded it from Chameleon CD ?
Does this really exist, i have never seen it/never had anything other than a generic 1024x768 during install...

Thank you devs, for your continuous efforts, will and time, keep up this great work !

#125
RaMDaY

RaMDaY

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 182 posts
  • Gender:Male
  • Location:New York City
Have you tried using NullCPUPowerManagement.kext ?




Please KP Chameleon-2.0-RC5-r518 ....



Posted Image



Snow 10.6.4 Retail


ok removed AppleIntelCPUPowerManagement

Still witing root device
:)



#126
taga

taga

    InsanelyMac Protégé

  • Members
  • Pip
  • 25 posts
  • Gender:Male

Have you tried using NullCPUPowerManagement.kext ?




yes , system works fine chameleon RC4

after install RC5 is problem


#127
MacKonsti

MacKonsti

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 228 posts
  • Gender:Male
  • Location:Muppet Show

yes , system works fine chameleon RC4

after install RC5 is problem

You know that you are supposed to also install again boot0 and booth etc. if you do it manually...
The old binaries are not compatible with RC5!
Please read the documentation in the standalone package, if you can.

#128
taga

taga

    InsanelyMac Protégé

  • Members
  • Pip
  • 25 posts
  • Gender:Male

You know that you are supposed to also install again boot0 and booth etc. if you do it manually...
The old binaries are not compatible with RC5!
Please read the documentation in the standalone package, if you can.



Instal package Chameleon-2.0-RC5-r530.pkg and Chameleon-2.0-RC5-r518.pkg

not works


sorry my english , i brazilian , only speak portuguese

#129
scrax

scrax

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,704 posts
  • Gender:Male

The installer crashes when trying to install. Only makes it past the first screen.

Sometimes if I click too fast on the next button it doesn't allows me to select any other device than root disk, but if I reopen it and click slowly it works.



Hi, I am on the same boat as Macfanatic76. I use a Nvidia 8800GT and no mater what I try I get the same nasty "ROM Revision: 0x00"., instead of internal... No idea what to do ! Can someone try to fix that ?! We do something wrong ?!


This post is not intended to offer support on chameleon issue, it's only about the issue of the installer, You better make your question to in the chameleon developers forum. Sorry but i don't have any clue about what your problem could be solved

yes , system works fine chameleon RC4

after install RC5 is problem

again this post is not for problems with chameleon . If RC5 gives problems we can't solve them, but if the installer fails maybe we can help :D

any of the other 54 downloaders can please report if any of the strange behaviors appened to XLR and kdawg appened to someone else?


kdawg, have you tried it in 32bit mode?
XLR what mode are you using? and if you select another volume are the options selectable (no skip)?

#130
XLR

XLR

    2cores1cpu.mov

  • Donators
  • 889 posts
  • Location:חולון

XLR what mode are you using? and if you select another volume are the options selectable (no skip)?

I've tried it on two different computers running Retail 10.6.3 in English, and when i got to the customize screen all options were selectable but most of the titles look screwed up like in the picture i posted earlier.

The installer works, thou it didn't asked for reboot or logout after installation. Here's the results (look at the files marked Today)
Posted Image

#131
taylorsyn

taylorsyn

    InsanelyMac Protégé

  • Members
  • PipPip
  • 95 posts
  • Gender:Male
  • Location:California
I found a critical bug!

System will not boot if i choose "Ignore Caches" on bootup. System just hangs after short time.

Had no problems with any prior boot loaders to this RC5.

System is listed below in SIG (first desktop)

Would be happy to help developers, any more information needed just ask.

#132
bandgeek1

bandgeek1

    InsanelyMac Protégé

  • Members
  • Pip
  • 36 posts
  • Gender:Male
  • Location:92262
So this is the first update i have installed in a while, and when i rebooted, the nice graphic was not there, just this (see picture). And, when I went to check out the utility, it was only a terminal file that said this when I opened it
[codebox]Last login: Mon May 17 16:27:23 on console
/Extra/Util/bdmesg ; exit;
Sams-EP45-UD3R:~ sam$ /Extra/Util/bdmesg ; exit;
"boot-log" property not found.
logout

[Process completed]
[/codebox]


Any ideas?

Attached Files



#133
scrax

scrax

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,704 posts
  • Gender:Male

So this is the first update i have installed in a while, and when i rebooted, the nice graphic was not there, just this (see picture). And, when I went to check out the utility, it was only a terminal file that said this when I opened it



Any ideas?

You have still r432 (not r530) when bdmesg was not yet implemented

I've tried it on two different computers running Retail 10.6.3 in English, and when i got to the customize screen all options were selectable but most of the titles look screwed up like in the picture i posted earlier.

The installer works, thou it didn't asked for reboot or logout after installation. Here's the results (look at the files marked Today)

It's all ok then, the title and description are full implemented only in Italian specially for the new function, I'll make the english text to translate for all who want to contribute with translations.
It will not ask for a reboot or logout because it's not needed to have it working.

I found a critical bug!

System will not boot if i choose "Ignore Caches" on bootup. System just hangs after short time.

Had no problems with any prior boot loaders to this RC5.

System is listed below in SIG (first desktop)

Would be happy to help developers, any more information needed just ask.


If you want to help, post in the developers forum, or make an issue in the forge.

#134
bandgeek1

bandgeek1

    InsanelyMac Protégé

  • Members
  • Pip
  • 36 posts
  • Gender:Male
  • Location:92262

You have still r432 (not r530) when bdmesg was not yet implemented


Any idea on how i can fix this, it will not seem to update it.

#135
sacdcn

sacdcn

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts
I can't find the Chameleon 2 RC5 rev. 530 download adress.

#136
XLR

XLR

    2cores1cpu.mov

  • Donators
  • 889 posts
  • Location:חולון

I can't find the Chameleon 2 RC5 rev. 530 download adress.


Here it is: Chameleon 2 RC5 rev. 530 download adress.

#137
svizi

svizi

    InsanelyMac Protégé

  • Members
  • Pip
  • 27 posts
  • Gender:Male
  • Location:Athens
Hi installed the latest package (this is the first of the rc5 i use) and bootloader get stucks in the booting process.
I booted in verbose mode and i saw it stucks at Sound assertion "0 !=widget ->setUnsolicited and then says something about Apple HDA. Anyh thoughts? Thanks in advance.

#138
mitch_de

mitch_de

    InsanelyMacaholic

  • Local Moderators
  • 2,879 posts
  • Gender:Male
  • Location:Stuttgart / Germany
Such things, if WORKED before with other Chameleon Version may happen if you activated P-States+C-STates generation (normally both off by default) and have an overclocked CPU. I would first disable the P-States/C-States generationa and try again.
2 things may happen : To less VID (Volts) for OCed PStates and/or an P-State 0 (fastest) with multi 10* if you setup OC by high FSB (266>333) but lowered multi (10>9*) in BIOS. Both problems arent not a bug in that part, they occour by OC and the automatic generator hasnt the AI to use OCed usable parameters.


#139
svizi

svizi

    InsanelyMac Protégé

  • Members
  • Pip
  • 27 posts
  • Gender:Male
  • Location:Athens
I haven't overclocked the cpu and i didn't change anything in the default installation.
Is there a chance to have a problem with the audio kext installed?

#140
mitch_de

mitch_de

    InsanelyMacaholic

  • Local Moderators
  • 2,879 posts
  • Gender:Male
  • Location:Stuttgart / Germany
No, chameleon would not make any problems with Audio.
Only : If you need 32 Bit Kernel Mode you may check your kernelflags!
You need arch=i386 (32 Bit Mode) with newer chameleon versions, older worked with -x32 (or other).






7 user(s) are reading this topic

0 members, 7 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy