Jump to content

Warcraft 3 now Universal


27 posts in this topic

Recommended Posts

I just tried to connect to Battle.net and it downloaded the latest update, 1.21 and I opened the patch.txt file and it showed this.


Patch 1.21










- The game now runs natively on both PowerPC-based and Intel-based Macs.


- Player can now view frames per second using the "/fps" chat command.








- Fixed a timing problem with the game on PCs with dual-core CPUs.


- Fixed a crash that could occur with the Frost Breath ability.


- Fixed a crash that could happen in multiplayer games.


- Fixed an exploit that could happen in multiplayer games.




Important Note on Patching for Mac Players: The file layout inside the


game folder is changed significantly by Patch 1.21. As a result, in order


to be able to install the Frozen Throne expansion from CD, you must


install Reign of Chaos first, then install Frozen Throne from CD, and then


patch to version 1.21, in that order. If you patch to v1.21 and then


attempt to install Frozen Throne after that, it will not install




This is good news for Intel owners like myself. I shall try this on my MBP in a little bit :angel:.

Link to comment
Share on other sites



Having to run it in Rosetta was pissing me off. Everything I run in Rosetta sends my MBP's fans into overdrive, regardless of the CPU temp. UniBins FTW!


EDIT: Cool, new maps. :thumbsdown_anim:


EDIT2: Holy GOD it's fast. I didn't think Rosetta was slowing it down until I used the new Universal version.

Edited by ErBiC
Link to comment
Share on other sites

It's damn fast, as fast as in Windows... Rosetta really sucks !


At least its there so people can run PPC apps, even if there a performance hit :( .

Link to comment
Share on other sites

I looked into the Warcraft 3 folder and the Warcraft 3 application is now a '.app' program, but the Frozen Throne application confuses me. It still has the no extension name, and when you get info on it all it says is Kind: Application, when you launch it it loads translated and says its PowerPC in Process viewer.


I switched to the desktop while it was running and killed translated to see if you needed it and the game didnt crash, still confused on how the game is structured :-/.

Link to comment
Share on other sites

Frozen Throne is an expansion, not a seperate game- in all likelihood the Frozen Throne executable simply launches the Warcraft 3 executable (sorry, Application :whistle:) with extra arguments added to the command line for the additional content. This is how UT2k4 mods work; for Red Orchestra I launch the RO app (which is PPC) and that app immediately calls to the (Universal) UT2k4 app with the mod data. Just like a batch file in DOS or Windows.

Edited by OMX-Knuckles
Link to comment
Share on other sites

OMX-Knuckles is correct. I have the Frozen Throne app in my dock. When I click it, it bounces a few times, as if it's going to open. Then it stops bouncing and the Warcraft III.app icon comes up in the right end of the dock. At first, it's the RoC icon, but switches to the TFT icon. Then TFT launches full screen.


This means the TFT app in the WCIII folder is simply a reference to Warcraft III.app with extra options to make it boot TFT. It's the same way in Windows; you open Frozen Throne.exe, then WC3.exe loads in Frozen Throne mode.

Edited by ErBiC
Link to comment
Share on other sites

  • 4 weeks later...
  • 3 weeks later...
  • 1 year later...
  • 2 weeks later...



Leopard completely locks up when I try connecting to battle.net. Could not force quit, had to hard reboot. I turned the firewall off, thinking that would solve the problem, but the issue still remains. Any thoughts? Specs below:


Kalyway Leopard + 10.5.2 combo update/graphics update + pc_efi_v8

ToH kernel 9.2.2

Intel C2D 6700

Asus P5E WS Pro

Sapphire Radeon HD3870 512 MB


Seagate SATA 160GB



Link to comment
Share on other sites


  • Create New...