Jump to content

[HOW TO] Convert Mac demos to full games

159 posts in this topic

Recommended Posts

Never mind about CoD- I found a No-CD. It works fine now.


BTW- It is possible to run Jedi Knight 2: Jedi outcast! Here's how

1. Download jkII demo

2. Install game on windows

3. Rename Demo folder to Base

4. On PC, goto gamedata/base

5. copy assets0,1,2, and 5 from windows into mac Base folder in the demo folder.

6. Rename jedi knight 2 demo to Jedi Knight II

7. Download 1.03 patch

8. Install patch

9. Find No-cd patch ;) (use google)

10. Runpatch

( Not nearly as complicated as it looks)

I can't find No-cd patch for Jedi Knight 2 : Jedi outcast in MacOS (I have googled for a while), although there are many No-cd patches for Jedi Knight 2 in Windows.

If I don't apply the patch for Universal Binary, I can play Jedi Knight 2 by mounting .dmg file with Toast 8 ( but with a slow speed ).

After using the patch for Universal Binary, I can't play by doing that way. Any idea?

A link to no-cd patch for MacOS should be useful ;)

No posting of direct or indirect links to warez

or pirated pieces of software, this includes cracks, serials and torrents.


This is what the rules say. I don't think that nocd patches fall under the "Warez" catigory :thumbsup_anim: , so,


For JKII- go to 6.

- Hope this is allowed!!!-

Usually the nocd patch is just the application. As long as you have the Assets in the base folder on your mac, you can just put the application into the demo folder and run it. If you are talking about the 1.03 update, make sure that you put the assets in a folder called base, and not gamedata. So the assets should be in /jedi outcast demo/Base. Also, make sure that the demo app is renamed to Jedi Knight II. You should be able to fool the installer.


Note- the assets.PK3 files pretty much ARE the game. As long as you copied them from the windows installation into the demo folder ( in base) it should work.

Edited by jka7273



Insert disc


Download 1.32c Mac Update (usually only 11 mb or so)


Create a folder called Quake 3 in /Applications


Drag baseq3 folder to the Quake 3 folder


Take the Quake 3.app engine from the downloaded 1.32c update, and put it in the Quake 3 folder


enjoy :)

Ok, so I figured out how to get Prey to work on the mac. Here is what I did.


1) First, and most important, buy Prey for the PC, you'll need the files.

2) Download Prey Demo from somewhere like Fileplanet

3) Install the Full Version on a PC (or Parallels)

4) Install the Demo

5) Delete (move) the files in the "Prey Demo/base" directory of the Mac System

6) On the PC go into "Prey/base" directory and rename pak000.pk4 to pak000.pk4.zip

7) You can browse into the pak000.pk4.zip file (just double click it, it should open in a window)

8) Copy the file "mainmenu.gui" to the desktop (just drag it to the desktop - original will not be moved, a copy will be made)

9) rename mainmenu.gui to demo_mainmenu.gui

10) Add the demo_mainmenu.gui back to the pak000.pk4.zip file (just drag it into the window where you are browsing pak000.pk4.zip)

11) Once the file is added to the zip file, go back to the base directory and rename pak000.pk4.zip to pak000.pk4

12) Copy all files in the base directory to the "Prey Demo/base" directory on the Mac

13) The full version will now play :)



If you have saved games on the PC, copy "My Documents/My Games/Prey/base/savegames" to "Library/Application Support/Prey Demo/base/savegames" and they will work. :D



There is a directory on the PC in the base directory called "game.so.package" that appears to be the Macintosh package, the layout and structure is identical to the Prey package of the demo except the file in the MacOS directory is called game.so instead of Prey. I have tried to rename it to Prey and execute it, it comes back as "invalid executable or dll". Otherwise it LOOK like it might work; maybe it isn't a universal binary, I don't have a PowerPC based system to try on.

Have fun!

Edited by Dajiu
  • 2 weeks later...

Hey guys, thanks for all the work you're putting into this stuff.


So here's my question. American McGee's Alice. It's based on the Q3A engine so it shouldn't be difficult, but after playing around a bit I'm still outta luck. I own the PC version obviously, and the Mac version is near impossible to find, so I was going to see if anyone here has an idea.



Well, after fiddling a bit, I did get Alice working.


Turns out the Alice Demo has a bug in it that prevents it from working in OS X (or perhaps at all, I dunno) and the bug fix for the demo was unable to be found anywheres.


Luckily the 1.1.1 patch has the Alice App contained within, so the Demo isn't needed at all. I will note that the recent Universal 1.1.2 patch is looking for the App to update so it by itself will not work, you'll have to install the 1.1.1 patch first.


So, once you have the 1.1.1 patch installed and then 1.1.2 installed on top of that, it's simply a matter of creating a folder named "base" in the same folder with the app, and then dumping all the files from the folder named "base" on discs 1 and 2 of Alice. Alice does require that you have disc 1 inserted to play the game.

Thanks for the testing Dark_Elf! I apologize for the lack of updates, I've been pretty busy with work and some personal stuff so I haven't had much of a chance to play games, let alone test them. If anyone has progress, questions or a suggestion please PM me and I'll update the primary posting if needed. Thanks for the community input on this, it's really helped out!

Sorry for the late.

I didn't have success with MOHAA I think because I used my father's installation that is full of maps and skins.

I'm searching for my old disks for a test with a fresh installation.

Main post updated. Sorry for the delay.


I have some news that will affect this project- As of this past Friday I'm no longer able to use Mac OS X, period. I've replaced my X1800XT with a Geforce 8800GTS which is a fantastic card, but unfortunately has no Mac support at all as of yet. I'm hoping that drivers will eventually be available but until then I have no way of testing any games of finding any solutions. I will continue to update the main post as long as community support is there! Thanks for everything you've done for this project so far, let's keep it coming! :censored2:


i do have prey cds, but i do not have a PC.

U mention dragging the all the stuff in the 'base' folder to the directory on Mac.

I notice, on the cds itself, have already a base folder, do u think it would work if i copied them from the cd to the Mac's directory?

And, do you mind if u tell me specifically whats in ur 'base' folder, the one on the mac, after the convert to the full one.


I'm sorry if this has been asked before but I couldn't find it. When following these steps:


Now follow these steps to make UT2004 full:


1. Now you can choose between these:


1a. By LAN: Access over your network to your PC, where you have installed your PC version of UT2004. Inside UT2004 folder, grab every folder and copy them over your Mac Installation.


1b. From your UT2004 CDs/DVD: put in your cds/dvd and copy every directory over your Mac Installation.


(((<<< NOW YOU HAVE UT2004 FULL AND UB >>>)))


I'm not sure if we have to install UT2004 on a Windows PC and then copy over the files from the installed directory, or if we can just copy over the files directly from the CDs without installing anywhere first?



I tried out Battlefield 1942, but after installing the patch it asks for the CD-Keys for both Battlefield 1942 and Road to Rome. My PC CD-Keys won't work though.

Yet I have been unable to find a no-cd patch online.

Any suggestions?


I also tried out Civilization 4, but there was a similar problem. After installing the demo, the latest update and copying data from my pc installation, the program asked for a game cd. Of course the pc-cd didn't qualify as an original. In this case I found a no-cd patch, but it was for an other (earlier) verions of the game. The no-cd patch wanted a Civ4 version 1.61 (9565), so I tried out all three versions, that I could find, which where 1.61 Rev A, 1.61 Rev B and 1.61 Rev C, but neither was the right one for the no-cd patcher and it always ended with the error message "wrong version".

So again help would be greatly appreciated!


Btw, Quake 4 and Unreal Tournament 2004 work fine for me. Thanks very much to whoever shared the information!

  • Create New...