Jump to content

HP Z400/Z600/Z800 Workstations OS X 10.10.x/10.11.x Installation


chatdeau
1,091 posts in this topic

Recommended Posts

@Rockey12

 
Here some testing for you and other users:
 
Clover on the fly audio is the best method. No problems and no intervention for updates.
 
 
The package includes:
Original (Vanilla) AppleHDA for Capitan including layout28.zml.zlib and Platforms.zml.zlib
realtekALC.kext for ConfigData
 
instructions:
1. Install AppleHDA by S/L/E with SIP 0x67
2. Copy realtekALC.kext by EFI/Clover/kexts/10.11/
3. Inject Clover's Kext to activate "Yes"
post-1358580-0-53822000-1457116967.png
4. Add the following in a config.plist with CloverConfigurator:
post-1358580-0-97011300-1457116975_thumb.png
5. rebuild cache (sudo kextcache -prelinked-kernel)
6. Reboot and have fun
 
  • Like 2
Link to comment
Share on other sites

Hi

After a lot try to setup my z800 with el capitan 10.11.4 Beta (15E49a) finally almost done :)  :)  :)  :)  :)  :)  

First I would like to thanks the forum and all the users that sharing information 

 

My setup procedure is:

first using http://www.insanelymac.com/forum/topic/307920-guide-clover-dell-precision-690-workstation/?st=0

this clover setup to make the usb with 10.11.3

then Post Installer HP Z800 http://www.insanelymac.com/forum/topic/307920-guide-clover-dell-precision-690-workstation/page-12?do=findComment&comment=2220137

I boot without any bootflags  in this step i have many freezes in finder

then i update to 10.11.4 Beta (15E49a) and now all works normal  :)  :)  :)  :) and the sas controller  :)  :)  :)  :)

 

many thanks to Chris 1111 and the Clover team

 

 

the only problem are the audio and the memory banks 

i haven't audio but i didn't try to fix it 

and the memory i have 12 banks of 4gb =48gb ram and el capitan recognise 6 banks  = 24gb i don't now if it is any configuration in clover

 

thanks 

 

ps i don't know how to upload screenshots

  • Like 1
Link to comment
Share on other sites

please don't forget to give the credit to Chris 1111 who made these wonderful Installer  and the Clover team for the Execelant bootloader

AppleHDA+CodecCommander+DSDT in post 135

 

AppleHDA+CodecCommander+DSDT   is that for audio

Link to comment
Share on other sites

I am finally booted inside OS X :)  now i have to do a post install..... THANKS! ROCKEY AND CHRIS!!!

 

Gkoruk how did you make LSI work i have 2 LSI cards inside now with 2 raids and also another ATTO card... I did not disconnect anything it booted :)

  • Like 2
Link to comment
Share on other sites

I am finally booted inside OS X :)  now i have to do a post install..... THANKS! ROCKEY AND CHRIS!!!

 

Gkoruk how did you make LSI work i have 2 LSI cards inside now with 2 raids and also another ATTO card... I did not disconnect anything it booted :)

It works by default when i update to 10.11.4 beta

Link to comment
Share on other sites

Confirmed working with z400 and 10.11 (El Cap)

 

What a breeze compared to Enoch method.

 

1. Create USB key via Chris1111

2. Copy files / DSDT into EFI partition of USB key (inside the 10.11 folder for kext)

3. Boot from USB key.

4. Install OS -- without boot flags - reboot.

5. Load OS, use post install via Chris1111.

6. Mount EFI partition and move DSDT and Kext files from USB key to folders.

7. Repair permissions.

8. Install Audio as above (Codec Commander)

9. Update to Beta (if you want).

 

Excellent work everyone. Clover is vastly superior due to the hidden Kext / DSDT files and update potential.

  • Like 3
Link to comment
Share on other sites

Hi

 

I have a problem with memory banks my system configuration has 12 banks of 4gb ram for 2 x cpu the problem is el capitan recognise the half memory  

post-1555245-0-76490300-1457162223_thumb.png

post-1555245-0-76490300-1457162223_thumb.png

 

 (mavericks recognise all banks)

 

can anyone help me to solve i think is inside clover configuration 

config.plist.zip

 

thanks a lot

 

 

 

 

post-1555245-0-45754900-1457162254_thumb.png

Link to comment
Share on other sites

Just updated.

I tried it last night with already made usb for precision 690, just replaced the dsdt and kexts inside kexts folder in efi and nothing shows up after the clover bootloader.  I just remade another vanilla usb with the universal os x installer by chris, will try again soon and report back.

Link to comment
Share on other sites

Yes, the best method for Capitan is Clover.

 
I wonder about the use of CodecComander. Your ALC262 has no EAPD. The Kext includes nothing for ALC262. The patched AppleHDA of Mavericks or Yosemite also work with Capitan. The best method is on the fly.
 
Some fixes are not necessary because they are in DSDT it (AddDTGP, FixIPIC and more).
Audio-Inject 28 with Clover is not necessary if HDEF is fixed in the DSDT.
 
rootless is no longer necessary (it was only during the Capitan beta < GM. Was replaced by SIP.)
PCIRootUID=0 is standard in Clover, I think
 
Here's what to test:
 
 
I have "HDA / hda-gfx" inserted for HDMI audio
when non-native HDMI support (AMD and Nvidia):
to EFI/Clover/kexts/10.11/
 
Here what for cosmetics:
 
Folder icon z800 for your desktop to store important data for the love HP:
 
...
 
For About This Mac:
 
...
 
copy to
 
/Applications/Utilities/System Information.app/Contents/Resources/
 
For About This Mac, Change the black Monitor:
 
 
copy to
 
/System/Library/CoreServices/CoreTypes/Contents/Resources/public.generic-lcd.icns
 
For About This Mac, Memory:
 
post-1358580-0-27139700-1457259597_thumb.png
 
insert, add or replace your free text at MAC_MEMORY_TEXT at
 
/Applications/Utilities/System Information.app/Contents/Resources/German.lproj/SPInfo.strings
or
/Applications/Utilities/System Information.app/Contents/Resources/English.lproj/SPInfo.strings
or
...
 
have fun  :wub:
  • Like 2
Link to comment
Share on other sites

Now i make a fresh install to ssd does anyone know how to fix shutdown?

The shut Down fix is  included on Post Installer  Clover RC Script on Destination Volume

Working on Dell Precision 690 !

  • Like 1
Link to comment
Share on other sites

The shut Down fix is included on Post Installer Clover RC Script on Destination Volume

Working on Dell Precision 690 !

Quick question about this installer.

 

Where specifically is it installing to and what changes is it making?

 

Is it going to S/L/E or elsewhere?

 

Is it possible to point it to the EFI / Clover partition?

 

Thanks!

Link to comment
Share on other sites

Quick question about this installer.

 

Where specifically is it installing to and what changes is it making?

 

Is it going to S/L/E or elsewhere?

 

Is it possible to point it to the EFI / Clover partition?

 

Thanks!

Post Installer contain only the Bootloader Clover Mode ESP (EFI Parttion)

Contain also Clover Panel and RC Script Clover thats it

 

Rockey12 gives me only EFI folder for Build this Installer

I am not change the EFI provided by Rockey12

  • Like 1
Link to comment
Share on other sites

For those of you who have El Capitan up and running on an HP Z400 using Clover. I would like to know what version of Clover was used, which Post Installer, DSDT file and where was it placed. I want to know any files that were added to the EFI Clover folder, and any other information and or files needed for a successful Install.  Thanking you in advance.

Link to comment
Share on other sites

×
×
  • Create New...