Jump to content

Driver for Realtek's RTL810x Fast Ethernet Series


178 posts in this topic

Recommended Posts

Sorry, I'm moving to a new home and so the tests I was intending to do will have to wait until the end of this month. But I did download the project and compiled it with Xcode. As soon as I have time to really test it, following your testing recommendations, I'll post here.

 

All the best!

 

No problem! 

 

Mieze

@Mieze:

 

I've just tested it and its working perfectly.

The problem I had with the 8169 driver (where OS X always saw the cable as plugged in) seems to have been resolved :)

No performance issues whatsoever so far.

 

On a cosmetic side note though, system profiler says gigabit ethernet instead of fast ethernet.

 

Once again, I cannot thank you enough for you efforts and contributions to this project :)

 

post-21972-0-18531800-1393053909_thumb.png

Thanks Mieze!!! Great work!

 

However, my ethernet failed to work after sleep. Network setting shows self-assigned IP, then indicate it is connected to the Internet but actually it is not. So should I tried the debug version to give u more information?

 

btw my ethernet card is 8105E, device id is 0x8136

2/23/14 12:08:56.000 PM kernel[0]: Ethernet [RealtekRTL8100]: Warning: PCIe ASPM enabled.
2/23/14 12:08:56.000 PM kernel[0]: Ethernet [RealtekRTL8100]: EEE support enabled.
2/23/14 12:08:56.000 PM kernel[0]: Ethernet [RealtekRTL8100]: TCP/IPv4 segmentation offload enabled.
2/23/14 12:08:56.000 PM kernel[0]: Ethernet [RealtekRTL8100]: TCP/IPv6 checksum offload enabled.
2/23/14 12:08:56.000 PM kernel[0]: Ethernet [RealtekRTL8100]: Using interrupt mitigate value 0x0.
2/23/14 12:08:56.000 PM kernel[0]: Ethernet [RealtekRTL8100]: RTL8105E: (Chipset 11) at 0xffffff80f0cd5000, 84:8f:69:c4:b5:12
 

 

 

Good job, my chip is RTL8136, mavericks 10.9.2, test works well. 

Mail/DHCP/sleep&wakeup/AppStore/plug&unplug, WoL haven't test. But all play good. 

post-459659-0-79845800-1393129300_thumb.png

post-459659-0-37416800-1393129347_thumb.png

However, my ethernet failed to work after sleep. Network setting shows self-assigned IP, then indicate it is connected to the Internet but actually it is not. So should I tried the debug version to give u more information?

 

Yes, please use the debug build and send me the kernel logs.

 

Mieze

First connection is around Feb 22 21:55:09, which is before sleep, so it works fine. Then did sleep and wake, plug ethernet to computer, but did not have Internet.

 

According to your log file the connection gets established and the link is up after wakeup.

Feb 22 21:57:55 Mac kernel[0]: Ethernet [RealtekRTL8100]: Link up on en0, 100-Megabit, Full-duplex, No flow-control

Please repeat the test and after wakeup use netstat -i in Terminal to check the packet statistics several times with intervals of a few seconds. Does the number of transmitted/received packets increase (which of them?). This is important in order to track down what is wrong.

 

Mieze

Mac:~ peter$ netstat -i
Name  Mtu   Network       Address            Ipkts Ierrs    Opkts Oerrs  Coll
lo0   16384 <Link#1>                           768     0      768     0     0
lo0   16384 localhost   ::1                    768     -      768     -     -
lo0   16384 127           localhost            768     -      768     -     -
lo0   16384 localhost   fe80:1::1              768     -      768     -     -
gif0* 1280  <Link#2>                             0     0        0     0     0
stf0* 1280  <Link#3>                             0     0        0     0     0
en0   1500  <Link#4>    08:9e:01:2b:b4:25     1342     0     1307     0     0
en0   1500  mac.local   fe80:4::a9e:1ff:f     1342     -     1307     -     -
en0   1500  169.254       mac.local           1342     -     1307     -     -
en0   1500  fd00::a9e:1 fd00::a9e:1ff:fe2     1342     -     1307     -     -
en0   1500  fd00::18c8: fd00::18c8:d09d:d     1342     -     1307     -     -
en1   1500  <Link#5>    44:6d:57:a3:50:fb    21180     0    22767     0     0
en1   1500  mac.local   fe80:5::466d:57ff    21180     -    22767     -     -
en1   1500  192.168.0     192.168.0.2        21180     -    22767     -     -
en1   1500  fd00::466d: fd00::466d:57ff:f    21180     -    22767     -     -
en1   1500  fd00::d021: fd00::d021:8fa2:4    21180     -    22767     -     -
p2p0  2304  <Link#6>    06:6d:57:a3:50:fb        0     0        0     0     0
utun0 1380  <Link#7>                             0     0        6     0     0
utun0 1380  fe80::c48d: fe80:7::c48d:2a75        0     -        6     -     -
utun0 1380  fd93:20a0:6 fd93:20a0:6edf:b3        0     -        6     -     -
Mac:~ peter$ 

en0 is ethernet and en1 is wifi. This is after wakeup, so ethernet is not working. I guess the number not changing? But my wifi is working normally.

Network setting first show this:

post-732552-0-32340400-1393134497_thumb.png

 

After few seconds:

post-732552-0-83845900-1393134510_thumb.png

Anyone else here who has tested sleep/wake? Does the network connection work properly after wake? Together with Zythyr, I'm currently preparing a new development release and will post it here as soon as he confirms that it works for him.

 

Mieze

 

The connection works perfectly fine after wake on my Inspiron with RTL8105  :)

Zythyr and I, we managed to finish the next development release of the driver. I updated the source code and the binaries attached to the first post of this thread a few minutes ago. Everyone is encouraged to test the new release on her/his system.

 

Mieze 

×
×
  • Create New...