Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

Search the Community: Showing results for tags 'realtek'.

More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


  • InsanelyMac Lounge
    • Front Page News and Rumors
    • Reader News and Reviews
    • Forum Information and Feedback
  • OSx86 Project
    • New Releases and Updates
    • New Users Lounge
    • Developers Corner
    • Tutorials (The Genius Bar)
    • Technical FAQ
    • OSx86 Installation
    • Post-Installation
    • DSDT
    • Hardware Components and Drivers
    • Complete Desktops
    • Notebooks
    • Netbooks
    • Tablets
    • MacMod of the Month
    • Multi-booting and Virtualisation
  • International
    • Your Language
    • Deutsch
    • Español
    • Français
    • Italiano
    • Português
    • Русский
  • Apple World
    • Mac OS X
    • Apple Computers and Hardware
    • iOS Devices
    • Mac Applications
    • Mac Programming and Development
    • iOS Programming and Development
    • Mac Gaming
    • Mac Accessories
  • Discuss and Learn
    • Windows Discussion
    • *nix
    • Apple Opinions and Discussion
    • The Great Debates
    • Internet(s), Servers, and Networks
    • Buying Thoughts, Reviews, and Recommendations
    • Mods and Overclocking
    • The Big Issues [Real Life]
  • Everything Else
    • Creativity
    • Thunderdome (Random Stuff)
    • Laughs
    • The Marketplace


  • Kexts
    • Graphics Cards
    • Audio
    • LAN and Wireless
    • Other
  • Kernels
  • Bootloaders
  • DSDTs
    • Patches
  • Pandora
  • Apps
  • Miscellaneous
  • Customization


  • OSx86
  • Apple News

The search index is currently processing. Current results may not be complete.

Found 81 results

  1. WARNING! I have no affiliation with “DiskMaker X”. Use at your own risk! Thank You to MaLd0n for all of his help getting me up and running! Pre-Requisites You must have a Mac with a working App Store You must have a USB Drive with a size of 8 GB or more Installation In the App Store download macOS High Sierra Download DiskMaker X and run it Setting the OS Install App and the USB Drive - You may want to format the drive into 1 partition If you encounter any errors, see the DiskMaker X FAQ page Download the latest Clover EFI Boot and install it on the same USB Drive - With these Settings: (Thanks to MaLd0n for these settings!) On the USB Drive, on the “EFI” volume, under the “EFI” folder, replace the “CLOVER” folder with the one in this archive: CLOVER Install.zip (Thanks to MaLd0n for these files!) Restart your computer and boot into the USB Drive’s EFI volume In Clover select “Boot OS X Install from ” + your USB Drive’s name ​The first “install” will copy the installer to your hard drive After the first reboot, in Clover, select “Boot macOS Install from ” + your Hard Drive name - Note: I had to do this step twice, before the next step was available to me After the next reboot, in Clover, select “Boot macOS from “ + your Hard Drive name - Note: This will be your normal option going forward Now you will have to install Clover on your Hard Drive, so that you don’t have to use your USB drive anymore. Download the latest Clover EFI Boot and install it on your Hard Drive - With these Settings: (Thanks to MaLd0n for these settings!) On the Hard Drive’s “EFI” volume, under the “EFI” folder, replace the “CLOVER” folder with the one in this archive: CLOVER Install.zip (Thanks to MaLd0n for these files!) Reboot to this new EIF volume on your Hard Drive - Note: This will be your default boot volume - You can set your BIOS to boot to it by default - In Clover, select “Boot macOS from “ + your Hard Drive name - Remember this will be your normal Clover option going forward Download and Install Clover Configurator Post Installation Manual Fixes The Mouse Scroll Wheel is set to the “Apple Touchpad direction” - To fix that, go to System Preferences -> Mouse and uncheck Scroll direction: Natural Eject button is stuck in the menu bar - To remove, hold down Cmd and drag it out of the menu Cannot view Hidden Files - In Finder hold down CMD + Shift + . (dot) ​Home and End keys have weird behavior - ​Use this Post to fix that - Note: The Folder/File you create need to go in your User’s hidden Library folder Known Unresolved Bugs Dual Monitor Bug - When booting up, 1 of your monitors will get turned off - To turn it back on, unplug both monitors, then plug them back in Software I Like to Install Note: I am not affiliated with any of these apps. I also do not guarantee nor take any responsibility for these apps. (This is really just a list to remind me what apps to install, when I do a clean OS install.) [i thought others might also find it useful.] AppCleaner Karabiner Lightshot The Unarchiver CLOVER Install.zip
  2. REALTEK ALC282 v2

    Version 1.00


    Hi people, This is a preliminary installer to activate the sound card REALTEK ALC282-v2 (10ec:0282) with LayoutID 1 or 3 in MacOS. This installer does not contain AppleHDA patched Kext. To work properly, it must be installed over vanilla AppleHDA.kext. I want to thank the whole community for their efforts and content provided, because without these it would not be possible to create this installer. I would appreciate comments and suggestions!! Status: Speakers : OKHeadphones : OKHDMI Audio : OK (Intel HD4K Tested)LineIn : N/A (Model Without LineIn)MicInt : OKMicIntNoiseReduction : OKMicExt : N/A (Model Without MicExt)AutoDetectLineIn : N/A (Model Without LineIn)Sleep : OKWakeUp : OKAutoSleep : OKHibernate : OKSiri : OK Tested Laptops: - HP Pavillion 15-D002SS Coming Soon: - Unified installer for the different supported operating systems. - Support model with LineIn jack. Modified Verbs: 01271C20 01271D00 01271EA0 01271F9001471C10 01471D00 01471E17 01471F9001871CF0 01871D00 01871E00 01871F40 01E71CF0 01E71D00 01E71E00 01E71F4002171C30 02171D10 02171E21 02171F0001470C02 DSDT: Patch to apply with MaciASL in your DSDT ######################################### HDEF v1.00######################################## into method label _DSM parent_label HDEF remove_entry;into device label HDEF insertbeginMethod (_DSM, 4, NotSerialized)\n{\n If (LEqual (Arg2, Zero)) { Return (Buffer() { 0x03 } ) }\n Return (Package()\n {\n "layout-id", Buffer() { 0x01, 0x00, 0x00, 0x00 },\n //"layout-id", Buffer() { 0x03, 0x00, 0x00, 0x00 },\n "hda-gfx", Buffer() { "onboard-1" },\n "PinConfigurations", Buffer() { },\n })\n}\nend;
  3. Hello. I've bought an Edimax EW-7822ULC card (link) that has the Realtek RTL8822BU chipset. It comes with a driver "com.realtek.driver.RtWlanU" and a configuration utility called "StatusBarApp". They both appear to work but the configuration utility is too simple. For example, when the Wireless network supports 2.4Ghz and 5Ghz but both frequencies broadcast the same SSID, I can't seem to force it to choose the 5Ghz band. Most other devices be it phones or laptops manage to connect to it fine. Even those that start on 2.4 eventually move to 5 automatically, but not this card. Is there some other utility, command line or graphical, that I can use on MacOS High Sierra to drive this card and make it use the 5Ghz band? Thank you and best regards.
  4. ¡Hello Guys! im here with a new build to make a fully working Hackintosh. The components are: -Gigabyte H270 HD3 -i5 7400 -8 GB Ram Corsair LPX 2400 MHZ -Samsung 850 evo 250 GB SSD -Integrated Kabylake graphics All are working and bootable but I have 3 problems: -Audio Realtek ALC 887 is not working (I tried with kexts but it doesn't shows anything) -The system restart when I press shutdown -I can only show 1 monitor when I have 2 plugged, (one in HDMI Port and the other in DVI Port) Could you help me with these? ¡thanks you so much!! Here are my files and clover folder: CLOVER.zip iMac ioreg.zip Send me iMac.zip
  5. Hola a toda la comunidad! Este es mi segundo tema. ya había hecho uno sobre la instalación de El Capitan, y este es sobre Sierra. Antes que nada, quiero decirles que soy muy novato en este tema, no entiendo todavía, la gran mayoría de acciones, términos, etc. Así que espero puedan entenderme y sepan disculpar si es que esta mal ubicado el tema y demás. Bueno paso a comentarles. Primero les dejo las specs de mi PC: Micro: i5 4690k Mother: Gigabyte Z97X Gaming 3 Ram: Kingston 10GB en DDR3 a 1300Mhz VGA: GTX 970 4GB Acabo de terminar mi instalación de Sierra 10.12.5 en mi pc. Seguí la guía de RampageDev para la instalación, y se hizo sin ningún problema ni complicación. El problema por así decirlo es que al reiniciar, inicia normalmente pero no tengo audio, hice la instalación con el archivo command que se ve en la imagen... Ejecuto el command, sigo las instrucciones, me detecta el codec, lo instalo lo mas bien, me pide reiniciar, lo hago y cuando inicia, sigo sin audio, lo comprobé en el apartado Audio de las preferencias del sistema y me dice que no hay dispositivo de salida.... A todo esto cuando inicie el equipo me doy cuenta que apareció una carpeta en el escritorio con unos kexts adentro, aquí les muestro... Que tengo que hacer con esos archivos? Tengo que montar la partición EFI? (No se como se monta jejeje...) Bueno, y mi segundo problema es el video... Siguiendo la guía de Rampage como dije, en el momento de elegir el config.plist, elijo el que activa los WebDrivers. Ahora, en la pagina de Rampage hay otras guías sobre la instalación de los drivers de las VGA, pero por ningún lado veo para poder instalar los WebDrivers. Yo pensaba que al elegir el config.plist que activa estos últimos bastaba con descargar los WebDrivers, instalarlos y ya, pero no quiero hacer nada sin antes consultar, no quiero joder la instalación. Bueno, basicamente esos son mis dos problemas. Desde ya les agradezco su ayuda, muchas gracias!
  6. I am running 10.12.4 on an ASRock Z97 Anniversary with an Intel Core i7 4790. I have no output device and consequently no sound. According to ASRock I should be using Realtek ALC 887 but according to DCPIManager I have this: 0x80860C0C, 0x18490C0C, 0x80862807, 0x0000, Intel (Unknown) 0x80868CA0, 0x18497662, 0x10EC0662, 0x0101, Realtek ALC662v2. I am new to Hackintosh so hope that's enough info for someone to very kindly offer me some help

    Hi friends. At times I try to make my microphone work on my Acer E1-572, I've followed a lot of tutorials, I used several kexts, even tried to patch my own kext, "a disaster", followed this guide: AppleALC, AppleHDA Patcher... I can get my audio work, the microphone is detected but does not capture anything, Someone could help me and see where I'm going wrong, I'm running the Sierra and everything is working, but no mic. I will attach my DSDT, SSDT, config.plist, the kexts I use for the Audio work and also my codec_dump.txt. Conf Acer E1-572.zip
  8. Since winter 2015 I've been slowly building my Hackintosh workstation based on Supermicro X9DAi. This mobo has quite good reputation in the community, that's why I have chosen it as my base platform. It quickly turned out the X9DAi Hackintosh setup process is time consuming and has very steep learning curve. Preparation of my rig went into months. Ethernet, USB, USB3, PM, ... step by step I fixed succeeding issues. Days, weeks – you probably know that. It was all worth it however, cause today I have 100% functional muscle hack. Thanks to wonderful community I overcame many obstacles and solved hundred of issues. So now is my turn to put my two cents. ___ Last thing which not worked in my system was audio. Many users reported lack of ability to fix this and after several attempts I also quit. Bought cheapo USB PnP sound card and left the issue unsolved. Having to test some DIY microphone project I did recently, I thought why not to give another shot to my onboard ALC889? I did, and after an hour had working audio onboard. Setup is very simple and you can proceed it in minutes. Of course this is not my developement but compilation of solutions from the web. Tested on OS X Yosemite 10.10.5 only. I don't know whether it works in other system versions. So, here's step by step how-to guide: ___ 1. Download "Realtek ALC888s Solution for Yosemite by Mister Thibard" here: http://www.osx86.net/files/file/4299-realtek-alc888s-solution-for-yosemite/ This is very convenient set of utilities suitable here. Download, mount DMG, read the README. 2. Run the PKG from "A" folder. App installs to S/L/E two kexts: VoodooHDA & AppleHDADisabler, Also Voodoo preference pane and VoodooHdaSettingsLoader.app in the Utilities. 3. Open the "B" folder from DMG and copy VoodooHDA.kext somewhere on your HD. Go to new kext location, do "show package content" and edit containing info.plist file in any plain text editor. VoodooHDA is an open source audio driver for devices compliant with the Intel High Definition Audio specification. It is intended as a replacement for AppleHDA on Mac OS X. 4. Check whether your device ID is indeed 0x1d208086 under the "IOPCIPrimaryMatch" key. <key>IOPCIPrimaryMatch</key> <string>0x1d208086</string> If it's not, refer to the README on DMG (or use DPCIManager utility to get device ID). 5. Find the "AllowMSI" key and change its value to "false". <key>AllowMSI</key> <true/> to: <key>AllowMSI</key> <false/> NOTE: if sound is lost after few seconds of any first play, it means you have missed this step 6. Save the info.plist file and close editor. 7. Using KextWizard, KextUtility or any similar app install edited VoodooHDA in /S/L/E and do usual full service. 8. Make VoodooHdaSettingsLoader load at startup. Go to System Preferences -> Users & Groups -> (select desired user) -> Login Items tab. Click "+" and locate VoodooHdaSettingsLoader.app in the Utilities. Select it and add to your startup items: 9. Restart machine. Enjoy your new sound. This solution is quick, effective and elegant. Checkout the Sound pane in System Preferences – all motherboard audio connectors are present: In the VoodooHDA preference pane you may fine-tune output & input source parameters. Very convenient. Cheers!
  9. Hi I have bought a USB Wifi and Bluetooth device for my Laptop (Lenovo U530 Touch) because I had to remove the internal PCIe card for an external GPU. In Windows it obviously works fine because of the given drivers. I have not tested Linux yet. Now i tought it would be nice to use it on my Yosemite installation. I have no idea how difficult it may be to port the driver from linux to osx with the linux C source code. I am a programmer but not in this field. So first question, is someone able to port the driver, and if it is not THAT difficult what do I need to do it. You can find the source code of the linux drivers and a documentation how to port the drivers to Android (was included in the driver package) here -> https://dl.dropboxusercontent.com/u/27661831/20150108_RTL8723BU_BT_android4.2_V2.20_P25_FW_svn13430-BTCOE.zip https://dl.dropboxusercontent.com/u/27661831/20150108_RTL8723BU_BT_android4.4_V2.21_P29_FW_svn13430-BTCOE.zip https://dl.dropboxusercontent.com/u/27661831/20150108_RTL8723BU_BT_android5.0_V2.21_P14_FW_svn13430-BTCOE.zip https://dl.dropboxusercontent.com/u/27661831/Linux_BT_USB_2.13.20141128_8723BU_COEX20140929_5443.zip https://dl.dropboxusercontent.com/u/27661831/RTL8723BU_WiFi_linux_v4.3.9_13200.20150106_BTCOEX20140929-54.zip kind regards Thomas
  10. At past versions of OSX we can use Antipop script, that not give OSX turnoff soundcard power at idle after 30sec. But in OSX Sierra, this script not working, so when no sound in soundcard between 30sec, OSX turn down power at soundcard, so when system need to play some notification sound, at first we can hear cracking pop sound, after sound of notification.
  11. I have audio woking but when I open a heavy program like Maya 3D, close it, or when using it I get audio cutted and it jumps or freezes every second. I have used the computer for average things like browsing and watch movies for several days and audio works fine. But when I start to use Maya or Zbrush it starts to fail. Sometimes even starts to add lot of noise and slowing the speed of the audio. ​ ​Trying to fix it I applied Toledas script http://www.insanelymac.com/forum/topic/308387-el-capitan-realtek-alc-applehda-audio/ Using the I.1) method and does not fix the issue. I don't even know how to describe the problem so I cannot find a fix properly in the forum. ​ ​Hope someone can point me in the right direction because I am having this issue from the beginning of this hackintosh and it's very annoying being watching a video tutorial and have to wait several minutes to come back the audio to work properly. ​ ​My system is: Asus Rampage V Extreme USB3.1 ​CPU i7-6900K 3.2Ghz ​64GB RAM at 2133Mhz ​Audio Realtek 1150 ​ ​Thank you very much. ​ ​Have a nice day.
  12. Hola a todos. Esta es una mini guía para instalar audio de manera "nativa" y capaz de ser inmune a las actualizaciones. La idea surgió en un post de un usuario que tuvo problemas para reinstalar el audio luego de la actualización 10.11.5. Dejaré el enlace de dicho post al final de este sencillo tutorial. Sin más palabras, empecemos. Requisitos: - Es necesario tener el AppleHDA.kext sin modificaciones; original. - No tener instalados otros métodos (Toleda, Mirone, VoodooHDA, etc). Pasos: 1) Descargar el kext: AppleALC De la siguiente página: https://github.com/vit9696/AppleALC/releases 2) Ir a la partición EFI/ Clover/ kexts/ 10.XX (según la versión que estén utilizando) y peguen el AppleALC.kext. O también, el kext puede ser instalado en EFI/ Clover/ kexts/ Others. Instalar en Others permite que los kexts se carguen para cualquier versión de OS X, sin necesidad de copiarlos en su carpeta específica (10.XX). *** Para quienes instalan los kexts en Sistema/ Librería /Extensions/, funciona igual. *** En su caso, no se olviden de "reparar los permisos" luego de instalarlo, sea con: utilidad de discos, Kext Wizard, Kext Utility. 3) En la partición EFI/ Clover, editen el config.plist. Agreguen el número de layout ID correspondiente a su sistema. En este ejemplo, utilizo el 1. Mi audio es el ALC1150. Pueden verificar su layout ID en la siguiente página. https://github.com/vit9696/AppleALC/wiki/Supported-codecs Y eso es todo. Ahora reinicien y deberá funcionar correctamente. Nota: Para aquellas personas que sean nuevas en el hackintosh y no saben cómo montar la partición EFI, les recomiendo utilizar este programa: EFI Mounter. http://www.insanelymac.com/forum/files/file/528-efi-mounter/ *********** Créditos al autor: vit9696 http://www.insanelymac.com/forum/topic/311293-applealc-%E2%80%94-dynamic-applehda-patching/ ---------- Post de donde surgió la idea: http://www.insanelymac.com/forum/topic/312591-no-audio-integrado-despues-de-actualizacion-10115/ /////////// Gracias Maniac10 por las recomendaciones.
  13. Hi. I'm having some issues with my PCIe ethernet. I installed applertl8139ethernet.kext using [url=&quot;http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/&quot;]#####[/url] on hackintosh zone yosemite distro. My laptop is dell n5010. This is my kernel panic after i use internet for a couple of minutes. BTW my ethernet used to work Out of the box on mavericks. PS: RehabMan's and lnx2mac's kexts dont work either.
  14. Hello! I'm running macOS 10.11.3, and I'm experiencing a rather odd issue with AppleHDA and my system's audio. The system appears to be detecting the card, and it knows it's an audio device. However, it doesn't show it as a usable output device. (http://i.imgur.com/ksWmCkO.png) Similarly, the input device doesn't show up. I'm using a patched AppleHDA (attached) and my AppleHDA clover config is below: <key>Audio</key> <dict> <key>Inject</key> <string>3</string> </dict> Is there anything I can do to solve this problem (preferably through the use of Clover only so it persists through updates)? If needed, I can attach my codecs and similar if a re-patch is needed. I have no DSDT patches for codecs or Layout IDs. AppleHDA.kext.zip
  15. Need Network Kexts

    Hello, Im running Hackintosh 10.11 El Capitan on my laptop. I wanted to be able to use WiFi and Ethernet in my hackintosh, and here are my device ids (in Windows) of my network drivers : Wired : VEN_10EC&DEV_8168 (Realtek PCIe GBE Family Controller) Wireless : VEN_14E4&DEV_4365 (Broadcom 802.11n Network Adapter) If anyone could help me search/make these network kexts, please do so, and post it here. Thank you very much for reading, and have a nice day!
  16. Hey everyone! Please excuse my lack of knowledge, as I'm new to hackintoshing! Anyway, I hackintoshed my HP laptop today and have a few problems with it. Right now, I'm looking for a driver/kext that works with my wireless adapter, which is a Realtek RTL8188EE b/g/n 802.11 adapter. I have already tried the driver that is pinned on this forum, but to no avail. I was hoping that someone can give me a link or an actual driver/kext. Any help is appreciated! Thanks! Nick
  17. hi, I've got a USB WiFi dongle based on a Realtek RTL8188CUS (because my internal Intel WiFi card is not supported) and I installed the official driver from the realtek website. Seems like it's a problem that the latest driver version is for OS X 10.8, because I'm getting kernel panics sometimes when using the driver's WiFi Utility to connect to my wifi. Is there a solution, maybe also a driver which uses the integrated "Wifi Connection Panel" (Dongle is detected as a WiFi device (not as a wired network as it is now) and i can connect to OS X without an additional 3rd party configuration panel). TheXorg
  18. Hello. I though I would start a weekly feature highlighting a great hackintosh utility, a good kext for wll known hardware, a good app for OS X that could or could not be hackintosh related. Anyways, let's start Pretty much every motherboard has ethernet and even in this age of WiFi, people still use it for It's speed and ease of use compared to WiFi. So you definitely need a good kext/driver to use that ethernet adapter and when it comes to Realtek's RTL 8111 series Mieze's RTL8111 kext is the de facto kext considering Realtek, TRENDnet, and Atharos. Specs from Mieze's thread for it here. You can download it from here
  19. Hi, got my yosemite hackintosh working right now, but i have sound problems first headset and mic wasnt working, i installed voodoohda and headset works now, but my microphone not also tried applehda but with this my mic/headset wasnt even detected. my mainboard is a asrock 960gc-gs fx hope u can help me cheers and merry christmas, jack
  20. OK...I am running out of fixes to try from what I'm reading everywhere and I am out of my depth when it comes to the whole AppleHDA.kext patching thing, so I am asking for help. I am new to Mac OS in general and this is my first hackintosh, so I'm a noob here and I'm learning a lot. So far here is my setup on a dual boot Dell Optiplex 7010: -I have Windows 10 running on it's own SSD -I have OS X 10.11.2 running on it's own HDD -I am using legacy boot mode in the BIOS and have the Clover boot loader on the Mac OS drive. -Everything seems to be working great except for audio output/device. I have a Realtek ALC269 as my soundcard driver and I have tried several scripts and kext combinations but nothing seems to work. Under audio devices I have no output devices found, but under input devices I have "Unknown USB audio device" available and it appears to be picking up the mic from my logitech USB camera. (which also works when I open FaceTime) I have verified DPCI Manager that it shows Realtek ALC269 with codecID 0x10EC0269. There is also an Intel HD 4000 Codec with ID 0x80862806 listed with the same Audio Device and Sub Device ID as the RealtekALC269. There is a third device with a different Device ID and Sub ID but everything else is blank on that line. I have also verified in IORegistryExplorer that the HDEF layout-id does = 01 00 00 00. Would anyone be kind enough to help me? If I could get the sound device recognized I'd be fully functioning. Most ALC269 scrips/kexts I find are for laptops or other versions. I can't find one that works for my setup. I am not opposed to making plst or text edits with some guidance I just can't seem to find anything that relates to my particular ALC269 setup. Thanks in advance!
  21. Hi to everybody, After a lot of time and troubles I have a (nearly) fully functional hackintosh. To make this dream real (lol) I need your help in some problems, first of all audio. The audio chip of my mb (signature) is realtek alc1150. I found a lot of guides (most of that on "toleda methods"), but nothing work for me, neither "apple hda audio" or other solutions ! The only admissible (is it?) solution is with vodoohda 2.8.8. Sound was popping and I solved it with the midi configurator of mac os x (i changed Hz). I had it on HDMI, but i can't slide volume down or up, when i plug in headphones the pc doesn't switch automatically the output source and the volume in headphones is ridicolously low. But when i use headphones as output I can slide volume. I tried tipical solutions to solve it, but, again, nothing solved. Another problem is that internal hd (i use it only for storage) is slow. It is formatted in NTFS because I use it also on windows. I really notice its slowness when I modify a song on iTunes (library stored there), I use Tuxera to write on it and I don't know what other file system I can use because there are some files (big sized like games) that I can't move on a fat32 hd. I test vga card and results are better on windows (sigh). What can I do to improve vga performance on mac? How can I optimize all the machine in few words. Thank you very much for all your time I appreciate it. [|OFFTOPIC| I installed and deleted MacFuse (a program for ntfs), but I can't remove panel on settings.]
  22. Realtek ALC650 kext help

    Hi Forum, Does anybody know where I might find a kext that works with the Reatek ALC650 or does anybody know how I can patch my AppleHDA to work with this? My Compaq Presario SR1401NX has iPC OS X 10.5.6 installed,1GB DDR SDRAM with 2.66GHz Intel Celeron D with graphics Intel 82845G Extreme Graphics 64MB (shared memory) works OK (no kext to install) but my sound doesnt work. I tried installing the AC'97 Codec from the customize menu on install but that did not work either . Please help.
  23. ALC887-VD2 Troubles.

    Hello for everyone! Recently I installed El Capitan (in a clean installation because a troubles after install) and I can't enable the audio. In my first installation (update from Yosemite) all was well but a few days, when I reboot, the logo freezes and that's all. In that installation the audio works fine (only the backside ports) BUT in this installation (the clean installation) I can't fix the audio. I tried a many tutorials for fix it but nothing result; also I followed a tutorial for a recognized dev but still not working. I leave my console output and specs of my computer. Please help and enjoy your weekend. CHEERS MY SPECS: Processor: i5 Haswell Graphics: Intel HD 4600 Audio: Realtek ALC887-VD2 LAN: Realtek 8111GR Motherboard: Asus B85M-G R2.0 Salida guardada de la terminal.zip config.plist.zip
  24. Audio - Realtek ALC AppleHDA, El Capitan Update Realtek ALC/Desktop: 269*, 283*, 885, 887, 888, 892, 898 and 1150 on board audio (*BRIX/NUC only) Supports OS X: 10.12, 10.11, 10.10, 10.9 and 10.8 DEPRECATED: See AppleHDA Realtek Audio - AppleHDA - InsanelyMac Forum Enables OS X Realtek ALC on board audio for Intel motherboards. El Capitan requires native AppleHDA.kext. Codec specific script edits binaries and installs specific files. Depending on user requirements, select one Realtek ALC Installation Method. Change Log v3: 8/17/16 - Initial 10.12/Sierra Support/cloverALC, see I. Realtek ALC AppleHDA Scripts v2.6 - 6/16/16 - 10.12 Audio/Temporary Fix, see Post #271, credit pcpaul v2.5 - 4/8/16 - x99/AppleHDA.kext/10.11 support, see 2. X99/Intel High Definition Audio, credit bOLEMO v2.4 -1/25/16 - Uninstall Realtek ALC AppleHDA added v2.3 - 1/18/16 - Audio/ALC Injection verification (Tools 3.) v2.2 - 12/15/15 - audio_pikeralpha-110 (Clover version of Piker Alpha/AppleHDA8Series.sh) v1.1 - 11/28/15 - 100 Series/Skylake (see Unsupported/Non-working Realtek ALC AppleHDA/1. 100 Series, below) and X99 update (see Unsupported/Non-working Realtek ALC AppleHDA/2. X99, below) v1.0 - 10/4/15 - El Captain Support Realtek ALC Installation Methods (Select one method) I. Realtek ALC AppleHDA Scripts Download script (select one script, Download/View Raw) audio_cloverALC.command.zip patch kernel cache no edits to any native AppleHDA.kext file 2-4 files added to Resources folder Clover only audio_realtekALC.command.zip patch kext in place edits AppleHDA.kext binaries and adds files run script after Software Update Chameleon, Clover, Osmosis, others audio_pikeralphaALC.command.zip patch kernel cache native AppleHDA.kext (signed) installs AppleHDAxxx.kext (ex., L/E/AppleHDA892.kext) Not supported: ALC269 and ALC 283 Clover only Double Click Downloads/audio_. . .ALC-110.command Enter Password Answer questions (y/n) Restart II. Piker-Alpha AppleHDA8series Script Download script (see README) Piker-Alpha/AppleHDA8Series.sh (10.10 working, 10.11TBA, 10.11 fix, see below) patch alias no edits to any native AppleHDA.kext file installs AppleHDAxxx.kext (ex., S/L/E/AppleHDA892.kext) Chameleon, Clover, Osmosis, Revoboot, others Terminal (Select one method) Clover/ALC audio $ ./AppleHDA8Series.s ​ALC audio: $ ./AppleHDA8Series.sh -b AppleHDA ALC audio and HD4600 HDMI audio: $ ./AppleHDA8Series.sh -b AppleHDA -b AppleHDAControll Enter Password ... choose desired codec: (1-7) ... layout-id (y/n) Answer questions (y/n) 10.11 fix, see Credit/lisai9093 (below) Restart Requirements OS X versions supported El Capitan/10.11.x Disable SIP: CsrActiveConfig=0x3 ​Yosemite/10.10.x Allow unsigned kexts: kext-dev-mode=1 Mavericks/10.9.x Mountain Lion/10.8.x Intel Desktop motherboards Native AppleHDA (Restore native AppleHDA [Guide].pdf) Audio codec/ALC Injection, see Tools 3. (below), confirms: Supported Codecs, see Realtek Codecs and Applications (below) Supported Audio IDs, see Audio IDs (below) Working Audio ID Injection, Audio ID Injection (below) Realtek Codecs and Applications (Codec/Device_ID/Application/Audio ID(s)/Audio Devices) ALC269/0x10ec0269/BRIX/1/HP, SPDIF ALC283/0x10ec0283/NUC and BRIX Pro/1/HP, Mic ALC885/0x10ec0885/Desktop/1/All ALC889A/same as ALC885 ALC887/0x10ec0887_v003002/Desktop/1 or 2 or 3/All ALC887-L/0x10ec0887_v002002Desktop/1 or 2/All ALC888B/same as ALC887 ALC888/0x10ec0888_v003002/Desktop/1 or 2 or 3/All ALC888-L/0x10ec0888_v002002Desktop/1 or 2/All ALC888S/same as ALC888 ALC889/0x10ec0889/Desktop/1 or 2/All ALC892/0x10ec0892/Desktop/1 or 2 or 3/All ALC898/0x10ec0899/Desktop/1 or 2 or 3/All ALC1150/0x10ec0900/Desktop/1 or 2 or 3/All Audio IDs Audio ID: 1 (motherboard with 3, 5 or 6 audio ports) Stereo (2 inputs, 4 outputs), 5.1 analog surround (3 outputs) and 5.1 digital surround (optical) Front Panel: Pink & GreenMotherboard: Pink, Blue, Green, Orange, Black and SPDIF Audio ID: 2 (motherboard with 3 audio ports, enables analog surround sound)) Stereo (1 input, 4 outputs), 5.1 analog surround (3 outputs) and 5.1 digital surround (optical) Front Panel: Pink & Green Motherboard: Green, Pink (> Orange), Blue (> Black) and SPDIF Audio ID: 3 (Enables HD3000/HD4000/HD5xx HDMI audio) Stereo (2 inputs, 3 outputs/) and 5.1 digital surround (optical) Front Panel: Pink & Green Motherboard: Pink, Blue, Green, Black and SPDIF No Orange support if required, see More Info/2. Customization guide (below) Audio ID Injection, audio_ALCInjection HDEF/kext/no dsdt/HDAEnabler_.kext = Audio_ID HDEF/dsdt/layout-id = Audio_ID HDEF/ssdt/layout-id = Audio_ID, see ssdt_hdef HDEF/Clover/config.plist/Devices/Audio/Inject/Audio_ID HDEF/Chameleon/Extra/org.chameleon.Boot.plist HDAEnabler = Yes HDEFLayoutID = 01000000 or 02000000 or 0300000 Unsupported/Non-working Realtek ALC AppleHDA.kext 100 Series/Intel High Definition Audio (Workaround requires 1, 2, 3 and 4) Rename dsdt/HDAS to HDEF (Select one method) Clover: Download/config-audio_cloverALC-100series.plist.zip Add config.plist/ACPI/DSDT/Patches/Rename HDAS to HDEF ssdt injection (Any bootloader. Select Audio ID and install) Audio ID: 1, ssdt_hdef-1-100-hdas.zip Audio ID: 2, ssdt_hdef-2-100-hdas.zip Audio ID: 3, ssdt_hdef-3-100-hdas.zi Restart Install Realtek ALC Audio (see Realtek ALC Installation Methods) Restart X99/Intel High Definition Audio (Workaround requires 1, 2, 3, 4 and 5), 10.11/credit bOLEMO Rename dsdt/ALSA to HDEF (Select one method) Clover: Download/config-audio_cloverALC-x99.plist.zip Add config.plist/ACPI/DSDT/Patches/Rename ALZA to HDEF ssdt injection (any bootloader): Audio ID: 1, install ssdt_hdef-1-x99_alza.zip Restart Install Realtek ALC Audio (see Realtek ALC Installation Methods) Add x99 HD Audio device_id (Select one method) Clover: Download/config-audio_cloverALC-x99.plist.zip (Select one, appropriate version) Add config.plist/KernelAndKextPatches/KextsToPatch/10.10-10.11+x99-ALC-Onboard-Audio Add config.plist/KernelAndKextPatches/KextsToPatch/110.9.4-10.9.5-x99-ALC-Onboard-Audio Patched AppleHDA.kext (RealtekALC) Double Click/audio_alc_x99-hda-100_patch.command.zip Restart 887_v100101 and earlier Workaround: try 887 Legacy 888_v100101 and earlier Workaround: try 888 Legacy Asus P67H67 3xxx BIOS: Phantom codec Workaround: 2xxx BIOS downgrade, 7/8 Series motherboard upgrade MSI motherboards, pre Sandy Bridge Workaround: 6/7/8 Series motherboard upgrade AC97 (Front Panel) Workaround: HD Audio Front panel More Information audio_ALC_guides Capabilities - Realtek ALC AppleHDA_v2 [Guide].pdf Audio_ID Configurations, Surround sound, audio popping, USB start up problem Customization - Realtek ALC AppleHDA_v2 [Guide].pdf Manual speaker and headphone selection, Substitute SPDIF-2 Wire Output Screenshots - Realtek ALC AppleHDA_v2.pdf System Information/Audio/Intel High Definition Audio, System Preferences/Sound/Output No Audio Devices - Realtek ALC AppleHDA [Guide].pdf No audio devices, no sound, no codec No Sound - Realtek ALC AppleHDA [Guide].pdf Audio devices present, no sound when selected No Audio After Sleep/Wake - Realtek ALC AppleHDA [Fixes].pdf No audio devices on wak Surround Sound - Realtek ALC - AppleHDA [Guide].pdf Players, analog, optical Uninstall Realtek ALC AppleHDA cloverALC, remove: S/L/E/AppleHDA.kext and install the native AppleHDA.kext or S/L/E/AppleHDA.kext/Contents/Resources/layout1.zml.zlib, layout2.zml.zlib, layout3.zml.zlib, Platforms.zml.zlib config.plist/.../KextsToPatch/AppleHDA (3x) EFI/CLOVER/kexts/10.xx or other/realtekALC.kext pikeralphaALC, remove: L/E/AppleHDA8xx.kext config.plist/.../KextsToPatch/AppleHDA (3x) realtekALC, remove: S/L/E/AppleHDA.kext and install the native AppleHDA.kext pikeralpha AppleHDA8Series, remove: S/L/E/AppleHDA8xx.kext and install the native AppleHDA.kext Tools IORegistry Explorer (choose one) IORegistryExplorer_v2.1.zip (View Raw) IOJones DPCIManager Audio/ALC Injection: audio_codecdetect.command.zip (select View Raw, double click) MaciASL Problem Reporting Description of audio problem OS X version/motherboard model/BIOS version/processor/graphics Procedure/Guide Used Audio/ALC Injection (Tools 3.) Double click/Downloads/audio_codecdetect.command Terminal/Shell/File/Export Text As. . Copy of IOReg - IOReg_v2.1/File/Save a Copy As…, verify file (Tools 1.) Copy Of Console/All Messages (last boot)/File/Save a Copy As.. Installed S/L/E/AppleHDA.kext or AppleHDA8Series AppleHDAxxx kext Screen shots: DPCIManager/Status (Tools 2.) System Information/Hardware/Audio/Intel High Definition Audio (not Devices) Terminal/Shell/Export Test As. . . (if script used) audio_realtekALC-100.command AppleHDA8Series.sh audio_cloverALC-100.command Chameleon Extra/org.chameleon.Boot.plist DPCIManager/Misc/Boot Log (Tools 2.) Extra/dsdt.aml (if installed) Extra/ssdt.aml (if installed Clover EFI/Clover/config.plist DPCIManager/Misc/Boot Log (Tools 2.) EFI/Clover/ACPI/Patched/dsdt.aml (if installed) EFI/Clover/ACP Patched/ssdt.aml (if installed) Credit bOLEMO, post #196, El Capitan: Realtek ALC AppleHDA Audio lisai9093, Post #5, AppleHDA for El Capitan discussion THe KiNG [HOW TO] Patch AppleHDA - Knowledge Base - Project OS X Forums PikeRAlpha New style of AppleHDA.kext patching for Yosemite | Pike's Universum abxite http://applelife.ru/...06/#post-353647 TimeWalker75a, Post # 20, No sound after waking from sleep RevoGirl
  25. I'm trying to install the driver for EP-N8508 to be used on Yosemite, but all the drivers get installed, the Wireless Utility App crashes without launching. Any idea what is happening and how to fix it?