Jump to content

Experimental Atheros AR81(31/32/51/52/61/62/71/72) Driver for 10.7/10.8


153 posts in this topic

Recommended Posts

Shailua, you are a genius! :)


I haven't had time to test this out yet, but will be doing so shortly with my Atheros AR8161 Lan card in this Asus N56VM I have and will post my results!


Can't wait to test it out, actually gave up on running OSX on this laptop due to the Ethernet not being supported so this gives me new hope!


Now if I could only convince you to try and port over support for this Intel wireless card as well... :)


I second the request for Shailua. Intel Centrino wifi 2230. :). Keep up the great work Shailua.

Link to comment
Share on other sites

Hi all,


under big load, crash with the kext with GA Z77 DS3H.


I was able to reproduce the crash 3 times.

Like it was a memory leak


i use an old kext AtherosL1cEthernet.kext, no crash, but pb with network browsing/discovering



Is there another version > 1.0.2 to fix the issues ?




I get crashes under load as well. I haven't found a fix yet, sorry. Z77-DS3H 1.1

  • Like 1
Link to comment
Share on other sites

I got very strange ALX Ethernet crashes on 10.8.2 and H77-D3H.


For example, I can download and seed torrents all day and night at 100 Mbps without any crashes. But when I play World of Tanks with Skype and media server running at the same time I got kernel panic. Once I got 3 crashes in 5 minutes at same circumstances, just started Skype, media server and WoT. Maybe driver cannot handle several opened ports and simultaneous connections.


Then I downloaded at googlecode alx sources, upgraded the project from SDK 10.7 to 10.8, validated project to recommended settings and compiled only x86_64 version (ML don't need x86 code). Got kext twice smaller than the original one.

Today it will be 10 days after install of recompiled kext and no kernel panics happened. Will test harder to see if kernel panic will happen in future.

Link to comment
Share on other sites

I have asus N56VZ too. Working perfectly however VMWARE isnt working in promiscuous mode to use bridged networking.

This is important, In the past there were similar issues with intel kextst ive heard but it was fixed. I dont know how. Do you know how to fix the promiscuous problem? Vmware images with windows cant get ip addresses in bridged mode. Nat is working but double nat is a problem for windows VM's. This is not a VMWare issue ! Latest VMWARE and different VMWare used in WIndows VM (Standard and enhanced)

Link to comment
Share on other sites

  • 2 weeks later...

Also got random exactly the same kernel panic under high load and multiple programs accessing network.

Is there another drivers i can use instead of ALXEthernet.kext for Atheros AR8161? Sometimes it's drivin me crazy with 2 KP in 5 minutes.


Hi, tried to install the kext v1.0.2 included in [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] but i'm getting a kernal panic. It usually happens when there is a high network load, with different programs trying to acces the web.


Photo: http://imageshack.us.../photo3ohl.jpg/



i3 3220


4gb memory


Hope you can fix it, cause there aren't good alternatives.

  • Like 1
Link to comment
Share on other sites

  • 2 weeks later...

Strange :)


i got AtherosL1cEthernet.kext source code v 1.2.3


with xcode, i upgraded the project from SDK 10.7 to 10.8


compile and tadatdatda


bonjour is now working flawless after sleep/wake on Z77 DS3H 1.0

and i've got network speed @ 108MB/s :)


the kext was compiled in debug mode, so ive got debug strings on console, but it doesnt matter at all


autosleep is working


i've tried several times, it seems ok.


Let see over time if its ok, perhaps Bonjour Issues was only an SDK issue


wait and see carefully



Could you possibly share your updated kext. I have the same problems you reported. I can only transfer files over my network at about 1-5mb/s, until the system freezes. Its driving me crazy.
Link to comment
Share on other sites

Works here not only with 10.8.3, but 10.8.4 (first beta) as well.


If I install 10.8.4 AR8161 will work?


PS, I have Chameleon booloader. If possible that with chimera AR8151 work in 10.8.2?


EDIT: Now, my Ethernet WORK with #####

Link to comment
Share on other sites

  • 2 weeks later...

I'm also getting random freezes under high network load with ALXEthernet 1.0.2 on ML 10.8.2.


I tried installing

AtherosL1cEthernet.kext 1.2.3, but it doesn't seem to load. I tried putting the kext in /System/Library/Extensions as well as /System/Library/Extension/IONetworkingFamily.kext/Contents/PlugIns/ but it didn't load.


My motherboard is a Gigabyte Z77-DS3H rev 1.1 with the Atheros AR8161 controller.

  • Like 1
Link to comment
Share on other sites

work on TOSHIBA L855-S558 laptop. 10.8.0 Use ##### to install under /S/L/E ( not under /System/Library/Extensions/IONetworkingFamily.kext/Contents/PlugIns like some others) but it appear to be working.

Originally, I install AtherosL1cEthernet.kext (add BuildinEtherner=Yes in org.chameleon.Boot.plist) but it did not work. then I realize 1969:1091 is AR8161 not AR8151 so I switch to ALXEthernet.kext. That it is. At this moment my internet connect is using this kext.


Link to comment
Share on other sites

Hi guys, ALXEthernet 1.0.2 on Mac OS 10.7.5.. it "works" but is very unstable. Really turning me off even using the computer as Kernel Panics have become so frequent.


Sometimes happens while doing random computer tasks, but once it has happened at boot time, screenshots attached.


Purchasing a PCI NIC is not an option as all my PCI slots are used by other cards. I would be willing to donate a modest amount to fund the project.



Link to comment
Share on other sites

My device:

Name: Qualcomm Atheros AR8161 Gigabit Ethernet
 Typ: ethernet
 Bus: PCI
 Hersteller-ID: 0x1969
 Geräte-ID: 0x1091
 Subsystem-Hersteller-ID: 0x1458
 Subsystem-ID: 0xe000
 Versions-ID: 0x0010
 Link-Breite: x1
 BSD-Name: en0
 Kext-Name: ALXEthernet.kext
 Ort: /System/Library/Extensions/ALXEthernet.kext
 Version: 1.0.2


The speed of the driver is nice. Worked so far but after a while of heavy file transfer (creating a TimeMachine Backup to NAS) the kernel always panics:

Interval Since Last Panic Report:  6128 sec
Panics Since Last Report:		  2
Anonymous UUID:				    57DEA0E0-1431-57DB-2C14-AE56B7CE255F
Thu May 16 15:45:01 2013
panic(cpu 1 caller 0xffffff800022e2a6): "thread_invoke: preemption_level 1, possible cause: blocking while holding a spinlock, or within interrupt context"@/SourceCache/xnu/xnu-2050.22.13/osfmk/kern/sched_prim.c:2026
Backtrace (CPU 1), Frame : Return Address
0xffffff81d95dba90 : 0xffffff800021d626
0xffffff81d95dbb00 : 0xffffff800022e2a6
0xffffff81d95dbb80 : 0xffffff800022da0c
0xffffff81d95dbbc0 : 0xffffff80002b1bd7
0xffffff81d95dbc10 : 0xffffff80002ad08d
0xffffff81d95dbc30 : 0xffffff80005724e4
0xffffff81d95dbcc0 : 0xffffff800058b8f3
0xffffff81d95dbd70 : 0xffffff7f821de996
0xffffff81d95dbdc0 : 0xffffff7f81091385
0xffffff81d95dbe00 : 0xffffff8000647444
0xffffff81d95dbe50 : 0xffffff7f81091467
0xffffff81d95dbe70 : 0xffffff7f810908a7
0xffffff81d95dbed0 : 0xffffff7f8109079d
0xffffff81d95dbef0 : 0xffffff80006467a8
0xffffff81d95dbf30 : 0xffffff80006452aa
0xffffff81d95dbf80 : 0xffffff80006453d9
0xffffff81d95dbfb0 : 0xffffff80002b2977
  Kernel Extensions in backtrace:
	    dependency: com.apple.iokit.IONetworkingFamily(3.0)[FE3163C6-2874-3843-A96F-5DB796ED27CA]@0xffffff7f81080000
	    dependency: com.apple.iokit.IOPCIFamily(2.7.3)[1D668879-BEF8-3C58-ABFE-FAC6B3E9A292]@0xffffff7f80844000
BSD process name corresponding to current thread: kernel_task
Boot args: npci=0x2000 slide=0
Mac OS version:
Kernel version:
Darwin Kernel Version 12.3.0: Sun Jan  6 22:37:10 PST 2013; root:xnu-2050.22.13~1/RELEASE_X86_64
Kernel UUID: 3EB7D8A7-C2D3-32EC-80F4-AB37D61492C6
System model name: iMac12,2 (Mac-942B59F58194171B)
System uptime in nanoseconds: 3146115022615
last loaded kext at 2793011961104: com.apple.filesystems.msdosfs 1.8 (addr 0xffffff7f822e8000, size 65536)
last unloaded kext at 307828758222: com.apple.filesystems.msdosfs 1.8 (addr 0xffffff7f822da000, size 57344)
loaded kexts:
org.hwsensors.driver.CPUSensors 249
org.virtualbox.kext.VBoxNetAdp 4.2.12
org.virtualbox.kext.VBoxNetFlt 4.2.12
org.virtualbox.kext.VBoxUSB 4.2.12
org.virtualbox.kext.VBoxDrv 4.2.12
com.insanelymac.ALXEthernet 1.0.2
org.netkas.driver.FakeSMC 480
com.apple.filesystems.msdosfs 1.8
com.apple.filesystems.afpfs 10.0
com.apple.nke.asp_tcp 7.0.0
com.apple.driver.AppleHWSensor 1.9.5d0
com.apple.filesystems.autofs 3.0
com.apple.iokit.IOBluetoothSerialManager 4.1.3f3
com.apple.driver.AudioAUUC 1.60
com.apple.filesystems.ntfs 3.10
com.apple.driver.AGPM 100.12.87
com.apple.driver.AppleHDA 2.3.7fc4
com.apple.iokit.IOUserEthernet 1.0.0d1
com.apple.Dont_Steal_Mac_OS_X 7.0.0
com.apple.driver.ApplePolicyControl 3.3.0
com.apple.driver.AppleUSBDisplays 357
com.apple.driver.AppleLPC 1.6.0
com.apple.GeForce 8.1.0
com.apple.driver.AppleUpstreamUserClient 3.5.10
com.apple.driver.AppleMCCSControl 1.1.11
com.apple.driver.ACPI_SMC_PlatformPlugin 1.0.0
com.apple.driver.AppleIntelFramebufferCapri 8.1.0
com.apple.iokit.SCSITaskUserClient 3.5.5
com.apple.AppleFSCompression.AppleFSCompressionTypeDataless 1.0.0d1
com.apple.AppleFSCompression.AppleFSCompressionTypeZlib 1.0.0d1
com.apple.BootCache 34
com.apple.driver.XsanFilter 404
com.apple.iokit.IOAHCIBlockStorage 2.3.1
com.apple.driver.AppleUSBHub 5.5.5
com.apple.driver.AppleUSBXHCI 5.5.5
com.apple.driver.AppleAHCIPort 2.5.1
com.apple.driver.AppleUSBEHCI 5.5.0
com.apple.driver.AppleEFINVRAM 1.7
com.apple.driver.AppleACPIButtons 1.7
com.apple.driver.AppleRTC 1.5
com.apple.driver.AppleHPET 1.8
com.apple.driver.AppleSMBIOS 1.9
com.apple.driver.AppleAPIC 1.6
com.apple.driver.AppleIntelCPUPowerManagementClient 196.0.0
com.apple.nke.applicationfirewall 4.0.39
com.apple.security.quarantine 2
com.apple.driver.AppleIntelCPUPowerManagement 196.0.0
com.apple.security.SecureRemotePassword 1.0
com.apple.kext.triggers 1.0
com.apple.driver.DspFuncLib 2.3.7fc4
com.apple.iokit.IOSurface 86.0.4
com.apple.iokit.IOBluetoothFamily 4.1.3f3
com.apple.driver.AppleGraphicsControl 3.3.0
com.apple.driver.AppleUSBAudio 2.9.0f6
com.apple.iokit.IOAudioFamily 1.8.9fc11
com.apple.kext.OSvKernDSPLib 1.6
com.apple.nvidia.gk100hal 8.1.0
com.apple.driver.AppleSMBusController 1.0.11d0
com.apple.iokit.IOSMBusFamily 1.1
com.apple.NVDAResman 8.1.0
com.apple.driver.AppleHDAController 2.3.7fc4
com.apple.iokit.IOHDAFamily 2.3.7fc4
com.apple.driver.AppleSMC 3.1.4d2
com.apple.driver.IOPlatformPluginLegacy 1.0.0
com.apple.driver.IOPlatformPluginFamily 5.3.0d51
com.apple.iokit.IOSerialFamily 10.0.6
com.apple.iokit.IONDRVSupport 2.3.7
com.apple.iokit.IOGraphicsFamily 2.3.7
com.apple.driver.AppleUSBHIDKeyboard 170.2
com.apple.driver.AppleHIDKeyboard 170.2
com.apple.iokit.IOUSBHIDDriver 5.2.5
com.apple.driver.AppleUSBMergeNub 5.5.5
com.apple.driver.AppleUSBComposite 5.2.5
com.apple.iokit.IOSCSIMultimediaCommandsDevice 3.5.5
com.apple.iokit.IOBDStorageFamily 1.7
com.apple.iokit.IODVDStorageFamily 1.7.1
com.apple.iokit.IOCDStorageFamily 1.7.1
com.apple.iokit.IOAHCISerialATAPI 2.5.1
com.apple.iokit.IOSCSIArchitectureModelFamily 3.5.5
com.apple.iokit.IOUSBUserClient 5.5.5
com.apple.iokit.IONetworkingFamily 3.0
com.apple.iokit.IOAHCIFamily 2.3.1
com.apple.iokit.IOUSBFamily 5.5.5
com.apple.driver.AppleEFIRuntime 1.7
com.apple.iokit.IOHIDFamily 1.8.1
com.apple.security.sandbox 220.2
com.apple.kext.AppleMatch 1.0.0d1
com.apple.security.TMSafetyNet 7
com.apple.driver.DiskImages 345
com.apple.iokit.IOStorageFamily 1.8
com.apple.driver.AppleKeyStore 28.21
com.apple.driver.AppleACPIPlatform 1.7
com.apple.iokit.IOPCIFamily 2.7.3
com.apple.iokit.IOACPIFamily 1.4
com.apple.kec.corecrypto 1.0
Model: iMac12,2, BootROM IM122.0047.B1F, 4 processors, Intel Core i5, 3.40 GHz, 24 GB, SMC 1.72f2
Graphics: NVIDIA GeForce GTX 660 Ti, NVIDIA GeForce GTX 660 Ti, PCIe, 3072 MB
Memory Module: BANK1/DIMM0, 8 GB, DDR3, 1333 MHz, 029E, CML16GX3M2A1600C10
Memory Module: BANK0/DIMM1, 8 GB, DDR3, 1600 MHz, Corsair, CML16GX3M2A1600C10
Memory Module: BANK1/DIMM1, 8 GB, DDR3, 1600 MHz, Corsair, CML16GX3M2A1600C10
Network Service: ALX, Ethernet, en0
Serial ATA Device: Samsung SSD 840 Series, 500,11 GB
Serial ATA Device: PIONEER DVD-RW  DVR-220
USB Device: hub_device, 0x8087  (Intel Corporation), 0x0024, 0x1d100000 / 2
USB Device: hub_device, 0x8087  (Intel Corporation), 0x0024, 0x1a100000 / 2
USB Device: USB Gaming Mouse, 0x046d  (Logitech Inc.), 0xc049, 0x1a130000 / 5
USB Device: Keyboard Hub, apple_vendor_id, 0x1006, 0x1a140000 / 4
USB Device: Apple Keyboard, apple_vendor_id, 0x0250, 0x1a142000 / 6
USB Device: hub_device, apple_vendor_id, 0x9126, 0x1a150000 / 3
USB Device: Apple LED Cinema Display, apple_vendor_id, 0x9226, 0x1a156000 / 9
USB Device: Display Audio, apple_vendor_id, 0x1105, 0x1a154000 / 8
USB Device: Display iSight, apple_vendor_id, 0x8508, 0x1a155000 / 7

  • Like 1
Link to comment
Share on other sites

  • 4 weeks later...

it works with my Z77-DS3H (AR8161). however when i use vmware fusion 5.02 , the virtual machine with ' the bridged mode network" does not work .(Good with NAT mode)


I tried the vmware troubleshooting (http://kb.vmware.com/selfservice/microsites/search.do?cmd=displayKC&externalId=1016466).

saying "Change your adapter from NAT to Bridged, or vice-versa. If one selection works, and the other does not, then the problem is with your network and not with Fusion or your virtual machine. "


any suggestions? thanks.

Link to comment
Share on other sites

it works with my Z77-DS3H (AR8161). however when i use vmware fusion 5.02 , the virtual machine with ' the bridged mode network" does not work .(Good with NAT mode)

I have some issue! Using Wi-Fi card from TP-Link for bridged networks

And I got 2 KP when copying many files from my Synology NAS

Link to comment
Share on other sites

  • 1 month later...

with my GA Z77-DS3H rev 1.1 cant make iMessage work.

think is something with network card, can some one confirm this problem?






Same trouble here, with error : [ALXEthernet] Hardware Error: error(2) when reset mac

To solve this, i desactivate "Bonjour" and all runs fine.



Link to comment
Share on other sites


  • Create New...