Jump to content

Nvidia Web Driver updates for macOS High Sierra (UPDATE 10/06/2017)

nvidia web driver

  • Please log in to reply
657 replies to this topic

#641
driftwood

driftwood

    InsanelyMac Protégé

  • Members
  • Pip
  • 45 posts
  • Gender:Male
  • Interests:Gigabyte Z170X Gaming G1, 64GB RAM Corsair vengeance, 2TB Samsung SSD, NVME 951 512Gb, GTX1080Ti...

Spotted! https://images.nvidi...0.10.15.120.pkg

 

All I did was open and mount EFI and open your EFi/config.plist inside clover configurator, enable SIP in Rt Variables panel (ie CsrActiveConfig= 0x00) save your config and reboot. When you're back in, install nvidia driver, DONT REBOOT, open clover again and change CsrActiveConfig back to 0x67. Now reboot. Polish up CUDA if required. Done.

Enjoy 
Metal: Supported, feature set OSX_GPUFamily1 v2



#642
sl0wtarget

sl0wtarget

    InsanelyMac Protégé

  • Members
  • Pip
  • 27 posts

Ya beat me to it! :thumbsup_anim:



#643
Badruzeus

Badruzeus

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 534 posts
  • Gender:Male
  • Location:Indonesia
  • Interests:Graphics Design.

You guys, awesome..!!!  :thumbsup_anim: Thanks.

 

Spoiler



#644
scj312

scj312

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 690 posts
  • Gender:Male
  • Location:Indianapolis

Updated and all is well. Doesn't fix the black screen issue I and others have run into (however I do have a workaround thanks to some trial and error and cyberdevs that may not help every scenario).

 

Installed with SIP enabled (using Clover boot menu to temporarily disable without plist edits) and Clover AGDP patch, and didn't need EmuVariableEfi, NVWebDriverLibValFix, or NvidiaGraphicsFixup.



#645
SavageAUS

SavageAUS

    What u lookn at?

  • Members
  • PipPipPipPipPipPipPipPip
  • 1,165 posts
  • Gender:Male

Hi sorry if this is obsolete or off-topic but I've got my Nvidia GTX 1050 working with 10.13.1 beta2 without lilu.kext and other things

I just put this in Clover's KextsToPatch

<dict>
 <key>Comment</key>
 <string>AppleGraphicsDevicePolicy (board-id) Patch (c) Pike R. Alpha</string>
 <key>Disabled</key>
 <false/>
 <key>Find</key>
 <data>
 Ym9hcmQtaWQ=
 </data>
 <key>Name</key>
 <string>AppleGraphicsDevicePolicy</string>
 <key>Replace</key>
 <data>
 Ym9hcmQtaXg=
 </data>
 </dict>
I found this on Piker's blog on internet.
In xcode or configurator.

Sent from my SM-G930F using Tapatalk

#646
Pavo

Pavo

    InsanelyMac Legend

  • Developers
  • 545 posts
  • Gender:Male
  • Location:Fort Gordon, GA

In xcode or configurator.

Sent from my SM-G930F using Tapatalk

Well since its a Find and Replace that would tell you that its Clover config file



#647
SavageAUS

SavageAUS

    What u lookn at?

  • Members
  • PipPipPipPipPipPipPipPip
  • 1,165 posts
  • Gender:Male

Well since its a Find and Replace that would tell you that its Clover config file

I know what file it is but it can be opened with xcode and clover configurator and the values would be different.

Sent from my SM-G930F using Tapatalk

#648
Pavo

Pavo

    InsanelyMac Legend

  • Developers
  • 545 posts
  • Gender:Male
  • Location:Fort Gordon, GA

I know what file it is but it can be opened with xcode and clover configurator and the values would be different.

Sent from my SM-G930F using Tapatalk

well of course it would, xcode display it as 64base encoded and Clover configurator displays it as Hex



#649
corint1

corint1

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts
  • Gender:Male
  • Location:Bucuresti, ROMANIA

how resolve you sound delay on hdmi with 1050 ?  new driver not help and anybody dont talk about this issue ... thank you 

 

 

Hi sorry if this is obsolete or off-topic but I've got my Nvidia GTX 1050 working with 10.13.1 beta2 without lilu.kext and other things

 

I just put this in Clover's KextsToPatch

<dict>
 <key>Comment</key>
 <string>AppleGraphicsDevicePolicy (board-id) Patch (c) Pike R. Alpha</string>
 <key>Disabled</key>
 <false/>
 <key>Find</key>
 <data>
 Ym9hcmQtaWQ=
 </data>
 <key>Name</key>
 <string>AppleGraphicsDevicePolicy</string>
 <key>Replace</key>
 <data>
 Ym9hcmQtaXg=
 </data>
 </dict>

I found this on Piker's blog on internet.



#650
vivo2016

vivo2016

    InsanelyMac Protégé

  • Members
  • Pip
  • 22 posts

I pasted it in Clover's config.plist with macOS TextEditor



#651
chris1111

chris1111

    Packager

  • Donators
  • 4,266 posts
  • Gender:Male
  • Location:Montreal Canada
  • Interests:Mac OS X Packaging / scripts

How much package WebDriver-378.10.10.10.15.120.pkg exist ??  :wacko:

And is this for HS (17A405) ?



#652
pbryanw

pbryanw

    InsanelyMac Protégé

  • Members
  • Pip
  • 17 posts

Hi, I was having an occasional instant-reboot on startup problem with my Nvidia graphics card (it happened just as my GPU was being initialised during boot).

 

I now think this was caused on my system by macOS sometimes falling back on the older, out-of-date, Nvidia drivers in S/L/E rather than the newly installed web ones in L/E.
 
To fix this, I disabled Nvidia Graphics injection in Clover by adding this to config.plist:

<key>Graphics</key>
<dict>
	<key>Inject</key>
	<dict>
	  	<key>Nvidia</key>
  		<false/>
	</dict>
</dict>

I had this problem on my hackintosh, which consists of a GTX 1070 with an Asus Ranger VIII Z170 motherboard. I've had no instant reboots since adding this code. Hope this might help someone :)



#653
fabiosun

fabiosun

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPipPip
  • 1,308 posts
  • Gender:Male

yes install fine in 17A405 without any info.plist modify

 

How much package WebDriver-378.10.10.10.15.120.pkg exist ??  :wacko:

And is this for HS (17A405) ?



#654
Fergarth

Fergarth

    I feel the apple's maggots inside me

  • Members
  • PipPipPipPipPip
  • 325 posts
  • Gender:Male
  • Location:Portugal

yes install fine in 17A405 without any info.plist modify

I was trying out again and this time I installed 10.13.1 beta 2 without any problem. But I'm not able to edit the Nvidia Installer (remove the check OS version). There is something wrong with the commands (to open and close pkg) on ​​the terminal or im not doing something well 😔

#655
fabiosun

fabiosun

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPipPip
  • 1,308 posts
  • Gender:Male

copy driver on desktop

pkgutil --expand /Users/fabio/Desktop/WebDriver-378.10.10.10.15.117.pkg fer

 

do modify in distribution file

 

copy fer from users folder (name I choose for driver expansion folder) on desktop

then

pkgutil --flatten /Users/fabio/Desktop/fer driverrrr.pkg

 

 

then you should find in user folder  driverrrrr.pkg

 

 

I was trying out again and this time I installed 10.13.1 beta 2 without any problem. But I'm not able to edit the Nvidia Installer (remove the check OS version). There is something wrong with the commands (to open and close pkg) on ​​the terminal or im not doing something well



#656
UltraLaser

UltraLaser

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 453 posts
  • Gender:Male
  • Location:Italy
1080ti owners : does work sleep mode? Have u instant wake?

#657
Kynyo

Kynyo

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 570 posts
  • Gender:Male

New driver available!  c0e821d733.png



#658
sl0wtarget

sl0wtarget

    InsanelyMac Protégé

  • Members
  • Pip
  • 27 posts

New driver available! 

Pssst!







Also tagged with one or more of these keywords: nvidia web driver


21 user(s) are reading this topic

5 members, 15 guests, 1 anonymous users


© 2017 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy