Jump to content

Experimental Atheros AR81(31/32/51/52/61/62/71/72) Driver for 10.7/10.8

Atheros

  • Please log in to reply
140 replies to this topic

#41
the_gael

the_gael

    not a complete idiot - some parts are missing

  • Members
  • PipPipPip
  • 113 posts
  • Gender:Male
Hello Shailua and thank you for your work! I tried your kext as it is included in ###### 5.2 and I had no trouble loading it and everything appeared fine until I used a VPN connection.

My board is Gigabyte Z77X-UD5H F14 and I am using Chimera as bootloader.

My problem is that after disconnecting the VPN yunnel my ethernet no longer works. I still have an IP address and I can renew the lease from the DHCP server but internet just does not work. I then have to reboot the machine in order to regain functionality. This behaviour is intermittent with the fault appearing somewhere between 30-40% of the time after closing a VPN tunnel. On my post on the subject over at tonymacx86.com I notice another user has reported inability to connect using the driver when the VPN is configured on his router. In his case removing the VPN from the router addressed his issue or using maolj's kext also addressed the issue.

In my case I also had slow performance over VPN using your kext from ###### 5.2. Reverting to maolj's kext resolved my connection problems and the slow speed over VPN issue.

Are you aware of issues using VPN? I am happy to load the kext again and provide verbose output if it will help.

edited to add - Shailua I just spotted that where the word _Multi_beast_ is hashes have replaced the letters in my post - but version 5.2 of that is what I am using.

Edited by the_gael, 15 December 2012 - 03:32 PM.


#42
tanguy_k

tanguy_k

    InsanelyMac Protégé

  • Members
  • Pip
  • 23 posts
That would be nice to see this on github

#43
Tauio111

Tauio111

    InsanelyMac Protégé

  • Members
  • PipPip
  • 96 posts
  • Gender:Male
  • Location:Estonia
Looks nice, but for some reason I cant change my MAC address in any way. I need it to connect to the internet because my ISP only allows connection from certain MAC address. The AtherosL1c kext doesnt connect after wake from sleep, but allows the MAC address to be changed.

#44
the_gael

the_gael

    not a complete idiot - some parts are missing

  • Members
  • PipPipPip
  • 113 posts
  • Gender:Male
is this driver still being developed - is there somewhere where we can feedback on what does not work?

#45
JamerTheProgrammer

JamerTheProgrammer

    InsanelyMac Protégé

  • Members
  • PipPip
  • 69 posts
  • Gender:Male
  • Location:In the zone
  • Interests:Programming, mucking about with Linux and making Hackintoshes!
It would be awesome if these worked. It recognises the card in system report (This is under Lion) but it doesnt show up in Network under System Preferences :(

#46
JamerTheProgrammer

JamerTheProgrammer

    InsanelyMac Protégé

  • Members
  • PipPip
  • 69 posts
  • Gender:Male
  • Location:In the zone
  • Interests:Programming, mucking about with Linux and making Hackintoshes!
Realised I didnt install them properly. I tried installing them and I get the error:
System extension cannot be used

#47
MrWouter

MrWouter

    InsanelyMac Protégé

  • Members
  • Pip
  • 4 posts
Hi, tried to install the kext v1.0.2 included in ##### but i'm getting a kernal panic. It usually happens when there is a high network load, with different programs trying to acces the web.

Photo: http://imageshack.us.../photo3ohl.jpg/

Specs:
i3 3220
z77x-d3h
4gb memory

Hope you can fix it, cause there aren't good alternatives.

#48
aankun.ganteng

aankun.ganteng

    InsanelyMac Protégé

  • Members
  • Pip
  • 33 posts
  • Gender:Male
  • Location:Bali, Indonesia
Thanks for the kext.
Just reporting it's working on my laptop (Asus N56VZ with AR8161)
Didn't find issue so far :thumbsup_anim:
Attached File  Screen Shot 2013-02-10 at 8.21.56 AM.png   423.03KB   66 downloads

#49
ovof

ovof

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 239 posts
Hi all,

under big load, crash with the kext with GA Z77 DS3H.

I was able to reproduce the crash 3 times.
Like it was a memory leak

i use an old kext AtherosL1cEthernet.kext, no crash, but pb with network browsing/discovering


Is there another version > 1.0.2 to fix the issues ?

regards

#50
ovof

ovof

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 239 posts
Strange :)

i got AtherosL1cEthernet.kext source code v 1.2.3

with xcode, i upgraded the project from SDK 10.7 to 10.8

compile and tadatdatda

bonjour is now working flawless after sleep/wake on Z77 DS3H 1.0
and i've got network speed @ 108MB/s :)

the kext was compiled in debug mode, so ive got debug strings on console, but it doesnt matter at all

autosleep is working

i've tried several times, it seems ok.

Let see over time if its ok, perhaps Bonjour Issues was only an SDK issue

wait and see carefully

Epal

#51
Anqa Singh

Anqa Singh

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts
  • Gender:Male

Shailua, you are a genius! :)

I haven't had time to test this out yet, but will be doing so shortly with my Atheros AR8161 Lan card in this Asus N56VM I have and will post my results!

Can't wait to test it out, actually gave up on running OSX on this laptop due to the Ethernet not being supported so this gives me new hope!

Now if I could only convince you to try and port over support for this Intel wireless card as well... :)


I second the request for Shailua. Intel Centrino wifi 2230. :). Keep up the great work Shailua.

#52
palebluedot

palebluedot

    InsanelyMac Protégé

  • Members
  • Pip
  • 21 posts

Hi all,

under big load, crash with the kext with GA Z77 DS3H.

I was able to reproduce the crash 3 times.
Like it was a memory leak

i use an old kext AtherosL1cEthernet.kext, no crash, but pb with network browsing/discovering


Is there another version > 1.0.2 to fix the issues ?

regards


I get crashes under load as well. I haven't found a fix yet, sorry. Z77-DS3H 1.1

#53
V1tol

V1tol

    InsanelyMac Protégé

  • Members
  • Pip
  • 3 posts
  • Gender:Male
I got very strange ALX Ethernet crashes on 10.8.2 and H77-D3H.

For example, I can download and seed torrents all day and night at 100 Mbps without any crashes. But when I play World of Tanks with Skype and media server running at the same time I got kernel panic. Once I got 3 crashes in 5 minutes at same circumstances, just started Skype, media server and WoT. Maybe driver cannot handle several opened ports and simultaneous connections.

Then I downloaded at googlecode alx sources, upgraded the project from SDK 10.7 to 10.8, validated project to recommended settings and compiled only x86_64 version (ML don't need x86 code). Got kext twice smaller than the original one.
Today it will be 10 days after install of recompiled kext and no kernel panics happened. Will test harder to see if kernel panic will happen in future.

#54
Kock Ronwell

Kock Ronwell

    InsanelyMac Protégé

  • Donators
  • 75 posts
  • Gender:Male
  • Location:Sint Oedenrode
  • Interests:MAC OSX and Apps | Hackintosh | Hardware | Gadgets | Tits, Cameltows and Asses
I have asus N56VZ too. Working perfectly however VMWARE isnt working in promiscuous mode to use bridged networking.
This is important, In the past there were similar issues with intel kextst ive heard but it was fixed. I dont know how. Do you know how to fix the promiscuous problem? Vmware images with windows cant get ip addresses in bridged mode. Nat is working but double nat is a problem for windows VM's. This is not a VMWare issue ! Latest VMWARE and different VMWare used in WIndows VM (Standard and enhanced)

#55
Alex Yankee

Alex Yankee

    InsanelyMac Protégé

  • Members
  • Pip
  • 9 posts
Also got random exactly the same kernel panic under high load and multiple programs accessing network.
Is there another drivers i can use instead of ALXEthernet.kext for Atheros AR8161? Sometimes it's drivin me crazy with 2 KP in 5 minutes.

Hi, tried to install the kext v1.0.2 included in ##### but i'm getting a kernal panic. It usually happens when there is a high network load, with different programs trying to acces the web.

Photo: http://imageshack.us.../photo3ohl.jpg/

Specs:
i3 3220
z77x-d3h
4gb memory

Hope you can fix it, cause there aren't good alternatives.



#56
eddypoon

eddypoon

    InsanelyMac Protégé

  • Members
  • Pip
  • 9 posts
Thank you Shailua . We appreciate it much.

#57
voxxdigital

voxxdigital

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 105 posts
Shailua - thanks for your effort - however is it possible to complie the kext to be used with Snow Leopard? I'm desperately needing it... thanks...

#58
rocksalt26

rocksalt26

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts

Strange :)

i got AtherosL1cEthernet.kext source code v 1.2.3

with xcode, i upgraded the project from SDK 10.7 to 10.8

compile and tadatdatda

bonjour is now working flawless after sleep/wake on Z77 DS3H 1.0
and i've got network speed @ 108MB/s :)

the kext was compiled in debug mode, so ive got debug strings on console, but it doesnt matter at all

autosleep is working

i've tried several times, it seems ok.

Let see over time if its ok, perhaps Bonjour Issues was only an SDK issue

wait and see carefully

Epal

Could you possibly share your updated kext. I have the same problems you reported. I can only transfer files over my network at about 1-5mb/s, until the system freezes. Its driving me crazy.

#59
Kikobeats

Kikobeats

    InsanelyMac Protégé

  • Members
  • Pip
  • 34 posts
  • Gender:Male
  • Location:Spain
  • Interests:Programming & Hacks
Don't work in ML 10.8.3 (fresh install)

:(

#60
theconnactic

theconnactic

    Stubborn AMD user

  • Local Moderators
  • 2,973 posts
  • Gender:Male
Works here not only with 10.8.3, but 10.8.4 (first beta) as well.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy