Jump to content

Leopard on Quad Core Q6600

236 posts in this topic

Recommended Posts

i booted with cpus=1 -f -s -x after i update my machine booted in safe mode i restarted it then it was smooth sailing from there im running the retail copy

try this method

FIRST: backup /System/Library/Extensions/


1) Download the update here: << Download >>

2) Open Terminal

3) Run the following commands:


sudo -s


Type your password. Hit enter. Then type this and hit enter:


while sleep 1; do rm -rf /System/Library/Extensions/AppleIntelCPUPowerManagement.kext; done


You CANNOT just delete it afterward. It WILL BREAK the install, and require a new install or restore from backup.


4) Run the installer.


5) When the installer finishes, DO NOT REBOOT!

6) In the Terminal window, hold the CONTROL key and press C.

7) Type in the following command:


sudo nano /System/InstallAtStartup/scripts/1


8) Find the line with /System/Library/Extensions/Dont Steal Mac OS X.kext

9) Replace it with:

For DSMOS users:




For R3D3 Users:




10) Hold CONTROL and press the O key. Then hit enter.

11) Hold CONTROL and press the X Key.

12) Type exit and enter. Repeat untill "Proccess Completed" is shown.

13) Close Terminal.


-- Before you reboot, move any KEXTS from the backups you made, back to the Extensions folder. This may include AppleACPIPlatform,kext and others, graphics, sound, etc. --


14) REBOOT and cross your fingers!


Nevermind..... just hosed system for the 6th time this week following the instructions above.

Link to comment
Share on other sites

for the first boot i had to use -x -f -v for it to boot then after that it work all on its on


I havent but i was curious about it, I have a laptop that I can't get past 10.5.2, with my current set up, and was thinking of some options - I still havent gotten the m9040n up to 10.5.5 yet.




have u gotten everything working on your machine

Link to comment
Share on other sites

none of the onboard networking works, I use that apple ethernet/usb adapter quite happily. The tv card that comes with it is useless in X, the card reader worked automatically, so other than the networking, it runs - i'm using it as my main home computer for a month at least now. Turned off the old G4 and backed it up. I used the ideneb, + the 1.1 updater.


Link to comment
Share on other sites

I installed Leo4Allv3 on my friend's Q6600/Intel DP35DP without a hitch. From there, the update to 10.5.5 (Software Update) was easy as pie.

Just make sure to backup Extensions and use netkas' script for instant AppleIntelCPUPowerManagement.kext removal. May want to check the startup script to change Don't Steal Mac OS.kext to dsmos.kext if it's there.


From the 10.5.2 Leo4All install to 10.5.5, all I had to do was reinstall IO80211Family.kext (with wireless PCI card Linksys WMP300N DevID added) and AppleHDA.kext/ALCinject.kext (provided with Leo4Allv3 and works). The new NVInstaller with EFI Studio worked a treat on his MSI 8800GT 512MB for QE/CI and his native LCD resolution (1280x1024).


IDE does require a patched kext. The one used is, I believe, the VIA option in Leo4Allv3.


Ethernet does not work, but he has the WMP300N for networking anyway.


Lemme know if any of have any troule and your devices match the DPCI Manager screenshot attached. PM preferred.


Link to comment
Share on other sites

  • 2 weeks later...
  • 2 weeks later...
  • 2 weeks later...

  • Create New...