Jump to content

[How to] Asus P5K-VM guide


1,244 posts in this topic

Recommended Posts

Make sure you have fakesmc.kext in /System/Library/Extensions, it will not work from /Extra/Extensions.

Try booting with UseKernelCache=n

About Messages:

You must install the NVRAM module in /Extra/Modules for Messages to work with Chameleon

Chameleon must be at least v2.2 svn r2170

You must delete the ACPICodec module from the modules folder, it cannot coexist with the NVRAM module (I wish I could remember where I read this)

An /Extra/smbios.plist with correct data (ie an accurately faked serial number for example) for the Mac model you're spoofing is required

A wired ethernet device at En0 with the built-in property set (EthernetBuiltIn=y) is required. A driver must be loaded for the hardware but you don't have to be actually using it.

Your Hackintosh must have a valid Hardware UUID (See System Profiler) - this is normally taken care of automatically by Chameleon

If Chameleon is installed to your EFI partition you must create an additional Extra folder at the root of your system drive so that the contents of NVRAM can be saved there - NVRAM contents cannot be written to the Extra folder on your EFI partition because it isn't mounted when the system is running.

If it still doesn't work with all the above in order, try logging in to Messages with your Apple ID on any real Apple device once, then try again on your Hackintosh.

For more information see this post:
You shouldn't have to mess with NVRAM variables though, it should just work. Well it does for me anyway.

To upgrade Chameleon, you can use my guide and files from here (must be logged in to download).

  • Like 2
Link to comment
Share on other sites

Thanks Gringo Vermelho;


Your instructions enabled booting with the most recent version of Chameleon (2181). All I had to do is install the fakesmc.kext as you indicated, and update Chameleon. Works fine. I also added the NVRAM module using the Chameleon installer, but could not get the iMessage to work.


I do have a functioning ethernet, smbios is correct, UUID is correct, NVRAM is created in /Extra, tried logging out and back in on a real mac (worked fine) but can not log in to iMessages on the hack. I am now going through the two posts you indicated, any other ideas. Many thanks...

Link to comment
Share on other sites

Thank you so much. What made it work is to log in to App Store with the account used in iMessages, add a credit card, and it started working. For others, here is the summary of what I did, based on your instructions:


- install Chameleon 2171 using installer, and with the option to install the NVRAM module.

- upgrade to 2181 using Chameleon Wizard (just the /boot part)

- copied FakeSMC to /System/Library/Extensions/ (otherwise does not boot)

- repaired permissions for good measure

- reboot

- add credit card in App Store to the Apple ID used for iMessage

- login to iMessage


Thanks once again. Much appreciated...

  • Like 1
Link to comment
Share on other sites

  • 6 months later...
  • 1 month later...

I installed Mavericks GM on this board, using Myhack. I applied the old dsdt which worked in ML and the AppleHDA from ML. Everything works good, I got sound, but I can't get network yet. I will keep you updated.

Link to comment
Share on other sites

I am currently running 10.7.2 on my ASUS-P5KVM and everything is working.

These are my specs:



Q6600 @ 2,4 GHZ

6 GB DDR2 ram

GT 240 512mb


I used iAtkos L2 and used the default settings @ costumization, there is 1 thing i selected wich is the Marvell 88E8056 at Drivers > Network.

When i rebooted only sound where not working and i used a basic kext which was for AppleHDA.kext and now that i working to.

Network and display where working out of the box, display with GraphicsEnabler=Yes but that was selected by iAtkos.

Also i didnt use chameleon but i used chimera.


Also remember to set ur HHD's to AHCI and dont use port 3&4 because they are not working with mac osx


When i get home today i will add the audio kext.




Link to comment
Share on other sites

After a long while of trying, I finally got OS X 10.9 GM fully working on Asus P5K-VM:

What you need: 

- OS X 10.9 installer

- Myhack beta for 10.9 http://www.insanelymac.com/forum/topic/289083-os-x-109-myhack-usb-installer-beta/

- Pandora http://www.insanelymac.com/forum/files/file/11-pandoraapp/

- Kext Wizard  http://www.insanelymac.com/forum/topic/253395-kext-wizard-easy-to-use-kext-installer-and-more/

- Chameleon Wizard:  http://www.osx86.net/files/file/242-chameleon-wizard-422/

- ALC883 Sound: http://www.insanelymac.com/forum/topic/292721-no-sound-with-alc883/

- Network Marvell Yukon 88e8056: http://www.insanelymac.com/forum/files/file/35-marvell-yukon-88e8056-108-1085/


1. Installation using MyHack. Attention, when you boot the USB installer created with Myhack, don't forget to use the argument "-f" or the installer will get stuck. Follow the direction of the installer (Default extra, remove proposed kexts). At the restart the computer may stall, use the reset button.

2. After the restart you may get a bios alert about the CMOS reset, don't worry it will be fixed, set the correct date and time in bios set the sata back to AHCI, and boot the system. Open Pandora, chose post install and then chose remove orange drives and CMOS reset.

3. Open Kext Wizard and install AppleHDA patched for ALC883 and IONetworkingFamily in /System/Library/Extensions (then put the kexts in a safe place)

4. Open Chameleon Wizard and set what you want, but "Restart Fix" and "Ethernet Built In" would be mandatory. You don't have functional network yet, Chameleon Wizard will ask you for Java, ignore the dialogs, it either works.

5. If you have other video card than me (nVidia Geforce 9500 GT or GS) you need to find the proper kexts, I don't need any other kexts for this card.

7. FakeSMC would be placed in /System/Library/Extensions instead of /Extra/Extensions. Use kext wizard and move it.

6. Cross the fingers and reboot. GOOD LUCK!


PS IMPORTANT! Place all kexts and applications in a safe place, you will need the kexts back after every OS update. Copy the AppleRTC.kext from /System/Library/Extensions in the safe place too, you will need it after every OS update, or use Pandora to put it back.

dsdt.aml is not needed or not mandatory.

  • Like 1
Link to comment
Share on other sites

  • 3 weeks later...

Xanthrax your guide works! Thanks.


I have now 10.9 up and working, except for Usb 3/4 port with mouse/keyboard not working, but usb storage working (they were ok on Montain Lion).


In Your guide, at point 2):


2. After the restart you may get a bios alert about the CMOS reset, don't worry it will be fixed, set the correct date and time in bios set the sata back to AHCI, and boot the system. Open Pandora, chose post install and then chose remove orange drives and CMOS reset.


I cannot find in Pandora any way to remove orange drives and CMOS reset.


help please

Link to comment
Share on other sites

  • 9 months later...
  • 1 month later...
  • 1 month later...
  • 2 weeks later...

Hi Hymdall,


which kexts did you use for audio and ethernet and which bootloader?


it would be great if you could write a short howto/tutorial (i'm stuck at ethernet, audio only through voodoo - slepp does not work at all).


thanks in advance,



Link to comment
Share on other sites

Modify entries in:



<key>Yukon-88E8053</key> to <key>Yukon-88E8056</key> 

<string>0x436211AB</string> to <string>0x436411AB</string>

<string>Yukon Gigabit Adapter 88E8053</string> to <string>Yukon Gigabit Adapter 88E8056</string>


next, apply the IONetworkingFamily Fix package, delete NetworkInterfaces.plist on /Library/Preferences/System Configuration, delete all the network interfaces in System Preferences/Network, restart the computer and recreate the network interfaces in System Preferences/Network. Oh, when recreating the network interfaces be sure to set ethernet first.


link bestand IOnetworkingfamilyFIX

Link to comment
Share on other sites

  • 2 weeks later...
  • 1 month later...

Anyone get the USB error when trying to boot from the myHack USB?  I hit -v to see the errors (as the install just hangs with apple logo and spinny thing).  I get IOUSB something, something error on port 5, will keep trying.  I even tried the "USBBugFix=Yes" and this didn't work.  Any help?  I have P5K-VM with intel duo core E6600


I followed Xanthrax install instructions on post #1234

Link to comment
Share on other sites

  • 2 years later...

What is the best vanilla way to install OS X on this Asus P5K-VM?

This is my setup:

- Asus P5K-VM

- Q6600

- 8GB DDR2 (4x 2GB PC2-6400)

- GTX 670 2GB (Palit GeForce GTX 670 JETSTREAM



I don't mind which version of OS X it is. Preferably the latest (Sierra or El Capitan) but older is also not a problem (Yosemite or Mavericks)

Link to comment
Share on other sites


  • Create New...