Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.


[How to] Asus P5K-VM guide

1,244 posts in this topic

Recommended Posts

Time to get all the info needed to get this motherboard working (almost) 100% gathered in one place, SATA port 3&4 is the only thing not working.


Im not gonna cover gfx-card installation here, since it is just like any other PCI-E mobo, search for drivers for your gfx-card.



Motherboard info:

Chipsett: Intel ICH9 (DevID 2923, 4 port SATA) & G33

Gfx: Intel GMA3100 (only VESA)

IDE: JM368 works native in Leo, or with driver in Tiger from here thanks to SkyZ

SATA port 1&2: set AHCI mode in BIOS

SATA port 3&4: not working in OSx86 yet

Audio: Realtek 883

Firewire: works fine

USB: works fine

Network: Marvell Yukon 88E8056



Install Taruga's ALC882 Sound Fix v0.4b and then:

Patch it with this codec dump alc883_ICH9.txt

Add 0x293e8086 DevID to:





Modify entries in:



<key>Yukon-88E8053</key> to <key>Yukon-88E8056</key>

<string>0x436211AB</string> to <string>0x436411AB</string>

<string>Yukon Gigabit Adapter 88E8053</string> to <string>Yukon Gigabit Adapter 88E8056</string>

Share this post

Link to post
Share on other sites

You might know that this board suffers from a great V-core drop issue of about 0.1 volts.

So if you set a Vcore of 1.6 in bios it only gives you about 1.5 real volts.

Anyway there is a solution to the problem, you can simply pencil over the resistor shown in the picture.

Use a 2B or softer lead and make sure you don't get near the other resistors.

Now 1.6v should get you 1.6 real volts and maybe help you get that extra speed from your cpu.




Notice this mod is not the same as the P5K ATX boards as they have 6 vertical resistors as to 5 this board has.


I'll provide you with the Vcore and Vdimm mod next.



For those of you who want the pre-patched kexts for Audio and Network I've attatched them for you. Put them in you Extensions folder



Share this post

Link to post
Share on other sites

I'm running a P5K-VM with an E-4400 C2D , and would like the vdimm and vcore mod...I can get to 2862 Mhz using 350 FSB x 8 ratio, Kingston DDR2-667 VP 2x1G at 2.0v running 5:6 at 5-5-5-9 I will do the pencil mod, as it will prevent the vcore drop from cooking the Vcdrop resistor, and causing it from going even higher in value, and let the processor ( which is closely monitored by the system ) do the job of shedding the heat. If you're going to OC 24/7 , it might even be better to add an actual resistor in parallel...


I'm hoping the pencil mod will get the mouse response back to normal...or close even....

Share this post

Link to post
Share on other sites

hi, i just bought this board after seeing your sucess. i installed vista, and installed acronis boot selector, then i install the mac os, when it's in the installation menu, i cant seem to find any avalible partition to install it on?


i formatted my harddrive to be

C:\ NTFS - vista

D:\ FAT32 - for mac os x

G:\ NTFS - for random things


this is a sata drive, any sugguestions? thanx in advance =)

Share this post

Link to post
Share on other sites

betachild: if you have SATA mode set to echanced(default) OSX only see SATA devices connected to SATA port 1&2

Share this post

Link to post
Share on other sites

delish, thanx for the advice, it was because i connected to the 3rd SATA port, i just finished installing the systems.


now just another quick question, i tried to setup the dual boot w/ the bcdedit, i used the following commands


bcdedit /copy {current} /d “Mac OS X”

bcdedit /enum active

bcdedit /set {ID OF THE OSX ENTRY SHOWN} PATH \chain0


i copied the chain0 file to C:\ already,


when i tried to boot it, the Mac OS X appears, but when i hit enter and try to go in, it just blanks for a few sec and returns to the boot selector.


i also tried the easybcd v1.7 application, no luck with it either. is there a way to boot w/ the vista boot selector?


thank you

Share this post

Link to post
Share on other sites

Hello, Slightly off topic but I am looking to get an Asus P5K MB and wanted to know if anyone has had any problems dual booting OSX86 and Windows when SATA AHCI is Enabled in the Bios? Do all OSX86 installs _require_ SATA AHCI to be enabled? Or is that only for certain motherboards?

The reason i ask is i have a Gigabyte ga-p965-ds3 MB and when try to install Win XP/Vista using SATA AHCI, i get the BSoD or the installer tells me my HDD does not meet the correct requirements.


Thanks in advance

Share this post

Link to post
Share on other sites

Just thought I would say THANK YOU!!!


Helped me out so much


Just one thing, with the onboard VGA, is it possible to increase the screen res up from 1024 x 768 to something more reasonable like 1280 x 1024?


Because the only screen res I see when I try and change it is 1024 x 768.

Share this post

Link to post
Share on other sites

Thanks for the info I've got the same board with an e6420 running 500fsb x7. My crucial balistix tracer is running at 2.1v and it's supposed to be at 2.2v I've been looking all over for a vdimm mod and you said you had one in your other thread so please please share it with us :)

Share this post

Link to post
Share on other sites

I'm not quite sure about the vdimm mod.

I thought I had it figured out but now I'm not sure since the "chip" doesn't have the same name as the one on the ATX P5K's i.e. (APW7120 MJ18Z) as (APW7120 MJ41Y) on the P5K-VM.

This chip is located between the floppy and ATX connector.


The vcore mod works though and will post it later today, but it doesn't help with OC my Q6600 anyway.

Anyway, Asus has released a new board the P5E-VM DO and I couldn't resist not to order it.

It's basically the same as the P5K-VM but it has more overclocking options.

From the manual:


Share this post

Link to post
Share on other sites

I would very much like to know how the new board works for you in the future as I am looking at creating another hackintosh but have been out of it for about 6 months now. I plan on purchasing a Q6600 soon also. Do you think either board set up will work with the a possible 10.5 hack in the future? Also what is some decent OCing RAM for this model? Also what series of install discs did you use? Thank you.

Share this post

Link to post
Share on other sites

Hi there, is anyone manage to get the onboard SATA port 3 & 4 (JMircon JMB368) working (tried AppleAHCIPort/AppleVIAATA plist editing already)? I very much need to add another HDD to my desktop hacintosh, please help (I can use the Silicon Image 3132 PCI-E SATA controller to add HDD, but it's way slower and affect the sleep function...).

Share this post

Link to post
Share on other sites

Just to let you know about the new P5E-VM DO....

I thought it would be a monster but I was so wrong. maybe I got a faulty MB..


First the vdroop is huge on this board, 1.7v in bios gives real 1.48v...

I tried to fix the vdroop but only managed to get 1.6v, pencil mod.


Second the board starts as fast as the PSU is turned on, powerbutton has no effect.

So when I tried to shut it down it just restarted over and over again.

Had to resort to the powerswitch at the back of the PSU to shut it down.


As far as OC:ing the best I got was 3.15 GHz on my G0 Q6600 which is {censored} and

not near the 4 GHz I get on my P5K-VM.


Maybe it's a faulty board and maybe a new bios release will sort things out.

But now I'm back on my old board and this new one will be sent back to the store...


Anyway the onboard NIC Intel 82566DM doesn't work with OSX but everything else is

like the 6 sata ports in AHCI mode and onboard sound, firewire etc.

Share this post

Link to post
Share on other sites

Alright, I just picked up this board and installed it last night, and everything seems to be working good.. except for the fact that I still can't boot my 10.4.10 disc.

I am using the P5K-VM in AHCI mode, and put my Plextor PX-755SA (SATA DVD-RW) in SATA 2, and my Maxtor 160GB HDD in SATA 1.

When I try to boot from the DVD drive, it literally ignores the disc as bootable media.

When I drop it out of AHCI mode and back into IDE, it boots up until the point that it says it's waiting for the root device.

Anyone have any idea what I might be missing here?



Alright, I have the disc booting in AHCI mode, with the same configuration.

The PX-755SA doesn't seem to work in AHCI mode without a firmware upgrade, which I performed.

However, the disc will still not boot fully, and gets stuck with a 'still waiting for root device' error.

Any clues?

Share this post

Link to post
Share on other sites

Not all OSx86 disks are created equal :) your 10.4.10 disk might use a driver that this board dislikes, or it lacks one it requires.

Share this post

Link to post
Share on other sites

Speaking of Jmicron, I think the whole reason I can't get it to boot is because I neglected to patch the ISO with the included extensions.mkext which says it's specifically for use with Jmicron.

The disc I'm using is Kalyway's 10.4.10 w/ SSE2 by the way.

Has anyone had luck with this disc, and, how do I replace the .mkext in the ISO assuming I haven't installed OSX yet (i.e. from Windows or Linux)?

Share this post

Link to post
Share on other sites

Did some digging in windows on the SATA ports,

Windows reports controller to be ICH9 DevID 2923, 4port SATA

A lookup on the web shows 2923 to be Intel ICH9 4 port ACHI SATA controller.


In both enhanced mode and compatible mode it lists:

Channel 0, 1, 4 and 5, all as having DevID 2923.


So Im guessing its cause of the channel numbering OSX doesnt see SATA port 3 & 4.

Gonna try adding 2923 to the AppleIntel kext to see if that makes any difference.

Share this post

Link to post
Share on other sites

Delish, great topic!


Just installed Jas 10.4.8 and will update trough koolkal to 4.10 (thanx to Skyz).


Allsop, you included some pre-patched kexts for our mobo, But do i still have Install Taruga's ALC882 Sound Fix v0.4b and

Patch it with codec dump?


does someone know a topic on overclocking/FBS this mobo ?

Can't wait for LeoX86!

Share this post

Link to post
Share on other sites

elbasofolous: its under <key>IOPCIMatch</key>


theyoung: you can just use the prepatch kexts Allsop posted.


Brazilmacs patch for Leo DVD over at osx86scene (howto section) works nice on this mobo.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.