Jump to content
fantomas1

Apple released macOS 10.13.4 Update

29 posts in this topic

Recommended Posts

macos_egpu.jpg

 

The macOS High Sierra 10.13.4 update improves the stability, performance, and security of your Mac, and it is recommended for all users.

 

This update:

  • Adds support for Business Chat conversations in Messages in the US
  • Adds support for external graphics processors (eGPUs)
  • Fixes graphics corruption issues affecting certain apps on iMac Pro
  • Allows jumping to the right-most open tab using Command+9 in Safari
  • Enables sorting Safari bookmarks by name or URL by right clicking and choosing "Sort by..."
  • Fixes an issue that may prevent web link previews from appearing in Messages
  • Helps protect privacy by only AutoFilling usernames and passwords after selecting them in a web form field in Safari
  • Displays warnings in the Safari Smart Search Field when interacting with password or credit card forms on non-encrypted web pages
  • Displays privacy icons and links to explain how your data will be used and protected when Apple features ask to use your personal information

 

View full article

 

Share this post


Link to post
Share on other sites
Advertisement

Running fine on my Optiplex 790, Macbook and Probook :P

Spoiler


MQWP0X7.png10ibhUk.pnglZ33CW0.png

 

 

Share this post


Link to post
Share on other sites

HI there , running with flickers on desktop icons , and chrome and safari .. dont know why

Share this post


Link to post
Share on other sites

10.13.4 show 2 Intel GPU in system preference panel.


从我的 iPhone 发送,使用 Tapatalk

Share this post


Link to post
Share on other sites

Update is OK. Image can be saved in HEIF format with "Aperçu" (French language) :)

Share this post


Link to post
Share on other sites

Could someone provide a working 10.13.4 port limit patch please?

Share this post


Link to post
Share on other sites
29 minutes ago, DSM2 said:

Could someone provide a working 10.13.4 port limit patch please?

            <dict>
                <key>Comment</key>
                <string>Disable USB Limit 10.13.4+</string>
                <key>Disabled</key>
                <false/>
                <key>Find</key>
                <data>g32UDw+DlwQAAA==</data>
                <key>Name</key>
                <string>AppleUSBXHCI</string>
                <key>Replace</key>
                <data>g32UGpCQkJCQkA==</data>
            </dict>

Share this post


Link to post
Share on other sites

Anyone try 10.13.4 with Kabylake graphics (HD630, model 0x5912)?  I'm getting flicker and screen artifacts.

See my post here

Any help is appreciated.

Share this post


Link to post
Share on other sites
Posted (edited)
2 hours ago, Zenith432 said:

Anyone try 10.13.4 with Kabylake graphics (HD630, model 0x5912)?  I'm getting flicker and screen artifacts.

See my post here

Any help is appreciated.

I have the same issue. UHD630 (Cannon Lake) shows up twice in System Information. Screen flickers like hell. Worked fine under 10.13.3.

Edited by mulder77

Share this post


Link to post
Share on other sites
8 hours ago, Zenith432 said:

Anyone try 10.13.4 with Kabylake graphics (HD630, model 0x5912)?  I'm getting flicker and screen artifacts.

See my post here

Any help is appreciated.

I have 0x5916 and it shows twice in System Profile too but no other issues at least for now. Same kexts you have. 

Share this post


Link to post
Share on other sites

@mulder77, bluenote56: I changed SMBIOS Model ID from iMac18.2 to iMac 18.1 and it fixed the problem.  The solution is posted in the thread I linked.

Share this post


Link to post
Share on other sites

The solution is posted in the thread

  • DVMT pre-allocated to 192MB
  • DVMT max to MAX
  • SMBIOS 18,3 to 18,1

Share this post


Link to post
Share on other sites

After updated to 10.13.4 and nVidia Web driver...30.103 for my Gigabyte GTX 1050 ti, needed to patch AppleHDAController from <de10e90b> to <de10b90f> for getting audio via DP-HDMI adapter

            <dict>
                <key>Comment</key>
                <string>AppleHDAController Patch</string>
                <key>Disabled</key>
                <false/>
                <key>Find</key>
                <data>3hDpCw==</data>
                <key>Name</key>
                <string>AppleHDAController</string>
                <key>Replace</key>
                <data>3hC5Dw==</data>
            </dict>
 

Previously didn't patch anything.

Share this post


Link to post
Share on other sites

It seems to be working well on my Z800.
Seems like the two Xeon X5690 are running a little bit cooler but I'm not sure.
No immediate problems noticed.

Share this post


Link to post
Share on other sites
On 3/30/2018 at 12:00 PM, maleorderbride said:

            <dict>
                <key>Comment</key>
                <string>Disable USB Limit 10.13.4+</string>
                <key>Disabled</key>
                <false/>
                <key>Find</key>
                <data>g32UDw+DlwQAAA==</data>
                <key>Name</key>
                <string>AppleUSBXHCI</string>
                <key>Replace</key>
                <data>g32UGpCQkJCQkA==</data>
            </dict>

Hi. Already went to the update and lost some of my USB 3.0. 

Excuse my noobness but where in the config plist I put this code? Already had under >KextsToPatch< some code to change  the 15 por limit from before (you can find the codes below)

Should I delete them and replace with the new code? 

Thanks in advance

 

 

<dict>
				<key>Comment</key>
				<string>change 15 port limit</string>
				<key>Disabled</key>
				<false/>
				<key>Find</key>
				<data>
				g32MEA==
				</data>
				<key>MatchOS</key>
				<string>10.13.x</string>
				<key>Name</key>
				<string>com.apple.driver.usb.AppleUSBXHCIPCI</string>
				<key>Replace</key>
				<data>
				g32Mfw==
				</data>
			</dict>
			<dict>
				<key>Comment</key>
				<string>change 15 port limit</string>
				<key>Disabled</key>
				<false/>
				<key>Find</key>
				<data>
				g710////EA==
				</data>
				<key>MatchOS</key>
				<string>10.12.x</string>
				<key>Name</key>
				<string>com.apple.driver.usb.AppleUSBXHCIPCI</string>
				<key>Replace</key>
				<data>
				g710////Gw==
				</data>
</dict>
			<dict>
				<key>Comment</key>
				<string>change 15 port limit</string>
				<key>Disabled</key>
				<false/>
				<key>Find</key>
				<data>
				g72M/v//EA==
				</data>
				<key>MatchOS</key>
				<string>10.11.x</string>
				<key>Name</key>
				<string>com.apple.driver.usb.AppleUSBXHCIPCI</string>
				<key>Replace</key>
				<data>
				g72M/v//Gw==
				</data>

 

Share this post


Link to post
Share on other sites

Replaying to my own noob question...

just replace in config.plist here after the "KextsToPatch" key. Then it should work. I did not delete the older patch´s and still works. 

<key>KextsToPatch</key>
        <array>
            <dict>
                <key>Comment</key>
                <string>Disable USB Limit 10.13.4+</string>
                <key>Disabled</key>
                <false/>
                <key>Find</key>
                <data>
                g32UDw+DlwQAAA==
                </data>
                <key>InfoPlistPatch</key>
                <false/>
                <key>MatchOS</key>
                <string>10.13.4+</string>
                <key>Name</key>
                <string>AppleUSBXHCI</string>
                <key>Replace</key>
                <data>
                g32UGpCQkJCQkA==
                </data>
            </dict>
 

Question for the mentors. Is still necessary to maintain in this new update the USBinjectALL.kext in "Other"? @MaLd0n

thxs.

Share this post


Link to post
Share on other sites

Clover 4411 or any other 3d party USB creators using 4411 is not showing the 10.13.4 USB installer at Clover boot menu, direct update went well but no way to fresh install from USB even if has been created successfully

Short: USB installer is showing in the BIOS just fine and it boots to it, but Clover 4411 boot menu is not showing the installer as it always did.. Clover 4411 and 10.13.3 no problem, Clover 4411 and 10.13.4 problem

Share this post


Link to post
Share on other sites
2 minutes ago, RandomTech said:

Clover 4411 or any other 3d party USB creators using 4411 is not showing the 10.13.4 USB installer at Clover boot menu, direct update went well but no way to fresh install from USB even if has been created successfully

Short: USB installer is showing in the BIOS just fine and it boots to it, but Clover 4411 boot menu is not showing the installer as it always did.. Clover 4411 and 10.13.3 no problem, Clover 4411 and 10.13.4 problem

Clover 4424

https://drive.google.com/file/d/1o1DLChbq9hpT_I9rnd-rSv8Pc7czpYfN/view?usp=sharing

Share this post


Link to post
Share on other sites

Is there a way of finding out why the update keeps coming up in my App Store after rebooting during the install? 

It seems as though it does not want to finish the update.

There is also a new clover entry, "mac OS install on Macintosh HD".

Do I boot from that one after initiating the install?

Share this post


Link to post
Share on other sites
5 hours ago, Careless said:

Is there a way of finding out why the update keeps coming up in my App Store after rebooting during the install? 

It seems as though it does not want to finish the update.

There is also a new clover entry, "mac OS install on Macintosh HD".

Do I boot from that one after initiating the install?

Yes. The update has 2 stages, you only went through the first stage. After the first stage the system will reboot and then will proceed the initial update process.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By Slice
      I successfully installed macOS 10.11.6 and Windows 7 Pro SP1 in UEFI mode on the laptop.
      I know, there are detailed guides here and on osxlatitude.com but I was not agree with them and carefully check and test every step to tune my Mac.
       
      Hardware
      Intel® Core� i5-3320M CPU @ 2.60GHz, speedstep works with Clover default settings
      Chipset Intel 7 series, no patches needed
      Video: IntelHD4000 or NVS5200M switchable in BIOS, work in both cases
      LAN; Intel 82579LM, works with IntelMausiEthernet.kext v2.2.1
      Audio: IDT 92HD93BXX, works with VoodooHDA 2.9.0.
      SDHC reader O2Micro; works with native AppleSDHC.kext with Clover Arbitrary properties.
      USB3.0 works natively if not disabled in DSDT
      PS2 keyboard and touchpad works with VoodooPS2.
      WiFi: Dell Intel WiFi was replaced by Dell DW1520, Broadcom BCM943224HMS. DeviceID=4353
      LCD Screen 1366x768
      BIOS A12. Initially was A02. Then I flashed A23 and found it is quite bad. The screen is full of artefacts. Flash A12 and all is OK. Not tested other versions.
      For some reason BIOS can switched from Intel to Nvidia by itself so I have to do my solution working independent on this state.
       
      WiFi
      It is not working OOB although it has DeviceID known to Apple. The reason is WhiteList in the driver.
      I set MacModel as MacBookPro10,1 while the WiFi will work on MacBookAir. I make a patch in Clover.
      As well a patch for channels.
      I deleted a kext Brcm4331 because it has the same DeviceID. Let kext Brcm4360 to work alone.
       
      VideoCards
      In Bios we can set Optimus = Enable/Disable
      If Enable then we have two videocards Intel first and Nvidia second. In this case additional SSDT-3.aml will switch off Nvidia.
      If Disable then we have only Nvidia card. It will work if Board-ID taken from iMac13,2.
      But here there is contradiction with WiFi with required Board-ID from MacBookAir.
      So I take MacModel as MacBookPro10,1 which is most close by CPU IvyBridge.
      Set BoardID like iMac13,2 to make Nvidia working.
      Patch BoardID in Brcm4360 to make WiFi working.
      Now I have
      Inject->
      ->Intel=YES
      ->Nvidia=YES
      and SSDT-3.aml in ACPI\patched folder. This SSDT will switch off Nvidia if Intel card ON.
      For Intel graphics there is a patch against 8 apples at start.
       
      Brightness
      No special kexts.
      The brightness controlled by keys F1,F2 and slider in Control Panel in both case Intel or Nvidia. Details here  #72 
       
      DSDT and SSDT
      This is very long story and finally I have working sleep in both cases Intel or Nvidia.
       
      Sensors
      I use my HWSensors3 with FakeSMC 3.5.0.
      I got monitoring:
      CPU temperature
      GPU temperature
      GPU main frequency
      GPU shader frequency
      Battery state % full, time to charged or time to empty.
      Battery voltage dinamically.
      Battery amperage dynamically. I can see it changes on heavy games.
      HDD temperature.

       
      Audio
      I like VoodooHDA and have no problems with it.
      The sound is clear, loud, and switchable between internal speaker and headphone.
      Mic is working.
       
      Bluetooth
      Just tested with BTFirmwareUpdate.kext and it works. I not needed it so switched off by wireless switch at right side.
       
      Keyboard, Touchpad and Touchstick
      Post #14
       
      My config, ACPI files and kexts are in attachment.
      05.12.2017
      EFI.7z
       
      EDITED:
      Better DSDT in the post #6.
      Sleep working even when AC inserted.
       
      EDITED 06.12.2018
      Now I have HighSierra and this is my EFI folder
       

       
       
      Welcome to discussion!
      EFI-E6430.7z
    • By gengik84
      First beta is out... build 18D21c
    • By fantomas1
      macOS Mojave 10.14.3 beta (18D21c)
    • By fantomas1
      Hi InsanelyMacaholics   

      Use this thread to link / talk about of the future Nvidia Web Driver updates for macOS Sierra.
       
      10.12.6
      Nvidia Web Driver - 378.05.05.25f12 --> build 16G1710 (thanks to BreBo) New!
      Nvidia Web Driver - 378.05.05.25f11 --> build 16G1618 (thanks to Frank Nitty)
      Nvidia Web Driver - 378.05.05.25f10 --> build 16G1510 (thanks to BreBo) 
      Nvidia Web Driver - 378.05.05.25f09 --> build 16G1408 (thanks to BreBo)
      Nvidia Web Driver - 378.05.05.25f08 --> build 16G1314 (thanks to BreBo)
      Nvidia Web Driver - 378.05.05.25f07 --> build 16G1314 (thanks to haring)
      Nvidia Web Driver - 378.05.05.25f06 --> build 16G1212 (thanks to WeBeRiO)
      Nvidia Web Driver - 378.05.05.25f04 --> build 16G1114 (thanks to lukazm)
      Nvidia Web Driver - 378.05.05.25f03 --> build 16G1036 (thanks to Gradou)
      Nvidia Web Driver - 378.05.05.25f01 --> build 16G29 (thanks to Badruzeus)
       
       
      10.12.5
      Nvidia Web Driver - 378.05.05.15f01 --> build 16F73 (see this post)
       
       
      10.12.4
      Nvidia Web Driver - 378.05.05.05f02 --> build 16E195(thanks to crachmaster4999)
      Nvidia Web Driver - 378.05.05.05f01 --> build 16E195 (thanks to Moviemakergr)  Pascal support!!!
      Nvidia Web Driver - 367.15.10.45f01 --> build 16E195 (thanks to Lanc)
       
       
      10.12.3

      Nvidia Web Driver - 367.15.10.35f01 --> build 16D32 (thanks to shatterhenner)
       
       
      10.12.2
      Nvidia Web Driver - 367.15.10.25f02 --> build 16C68 (see this post)
      Nvidia Web Driver - 367.15.10.25f01 --> build 16C67 (see this post)
      Nvidia Web Driver - 367.15.10.25b06 --> build 16C60b/16C63a (see this post)
       
       
      10.12.1
      Nvidia Web Driver - 367.15.10.15f03 --> build 16B2657/16B2659 (thanks to Moviemakergr).
      Nvidia Web Driver - 367.15.10.15f01 --> build 16B2555 (thanks to Moviemakergr)
       
       
      10.12.0
      Nvidia Web Driver - 367.15.10.05f01 --> build 16A323 (thanks to phi777)
       
       
      GM
      Nvidia Web Driver - 367.10.10.05b01 --> build 16A323 (same driver since DP4/PB3)
      Nvidia Web Driver - 367.10.10.05b01 --> build 16A322 (see this post)
      Nvidia Web Driver - 367.10.10.05b01 --> build 16A320 (see this post)
       
       
      DP/PB
      Nvidia Web Driver - 367.10.10.05b01 --> build 16A313a (DP8 & PB7) (see this post)
      Nvidia Web Driver - 367.10.10.05b01 --> build 16A304a (DP7 & PB6) (see this post)
      Nvidia Web Driver - 367.10.10.05b01 --> build 16A294a (DP6 & PB5) (see this post)
      Nvidia Web Driver - 367.10.10.05b01 --> build 16A286a (DP5 & PB4) (see this post)
      Nvidia Web Driver - 367.10.10.05b01 --> build 16A270f (DP4 & PB3) (thanks to TheRacerMaster)
      Nvidia Web Driver - 367.05.10.05b07 --> build 16A254g (DP3 & PB2) (see this post)
      Nvidia Web Driver - 367.05.10.05b07 --> build 16A238m (PB1) (thanks to Faun) 
      Nvidia Web Driver - 367.05.10.05b07 --> build 16A239j (DP2) (thanks to Faun)
      Nvidia Web Driver - 367.05.10.05b03 --> build 16A201w (DP1) (thanks to Xmedik)
       
    • By fantomas1
      La version finale (build 18C54) est disponible sur App Store
×