Jump to content

AMD High Sierra Kernel Release and Testing


1,119 posts in this topic

Recommended Posts

first of all I want to thank all those who contribute to this great forum, it is really fabulous.

I'm new to this Hackintosh, but I've always used mac, so now that I bought a new computer I thought about installing the apple operating system from the beginning and thanks to its guidance I almost achieved it, the bad thing is that I have a small problem, it may be that someone already solved it, but I could not find the solution between the mountain of information that is here, I hope you forgive me if it is something redundant.

The issue is that my installation is great until I have to do the first reboot from my HD where I install the high saw, since it loads a black screen with white letters as if it were charging and then turns off the screen and is completely black and does not advance or let me go anywhere, attached I leave the last image I can take and a video that I record with my cell phone, I hope you can see it

 

https://drive.google.com/file/d/1dIoAmgI0Afh8_p4qec9XfsyteZTvicHw/view?usp=sharing  https://drive.google.com/file/d/1G3l48YHOb7YzL-6vICE1GZdvzWm5-QNn/view?usp=sharing 

 

Hi !

Whats your complete system specs ?

Also what installer did you use to install high sierra ?

 

Sent from my iPhone using Tapatalk

  • Like 1
Link to comment
Share on other sites

8 minutes ago, XLNC said:

 

Hi !

Whats your complete system specs ?

Also what installer did you use to install high sierra ?

 

Sent from my iPhone using Tapatalk

Thank you for answering so quickly

CPU: Ryzen 7 2700x
Motherboard: ASUS TUF X470-Plus Gaming
Graphics: AMD Radeon Pro WX 7100
RAM: Ballistix 32GB Sport LT Series
Cooler: EVGA CLC 280
HDD: Samsung 500GB 970 EVO

 

the guide is according to this video

 

 

and the items for the installation are those that are in this post


 

another thing ... the bios configuration of this other post 
https://forum.amd-osx.com/viewtopic.php?f=24&t=4127

 

Link to comment
Share on other sites

13 minutes ago, longcoming said:

Is there a working kernel for FX 8370 for 10.13.5?

I tried many,bot Shanee's and Al Grey and both gave me a restart.

 

You used the latest one here, https://github.com/Shaneee92/AMD-High-Sierra-XNU/releases

 

It's confirmed working on FX. 10.13.5 though you need to roll back alot of kexts to get the prelinkedkernel to compile.

  • Like 2
Link to comment
Share on other sites

  • 4 weeks later...

Hello Shaneee,

I successfully installed 10.13.3 with latest kernel from your GitHub. But System not recognised my ryzen 2700. Just like 4 Ghz Unknown.

Also Radeon ProRender for Autodesk Maya 2018 is not working at all. Could you please help me this?

Thank you

Screen Shot 2018-10-03 at 8.32.30 AM.png

Link to comment
Share on other sites

14 minutes ago, jsl2000 said:

Yes, but it did not work at both FX-6300 & Ryzen 1700X hackintoshes.

 

What's the exact issue with building the prelinkedkernel. Worked fine for me. Post the terminal output from running kextcache.

Link to comment
Share on other sites

34 minutes ago, shrisha said:

OK I added your system.kext and it gives different result at the end

Prelink failed for com.apple.driver.AppleBusPowerController; aborting prelink.

 

What version is AppleSMC and AppleBusPowerController. I've got 3.1.9 for AppleSMC and 1 for AppleBusPowerController. It could be that some kexts on my system weren't updated as before on 10.13.5 I used the 10.13.3 kernel with rolled back kexts. May have to do the same thing. I can upload if required though.

  • Like 1
Link to comment
Share on other sites

×
×
  • Create New...